apr-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416
  1. %define aprver 1
  2. # Arches on which the multilib apr.h hack is needed:
  3. %define multilib_arches %{ix86} ia64 ppc ppc64 s390 s390x x86_64
  4. Summary: Apache Portable Runtime library
  5. Summary(ja): Apache ポータブルランタイムライブラリ
  6. Name: apr
  7. Version: 1.3.9
  8. Release: 2%{?_dist_release}
  9. License: Apache Software License
  10. Group: System Environment/Libraries
  11. URL: http://apr.apache.org/
  12. Source0: %{name}-%{version}.tar.bz2
  13. Source1: apr-wrapper.h
  14. Patch2: apr-0.9.7-deepbind.patch
  15. Patch3: apr-1.2.2-locktimeout.patch
  16. Patch4: apr-1.2.2-libdir.patch
  17. Patch5: apr-1.3.3-pkgconf.patch
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. BuildRequires: autoconf, libtool, doxygen, e2fsprogs-devel
  20. Conflicts: subversion < 0.20.1-2
  21. Obsoletes: apache2-apr
  22. %description
  23. The mission of the Apache Portable Runtime (APR) is to provide a
  24. free library of C data structures and routines, forming a system
  25. portability layer to as many operating systems as possible,
  26. including Unices, MS Win32, BeOS and OS/2.
  27. %package devel
  28. Group: Development/Libraries
  29. Summary: APR library development kit
  30. Summary(ja): APR ライブラリ開発キット
  31. Conflicts: subversion-devel < 0.20.1-2
  32. Obsoletes: apache2-apr-devel
  33. Requires: apr = %{version}-%{release}
  34. Requires: pkgconfig
  35. %description devel
  36. This package provides the support files which can be used to
  37. build applications using the APR library. The mission of the
  38. Apache Portable Runtime (APR) is to provide a free library of
  39. C data structures and routines.
  40. %prep
  41. %setup -q
  42. %patch2 -p1 -b .deepbind
  43. %patch3 -p1 -b .locktimeout
  44. %patch4 -p1 -b .libdir
  45. %patch5 -p1 -b .pkgconf
  46. %build
  47. # regenerate configure script etc.
  48. ./buildconf
  49. # Forcibly prevent detection of shm_open (which then picks up but
  50. # does not use -lrt).
  51. export ac_cv_search_shm_open=no
  52. %configure \
  53. --includedir=%{_includedir}/apr-%{aprver} \
  54. --with-installbuilddir=%{_libdir}/apr-%{aprver}/build \
  55. --with-devrandom=/dev/urandom \
  56. CC=gcc CXX=g++
  57. make %{?_smp_mflags} && make dox
  58. %install
  59. rm -rf $RPM_BUILD_ROOT
  60. make install DESTDIR=$RPM_BUILD_ROOT
  61. # Move docs to more convenient location
  62. rm -rf html
  63. mkdir -p html
  64. cp -pr docs/dox/html/* html/
  65. # mv docs/dox/html html
  66. # Trim exported dependecies
  67. sed -ri '/^dependency_libs/{s,-l(uuid|crypt) ,,g}' \
  68. $RPM_BUILD_ROOT%{_libdir}/libapr*.la
  69. sed -ri '/^LIBS=/{s,-l(uuid|crypt) ,,g;s/ */ /g}' \
  70. $RPM_BUILD_ROOT%{_bindir}/apr-%{aprver}-config
  71. %ifarch %{multilib_arches}
  72. # Ugly hack to allow parallel installation of 32-bit and 64-bit apr-devel
  73. # packages:
  74. mv $RPM_BUILD_ROOT%{_includedir}/apr-%{aprver}/apr.h \
  75. $RPM_BUILD_ROOT%{_includedir}/apr-%{aprver}/apr-%{_arch}.h
  76. install -c -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_includedir}/apr-%{aprver}/apr.h
  77. %endif
  78. # Unpackaged files:
  79. rm -f $RPM_BUILD_ROOT%{_libdir}/apr.exp
  80. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
  81. %check
  82. # Fail if LFS support isn't present in a 32-bit build, since this
  83. # breaks ABI and the soname doesn't change: see #254241
  84. if grep 'define SIZEOF_VOIDP 4' include/apr.h \
  85. && ! grep off64_t include/apr.h; then
  86. cat config.log
  87. : LFS support not present in 32-bit build
  88. exit 1
  89. fi
  90. %clean
  91. rm -rf $RPM_BUILD_ROOT
  92. %post -p /sbin/ldconfig
  93. %postun -p /sbin/ldconfig
  94. %files
  95. %defattr(-,root,root,-)
  96. %doc CHANGES LICENSE NOTICE
  97. %{_libdir}/libapr-%{aprver}.so.*
  98. %files devel
  99. %defattr(-,root,root,-)
  100. %doc docs/APRDesign.html docs/canonical_filenames.html
  101. %doc docs/incomplete_types docs/non_apr_programs
  102. %doc --parents html
  103. %{_bindir}/apr-%{aprver}-config
  104. %{_libdir}/libapr-%{aprver}.a
  105. %{_libdir}/libapr-%{aprver}.so
  106. %{_libdir}/pkgconfig/*.pc
  107. %dir %{_libdir}/apr-%{aprver}
  108. %dir %{_libdir}/apr-%{aprver}/build
  109. %{_libdir}/apr-%{aprver}/build/*
  110. %dir %{_includedir}/apr-%{aprver}
  111. %{_includedir}/apr-%{aprver}/*.h
  112. %changelog
  113. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.10-1
  114. - rebuilt with new toolchain
  115. * Thu Dec 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.9-1
  116. - new upstream release
  117. * Mon Aug 10 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.8-1
  118. - new upstream release with security fix (CVE-2009-2412)
  119. * Mon Jun 08 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.5-1
  120. - new upstream release
  121. * Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.3-1vl5
  122. - new upstream release
  123. - updated Patch5
  124. * Wed Jun 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.0-1vl5
  125. - new upstream release
  126. - removed Patch1 and 6
  127. * Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-2vl5
  128. - removed *.la files from devel package
  129. * Sat Apr 5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-1vl5
  130. - new upstream release
  131. - added Patch2 and 6 from Fedora
  132. * Mon Jun 19 2006 Joe Orton <jorton@redhat.com> 1.2.7-9
  133. - add fix for use of %%pI with psprintf
  134. * Thu Nov 24 2005 Joe Orton <jorton@redhat.com> 0.9.7-3
  135. - use RTLD_DEEPBIND in apr_dso_open by default
  136. * Sat Sep 29 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.11-0vl1
  137. - new upstream release
  138. * Thu Jul 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.9-0vl1
  139. - new upstream release
  140. * Mon May 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl3
  141. - remove Requires: gcc = %%(gcc -dumpversion)
  142. * Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.8-0vl2
  143. - rebuilt with new toolchain
  144. * Sat Jan 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8-0vl1
  145. - new upstream release
  146. * Mon May 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-0vl1
  147. - initial build for Vine Linux based on FC package
  148. * Tue May 23 2006 Joe Orton <jorton@redhat.com> 1.2.7-7
  149. - fix another multilib conflict (#192659)
  150. * Tue May 16 2006 Joe Orton <jorton@redhat.com> 1.2.7-6
  151. - BR e2fsprogs-devel for libuuid
  152. * Mon May 8 2006 Joe Orton <jorton@redhat.com> 1.2.7-4
  153. - use multilib parallel-installation wrapper hack for apr.h
  154. * Tue May 2 2006 Joe Orton <jorton@redhat.com> 1.2.7-3
  155. - fix installbuilddir in apr-1-config
  156. * Tue May 2 2006 Joe Orton <jorton@redhat.com> 1.2.7-2
  157. - update to 1.2.7
  158. - use pkg-config in apr-1-config to make it libdir-agnostic
  159. * Thu Apr 6 2006 Joe Orton <jorton@redhat.com> 1.2.6-2
  160. - update to 1.2.6
  161. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.2.2-7.2
  162. - bump again for double-long bug on ppc(64)
  163. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.2.2-7.1
  164. - rebuilt for new gcc4.1 snapshot and glibc changes
  165. * Wed Jan 4 2006 Joe Orton <jorton@redhat.com> 1.2.2-7
  166. - fix namespace pollution (r354824, r355464)
  167. * Wed Jan 4 2006 Joe Orton <jorton@redhat.com> 1.2.2-6
  168. - fix build with recent glibc (#176911)
  169. * Tue Jan 3 2006 Jesse Keating <jkeating@redhat.com> 1.2.2-5.2
  170. - rebuilt again
  171. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  172. - rebuilt
  173. * Fri Dec 9 2005 Joe Orton <jorton@redhat.com> 1.2.2-5
  174. - rebuild for new gcc
  175. * Thu Dec 8 2005 Joe Orton <jorton@redhat.com> 1.2.2-4
  176. - add apr_file_seek() fixes from upstream (r326593, r326597)
  177. * Wed Dec 7 2005 Joe Orton <jorton@redhat.com> 1.2.2-3
  178. - apr-1-config: strip more exports (#175124)
  179. * Tue Dec 6 2005 Joe Orton <jorton@redhat.com> 1.2.2-2
  180. - avoid linking against -lrt
  181. - don't print -L${libdir} in --libs output
  182. - don't export -lcrypt/-luuid in .la file
  183. * Fri Dec 2 2005 Joe Orton <jorton@redhat.com> 1.2.2-1
  184. - update to 1.2.2
  185. * Thu Nov 24 2005 Joe Orton <jorton@redhat.com> 0.9.7-3
  186. - use RTLD_DEEPBIND in apr_dso_open by default
  187. * Thu Oct 20 2005 Joe Orton <jorton@redhat.com> 0.9.7-2
  188. - update to 0.9.7
  189. * Fri Sep 30 2005 Florian La Roche <laroche@redhat.com>
  190. - rebuild for new gcc
  191. * Thu Sep 15 2005 Joe Orton <jorton@redhat.com> 0.9.6-6
  192. - don't override CFLAGS at build time
  193. - allow setting TCP_NODELAY and TCP_CORK concurrently
  194. - use _exit() not exit() in child if exec*() fails (upstream #30913)
  195. * Fri Sep 9 2005 Joe Orton <jorton@redhat.com> 0.9.6-5
  196. - add from 0.9.x branch:
  197. * fix for apr_{uid,gid}_* error handling (r239592)
  198. * fix for apr_file_ write flushing (r267192)
  199. - add backport for use of readdir64_r (r265032, r265681, r265684)
  200. * Mon Jul 11 2005 Florian La Roche <laroche@redhat.com>
  201. - rebuild
  202. * Tue May 17 2005 Joe Orton <jorton@redhat.com> 0.9.6-3
  203. - fix apr_procattr_child_*_set error handling
  204. * Tue Mar 1 2005 Joe Orton <jorton@redhat.com> 0.9.6-2
  205. - have apr-devel depend on specific version of gcc
  206. - add NOTICE to docdir
  207. * Wed Feb 9 2005 Joe Orton <jorton@redhat.com> 0.9.6-1
  208. - update to 0.9.6
  209. * Wed Feb 2 2005 Joe Orton <jorton@redhat.com> 0.9.5-4
  210. - don't disable sendfile on s390 (IBM LTC, #146891)
  211. * Mon Nov 22 2004 Joe Orton <jorton@redhat.com> 0.9.5-3
  212. - really fix apr-config --srcdir
  213. * Mon Nov 22 2004 Joe Orton <jorton@redhat.com> 0.9.5-2
  214. - fix apr-config --srcdir again
  215. * Sun Nov 21 2004 Joe Orton <jorton@redhat.com> 0.9.5-1
  216. - update to 0.9.5
  217. * Mon Sep 27 2004 Joe Orton <jorton@redhat.com> 0.9.4-24
  218. - rebuild
  219. * Wed Sep 1 2004 Joe Orton <jorton@redhat.com> 0.9.4-23
  220. - have -devel require apr of same V-R
  221. * Tue Aug 31 2004 Joe Orton <jorton@redhat.com> 0.9.4-22
  222. - backport fixes from HEAD:
  223. * correct implementation of nested mutexes
  224. * support for POSIX semaphores on LP64 platforms
  225. * Thu Jul 15 2004 Joe Orton <jorton@redhat.com> 0.9.4-21
  226. - rebuild for another attempt at using sem_open
  227. * Tue Jul 13 2004 Joe Orton <jorton@redhat.com> 0.9.4-20
  228. - move sticky/suid bits outside APR_OS_DEFAULT bitmask (Greg Hudson)
  229. * Thu Jul 1 2004 Joe Orton <jorton@redhat.com> 0.9.4-19
  230. - rebuild
  231. * Wed Jun 30 2004 Joe Orton <jorton@redhat.com> 0.9.4-18
  232. - rebuild now /dev/shm is mounted
  233. * Thu Jun 17 2004 Joe Orton <jorton@redhat.com> 0.9.4-17
  234. - add fix for cleanup structure reuse (part of upstream #23567)
  235. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  236. - rebuilt
  237. * Thu Jun 10 2004 Joe Orton <jorton@redhat.com> 0.9.4-15
  238. - add support for setuid/setgid/sticky bits (Andr辿 Malo)
  239. - add apr_threadattr_{guardsize,stacksize}_set() (latter by Jeff Trawick)
  240. * Mon Jun 7 2004 Joe Orton <jorton@redhat.com> 0.9.4-14
  241. - enable posixsem and process-shared pthread mutex support, but
  242. ensure that sysvsem remains the default mechanism
  243. * Mon May 24 2004 Joe Orton <jorton@redhat.com> 0.9.4-13
  244. - entirely remove 2Gb file size limit from apr_file_copy();
  245. fixes "svnadmin hotcopy" on repos with >2Gb strings table
  246. - work around getnameinfo bugs with v4-mapped addresses
  247. - fix apr_time_exp_get() for dates in 2038 (Philip Martin)
  248. * Thu May 13 2004 Joe Orton <jorton@redhat.com> 0.9.4-12
  249. - use APR_LARGEFILE in apr_file_{copy,append}
  250. * Wed Mar 24 2004 Joe Orton <jorton@redhat.com> 0.9.4-11
  251. - add APR_LARGEFILE flag
  252. * Mon Mar 15 2004 Joe Orton <jorton@redhat.com> 0.9.4-10
  253. - fix configure check for mmap of /dev/zero
  254. - just put -D_GNU_SOURCE in CPPFLAGS not _{BSD,SVID,XOPEN}_SOURCE
  255. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com> 0.9.4-9.1
  256. - rebuilt
  257. * Thu Feb 19 2004 Joe Orton <jorton@redhat.com> 0.9.4-9
  258. - undocument apr_dir_read() ordering constraint and fix tests
  259. * Sun Feb 15 2004 Joe Orton <jorton@redhat.com> 0.9.4-8
  260. - rebuilt without -Wall -Werror
  261. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com> 0.9.4-7
  262. - rebuilt
  263. * Tue Feb 3 2004 Joe Orton <jorton@redhat.com> 0.9.4-6
  264. - define apr_off_t as int/long/... to prevent it changing
  265. with _FILE_OFFSET_BITS on 32-bit platforms
  266. * Mon Jan 12 2004 Joe Orton <jorton@redhat.com> 0.9.4-5
  267. - add apr_temp_dir_get fixes from HEAD
  268. * Thu Jan 8 2004 Joe Orton <jorton@redhat.com> 0.9.4-4
  269. - ensure that libapr is linked against libpthread
  270. - don't link libapr against -lnsl
  271. * Thu Nov 13 2003 Joe Orton <jorton@redhat.com> 0.9.4-3
  272. - -devel package no longer requires libtool
  273. * Fri Oct 3 2003 Joe Orton <jorton@redhat.com> 0.9.4-2
  274. - disable tests on x86_64 (#97611)
  275. * Fri Oct 3 2003 Joe Orton <jorton@redhat.com> 0.9.4-1
  276. - update to 0.9.4, enable tests
  277. - ensure that libresolv is not used
  278. * Sun Sep 7 2003 Joe Orton <jorton@redhat.com> 0.9.3-14
  279. - use /dev/urandom (#103049)
  280. * Thu Jul 24 2003 Joe Orton <jorton@redhat.com> 0.9.3-13
  281. - add back CC=gcc, CXX=g++
  282. * Tue Jul 22 2003 Nalin Dahyabhai <nalin@redhat.com> 0.9.3-12
  283. - rebuild
  284. * Mon Jul 14 2003 Joe Orton <jorton@redhat.com> 0.9.3-11
  285. - work round useless autoconf 2.57 AC_DECL_SYS_SIGLIST
  286. * Thu Jul 10 2003 Joe Orton <jorton@redhat.com> 0.9.3-10
  287. - support --cc and --cpp arguments in apr-config
  288. * Thu Jul 3 2003 Joe Orton <jorton@redhat.com> 0.9.3-9
  289. - force libtool to use CC=gcc, CXX=g++
  290. * Thu Jul 3 2003 Joe Orton <jorton@redhat.com> 0.9.3-8
  291. - fix libtool location in apr_rules.mk
  292. * Mon Jun 30 2003 Joe Orton <jorton@redhat.com> 0.9.3-7
  293. - use AI_ADDRCONFIG in getaddrinfo() support (#73350)
  294. - include a working libtool script rather than relying on
  295. /usr/bin/libtool (#97695)
  296. * Wed Jun 18 2003 Joe Orton <jorton@redhat.com> 0.9.3-6
  297. - don't use /usr/bin/libtool
  298. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  299. - rebuilt
  300. * Tue May 20 2003 Joe Orton <jorton@redhat.com> 0.9.3-5
  301. - add fix for psprintf memory corruption (CAN-2003-0245)
  302. - remove executable bit from apr_poll.h
  303. * Thu May 1 2003 Joe Orton <jorton@redhat.com> 0.9.3-4
  304. - link libapr against libpthread
  305. - make apr-devel conflict with old subversion-devel
  306. - fix License
  307. * Tue Apr 29 2003 Joe Orton <jorton@redhat.com> 0.9.3-3
  308. - run ldconfig in post/postun
  309. * Tue Apr 29 2003 Joe Orton <jorton@redhat.com> 0.9.3-2
  310. - patch test suite to not care if IPv6 is disabled
  311. * Mon Apr 28 2003 Joe Orton <jorton@redhat.com> 0.9.3-1
  312. - initial build