aqbanking-vl.spec 7.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269
  1. %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  2. Name: aqbanking
  3. Summary: A library for online banking functions and financial data import/export
  4. Version: 3.7.2
  5. Release: 1%{?_dist_release}
  6. Source: http://download.sourceforge.net/aqbanking/%{name}-%{version}.tar.gz
  7. Group: System Environment/Libraries
  8. License: GPLv2+
  9. URL: http://www.aquamaniac.de/aqbanking/
  10. Patch2: aqbanking-3.7.2-pkgconfig.patch
  11. Patch3: aqbanking-2.1.0-conflict.patch
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. # qbanking
  14. BuildRequires: qt-devel
  15. # python
  16. BuildRequires: python, PyXML, gmp-devel
  17. BuildRequires: gwenhywfar-devel >= 3.4.1
  18. BuildRequires: libofx-devel >= 0.9.0
  19. BuildRequires: gettext
  20. BuildRequires: libtool
  21. Requires(post): /sbin/ldconfig
  22. Requires(postun): /sbin/ldconfig
  23. Obsoletes: aqhbci <= 1.0.3
  24. Obsoletes: g2banking < %{version}
  25. %description
  26. The intention of AqBanking is to provide a middle layer between the
  27. program and the various Online Banking libraries (e.g. AqHBCI). The
  28. first backend which is already supported is AqHBCI, a library which
  29. implements a client for the German HBCI (Home Banking Computer
  30. Interface) protocol. Additionally, Aqbanking provides various plugins
  31. to simplify import and export of financial data. Currently there are
  32. import plugins for the following formats: DTAUS (German financial
  33. format), SWIFT (MT940 and MT942).
  34. %package devel
  35. Summary: Development headers for Aqbanking
  36. Group: Development/Libraries
  37. Requires: %{name} = %{version}-%{release}
  38. Requires: pkgconfig
  39. # for %{_datadir}/aclocal
  40. Requires: automake
  41. Obsoletes: aqhbci-devel <= 1.0.3
  42. Obsoletes: g2banking-devel < %{version}
  43. %description devel
  44. This package contains aqbanking-config and header files for writing and
  45. compiling programs using Aqbanking.
  46. %package -n qbanking
  47. Summary: Qt bindings for Aqbanking
  48. Group: System Environment/Libraries
  49. Requires: %{name} = %{version}-%{release}
  50. Requires(post): /sbin/ldconfig
  51. Requires(postun): /sbin/ldconfig
  52. Obsoletes: aqhbci-qt-tools <= 1.0.3
  53. Obsoletes: kbanking < %{version}
  54. %description -n qbanking
  55. This package contains the qbanking KDE bindings for the Aqbanking
  56. online banking library.
  57. %package -n qbanking-devel
  58. Summary: Development headers for qbanking
  59. Group: Development/Libraries
  60. Requires: %{name}-devel = %{version}-%{release}
  61. Requires: qbanking = %{version}-%{release}
  62. Requires: pkgconfig
  63. Requires: qt-devel
  64. Obsoletes: kbanking-devel < %{version}
  65. %description -n qbanking-devel
  66. This package contains qbanking-config and header files for writing and
  67. compiling programs using the qbanking bindings for Aqbanking.
  68. %package -n python-%{name}
  69. Summary: Python bindings for Aqbanking
  70. Group: Development/Libraries
  71. Requires: %{name} = %{version}-%{release}
  72. %description -n python-%{name}
  73. This package contains python bindings for Aqbanking.
  74. %prep
  75. %setup -q
  76. %patch2 -p1 -b .pkgconfig
  77. %patch3 -p1 -b .conflict
  78. %build
  79. [ -z "$QTDIR" ] && . /etc/profile.d/qt.sh
  80. %{configure} --disable-static \
  81. --with-kde3-libs=%{_libdir} \
  82. --enable-libofx \
  83. --enable-python
  84. make LIBTOOL=/usr/bin/libtool
  85. %install
  86. rm -rf $RPM_BUILD_ROOT
  87. make DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool install
  88. find $RPM_BUILD_ROOT -name *.la -exec rm -f {} \;
  89. find $RPM_BUILD_ROOT -name *.a -exec rm -f {} \;
  90. cd tutorials
  91. make clean
  92. rm -rf .deps
  93. cd ..
  94. mkdir -p $RPM_BUILD_ROOT/%{_datadir}/doc/%{name}-%{version}
  95. mv $RPM_BUILD_ROOT/%{_datadir}/doc/{aqbanking,aqhbci} $RPM_BUILD_ROOT/%{_datadir}/doc/%{name}-%{version}
  96. mv AUTHORS README COPYING ChangeLog NEWS $RPM_BUILD_ROOT/%{_datadir}/doc/%{name}-%{version}
  97. %find_lang %{name}
  98. %clean
  99. rm -rf $RPM_BUILD_ROOT
  100. %post -p /sbin/ldconfig
  101. %postun -p /sbin/ldconfig
  102. %post -n qbanking -p /sbin/ldconfig
  103. %postun -n qbanking -p /sbin/ldconfig
  104. %files -f %{name}.lang
  105. %defattr(-,root,root)
  106. %doc %{_datadir}/doc/%{name}-%{version}
  107. %{_libdir}/libaq*.so.*
  108. %{_libdir}/aqbanking
  109. %exclude %{_libdir}/aqbanking/plugins/*/debugger
  110. %exclude %{_libdir}/aqbanking/plugins/*/frontends/qbanking
  111. %exclude %{_libdir}/aqbanking/plugins/*/wizards
  112. %{_libdir}/gwenhywfar/*
  113. %{_datadir}/aqbanking
  114. %exclude %{_datadir}/aqbanking/frontends/*
  115. %exclude %{_datadir}/aqbanking/i18n
  116. %{_bindir}/*-tool3
  117. %files devel
  118. %defattr(-,root,root)
  119. %doc doc/0[12]* tutorials
  120. %{_bindir}/hbcixml3
  121. %{_bindir}/aq*-config
  122. %{_libdir}/libaq*.so
  123. %{_includedir}/aq*
  124. %{_libdir}/pkgconfig/*
  125. %{_datadir}/aclocal/aq*
  126. %files -n qbanking
  127. %defattr(-,root,root)
  128. %{_bindir}/qb-help5
  129. %{_libdir}/libqbanking.so.*
  130. %{_libdir}/aqbanking/plugins/*/debugger
  131. %{_libdir}/aqbanking/plugins/*/frontends/qbanking
  132. %{_libdir}/aqbanking/plugins/*/wizards
  133. %{_datadir}/aqbanking/i18n
  134. %{_datadir}/aqbanking/frontends/qbanking
  135. %files -n qbanking-devel
  136. %defattr(-,root,root)
  137. %{_includedir}/qbanking
  138. %{_libdir}/libqbanking.so
  139. %files -n python-%{name}
  140. %defattr(-,root,root)
  141. %{python_sitelib}/%{name}
  142. %changelog
  143. * Sat Oct 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.7.1-1
  144. - update to 3.7.2
  145. - obsolete the no-longer-existing g2banking/kbanking packages
  146. * Mon Jan 21 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.3.3-0vl1
  147. - update to 2.3.3
  148. * Sat Dec 29 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.3.2-2vl1
  149. - modify and build for VineSeed
  150. * Wed Aug 29 2007 Bill Nottingham <notting@redhat.com> - 2.3.2-2
  151. - Rebuild for selinux ppc32 issue.
  152. - fix build with current glibc/headers
  153. * Fri Aug 3 2007 Bill Nottingham <notting@redhat.com>
  154. - tweak license tag
  155. * Wed Jul 11 2007 Bill Nottingham <notting@redhat.com> - 2.3.2-1
  156. - update to 2.3.2
  157. * Mon Jun 25 2007 Bill Nottingham <notting@redhat.com> - 2.2.9-3
  158. - fix some build bogosity
  159. * Wed Jun 20 2007 Bill Nottingham <notting@redhat.com> - 2.2.9-2
  160. - add a dist tag
  161. * Mon Mar 19 2007 Bill Nottingham <notting@redhat.com> - 2.2.9-1
  162. - update to 2.2.9
  163. * Wed Jan 17 2007 Bill Nottingham <notting@redhat.com> - 2.1.0-14
  164. - fix docdir, obsoletes for aqhbci-devel, and %%clean
  165. * Tue Jan 16 2007 Bill Nottingham <notting@redhat.com> - 2.1.0-13
  166. - fix docs
  167. - add PyXML buildreq
  168. * Mon Jan 15 2007 Bill Nottingham <notting@redhat.com> - 2.1.0-12
  169. - fix missing %%defattrs
  170. - fix %%excludes
  171. - other cleanups from review
  172. - use %%{_python_sitelib}
  173. - require automake
  174. - twiddle aqhbci obsoletes
  175. * Sat Jan 13 2007 Bill Nottingham <notting@redhat.com> - 2.1.0-11
  176. - split into a variety of packages
  177. * Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 2.1.0-10
  178. - rebuild for python 2.5
  179. * Thu Sep 7 2006 Bill Nottingham <notting@redhat.com> - 2.1.0-9
  180. - rebuild for fixed debuginfo (#205248)
  181. * Fri Sep 1 2006 Bill Nottingham <notting@redhat.com> - 2.1.0-8
  182. - fix multilib conficts (#205204)
  183. * Mon Aug 28 2006 Bill Nottingham <notting@redhat.com> - 2.1.0-4
  184. - rebuild against latest libofx
  185. * Tue Aug 1 2006 Bill Nottingham <notting@redhat.com> - 2.1.0-3
  186. - reenable visibility
  187. * Fri Jul 14 2006 Bill Nottingham <notting@redhat.com> - 2.1.0-2
  188. - port *-config to pkgconfig
  189. - don't use -fvisibility=hidden
  190. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.1.0-1.1
  191. - rebuild
  192. * Tue Jul 11 2006 Bill Nottingham <notting@redhat.com> - 2.1.0-1
  193. - update to 2.1.0
  194. * Mon Jun 12 2006 Bill Nottingham <notting@redhat.com> - 1.8.1beta-5
  195. - buildreq autoconf, libtool
  196. * Tue May 30 2006 Bill Nottingham <notting@redhat.com> - 1.8.1beta-4
  197. - add gettext buildreq (#193348)
  198. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.8.1beta-3.1
  199. - bump again for double-long bug on ppc(64)
  200. * Tue Feb 07 2006 Karsten Hopp <karsten@redhat.de> 1.8.1beta-3
  201. - buildrequire libofx-devel instead of libofx (pulls in libofx)
  202. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.8.1beta-2.1
  203. - rebuilt for new gcc4.1 snapshot and glibc changes
  204. * Sun Jan 22 2006 Bill Nottingham <notting@redhat.com> 1.8.1beta-2
  205. - add an obsolete (#178554)
  206. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  207. - rebuilt
  208. * Mon Mar 7 2005 Bill Nottingham <notting@redhat.com> 1.0.4beta-2
  209. - rebuild
  210. * Wed Feb 9 2005 Bill Nottingham <notting@redhat.com> 1.0.4beta-1
  211. - initial packaging, adopt upstream specfile