123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120 |
- Summary: A unit test framework for C
- Summary(ja): C 言語用単体テストフレームワーク
- Name: check
- Version: 0.9.8
- Release: 1%{?_dist_release}
- License: LGPL
- Group: Development/Tools
- URL: http://check.sourceforge.net/
- Source0: http://prdownloads.sourceforge.net/check/%{name}-%{version}.tar.gz
- Patch0: %{name}-examples-bootstrap.patch
- Patch1: check-0.9.5-fPIC.patch
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- BuildRequires: docbook-utils
- Requires(post,preun): /sbin/install-info
- Vendor: Project Vine
- Distribution: Vine Linux
- Packager: USAMI Kosuke <usami-k@yc5.so-net.ne.jp>
- %description
- Check is a unit test framework for C. It features a simple interface
- for defining unit tests, putting little in the way of the developer.
- Tests are run in a separate address space, so Check can catch both
- assertion failures and code errors that cause segmentation faults or
- other signals. The output from unit tests can be used within source
- code editors and IDEs.
- %package devel
- Summary: Libraries and headers for developing programs with check
- Summary(ja): Check を使ったプログラム開発用ライブラリとヘッダファイル
- Group: Development/Libraries
- Requires: pkgconfig
- Requires: %{name} = %{version}-%{release}
- %description devel
- Libraries and headers for developing programs with check
- %prep
- %setup -q
- %patch0 -p1
- #patch1 -p1 -b .fPIC
- %build
- %configure --disable-static
- make %{?_smp_mflags}
- %install
- rm -rf $RPM_BUILD_ROOT
- %makeinstall
- rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
- rm -rf $RPM_BUILD_ROOT%{_infodir}/dir
- rm -rf example
- cp -pr $RPM_BUILD_ROOT%{_datadir}/doc/check/example .
- rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/check
- %clean
- rm -rf $RPM_BUILD_ROOT
- %post
- /sbin/ldconfig
- /sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir || :
- %postun -p /sbin/ldconfig
- %preun
- if [ $1 = 0 ]; then
- /sbin/install-info --delete %{_infodir}/%{name}.info %{_infodir}/dir || :
- fi
- %files
- %defattr(-,root,root)
- %doc AUTHORS COPYING.LESSER ChangeLog ChangeLogOld NEWS README SVNChangeLog
- %{_libdir}/libcheck.so.*
- %{_infodir}/check.info*
- %files devel
- %defattr(-,root,root)
- %doc example
- %{_includedir}/check.h
- %{_libdir}/libcheck.so
- %{_libdir}/pkgconfig/check.pc
- %{_datadir}/aclocal/check.m4
- %changelog
- * Sat Apr 24 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.9.8-1
- - new upstream release
- - dropt Patch1
- * Mon May 26 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.9.5-2
- - spec in UTF-8
- - split devel subpackage
- * Sat Apr 5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.5-1vl5
- - new upstream release
- - updated Patch1
- * Mon Sep 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.3-0vl2
- - enable -fPIC to build gstreamer on x86_64
- * Mon Jan 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.3-0vl1
- - upstream release
- - add BuildRequires: docbook-utils instead of lyx
- * Fri Aug 1 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 0.8.4-0vl2
- - Rebuild for new Vine.
- * Wed Jun 18 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> 0.8.4-0vl1
- - Initial build.
|