epiphany-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357
  1. # gecko backend was removed 2.27.0
  2. %define with_gecko 0
  3. %define with_webkit 1
  4. %define gecko_version 1.9.1
  5. %define webkit_version 1.1.15
  6. ExclusiveArch: %ix86 ppc x86_64 alpha
  7. Summary: GNOME web browser based on Gecko/WebKit
  8. Summary(ja): Gecko/WebKit レンダリングエンジンベースの GNOME ウェブブラウザ
  9. Name: epiphany
  10. Version: 2.30.0
  11. Release: 1%{?_dist_release}
  12. License: GPL
  13. Group: Applications/Internet
  14. URL: http://www.gnome.org/projects/epiphany/
  15. Source0: http://ftp.gnome.org/pub/GNOME/sources/epiphany/2.28/%{name}-%{version}.tar.bz2
  16. Patch1: epiphany-2.26.2-gecko191.patch
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  18. Requires: gnome-icon-theme >= 2.30.0
  19. %if %{with_gecko}
  20. Requires: gecko-libs
  21. %endif
  22. Requires(post,pre,preun): GConf2
  23. Requires(post,postun): scrollkeeper, shared-mime-info
  24. %if %{with_gecko}
  25. BuildRequires: gecko-devel-unstable >= %{gecko_version}
  26. %endif
  27. %if %{with_webkit}
  28. BuildRequires: WebKit-gtk-devel >= %{webkit_version}
  29. %endif
  30. BuildRequires: glib2-devel >= 2.24.0
  31. BuildRequires: gtk2-devel >= 2.20.0
  32. BuildRequires: libxml2-devel >= 2.6.12
  33. BuildRequires: libxslt-devel >= 1.1.7
  34. BuildRequires: libnotify-devel >= 0.4.0
  35. BuildRequires: dbus-glib-devel >= 0.35
  36. BuildRequires: libsoup-devel >= 2.30.0
  37. BuildRequires: gnome-desktop-devel >= 2.30.0
  38. BuildRequires: GConf2-devel
  39. BuildRequires: nss-devel
  40. BuildRequires: avahi-gobject-devel >= 0.6.22
  41. BuildRequires: NetworkManager-devel
  42. BuildRequires: iso-codes
  43. BuildRequires: intltool >= 0.40
  44. BuildRequires: libICE-devel
  45. BuildRequires: libSM-devel
  46. BuildRequires: libgnome-keyring-devel
  47. BuildRequires: gobject-introspection-devel
  48. BuildRequires: gir-repository-devel
  49. BuildRequires: gnome-doc-utils
  50. %description
  51. epiphany is a simple GNOME web browser based on the Mozilla rendering
  52. engine
  53. %description -l ja
  54. epiphany は Mozilla レンダリングエンジンベースのシンプルな GNOME
  55. ウェブブラウザです。
  56. %prep
  57. %setup -q
  58. #patch1 -p1
  59. %build
  60. MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %{__sed} -e 's/-O2/-Os/' -e 's/-Wall//')
  61. export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
  62. %configure \
  63. %if %{with_gecko}
  64. --with-gecko=libxul-embedding \
  65. %endif
  66. %if %{with_webkit}
  67. --with-engine=webkit \
  68. %endif
  69. --enable-zeroconf \
  70. --enable-network-manager \
  71. --disable-scrollkeeper \
  72. --without-ca-file
  73. %__make %{?_smp_mflags}
  74. %install
  75. rm -rf $RPM_BUILD_ROOT
  76. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  77. make install DESTDIR=$RPM_BUILD_ROOT
  78. unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
  79. %find_lang %{name} --with-gnome
  80. rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
  81. rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/*/plugins/*.la
  82. rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
  83. %pre
  84. if [ "$1" -gt 1 ]; then
  85. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  86. SCHEMAS="epiphany.schemas epiphany-lockdown.schemas"
  87. for S in $SCHEMAS; do
  88. gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/$S > /dev/null
  89. done
  90. fi
  91. %post
  92. touch --no-create %{_datadir}/icons/hicolor >& /dev/null ||:
  93. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  94. SCHEMAS="epiphany.schemas epiphany-lockdown.schemas"
  95. for S in $SCHEMAS; do
  96. gconftool-2 --makefile-install-rule /etc/gconf/schemas/$S > /dev/null
  97. done
  98. %preun
  99. if [ "$1" -eq 0 ]; then
  100. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  101. SCHEMAS="epiphany.schemas epiphany-lockdown.schemas"
  102. for S in $SCHEMAS; do
  103. gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/$S > /dev/null
  104. done
  105. fi
  106. %postun
  107. if [ $1 -eq 0 ] ; then
  108. touch --no-create %{_datadir}/icons/hicolor >& /dev/null ||:
  109. gtk-update-icon-cache -q %{_datadir}/icons/hicolor >& /dev/null ||:
  110. update-desktop-database %{_datadir}/applications >& /dev/null ||:
  111. scrollkeeper-update >& /dev/null ||:
  112. fi
  113. %posttrans
  114. gtk-update-icon-cache -q %{_datadir}/icons/hicolor >& /dev/null ||:
  115. update-desktop-database %{_datadir}/applications >& /dev/null ||:
  116. scrollkeeper-update >& /dev/null ||:
  117. %clean
  118. rm -rf $RPM_BUILD_ROOT
  119. %files -f %{name}.lang
  120. %defattr(-,root,root,-)
  121. %doc AUTHORS ChangeLog* COPYING* NEWS README
  122. %{_sysconfdir}/gconf/schemas/epiphany*.schemas
  123. %{_bindir}/epiphany
  124. %{_includedir}/epiphany/*
  125. %{_libdir}/pkgconfig/epiphany*.pc
  126. %{_libdir}/girepository-1.0/Epiphany-2.29.typelib
  127. %if %{with_gecko}
  128. %{_libdir}/epiphany
  129. %endif
  130. %{_datadir}/gir-1.0/Epiphany-2.29.gir
  131. #{_datadir}/pygtk/*/defs/*
  132. %{_datadir}/applications/*.desktop
  133. %{_datadir}/epiphany
  134. %{_datadir}/gtk-doc/html/*
  135. %{_datadir}/icons/*
  136. %{_datadir}/aclocal/*
  137. %{_datadir}/dbus-1/services/*
  138. %{_mandir}/man1/epiphany.1*
  139. %changelog
  140. * Sat Apr 17 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  141. - new upstream release
  142. - add BuildRequires: gobject-introspection-devel, gir-repository-devel
  143. - change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
  144. - add configure option (--without-ca-file)
  145. - remove unrecognized configure option (--with-engine)
  146. * Sat Jan 09 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.2-1
  147. - new upstream release
  148. - added BR: libICE-devel, libSM-devel and gnome-keyring-devel
  149. * Sat Nov 07 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
  150. - new upstream release
  151. * Mon Jul 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-2
  152. - run gtk-update-icon-cache in %%post/postun script.
  153. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
  154. - new upstream release
  155. * Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
  156. - rebuild with gecko-1.9.1
  157. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
  158. - new upstream release
  159. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
  160. - new upstream release
  161. - build with xulrunner-1.9.0.7
  162. * Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
  163. - new upstream release
  164. * Wed Oct 01 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-2
  165. - build with gecko-1.9.0.3 instead of WebKit.
  166. - WebKit port is unstable yet.
  167. - enable zeroconf, NetworkManager support
  168. * Thu Sep 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-1
  169. - new upstream release
  170. * Thu Jul 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.1.1-2vl5
  171. - build with WebKit instead of gecko.
  172. * Sun Apr 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
  173. - new upstream release
  174. - added %%pre and %%preun section
  175. * Fri Aug 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.3-0vl1
  176. - new upstream release
  177. - rebuilt with firefox-2.0.0.6-0vl3
  178. * Sun Jul 08 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.2-0vl2
  179. - add BuildRequires: gnome-python
  180. * Sun Jun 10 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl1
  181. - new upstream release
  182. - rebuilt with new toolchain and firefox-2.0.0.4-0vl6
  183. * Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
  184. - new upstream release
  185. * Tue Nov 21 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.14.3-0vl1
  186. - source update
  187. - add Patch0 to build with firefox 2.0 <BTS:VineLinux:342>
  188. - add BuildRequires: pygtk2-devel
  189. * Sun Jun 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2.1-0vl1
  190. - new upstream release
  191. * Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
  192. - rebuild with firefox-1.5.0.2-0vl4
  193. * Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
  194. - new upstream release
  195. - build with firefox-1.5.0.2
  196. * Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
  197. - new upstream release
  198. * Thu Feb 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.3-0vl1
  199. - new upstream release
  200. - build with firefox-1.5.0.1
  201. * Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-0vl1
  202. - new upstream release
  203. - build with mozilla-1.7.12
  204. * Fri May 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.3-0vl2
  205. - rebuild with mozilla-1.7.8
  206. * Sun Apr 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.3-0vl1
  207. - new upstream release
  208. * Sun Apr 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.2-0vl1
  209. - new upstream release
  210. - build with mozilla-1.7.7
  211. * Fri Apr 1 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl2
  212. - rebuild with mozilla-1.7.6
  213. * Wed Mar 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl1
  214. - new upstream release
  215. * Sun Dec 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.7-0vl1
  216. - new upstream release
  217. - build with mozilla-1.7.5
  218. * Tue Nov 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.6-0vl1
  219. - new upstream release
  220. * Tue Nov 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.5-0vl1
  221. - new upstream release
  222. * Mon Sep 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl2
  223. - rebuild with mozilla-1.7.3
  224. * Wed Aug 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl1
  225. - new upstream release
  226. - build with mozilla-1.7.2
  227. - add Patch10 to build with gnome-2.4
  228. * Wed Jan 21 2004 Satoshi MACHINO <machino@vinelinux.org> 1.0.7-0vl1
  229. - new upstream version
  230. -- dropped patch10
  231. - changed URL
  232. * Fri Jan 9 2004 Tomoya TAKA <taka@vinelinux.org> 1.0.6-0vl3
  233. - add alpha into ExclusiveArch
  234. * Mon Dec 29 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-0vl2
  235. - rebuild with mozilla-1.5.1
  236. * Sat Dec 6 2003 Ryoichi INAGAKI <daisuke@linux.or.jp> 1.0.6-0vl1
  237. - new upstream release
  238. * Sat Oct 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.3-0vl1
  239. - new upstream release
  240. * Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0-0vl2
  241. - fixed missing locale files
  242. * Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0-0vl1
  243. - new upstream release
  244. * Thu Sep 04 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3-0vl1
  245. - new upstream release
  246. * Sun Jul 20 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.0-0vl1
  247. - new upstream release
  248. * Sun Jul 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.3-0vl1
  249. - new upstream release
  250. - build with mozilla 1.4
  251. * Sat Jun 07 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.0-0vl1
  252. - new upstream release
  253. * Thu Jun 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.1-0vl1
  254. - build for Vine Linux
  255. * Mon Jun 2 2003 Elliot Lee <sopwith@redhat.com> 0.6.1-2
  256. - Rebuild to fix broken mozilla dep, patch for mozilla 1.4
  257. * Mon May 19 2003 Jeremy Katz <katzj@redhat.com> 0.6.1-1
  258. - 0.6.1
  259. * Fri May 9 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-4
  260. - add patch to fix gint/gpointer conversion bugs for 64bit arches
  261. * Fri May 9 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-3
  262. - only build on arches mozilla is built on
  263. * Fri May 9 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-2
  264. - rebuild against new mozilla, make mozilla requires dynamic
  265. * Sun May 4 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-1
  266. - update to 0.6.0
  267. - fix tyop in %%postun
  268. * Wed Apr 16 2003 Bill Nottingham <notting@redhat.com> 0.5.0-3
  269. - make it build with mozilla-1.4 (shouldn't affect moz-1.2/moz-1.3 builds)
  270. * Mon Apr 14 2003 Jeremy Katz <katzj@redhat.com> 0.5.0-2
  271. - add some buildrequires, prereq GConf2
  272. - disable building nautilus view
  273. * Sun Apr 13 2003 Jeremy Katz <katzj@redhat.com>
  274. - Initial build.