fftw-vl.spec 6.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203
  1. %define name fftw
  2. %define version 2.1.5
  3. %define release 1%{?_dist_release}
  4. Name: %{name}
  5. Summary: C subroutines for computing the Discrete Fourier Transform.
  6. Version: %{version}
  7. Release: %{release}
  8. License: GPL
  9. Icon: fftw-logo-thumb.gif
  10. Group: Development/Libraries
  11. Source: %{name}-%{version}.tar.gz
  12. %{?nosrc:NoSource: 0}
  13. Patch0: %{name}-%{version}-pentium.patch
  14. URL: http://www.fftw.org/
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
  16. BuildRequires: glibc, gcc-gfortran
  17. Requires: glibc
  18. Vendor: Project Vine
  19. Distribution: Vine Linux
  20. %description
  21. FFTW is a collection of fast C routines for computing the Discrete Fourier Transform in one or more dimensions. It includes complex, real, and parallel transforms, and can handle arbitrary array sizes efficiently. This RPM package includes both the double- and single-precision FFTW uniprocessor and threads libraries. (The single-precision files have an "s" prefix.)
  22. %description -l ja
  23. FFTWは、1次元または多次元の離散的フーリエ変換(DFT)を計算する高速なCルーチンのコレクションです。FFTWは複素数、実数、並列変換ができ、任意のサイズの配列を効果的に扱うことができます。このパッケージには、倍精度と単精度の単一CPUとスレッドに対応したFFTWのライブラリが収められています。(単精度用のファイル名にはsが最初に付けられています。)
  24. %package devel
  25. Summary: Headers, libraries, & docs for FFTW fast fourier transform library
  26. Group: Development/Libraries
  27. Prefix: %{_prefix}
  28. Requires: %{name} = %{version}-%{release}
  29. %description devel
  30. This package contains the additional header files, documentation, and
  31. libraries you need to develop programs using the FFTW fast fourier
  32. transform library.
  33. %description devel -l ja
  34. このパッケージには、高速フーリエ変換のライブラリであるFFTWを使ってプログラムを開発する際に必要となるヘッダーファイルやドキュメント、ライブラリが収められています。
  35. %prep
  36. rm -rf $RPM_BUILD_ROOT
  37. # We will be compiling two copies of FFTW, one for double precision and
  38. # one for single precision. During the build process, these copies
  39. # will be stored in fftw-%{version}/double and fftw-%{version}/single
  40. # Unpack the tar archive, first (-c) creating a fftw-%{version}
  41. # directory and then unpacking in there.
  42. %setup -q -c
  43. # Now, rename the unpacked FFTW directory to "double":
  44. mv ${RPM_PACKAGE_NAME}-${RPM_PACKAGE_VERSION} double
  45. # Apply patch to enable pentium optimizations
  46. cd double
  47. %patch0 -p1
  48. cd ..
  49. # Last, make a copy of this directory in "single":
  50. cp -r double single
  51. %build
  52. # Configure and build the double and single precision versions.
  53. # Notes:
  54. # (1) We install into ${RPM_BUILD_ROOT}, which is set either
  55. # by the BuildRoot option above or by --buildroot at build-time.
  56. # This allows you to build the RPM without blowing away your existing
  57. # FFTW installation, and even without being root.
  58. # (2) The double-precision version is installed with the normal library
  59. # names, while the single-precision version is installed with an "s"
  60. # prefix.
  61. cd double
  62. %ifarch i386
  63. %configure --enable-shared --enable-threads --infodir=$RPM_BUILD_ROOT%{_infodir} --enable-i386-hacks
  64. %else
  65. %configure --enable-shared --enable-threads --infodir=$RPM_BUILD_ROOT%{_infodir}
  66. %endif
  67. make
  68. cd ../single
  69. %ifarch i386
  70. %configure --enable-shared --enable-threads --infodir=$RPM_BUILD_ROOT%{_infodir} --enable-i386-hacks --enable-float --enable-type-prefix
  71. %else
  72. %configure --enable-shared --enable-threads --infodir=$RPM_BUILD_ROOT%{_infodir} --enable-float --enable-type-prefix
  73. %endif
  74. make
  75. %install
  76. cd double
  77. %makeinstall
  78. cd ../single
  79. %makeinstall
  80. # copy doc files where RPM will find them
  81. # put the HTML stuff in a sperate dir, so it appears nicely in the docdir
  82. mkdir -p ../html
  83. cp doc/*html doc/*gif ../html
  84. # remove HTML files from doc so that they don't appear double
  85. rm -f doc/*html doc/*gif
  86. # place the doc directory in a "findable" location
  87. mkdir -p ../doc
  88. cp -a doc/* ../doc
  89. # the FAQ directory is also "nice" to have
  90. mkdir -p ../FAQ
  91. cp -a FAQ/* ../FAQ
  92. # do the same to the other %doc files
  93. cp AUTHORS ChangeLog NEWS README* TODO ..
  94. ## remove unuse files
  95. rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
  96. %clean
  97. rm -rf $RPM_BUILD_ROOT
  98. %post
  99. /sbin/ldconfig
  100. %postun
  101. /sbin/ldconfig
  102. %files
  103. %defattr (-,root,root)
  104. %doc html FAQ doc/*ps doc/*fig doc/*tex* AUTHORS ChangeLog NEWS README* TODO
  105. %{_libdir}/lib*fftw*.so.2*
  106. %files devel
  107. %defattr (-,root,root)
  108. %{_includedir}/*fftw*.h
  109. %doc %{_infodir}/*
  110. %{_libdir}/lib*fftw*.a
  111. %{_libdir}/lib*fftw*.so
  112. %changelog
  113. * Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 2.1.5-1vl5
  114. - applied new versioning policy, spec in utf-8
  115. - removed *.la
  116. * Wed Dec 19 2007 Shu KONNO <owa@bg.wakwak.com> 2.1.5-0vl2
  117. - s/gcc-f77/gcc-gfortran/
  118. - updated library file names in %%files section (for x86_64)
  119. * Wed Mar 03 2004 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.1.5-0vl1
  120. - source update.
  121. * Thu Jul 18 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.1.3-0vl1
  122. - modified for Vine.
  123. * Mon Feb 25 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 2.1.3-12bw
  124. - rebuild for RH72.
  125. * Tue Oct 09 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 2.1.3-11bw
  126. - corrected some wrong descriptions in this spec for RH71
  127. * Tue Oct 09 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 2.1.3-10bw
  128. - corrected some wrong descriptions in this spec
  129. * Mon Oct 08 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 2.1.3-9bw
  130. - rebuilt for Vine Linux 2.1.5
  131. * Thu Jun 14 2001 Lenny Cartier <lenny@mandrakesoft.com> 2.1.3-8mdk
  132. - fixed by Mika Korhonen <mikak@ee.oulu.fi> :
  133. - removed broken ld.so.conf test (/usr/lib is not listed there anyways)
  134. - made install-info work with RPM macros shipping with newer Mandrakes
  135. and actually add an entry to the top dir file
  136. * Tue Jan 09 2001 Lenny Cartier <lenny@mandrakesoft.com> 2.1.3-7mdk
  137. - rebuild
  138. * Tue Aug 31 2000 Lenny Cartier <lenny@mandrakesoft.com> 2.1.3-6mdk
  139. - add installinfo
  140. * Wed Aug 30 2000 Alexander Skwar <ASkwar@DigitalProjects.com> 2.1.3-5mdk
  141. - Actually used macros
  142. - Added %doc files
  143. - Shortened %files section of the SPEC file a lot
  144. - Provide libfftw as eXtace requires it
  145. - Obsolote libfftw package
  146. - Optimized for Pentium builds per README.hacks
  147. * Wed Aug 30 2000 Lenny Cartier <lenny@mandrakesoft.com> 2.1.3-4mdk
  148. - BM
  149. - macros
  150. * Wed Apr 26 2000 Lenny Cartier <lenny@mandrakesoft.com> 2.1.3-3mdk
  151. - fix group
  152. - spec helper fixes
  153. * Tue Jan 25 2000 Lenny Cartier <lenny@mandrakesoft.com>
  154. - updated, installs in /usr instead of /usr/local by Dara Hazeghi
  155. <dara@pacbell.net>
  156. * Thu Dec 16 1999 Lenny Cartier <lenny@mandrakesoft.com>
  157. - new in contribs
  158. - bz2 archive
  159. - add defattr