fftw3-vl.spec 6.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195
  1. %define name fftw3
  2. %define version 3.1.2
  3. %define release 1%{?_dist_release}
  4. Name: %{name}
  5. Summary: C subroutines for computing the Discrete Fourier Transform.
  6. Version: %{version}
  7. Release: %{release}
  8. License: GPL
  9. Group: Development/Libraries
  10. Source: fftw-%{version}.tar.gz
  11. URL: http://www.fftw.org/
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: gcc, gcc-gfortran
  14. Requires: glibc
  15. Vendor: Project Vine
  16. Distribution: Vine Linux
  17. %description
  18. FFTW is a collection of fast C routines for computing the Discrete Fourier Transform in one or more dimensions. It includes complex, real, and parallel transforms, and can handle arbitrary array sizes efficiently. This RPM package includes both the double- and single-precision FFTW uniprocessor and threads libraries. (The single-precision files have an "f" postfix.)
  19. %description -l ja
  20. FFTWは、1次元または多次元の離散的フーリエ変換(DFT)を計算する高速なCルーチンのコレクションです。FFTWは複素数、実数、並列変換ができ、任意のサイズの配列を効果的に扱うことができます。このパッケージには、倍精度と単精度の単一CPUとスレッドに対応したFFTWのライブラリが収められています。(単精度用のファイル名にはfが最後に付けられています。)
  21. %package devel
  22. Summary: Headers, libraries, & docs for FFTW fast fourier transform library
  23. Group: Development/Libraries
  24. Prefix: %{_prefix}
  25. Requires: %{name} = %{version}-%{release}
  26. %description devel
  27. This package contains the additional header files, documentation, and
  28. libraries you need to develop programs using the FFTW fast fourier
  29. transform library.
  30. %description devel -l ja
  31. このパッケージには、高速フーリエ変換のライブラリであるFFTWを使ってプログラムを開発する際に必要となるヘッダーファイルやドキュメント、ライブラリが収められています。
  32. %prep
  33. rm -rf $RPM_BUILD_ROOT
  34. # We will be compiling two copies of FFTW, one for double precision and
  35. # one for single precision. During the build process, these copies
  36. # will be stored in fftw-%{version}/double and fftw-%{version}/single
  37. # Unpack the tar archive, first (-c) creating a fftw-%{version}
  38. # directory and then unpacking in there.
  39. %setup -q -c -n fftw-%{version}
  40. # Now, rename the unpacked FFTW directory to "double":
  41. mv fftw-%{version} fftw-%{version}-double
  42. # Last, make a copy of this directory in "single":
  43. cp -r fftw-%{version}-double fftw-%{version}-single
  44. %build
  45. # Configure and build the double and single precision versions.
  46. # Notes:
  47. # (1) We install into ${RPM_BUILD_ROOT}, which is set either
  48. # by the BuildRoot option above or by --buildroot at build-time.
  49. # This allows you to build the RPM without blowing away your existing
  50. # FFTW installation, and even without being root.
  51. # (2) The double-precision version is installed with the normal library
  52. # names, while the single-precision version is installed with an "f"
  53. # postfix.
  54. cd fftw-%{version}-double
  55. %ifarch i386 | x86_64
  56. %configure --enable-shared --enable-threads --infodir=$RPM_BUILD_ROOT%{_infodir} --enable-sse2
  57. %else
  58. %configure --enable-shared --enable-threads --infodir=$RPM_BUILD_ROOT%{_infodir}
  59. %endif
  60. make %{?_smp_mflags}
  61. cd ../fftw-%{version}-single
  62. %ifarch i386 | x86_64
  63. %configure --enable-shared --enable-threads --infodir=$RPM_BUILD_ROOT%{_infodir} --enable-sse --enable-float
  64. %else
  65. %configure --enable-shared --enable-threads --infodir=$RPM_BUILD_ROOT%{_infodir} --enable-float
  66. %endif
  67. make %{?_smp_mflags}
  68. %install
  69. cd fftw-%{version}-double
  70. %makeinstall
  71. cd ../fftw-%{version}-single
  72. %makeinstall
  73. # copy doc files where RPM will find them
  74. # put the HTML stuff in a sperate dir, so it appears nicely in the docdir
  75. cp -a doc ../
  76. # do the same to the other %doc files
  77. cp AUTHORS CONVENTIONS COPYING COPYRIGHT ChangeLog NEWS README TODO ..
  78. ## remove unuse files
  79. rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
  80. %clean
  81. rm -rf $RPM_BUILD_ROOT
  82. %post
  83. /sbin/ldconfig
  84. %postun
  85. /sbin/ldconfig
  86. %files
  87. %defattr (-,root,root)
  88. %doc doc/html doc/FAQ doc/*ps doc/*tex*
  89. %doc AUTHORS CONVENTIONS COPYING COPYRIGHT ChangeLog NEWS README TODO
  90. %{_bindir}/fftw*
  91. %{_libdir}/libfftw3*.so*
  92. %{_infodir}/fftw3*
  93. %{_mandir}/man1/fftw*
  94. %files devel
  95. %defattr (-,root,root)
  96. %{_includedir}/fftw3.*
  97. %{_libdir}/libfftw3*.a
  98. %{_libdir}/pkgconfig/fftw3*.pc
  99. %changelog
  100. * Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 3.1.2-1vl5
  101. - applied new versioning policy, spec in utf-8
  102. - removed *.la
  103. - moved *.pc file to devel
  104. * Thu Jan 03 2008 Satoshi MACHINO <machino@vinelinux.org> 3.1.2-0vl1
  105. - new upstream release
  106. * Tue Nov 27 2007 Shu KONNO <owa@bg.wakwak.com> 3.1.1-0vl2
  107. - s/gcc-g77/gcc-gfortran/
  108. - x86_64 support
  109. * Tue May 30 2006 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 3.1.1-0vl1
  110. - source version up
  111. * Thu Jan 29 2004 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 3.0.1-0vl1
  112. - source version up to 3
  113. - package name to fftw3
  114. - enable sse2 for double and sse for single
  115. * Thu Jul 18 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.1.3-0vl1
  116. - modified for Vine.
  117. * Mon Feb 25 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 2.1.3-12bw
  118. - rebuild for RH72.
  119. * Tue Oct 09 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 2.1.3-11bw
  120. - corrected some wrong descriptions in this spec for RH71
  121. * Tue Oct 09 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 2.1.3-10bw
  122. - corrected some wrong descriptions in this spec
  123. * Mon Oct 08 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 2.1.3-9bw
  124. - rebuilt for Vine Linux 2.1.5
  125. * Thu Jun 14 2001 Lenny Cartier <lenny@mandrakesoft.com> 2.1.3-8mdk
  126. - fixed by Mika Korhonen <mikak@ee.oulu.fi> :
  127. - removed broken ld.so.conf test (/usr/lib is not listed there anyways)
  128. - made install-info work with RPM macros shipping with newer Mandrakes
  129. and actually add an entry to the top dir file
  130. * Tue Jan 09 2001 Lenny Cartier <lenny@mandrakesoft.com> 2.1.3-7mdk
  131. - rebuild
  132. * Tue Aug 31 2000 Lenny Cartier <lenny@mandrakesoft.com> 2.1.3-6mdk
  133. - add installinfo
  134. * Wed Aug 30 2000 Alexander Skwar <ASkwar@DigitalProjects.com> 2.1.3-5mdk
  135. - Actually used macros
  136. - Added %doc files
  137. - Shortened %files section of the SPEC file a lot
  138. - Provide libfftw as eXtace requires it
  139. - Obsolote libfftw package
  140. - Optimized for Pentium builds per README.hacks
  141. * Wed Aug 30 2000 Lenny Cartier <lenny@mandrakesoft.com> 2.1.3-4mdk
  142. - BM
  143. - macros
  144. * Wed Apr 26 2000 Lenny Cartier <lenny@mandrakesoft.com> 2.1.3-3mdk
  145. - fix group
  146. - spec helper fixes
  147. * Tue Jan 25 2000 Lenny Cartier <lenny@mandrakesoft.com>
  148. - updated, installs in /usr instead of /usr/local by Dara Hazeghi
  149. <dara@pacbell.net>
  150. * Thu Dec 16 1999 Lenny Cartier <lenny@mandrakesoft.com>
  151. - new in contribs
  152. - bz2 archive
  153. - add defattr