gnumeric-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422
  1. %define gnumeric_version %{version}-bonobo
  2. %define goffice_version 0.8.2
  3. Summary: A spreadsheet program for GNOME.
  4. Summary(ja): GNOME スプレッドシート
  5. Name: gnumeric
  6. Version: 1.10.2
  7. Release: 1%{?_dist_release}
  8. License: GPLv2
  9. Group: Applications/Productivity
  10. URL: http://www.gnome.org/projects/gnumeric
  11. Source: ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/1.8/%{name}-%{version}.tar.bz2
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. Distribution: Vine Linux
  14. Vendor: Project Vine
  15. BuildRequires: gtk2-devel >= 2.10.0
  16. BuildRequires: libglade2-devel >= 2.3.6
  17. BuildRequires: libgnomeprint-devel >= 2.8.2
  18. BuildRequires: libgnomeprintui-devel >= 2.8.2
  19. BuildRequires: libart_lgpl-devel >= 2.3.11
  20. BuildRequires: libxml2-devel >= 2.4.12
  21. BuildRequires: libgsf-devel >= 1.13.2
  22. BuildRequires: goffice-devel >= %{goffice_version}
  23. BuildRequires: libbonobo-devel libgnomeui-devel
  24. BuildRequires: libffi-devel
  25. #BuildPreReq: libgda-devel >= 1.9.100
  26. #BuildPreReq: libgnomedb-devel >= 1.9.100
  27. BuildRequires: perl python-devel
  28. BuildRequires: automake autoconf libtool docbook-utils
  29. BuildRequires: intltool >= 0.28 desktop-file-utils
  30. BuildRequires: libSM-devel
  31. Requires: gtk2 >= 2.10.0
  32. Requires: libglade2 >= 2.3.6
  33. Requires: libgnomeprint >= 2.8.2
  34. Requires: libgnomeprintui >= 2.8.2
  35. Requires: libgsf >= 1.14.6
  36. Requires: perl python
  37. Requires: GConf2 scrollkeeper
  38. # no longer devel package
  39. #Provides: %{name}-devel
  40. Obsoletes: %{name}-devel
  41. %description
  42. GNOME (GNU Network Object Model Environment) is a user-friendly set of
  43. applications and desktop tools to be used in conjunction with a window
  44. manager for the X Window System.
  45. This is the Gnumeric, a spreadsheet for GNOME. It aims to be a drop in
  46. replacement for commercial spreadsheets. It provides import/export from
  47. MS Excel files and many other formats (csv, latex, xbase, applix).
  48. %description -l ja
  49. GNOME (GNU Network Object Model Environment)は
  50. Xウィンドウシステム用の、ウィンドウマネージャと連結した
  51. GUIアプリケーションおよびデスクトップツールのセットです。
  52. これは Gnumeric, GNOMEスプレッドシート・プログラムです。
  53. 商用のスプレッドシート・プログラムを代替できるものを目指しています。
  54. MS Excelファイルや他の多くのフォーマット(csv, latex, xbase, applix)
  55. を読込み、出力できます.
  56. # %package devel
  57. #Summary: Files necessary to develop gnumeric-based applications.
  58. #Group: Development/Libraries
  59. #Requires: %{name} = %{PACKAGE_VERSION}
  60. #%#description devel
  61. #The gnumeric-devel package includes files necessary to develop gnumeric-based
  62. #applications.
  63. #Install gnumeric-devel if you want to develop programs which will use gnumeric.
  64. %prep
  65. %setup -q
  66. # fix desktop file Icon path
  67. sed -i -e "s/Icon=/Icon=\/usr\/share\/pixmaps\//" \
  68. gnumeric.desktop.in
  69. %build
  70. %ifarch alpha
  71. MYARCH_FLAGS="--host=alpha-redhat-linux"
  72. %endif
  73. export mllibname=%{_lib}
  74. %configure --with-gnome \
  75. --with-gda --without-gb --with-perl --with-python \
  76. --disable-schemas-install
  77. make
  78. %install
  79. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  80. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  81. make DESTDIR=$RPM_BUILD_ROOT install
  82. unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
  83. ./mkinstalldirs $RPM_BUILD_ROOT%{_datadir}/applications
  84. desktop-file-install --vendor gnome --delete-original \
  85. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  86. --add-category X-Red-Hat-Extra \
  87. --add-category Office \
  88. --add-category Application \
  89. --add-category Spreadsheet \
  90. $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
  91. %find_lang %{name}
  92. %find_lang %{name}-functions
  93. cat %{name}-functions.lang >> %{name}.lang
  94. rm -rf $RPM_BUILD_ROOT%{_libdir}/libspreadsheet.la
  95. rm -rf $RPM_BUILD_ROOT%{_libdir}/goffice/%{goffice_version}/plugins/gnumeric/*.la
  96. rm -rf $RPM_BUILD_ROOT%{_libdir}/pkgconfig
  97. rm -rf $RPM_BUILD_ROOT%{_includedir}/libspreadsheet-1.10
  98. rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
  99. %clean
  100. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  101. %post
  102. /sbin/ldconfig
  103. scrollkeeper-update > /dev/null 2>&1 || :
  104. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  105. gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/gnumeric*.schemas > /dev/null
  106. %pre
  107. if [ "$1" -gt 1 ]; then
  108. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  109. gconftool-2 --makefile-uninstall-rule \
  110. %{_sysconfdir}/gconf/schemas/gnumeric*.schemas >& /dev/null ||:
  111. fi
  112. %preun
  113. if [ "$1" -eq 0 ]; then
  114. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  115. gconftool-2 --makefile-uninstall-rule \
  116. %{_sysconfdir}/gconf/schemas/gnumeric*.schemas >& /dev/null ||:
  117. fi
  118. %postun
  119. /sbin/ldconfig
  120. scrollkeeper-update > /dev/null 2>&1 || :
  121. %files -f %{name}.lang
  122. %defattr (-, root, root)
  123. %doc AUTHORS BUGS *ChangeLog* COPYING HACKING NEWS README
  124. %config %{_sysconfdir}/gconf/schemas/*
  125. %{_bindir}/*
  126. %{_libdir}/lib*.so*
  127. %{_libdir}/gnumeric
  128. %{_libdir}/goffice/%{goffice_version}/plugins/gnumeric/*
  129. #{_libdir}/bonobo/servers/*
  130. %{_datadir}/applications/*.desktop
  131. %{_datadir}/gnome/help/gnumeric
  132. %{_datadir}/gnumeric
  133. %{_datadir}/pixmaps/*
  134. #{_datadir}/mime-info/*
  135. #{_datadir}/mc/templates/*
  136. %{_datadir}/omf/*
  137. %{_datadir}/icons/hicolor/*
  138. %{_mandir}/man*/*
  139. %exclude %{_datadir}/pixmaps/win32-gnumeric.ico
  140. #%{_libexecdir}/gnumeric-component
  141. #%#dir %{_libdir}/gnumeric
  142. #%#dir %{_libdir}/gnumeric/%{bonobover}
  143. #%#dir %{_libdir}/gnumeric/%{bonobover}/plugins
  144. #%#dir %{_libdir}/gnumeric/%{bonobover}/plugins/*
  145. # This is really silly. The .la files are useless for plugins.
  146. #%#{_libdir}/gnumeric/%{bonobover}/plugins/*/*.la
  147. #%#{_libdir}/gnumericConf.sh
  148. #%#if %{bonobo}
  149. #%#dir %{_datadir}/gnumeric
  150. #%#dir %{_datadir}/gnumeric/%{bonobover}
  151. #%#{_datadir}/gnumeric/%{bonobover}/idl
  152. #%#endif
  153. %changelog
  154. * Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
  155. - new upstream release
  156. * Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.1-1
  157. - new upstream release
  158. - add BuildRequires: libSM-devel
  159. - fix BuildRequires: goffice-devel >= 0.8.1
  160. * Sun May 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-3
  161. - spec in UTF-8 (fixed)
  162. * Sat May 9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-2
  163. - spec in UTF-8
  164. - added BuildRequires: libffi-devel
  165. - added %%pre, %%preun section
  166. * Mon Jun 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-1
  167. - new upstream release
  168. - built with libgda-3.1.4, libgnomedb-3.1.2
  169. - applied new versioning policy
  170. * Mon Mar 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
  171. - new upstream release
  172. * Sat Jun 17 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.6.3-0vl2
  173. - rebuild
  174. * Fri May 5 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-0vl1
  175. - new upstream release
  176. * Sun Mar 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.2-0vl1
  177. - new upstream release
  178. - updated build dependancies
  179. - rebuilt with libgsf-1.14.0
  180. - built with libgda and libgnomedb again
  181. * Tue Nov 15 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.1-0vl1
  182. - new upstream release
  183. - updated build dependancies
  184. - not compile with libgda and libgnomedb in this version
  185. * Mon Mar 14 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.3-0vl1
  186. - new upstream release
  187. * Fri Feb 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl2
  188. - rebuild with libgda 1.2.0 and libgnome 1.2.0
  189. * Tue Jan 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl1
  190. - new upstream release
  191. * Mon Dec 13 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1-0vl1
  192. - new upstream release
  193. * Thu Dec 2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-0vl1
  194. - new upstream release
  195. * Fri Nov 12 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.13-0vl2
  196. - rebuild with gnome-2.8 environment and libgsf-1.10.1
  197. * Tue Jun 29 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.13-0vl1
  198. - new upstream release
  199. - added BuildRequires: desktop-file-utils
  200. * Thu May 6 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-0vl1
  201. - new upstream release
  202. - Requires: libgsf >= 1.9.0, BuildPrereq: libgsf-devel >= 1.9.0
  203. * Wed Apr 21 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.11-0vl1
  204. - new upstream release
  205. * Wed Apr 14 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.10-0vl1
  206. - new upstream release
  207. * Sun Apr 11 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.9-0vl1
  208. - new upstream release
  209. * Thu Mar 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8-0vl1
  210. - new upstream release
  211. * Wed Mar 17 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.7-0vl1
  212. - new upstream release
  213. - clean up spec file (a little bit!)
  214. * Thu Jan 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl1
  215. - new upstream release
  216. * Fri Jan 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.4-0vl1
  217. - new upstream release
  218. - to use intltool-0.28
  219. * Sun Dec 28 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.3-0vl1
  220. - new upstream release
  221. - rebuild with new toolchains
  222. * Sun Nov 30 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.2-0vl1
  223. - new upstream release
  224. - build with new libgnomeprint, libgnomeprintui
  225. * Fri Oct 10 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-0vl1
  226. - new upstream release
  227. * Thu Oct 2 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl2
  228. - rebuild with newer libgda, libgnomedb
  229. * Thu Sep 25 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl1
  230. - updated to 1.2.0 (stable release)
  231. - guile support is temporarily off this version.
  232. * Mon Sep 9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.20-1vl1
  233. - update to 1.1.20 (gtk+-2 port)
  234. - based on Redhat Rawhide 1.1.20-1
  235. * Thu May 1 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.13-0vl1
  236. - update to 1.0.13
  237. - rebuild with gal 0.24
  238. * Sun Mar 9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.12-0vl2
  239. - guile support on
  240. - rebuild with new gal, bonobo, libgda
  241. * Fri Feb 7 2003 Masaki Shinomiya <shino@pos.to> 1.0.12-0vl1
  242. - New upstream release, remove xmliobackward.patch
  243. * Mon Dec 16 2002 Masaki Shinomiya <shino@pos.to> 1.0.11-0vl2
  244. - xml-io back to 1.0.10 because japanese corrups with new xml_parser
  245. * Sun Dec 15 2002 Masaki Shinomiya <shino@pos.to> 1.0.11-0vl1
  246. - New upstream release, fix for xml importing files with non ASCII characters.
  247. - Without guile, changelog.archive, requires, build scripts, description
  248. * Mon Nov 19 2002 Masaki Shinomiya <shino@pos.to> 1.0.10-0vl2
  249. - files: add gnumericConf.sh, which was missing
  250. * Mon Nov 4 2002 Masaki Shinomiya <shino@pos.to> 1.0.10-0vl1
  251. - New upstream release.
  252. - BuildPrereq oaf-devel
  253. * Mon Jul 29 2002 Masaki Shinomiya <shino@pos.to> 1.0.9-0vl1
  254. - New upstream release.
  255. * Mon Jul 1 2002 Masaki Shinomiya <shino@pos.to> 1.0.8-0vl1
  256. - New upstream release.
  257. - Default font and Japanese fonts in excel
  258. - requires
  259. * Sun Jun 30 2002 Masaki Shinomiya <shino@pos.to> 1.0.7-0vl1
  260. - New upstream release.
  261. - fixed plugins, apply patch2, remove patch3
  262. - files - no longer devel package
  263. - function-reference.html in help file
  264. * Thu Jan 24 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.3-0vl1
  265. - New upstream release.
  266. * Wed Jan 16 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.2-0vl1
  267. - New upstream release.
  268. - Fixed several owner dir.
  269. * Tue Jan 15 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl2
  270. - Build against with new gal
  271. * Mon Jan 7 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl1
  272. - New upstream release.
  273. * Fri Jan 4 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.0-0vl1
  274. - New upstream release.
  275. * Fri Dec 28 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.99.1-0vl1
  276. - New upstream release.
  277. - Applied XIM over-the-spot patch.
  278. - Fixed directories owner.
  279. * Wed Dec 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.99.0-0vl1
  280. - New upstream release.
  281. - Enable Bonobo.
  282. - Merged several RH patches.
  283. - Added BuildPreReq tags.
  284. * Tue Jun 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl3
  285. - Fixed packaging mistake.
  286. * Mon May 14 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl2
  287. - Rebuild for GAL 0.7
  288. * Fri Mar 23 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl1
  289. - New upstream release.
  290. - Use rpmmacros.
  291. * Mon Feb 5 2001 Jun Nishii <jun@vinelinux.org>
  292. - 0.56-0vl2
  293. - update ja.po
  294. - avoid core dump when inserting a row
  295. * Mon Jul 10 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  296. - updated to 0.56
  297. - remake spec with the orginal gnumeric spec file.
  298. - added ms_excel_read and edit_item patch from Japanese gnome users mailing list.
  299. * Tue May 16 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  300. - updated to 0.53
  301. - remake SPEC based on gnumeric original.
  302. - added libxml183 patch for libxml 1.8.3
  303. * Thu Mar 29 2000 Kjartan Maraas <kmaraas@online.no>
  304. - Removed gnome-gnumeric-xl.png since it is nowhere to be found.
  305. - Added --without-bonobo and --without-gb.
  306. - Added %define for sysconfdir
  307. * Mon Feb 29 2000 Jody Goldberg <jgolbderg@home.com>
  308. - Updated version requirements for gnome-print, and gnome-libs.
  309. * Sun Jan 30 2000 Gregory McLean <gregm@comstar.net>
  310. - Added in some auto-detect the language files logic (rpm 3.0.xx only)
  311. * Mon Jan 12 2000 Jody Goldberg <jgolbderg@home.com>
  312. - Add depend on gtk+ >= 1.2.2 so that we can get gtk_object_get.
  313. * Mon Jan 03 2000 Gregory McLean <gregm@comstar.net>
  314. - Updated to 0.47
  315. * Mon Dec 20 1999 Jody Goldberg <jgolbderg@home.com>
  316. - Updated the libglade dependancy.
  317. - Remove req for guile. We can build without it.
  318. * Thu Sep 02 1999 Gregory McLean <gregm@comstar.net>
  319. - Added small fix so glade generated dialogs appear.
  320. * Wed Jul 14 1999 Gregory McLean <gregm@comstar.net>
  321. - Added the gnome-print requirement.
  322. - Updated the file list to try and quiet down the updating.
  323. - added the sysconfdir
  324. * Tue Mar 9 1999 Gregory McLean <gregm@comstar.net>
  325. - Updated the spec file.
  326. * Thu Sep 24 1998 Michael Fulbright <msf@redhat.com>
  327. - Version 0.2