kdemultimedia-vl.spec 17 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566
  1. %define vine3 %(grep -c 3. /etc/vine-release)
  2. %define vine4 %(grep -c 4. /etc/vine-release)
  3. %define vine5 %(grep -c 5. /etc/vine-release)
  4. Name: kdemultimedia
  5. Summary: Multimedia applications for the K Desktop Environment (KDE).
  6. Summary(ja): K デスクトップ環境 - マルチメディアアプリケーション集
  7. Version: 4.4.2
  8. Release: 1%{?_dist_release}
  9. Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/%{name}-%{version}.tar.bz2
  10. Patch1: kdemultimedia-4.2.85-nomplayerthumbs.patch
  11. URL: http://www.kde.org/
  12. Group: Applications/Multimedia
  13. License: GPLv2+
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. # This one is normal, FLAC_OGG_LIBRARY is not actually used anyway:
  16. # FLAC_OGG_LIBRARY:FILEPATH=FLAC_OGG_LIBRARY-NOTFOUND
  17. BuildRequires: alsa-lib-devel
  18. BuildRequires: cdparanoia-devel
  19. BuildRequires: flac-devel
  20. BuildRequires: glib2-devel
  21. BuildRequires: kdebase-workspace-devel >= %{version}
  22. BuildRequires: kdelibs4-devel
  23. BuildRequires: libtheora-devel
  24. ## needed to build Kscd, keep for now -- Kevin
  25. #BuildRequires: libtunepimp-devel
  26. BuildRequires: libmusicbrainz-devel
  27. BuildRequires: libvorbis-devel
  28. # KMix PulseAudio integration is not anywhere near shippable.
  29. # Almost everything is commented out, it basically does nothing.
  30. # BuildRequires: pulseaudio-libs-devel
  31. BuildRequires: taglib-devel
  32. BuildRequires: xine-lib-devel libxcb-devel
  33. Requires: %{name}-libs = %{version}-%{release}
  34. Requires: kdelibs4 >= %{version}
  35. Requires: kdebase-workspace >= %{version}
  36. Provides: dragonplayer = 2.0.2-0.1
  37. Obsoletes: dragonplayer < 2.0.2-0.1
  38. Obsoletes: %{name}-extras < %{version}-%{release}
  39. Obsoletes: kmidi koncd
  40. %description
  41. Multimedia applications for the K Desktop Environment.
  42. What it is
  43. ----------
  44. * dragonplayer (a simple video player)
  45. * juk (a music manager and player)
  46. * kmix (an audio mixer)
  47. * kscd (an Audio-CD player)
  48. %package libs
  49. License: LGPLv2+ and GPLv2+
  50. Summary: Runtime libraries for %{name}
  51. Group: System Environment/Libraries
  52. Obsoletes: %{name}-extras-libs < %{version}-%{release}
  53. Conflicts: dragonplayer < 2.0.2-0.1
  54. %description libs
  55. %{summary}.
  56. %package devel
  57. Summary: Developer files for %{name}
  58. Group: Development/Libraries
  59. Requires: %{name}-libs = %{version}-%{release}
  60. Requires: kdelibs4-devel
  61. %description devel
  62. %{summary}.
  63. %prep
  64. %setup -q
  65. %patch1 -p1 -b .nomplayerthumbs
  66. %build
  67. mkdir -p %{_target_platform}
  68. pushd %{_target_platform}
  69. unset QTDIR || : ; . /etc/profile.d/qt4.sh
  70. %cmake \
  71. -DCMAKE_BUILD_TYPE=release \
  72. -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
  73. -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
  74. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
  75. -DLIB_INSTALL_DIR:PATH=%{_libdir} \
  76. -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
  77. -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
  78. ..
  79. popd
  80. make %{?_smp_mflags} -C %{_target_platform}
  81. %install
  82. rm -rf $RPM_BUILD_ROOT
  83. make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
  84. %clean
  85. rm -rf $RPM_BUILD_ROOT
  86. %post
  87. touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
  88. touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
  89. %posttrans
  90. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
  91. gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
  92. update-desktop-database -q &> /dev/null ||:
  93. %postun
  94. if [ $1 -eq 0 ] ; then
  95. touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
  96. touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
  97. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
  98. gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
  99. update-desktop-database -q &> /dev/null ||:
  100. fi
  101. %post libs -p /sbin/ldconfig
  102. %postun libs -p /sbin/ldconfig
  103. %files
  104. %defattr(-,root,root)
  105. %{_bindir}/*
  106. %{_datadir}/kde4/apps/dragonplayer
  107. %{_datadir}/kde4/apps/juk
  108. %{_datadir}/kde4/apps/kmix
  109. %{_datadir}/kde4/apps/kconf_update/*
  110. %{_datadir}/kde4/apps/konqsidebartng
  111. %{_datadir}/kde4/apps/profiles
  112. %{_datadir}/kde4/apps/kscd
  113. %{_datadir}/kde4/apps/solid/actions/dragonplayer-opendvd.desktop
  114. %{_datadir}/kde4/apps/solid/actions/kscd-play-audiocd.desktop
  115. %{_datadir}/kde4/apps/solid/actions/solid_audiocd.desktop
  116. %{_datadir}/config/dragonplayerrc
  117. %{_datadir}/applications/kde4/*
  118. %{_datadir}/autostart/*
  119. %{_datadir}/kde4/services/*
  120. %{_datadir}/config.kcfg/*
  121. %{_datadir}/dbus-1/interfaces/*
  122. %{_docdir}/HTML/en/dragonplayer/
  123. %{_docdir}/HTML/en/juk/
  124. %{_docdir}/HTML/en/kcontrol/
  125. %{_docdir}/HTML/en/kioslave/
  126. %{_docdir}/HTML/en/kmix/
  127. %{_datadir}/icons/hicolor/*/*/*
  128. %{_datadir}/icons/oxygen/*/actions/player-volume-muted.*
  129. %{_datadir}/icons/oxygen/*/actions/kscd-dock.*
  130. %{_libdir}/libkdeinit*.so
  131. %files libs
  132. %defattr(-,root,root,-)
  133. %{_libdir}/lib*.so.*
  134. %{_libdir}/kde4/*
  135. %files devel
  136. %defattr(-,root,root)
  137. %{_includedir}/kde4/audiocdencoder.h
  138. %{_includedir}/kde4/libkcddb
  139. %{_includedir}/kde4/libkcompactdisc
  140. %{_libdir}/lib*.so
  141. %exclude %{_libdir}/libkdeinit*.so
  142. %changelog
  143. * Wed Apr 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
  144. - new upstream release
  145. * Sun Mar 7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
  146. - new upstream release
  147. * Sat Mar 6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.0-1
  148. - new upstream release
  149. - built with new toolchain
  150. * Wed Nov 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.3-1
  151. - new upstream release
  152. * Sun Oct 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-1
  153. - new upstream release
  154. * Mon Sep 7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
  155. - new upstream release
  156. - used %%cmake macro
  157. * Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.0-1
  158. - new upstream release
  159. - split libs sub-package
  160. * Sun May 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-3
  161. - added Japanese summary, spec in UTF-8
  162. - updated BR
  163. * Sat Mar 2 2009 TOSHI <milk-tea1977@dune.ocn.ne.jp> 3.5.8-2vl4
  164. - Change BuildPrereq: (Use BuildRequires)
  165. - Change BuildRequires: self-build-libmad
  166. - applied vine versioning policy
  167. * Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
  168. - rebuild for VineSeed
  169. * Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
  170. - new upstream release
  171. * Thu Sep 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl4
  172. - rebuild without acl
  173. * Tue Aug 21 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl3
  174. - rebuild with flac-1.2.0
  175. * Tue Jul 3 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
  176. - rebuild for VineSeed
  177. - add BuildPrereq: cdparanoia-devel
  178. - delete our own copy of cdparanoia and BuildConflicts: cdparanoia-devel
  179. * Tue May 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
  180. - new upstream release
  181. - enable-cdparanoia
  182. * Tue Jan 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
  183. - new upstream release
  184. * Sun Oct 22 2006 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.5-0vl3
  185. - added --with-qt-libraries and --enable-libsuffix option
  186. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
  187. - rebuild for VineSeed
  188. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
  189. - new upstream release
  190. * Tue Aug 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
  191. - rebuild for VineSeed
  192. * Tue Aug 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
  193. - new upstream release
  194. * Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
  195. - rebuild for VineSeed
  196. * Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
  197. - new upstream release
  198. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
  199. - rebuild for VineSeed
  200. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
  201. - new upstream release
  202. - remove BuildPrereq: gstreamer-plugins-devel
  203. * Tue Jan 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
  204. - rebuild for VineSeed
  205. * Tue Jan 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
  206. - new upstream release
  207. * Thu Dec 8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl2
  208. - rebuild for VineSeed
  209. * Mon Nov 28 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl1
  210. - new upstream release
  211. * Mon Nov 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl0.rc1
  212. - new upstream release
  213. - add --includedir=%%{_includedir}/kde to configure option
  214. * Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.92-0vl1
  215. - new upstream release
  216. * Tue Sep 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.91-0vl1
  217. - new upstream release
  218. * Thu Aug 11 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl4
  219. - rebuild for VineSeed
  220. * Thu Aug 11 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl3
  221. - rebuild with kdelibs-3.4.2
  222. * Mon Jun 6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl2
  223. - build for VineSeed
  224. - add --disable-rpath to configure option
  225. - add alsa support for VineSeed
  226. * Mon Jun 6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl1
  227. - new upstream release
  228. - use %%{?_smp_mflags} for make option
  229. * Sat Mar 19 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl2
  230. - rebuild for VineSeed
  231. * Thu Mar 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl1
  232. - new upstream release
  233. - change configure option
  234. - add BuildPrereq: gstreamer-plugins-devel libmad-devel
  235. * Sat Feb 12 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl3
  236. - rebuild with flac-1.1.2 (VineSeed)
  237. * Sat Jan 1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
  238. - rebuild for VineSeed
  239. * Sat Jan 1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
  240. - new upstream release
  241. - move all files under %%{_libdir} to main package
  242. - add --sysconfdir=/etc to configure option
  243. - add /etc/xdg/menus/applications-merged/kde-multimedia-music.menu to %%files
  244. * Sat Oct 23 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl2
  245. - rebuild with flac-1.1.1 (VineSeed)
  246. * Thu Oct 21 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
  247. - source upgrade
  248. - add patch0 again
  249. - update %%files
  250. * Wed Aug 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl2
  251. - rebuild with qt32
  252. * Mon Jun 14 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl1
  253. - source upgrade
  254. - remove lines about vine26
  255. - add URL: http://www.kde.org/
  256. - remove patch0 and patch1
  257. - add BuildPrereq: audiofile-devel flac-devel taglib-devel gstreamer-devel
  258. - add BuildConflicts: cdparanoia-devel
  259. * Sat May 1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
  260. - source upgrade
  261. - kernel-2.4.26 does not need patch0
  262. * Sun Mar 21 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
  263. - source upgrade
  264. * Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl2
  265. - rebuild for VineSeedPlus
  266. * Mon Jan 12 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl1
  267. - source upgrade
  268. - build for VinePlus/2.6
  269. - (VinePlus/2.6) BuildPrereq: autoconf258
  270. - build without cdparanoia
  271. * Thu Jan 8 2004 Tomoya TAKA <taka@vinelinux.org> 3.1.4-0vl2
  272. - add Patch1 to resolve conflicting typedef on alpha
  273. - remove ExcludeArch: alpha
  274. * Sun Dec 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl1
  275. - source upgrade
  276. - change spec to build with gcc3
  277. - add Patch0 to build kaudiocreator
  278. (patch to /usr/include/asm/byteorder.h)
  279. - include our own copy of cdparanoia, nuke FixupTOC() from it
  280. - build without cdparanoia-devel
  281. - revised description
  282. - change spec to make monolithic package only
  283. - add Obsoletes: kmidi koncd
  284. - remove KOnCD configuration
  285. - rename timidity to avoid conflict with timidy++
  286. * Mon Jul 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0vl1
  287. - source upgrade
  288. - change spec to build with gcc295
  289. - change make option for SMP and add script
  290. * Sat Jun 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
  291. - source upgrade
  292. - change spec to build both VineSeed and Vine2.5/2.6
  293. - remove all patches
  294. - add BuildPrereq: cdparanoia-devel cdrtools-devel
  295. - built with libpng >= 1.2.5 when %%{vine26} is set to 0 (ie VineSeedPlus)
  296. - change spec to build with g++-2.95.3
  297. * Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
  298. - objprelink2 support only ix86 (add %%ifarch %%{ix86} ... )
  299. * Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
  300. - source upgrade
  301. - BuildPrereq: autoconf253 objprelink2
  302. * Mon Aug 26 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
  303. - source upgrade
  304. * Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.2-1vl2
  305. - rebuild with libvorbis-1.0-0vl1
  306. * Tue Jul 16 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.2-1vl1
  307. - build for Vine Linux 2.5 / VineSeed
  308. - delete Epoch
  309. - objprelink (i386 only)
  310. - add %%define monolithic 1
  311. - add BuildPrereq: autoconf252 automake15 libogg-devel libvorbis-devel
  312. - delete BuildPrereq: desktop-file-utils and use default .desktop files
  313. - koncd: delete Requires: mkisofs and add Requires: cdrdao
  314. - kmidi: change Requires: timidity++ -> TiMidity++
  315. delete Obsoletes: kdemultimedia
  316. - devel: Requires: kdemultimedia = %%{version}-%%{rel}
  317. * Wed Jul 10 2002 Than Ngo <than@redhat.com> 3.0.2-1
  318. - 3.0.2
  319. - use desktop-file-install
  320. * Thu Jun 06 2002 Than Ngo <than@redhat.com> 3.0.1-3
  321. - rebuild
  322. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  323. - automated rebuild
  324. * Fri May 10 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.1-1
  325. - 3.0.1
  326. * Wed Apr 17 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-3
  327. - Make sure we link to the just built libraries instead of libs in the
  328. build environment from older releases
  329. * Tue Apr 16 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-2
  330. - Update ABI
  331. - Add cdrecord/mkisofs requirements for KOnCD (#63606)
  332. - Tell koncd where to find cdrecord and mkisofs (#63604)
  333. * Wed Mar 27 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-1
  334. - 3.0.0 final
  335. * Thu Mar 21 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020321.1
  336. - Adapt spec file to recent changes in base
  337. * Thu Mar 7 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020307.1
  338. - Update
  339. - Rename subpackages
  340. * Fri Feb 1 2002 Tim Powers <timp@redhat.com>
  341. - kdemultimedia-devel shouldn't obsolete itself
  342. - temporarily ExcludeArch ia64
  343. * Mon Aug 6 2001 Than Ngo <than@redhat.com> 2.2-1
  344. - update to 2.2 release
  345. * Fri Aug 3 2001 Than Ngo <than@redhat.com> 2.2-0.cvs20010803.1
  346. - update
  347. - fix bug #24132
  348. - get rid of aktion
  349. * Sun Jul 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010722.1
  350. - Update
  351. - move devel files to a separate package
  352. - Add BuildPrereqs (#44914)
  353. * Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  354. - 2.1-respin
  355. * Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  356. - 2.1
  357. * Tue Feb 13 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  358. - Remove copyrighted midi files (#26431)
  359. - Use a real file list rather than find/sed (#26565)
  360. - Fix build with current glibc
  361. * Thu Feb 1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  362. - Replace absolute symlinks with relative ones (#24794)
  363. - Don't use more than 2 CPUs at build time to shut up asok
  364. * Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  365. - Update
  366. * Mon Jan 1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  367. - Update
  368. - Don't optimize on sparc, compiler breakage
  369. * Wed Dec 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  370. - Update to CVS
  371. - re-exclude ia64, the compiler can't handle this package
  372. * Sun Oct 22 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  373. - 2.0 final
  374. * Tue Oct 3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  375. - 2.0
  376. * Thu Aug 24 2000 Than Ngo <than@redhat.com>
  377. - update kdemultimedia-1.93
  378. - fix to rebuilt with gcc-2.96
  379. * Mon Aug 7 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  380. - new version
  381. * Wed Jul 19 2000 Than Ngo <than@redhat.de>
  382. - fix to build against gcc-2.96-40 on sparc, alpha
  383. - disable motif
  384. * Thu Jul 13 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  385. - SMPify
  386. - don't hardcode QTDIR
  387. * Tue Jul 11 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  388. - use gcc 2.96
  389. - new snapshot
  390. * Sun Jul 2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  391. - use kernelcc
  392. - new snapshot
  393. * Fri Jun 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  394. - Obsoletes: aktion (it's included now)
  395. * Wed Jun 21 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  396. - new snapshot
  397. - ExcludeArch ia64 for now
  398. * Sat Apr 8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  399. - 2.0 snapshot
  400. * Tue Feb 29 2000 Preston Brown <pbrown@redhat.com>
  401. - fix localkscd patch, broken since 6.1 (#9404).
  402. * Fri Feb 4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  403. - Remove (world!) write permissions to %%{prefix}/share/apps/kscd/cddb/*
  404. - fix description
  405. * Thu Feb 3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  406. - Change the kmix error message (Bug #9065)
  407. - Fix kmidi behavior when trying to play an empty playlist (Bug #8843)
  408. - Fix compilation with kernel 2.3.x headers
  409. * Sat Jan 8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  410. - current version from KDE_1_1_BRANCH
  411. - work around make install-strip breakage
  412. - Rebuild for 6.2
  413. * Sat Sep 25 1999 Preston Brown <pbrown@redhat.com>
  414. - patched kscd to use local user directory for cddb entries
  415. * Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
  416. - mark doc files as such
  417. * Thu Sep 09 1999 Preston Brown <pbrown@redhat.com>
  418. - 1.1.2 release.
  419. * Mon Jun 14 1999 Preston Brown <pbrown@redhat.com>
  420. - snapshot, includes kde 1.1.1 + fixes
  421. * Mon Apr 19 1999 Preston Brown <pbrown@redhat.com>
  422. - last snapshot before release
  423. * Tue Apr 13 1999 Preston Brown <pbrown@redhat.com>
  424. - snapshot from today fixed kmid freeze issues
  425. * Mon Apr 12 1999 Preston Brown <pbrown@redhat.com>
  426. - latest stable snapshot
  427. * Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
  428. - Injected new description and group.
  429. * Mon Feb 08 1999 Preston Brown <pbrown@redhat.com>
  430. - upgraded to KDE 1.1 final.
  431. * Sat Feb 06 1999 Preston Brown <pbrown@redhat.com>
  432. - complies w/new RPM, newer libstdc++
  433. * Wed Jan 06 1999 Preston Brown <pbrown@redhat.com>
  434. - re-merged in updates from Duncan Haldane