kdepim-vl.spec 21 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678
  1. %define beta 0
  2. %define vine4 %(grep -c 4. /etc/vine-release)
  3. Name: kdepim
  4. Version: 4.4.2
  5. Release: 1%{?_dist_release}
  6. Summary: PIM (Personal Information Manager) for KDE
  7. Summary(ja): KDE の個人情報管理(PIM)アプリケーション集
  8. Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/%{name}-%{version}.tar.bz2
  9. Patch0: kdepim-4.1.80-libqgpgme-link-fix.patch
  10. # http://bugzilla.redhat.com/show_bug.cgi?id=496988
  11. Patch1: kdepim-4.3.1-kmail-saveAttachments.patch
  12. ## upstream
  13. # KDE.org patches
  14. # KDE.gr.jp patches
  15. URL: http://www.kde.org/
  16. Group: Applications/Productivity
  17. License: GPLv2
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. BuildRequires: akonadi-devel
  20. BuildRequires: bison flex
  21. BuildRequires: libboost-devel
  22. BuildRequires: cyrus-sasl-devel
  23. BuildRequires: desktop-file-utils
  24. BuildRequires: gnokii-devel
  25. BuildRequires: gpgme-devel
  26. BuildRequires: kdepimlibs-devel >= %{version}
  27. BuildRequires: kdelibs-experimental-devel
  28. BuildRequires: libassuan-devel
  29. BuildRequires: libical-devel
  30. BuildRequires: libXpm-devel libXScrnSaver-devel
  31. # TODO: libmapi from http://www.openchange.org/
  32. #BuildRequires: libmapi-devel
  33. BuildRequires: libxslt-devel
  34. # libmal currently not used, recheck with kdepim-4.3
  35. BuildRequires: pilot-link-devel >= 0.12.4
  36. BuildRequires: python-devel
  37. BuildRequires: soprano-devel
  38. BuildRequires: qca2-devel
  39. BuildRequires: zlib-devel
  40. Provides: kdepim4 = %{version}-%{release}
  41. Requires: %{name}-libs = %{version}-%{release}
  42. %description
  43. A PIM (Personal Information Manager) for KDE.
  44. What it is
  45. ----------
  46. * kmail: email client
  47. * knode: newsreader
  48. * knotes: sticky notes for the desktop
  49. * kontact: integrated PIM management
  50. * korganizer: journal, appointments, events, todos
  51. %{?_with_pilot_link:* kpilot: HotSync® software for Palm OS® devices}
  52. %package libs
  53. Summary: %{name} runtime libraries
  54. Group: System Environment/Libraries
  55. Requires: kdelibs4 >= %{version}
  56. %description libs
  57. %{summary}.
  58. %package devel
  59. Summary: Development files for kdepim
  60. Group: Development/Libraries
  61. Provides: kdepim4-devel = %{version}-%{release}
  62. Requires: %{name}-libs = %{version}-%{release}
  63. Requires: kdelibs4-devel
  64. %description devel
  65. Development files for %{name}.
  66. Install %{name}-devel if you want to write or compile %{name} plugins.
  67. %prep
  68. %setup -q
  69. %patch0 -p1 -b .libqgpgme-link-fix
  70. %patch1 -p0 -b .kmail-saveAttachments
  71. %build
  72. mkdir -p %{_target_platform}
  73. pushd %{_target_platform}
  74. unset QTDIR || : ; . /etc/profile.d/qt4.sh
  75. %cmake \
  76. -DCMAKE_BUILD_TYPE=release \
  77. -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
  78. -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
  79. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
  80. -DLIB_INSTALL_DIR:PATH=%{_libdir} \
  81. -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
  82. -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
  83. ..
  84. popd
  85. make %{?_smp_mflags} -C %{_target_platform}
  86. %install
  87. rm -rf $RPM_BUILD_ROOT
  88. make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
  89. # make symlinks relative
  90. mkdir -p $RPM_BUILD_ROOT%{_docdir}/HTML/en/common
  91. pushd $RPM_BUILD_ROOT%{_docdir}/HTML/en
  92. for i in *; do
  93. if [ -d $i -a -L $i/common ]; then
  94. rm -f $i/common
  95. ln -nfs ../common $i
  96. fi
  97. done
  98. popd
  99. %check
  100. for f in $RPM_BUILD_ROOT%{_datadir}/applications/kde4/*.desktop ; do
  101. desktop-file-validate $f
  102. done
  103. %post
  104. touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
  105. touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
  106. %posttrans
  107. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
  108. gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
  109. update-desktop-database -q &> /dev/null ||:
  110. %postun
  111. if [ $1 -eq 0 ] ; then
  112. touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
  113. touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
  114. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
  115. gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
  116. update-desktop-database -q &> /dev/null ||:
  117. fi
  118. %post libs -p /sbin/ldconfig
  119. %postun libs -p /sbin/ldconfig
  120. %clean
  121. rm -rf $RPM_BUILD_ROOT
  122. %files
  123. %defattr(-,root,root)
  124. %{_bindir}/*
  125. #{_libdir}/libkpilot_*.so
  126. %{_libdir}/kde4/*.so
  127. %{_libdir}/strigi/*.so
  128. %{_libdir}/akonadi/*
  129. %{_datadir}/applications/kde4/*.desktop
  130. %{_datadir}/kde4/apps/akregator
  131. #{_datadir}/kde4/apps/akonadi/*
  132. %{_datadir}/kde4/apps/akonadiconsole/*
  133. %{_datadir}/kde4/apps/blogilo/*
  134. %{_datadir}/kde4/apps/kaddressbook
  135. %{_datadir}/kde4/apps/kalarm
  136. %{_datadir}/kde4/apps/kconf_update/*
  137. %{_datadir}/kde4/apps/kdepimwidgets
  138. %{_datadir}/kde4/apps/kjots
  139. %{_datadir}/kde4/apps/kleopatra
  140. %{_datadir}/kde4/apps/kmail
  141. %{_datadir}/kde4/apps/kmailcvt
  142. %{_datadir}/kde4/apps/knode
  143. %{_datadir}/kde4/apps/knotes
  144. %{_datadir}/kde4/apps/konsolekalendar
  145. %{_datadir}/kde4/apps/kontact
  146. %{_datadir}/kde4/apps/kontactsummary
  147. %{_datadir}/kde4/apps/korgac
  148. %{_datadir}/kde4/apps/korganizer
  149. #{_datadir}/kde4/apps/kpilot
  150. %{_datadir}/kde4/apps/ktimetracker
  151. %{_datadir}/kde4/apps/kwatchgnupg
  152. %{_datadir}/kde4/apps/libkdepim
  153. %{_datadir}/kde4/apps/libkleopatra
  154. %{_datadir}/dbus-1/interfaces/*.xml
  155. %{_datadir}/autostart/*
  156. #{_datadir}/akonadi/*
  157. %{_datadir}/config/*
  158. %{_datadir}/config.kcfg/*
  159. %{_datadir}/icons/hicolor/*/*/*
  160. %{_datadir}/icons/oxygen/*/*/*
  161. %{_datadir}/kde4/services/*
  162. %{_datadir}/kde4/servicetypes/*
  163. %doc %{_docdir}/HTML/en/*
  164. %{_mandir}/man1/*
  165. %files libs
  166. %defattr(-,root,root)
  167. %{_libdir}/lib*.so.*
  168. %{_libdir}/kde4/plugins/designer/*.so
  169. %files devel
  170. %defattr(-,root,root)
  171. #{_includedir}/kde4/*
  172. %{_libdir}/lib*.so
  173. #exclude %{_libdir}/libkpilot_*.so
  174. %changelog
  175. * Mon Apr 12 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
  176. - new upstream release
  177. * Sun Mar 7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
  178. - new upstream release
  179. * Sat Mar 6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.0-1
  180. - new upstream release
  181. - built with new toolchain
  182. * Sun Oct 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-1
  183. - new upstream release
  184. * Sun Sep 6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
  185. - new upstream release
  186. - dropped Patch100 (merged into upstream)
  187. - used %%cmake macro
  188. * Thu Aug 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.0-1
  189. - new upstream release
  190. * Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
  191. - applied new versioning policy, spec in UTF-8
  192. - added Japnaese summary
  193. * Tue Oct 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
  194. - rebuild for VineSeed
  195. * Tue Oct 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
  196. - new upstream release
  197. * Wed Jun 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
  198. - rebuild for VineSeed
  199. * Wed May 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
  200. - new upstream release
  201. - remove all patches
  202. * Mon Apr 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
  203. - new upstream release
  204. - add Patch0, 1 , 2 and 3
  205. * Mon Oct 23 2006 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.5-0vl3
  206. - added --with-qt-libraries and --enable-libsuffix option
  207. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
  208. - rebuild for VineSeed
  209. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
  210. - new upstream release
  211. * Mon Sep 4 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl3
  212. - rebuild with pilot-link-0.12.0-0vl1
  213. * Wed Aug 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
  214. - rebuild for VineSeed
  215. * Wed Aug 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
  216. - new upstream release
  217. * Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
  218. - rebuild for VineSeed
  219. * Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
  220. - new upstream release
  221. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
  222. - rebuild for VineSeed
  223. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
  224. - new upstream release
  225. * Tue Jan 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
  226. - rebuild for VineSeed
  227. * Tue Jan 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
  228. - new upstream release
  229. - delete BuildPrereq: libmal-devel and Requires: libmal
  230. * Thu Dec 8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl2
  231. - rebuild for VineSeed
  232. * Mon Nov 28 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl1
  233. - new upstream release
  234. * Mon Nov 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl0.rc1
  235. - new upstream release
  236. * Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.92-0vl1
  237. - new upstream release
  238. - delete all patches
  239. - add Requires: kdeaccessibility >= %%{version}
  240. - add --enable-indexlib to configure option
  241. * Tue Sep 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.91-0vl1
  242. - new upstream release
  243. - remove Patch0
  244. - add Patch0 - Patch1
  245. * Tue Aug 2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl2
  246. - rebuild for VineSeed
  247. * Tue Aug 2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl1
  248. - new upstream release
  249. - remove Patch0
  250. - add BuildPrereq: gpgme-devel >= 0.4.5
  251. - add Patch0 (http://bugs.kde.org/show_bug.cgi?id=109003)
  252. * Mon Jul 4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl2
  253. - rebuild for VineSeed
  254. - add --disable-rpath to configure option
  255. * Mon Jun 6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl1
  256. - new upstream release (delete old patch and add new security patch)
  257. - use %%{?_smp_mflags} for make option
  258. * Thu Mar 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl2
  259. - rebuild for VineSeed
  260. * Wed Mar 16 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl1
  261. - new upstream release
  262. - add patch0
  263. * Fri Mar 4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl0.rc1
  264. - new upstream release (3.4.0-rc1)
  265. * Tue Feb 8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.92-0vl1
  266. - new upstream release
  267. * Wed Feb 2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.91-0vl1
  268. - new upstream release
  269. * Sat Jan 1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
  270. - rebuild for VineSeed
  271. * Sat Jan 1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
  272. - new upstream release
  273. * Sun Oct 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
  274. - source upgrade
  275. - update %%files
  276. - all sub-packages are integrated into main package (exclude devel)
  277. * Tue Aug 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl2
  278. - rebuild with qt32
  279. * Tue Jun 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl1
  280. - source upgrade
  281. - remove lines about vine26
  282. * Sat May 1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
  283. - source upgrade
  284. - update %%files
  285. * Sat Mar 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
  286. - source upgrade
  287. - update %%description
  288. - add Obsoletes: kdenetwork < 3.2.0
  289. * Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl2
  290. - rebuild for VineSeedPlus
  291. * Sun Jan 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl1
  292. - source upgrade
  293. - build for VinePlus/2.6
  294. - (VinePlus/2.6) BuildPrereq: autoconf258
  295. - remove Patch
  296. * Sun Dec 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl3
  297. - build for VineSeed with new toolchain and qt-3.2.3
  298. - add configure option --with-xinerama --enable-final
  299. * Sun Nov 2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl2
  300. - rebuild with qt-3.2.1-0.26vl3
  301. * Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl2
  302. - rebuild with qt-3.2.1-0vl3
  303. * Sat Sep 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl1
  304. - build with gcc-3.2.3
  305. * Thu Sep 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl1
  306. - source upgrade
  307. - BuildPrereq: qt-devel >= 3.2.1 arts-devel >= 1:1.1.4
  308. * Sat Aug 2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0.26vl1
  309. - rebuild for Vine2.6
  310. * Mon Jul 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0vl1
  311. - source upgrade
  312. - change spec to build with gcc295
  313. - change make option for SMP and add script
  314. - add BuildPrereq: libmal-devel
  315. - add Requires: libmal for pilot
  316. * Sat May 10 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
  317. - source upgrade
  318. - remove Patch800 (included in this source)
  319. - built with libpng >= 1.2.5 when %%{vine26} is set to 0 (ie VineSeedPlus)
  320. * Sat Apr 5 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
  321. - source upgrade
  322. - change spec to build both VineSeed and Vine2.5/2.6
  323. - revised description and files section
  324. - remove source900
  325. - add patch0 (http://bugs.kde.org/show_bug.cgi?id=55541)
  326. - add patch800 (Kdeveloper:02753)
  327. * Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
  328. - objprelink2 support only ix86 (add %%ifarch %%{ix86} ... )
  329. * Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
  330. - source upgrade
  331. * Wed Oct 9 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl2
  332. - rebuild with qt-3.0.5-0vl1
  333. - BuildPrereq: autoconf253 objprelink2
  334. * Wed Sep 18 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
  335. - source upgrade
  336. * Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.2-0vl1
  337. - source upgrade
  338. - add BuildPrereq: autoconf252 automake15
  339. * Thu Jul 4 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.1-1vl1
  340. - merged with rawhide 3.0.1-1
  341. - change %%doc %%{_docdir}/HTML -> %%doc %%{_datadir}/doc/HTML
  342. - add Requires: for each package
  343. - There is Vine's previous changes, hacked for Vine
  344. -- Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-1vl1
  345. - build for VineSeed
  346. - delete Epoch
  347. - objprelink (i386 only)
  348. * Tue Jun 25 2002 Than Ngo <than@redhat.com> 3.0.1-1
  349. - 3.0.1
  350. - fixed bug #67303
  351. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  352. - automated rebuild
  353. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  354. - automated rebuild
  355. * Tue Apr 16 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-3
  356. - Rename libraries
  357. * Wed Apr 10 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-2
  358. - Fix #61901
  359. * Fri Mar 29 2002 Than Ngo <than@redhat.com> 3.0.0-1
  360. - final
  361. * Tue Jan 22 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020122.1
  362. - Update
  363. - Fix build on ia64
  364. * Thu Jul 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010726.1
  365. - Update, fixes korganizer (#50006)
  366. * Sun May 13 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  367. - Update to get rid of abbrowser (moved to kdebase)
  368. * Thu Feb 22 2001 Than Ngo <than@redhat.com>
  369. - add missing ldconfig in %post anf %postun again
  370. - clean up specfile
  371. * Wed Feb 21 2001 Than Ngo <than@redhat.com>
  372. - 2.1-respin
  373. - fix dangling symlink
  374. - remove excludearch ia64, some hacks to build on ia64
  375. * Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  376. - 2.1
  377. * Mon Feb 5 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  378. - Update
  379. * Tue Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  380. - Update
  381. * Wed Dec 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  382. - Update to CVS
  383. - Enable building kpilot
  384. - Obsolete kpilot
  385. - Don't exclude ia64, use -O0 on ia64
  386. - Disable building kpilot on ia64 (compiler breakage)
  387. * Mon Oct 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  388. - 2.0 final
  389. * Wed Oct 4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  390. - 2.0
  391. * Sun Oct 1 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  392. - new CVS
  393. - fix installation of fonts
  394. * Sat Sep 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  395. - new CVS snapshot
  396. - fix up spec file
  397. * Wed Aug 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  398. - get rid of the 3d-screensavers package - now that qt-GL is part of qt,
  399. there's no need to keep them separate to avoid the dependency.
  400. * Mon Aug 21 2000 Than Ngo <than@redhat.com>
  401. - fix gnome-session so that KDE2 can be started from gdm
  402. - pam/kde2 instead pam/kde to avoid problem with KDE1
  403. - don't requires qt-GL, It's now in qt
  404. * Sun Aug 20 2000 Than Ngo <than@redhat.com>
  405. - fix dependency problem with KDE1 so that KDE1 and KDE2 can be installed
  406. at the same time
  407. - add missing ldconfig in %post anf %postun
  408. - fix for reading config files in /etc/X11/xdm, add Xsession to requires
  409. * Tue Aug 8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  410. - Fix keytable in konsole (Bug #15682)
  411. * Sun Aug 6 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  412. - rebuild, now that kdelibs2 works on alpha
  413. - use the same ugly hack to get kdebase to compile
  414. - remove ksysguard on alpha (even more compiler problems)
  415. * Fri Aug 4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  416. - new snapshot (fixed libGL detection in CVS)
  417. * Wed Aug 2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  418. - move to /usr/lib/kde2
  419. - new snapshot
  420. * Sun Jul 23 2000 Nalin Dahyabhai <nalin@redhat.com>
  421. - fix the --xdmdir arg to be correct (oops)
  422. * Fri Jul 21 2000 Nalin Dahyabhai <nalin@redhat.com>
  423. - move kdm config files from /usr/config to /etc/X11 by forcing xdmdir
  424. * Fri Jul 21 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  425. - new snapshot
  426. - some fixes to spec file
  427. * Tue Jul 18 2000 Than Ngo <than@redhat.de>
  428. - rebuilt against glibc-2.1.92-14, gcc-2.96-40
  429. * Sun Jul 16 2000 Than Ngo <than@redhat.de>
  430. - use new snapshot
  431. - disable Motif
  432. * Tue Jul 11 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  433. - use gcc 2.96
  434. - new snapshot
  435. * Sun Jul 2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  436. - Epoch 3
  437. - Update to current
  438. - Use egcs++
  439. * Fri Jun 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  440. - Update (I put the fixes directly to CVS rather than collecting them
  441. in the spec)
  442. * Fri Jun 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  443. - remove man2html; we get that from man
  444. - new snapshot
  445. * Tue Jun 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  446. - new snapshot
  447. - ExcludeArch ia64 for now
  448. - remove gnome .desktop file, we get it from gnome-core now.
  449. * Wed Apr 5 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  450. - remove dependency on xpm (now in XFree86)
  451. * Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  452. - new snapshot
  453. - move it to /usr, where it belongs
  454. * Sat Dec 25 1999 Bernhard Rosenkraenzer <bero@redhat.com>
  455. - Build the OpenGL screensavers, and move them to a separate package
  456. - Improve the spec file (BuildPrereqs etc.)
  457. * Thu Dec 16 1999 Bernhard Rosenkraenzer <bero@redhat.com>
  458. - remove patch #3 (obsoleted by kwin)
  459. * Sun Oct 24 1999 Bernhard Rosenkraenzer <bero@redhat.de>
  460. - 2.0 CVS snapshot
  461. - fix compilation
  462. * Thu Sep 23 1999 Preston Brown <pbrown@redhat.com>
  463. - clean up files in /tmp from startkde
  464. - mark doc files as such
  465. * Tue Sep 21 1999 Preston Brown <pbrown@redhat.com>
  466. - start autorun if present in startkde
  467. - check for configured soundcard before running sound services
  468. * Mon Sep 20 1999 Preston Brown <pbrown@redhat.com>
  469. - made kdelnks display Name property if they are of type Link
  470. * Thu Sep 16 1999 Preston Brown <pbrown@redhat.com>
  471. - moved png handling here (from kdelibs)
  472. - changed low color icon directory name to locolor
  473. * Tue Sep 14 1999 Preston Brown <pbrown@redhat.com>
  474. - added optional session management to logout dialog
  475. - include GNOME menus
  476. * Mon Sep 13 1999 Preston Brown <pbrown@redhat.com>
  477. - added link to /etc/X11/applnk, .directory file
  478. - included lowcolor icon sub-package
  479. - enable .desktop file access
  480. * Fri Sep 10 1999 Preston Brown <pbrown@redhat.com>
  481. - customized startkde script to set up user environment if not present.
  482. - mention kthememgr in description.
  483. * Wed Sep 08 1999 Preston Brown <pbrown@redhat.com>
  484. - upgraded to 1.1.2 release
  485. - kvt is back
  486. - kde icon included
  487. - linux console fonts included
  488. * Thu Jul 15 1999 Preston Brown <pbrown@redhat.com>
  489. - PAM console logout problem solved.
  490. * Mon Jul 12 1999 Preston Brown <pbrown@redhat.com>
  491. - now includes screensaver password security fix
  492. * Fri Jun 11 1999 Preston Brown <pbrown@redhat.com>
  493. - snapshot, includes kde 1.1.1 + fixes
  494. - kvt removed for security reasons. It is a steaming pile of...
  495. * Mon Apr 19 1999 Preston Brown <pbrown@redhat.com>
  496. - last snapshot before release
  497. * Fri Apr 16 1999 Preston Brown <pbrown@redhat.com>
  498. - today's snapshot makes kfm a bit nicer and some other fixes
  499. - moved default rc files to kdesupport
  500. * Thu Apr 15 1999 Preston Brown <pbrown@redhat.com>
  501. - SUID bit removed from konsole_grantpty -- not needed w/glibc 2.1
  502. * Wed Apr 14 1999 Preston Brown <pbrown@redhat.com>
  503. - built with today's snapshot -- had to rebuild to fix pam problems.
  504. * Tue Apr 13 1999 Preston Brown <pbrown@redhat.com>
  505. - new snapshot fixes mimetype video/x-flic problem
  506. * Mon Apr 12 1999 Preston Brown <pbrown@redhat.com>
  507. - latest stable snapshot
  508. * Fri Apr 09 1999 Preston Brown <pbrown@redhat.com>
  509. - removed bell.xpm (used to be in fvwm2-icons, don't want installer to see
  510. - this previous connection and autoselect kdebase for upgrade).
  511. * Tue Mar 23 1999 Preston Brown <pbrown@redhat.com>
  512. - moved gdm patch
  513. * Mon Mar 22 1999 Preston Brown <pbrown@redhat.com>
  514. - added gdm session control file
  515. * Fri Mar 19 1999 Preston Brown <pbrown@redhat.com>
  516. - added pam-console stuff to kde pam file
  517. * Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
  518. - Injected new description and group.
  519. * Mon Feb 07 1999 Preston Brown <pbrown@redhat.com>
  520. - upgraded to KDE 1.1 final.
  521. * Tue Jan 19 1999 Preston Brown <pbrown@redhat.com>
  522. - updated macros for RPM 3.0, removed red hat logo.
  523. * Tue Jan 05 1999 Preston Brown <pbrown@redhat.com>
  524. - re-merged from Duncan Haldane's stuff