123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253 |
- Summary: PolicyKit Authorization Framework
- Summary(ja): PolicyKit 認証フレームワーク
- Name: polkit
- Version: 0.96
- Release: 1%{?_dist_release}
- License: LGPLv2+
- URL: http://www.freedesktop.org/wiki/Software/PolicyKit
- Source0: http://hal.freedesktop.org/releases/%{name}-%{version}.tar.gz
- BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
- Group: System Environment/Libraries
- BuildRequires: glib2-devel
- BuildRequires: expat-devel
- BuildRequires: pam-devel
- BuildRequires: eggdbus-devel >= 0.6
- BuildRequires: gtk-doc
- BuildRequires: intltool
- BuildRequires: gobject-introspection-devel
- Requires: ConsoleKit
- Requires: dbus
- #Obsoletes: PolicyKit <= 0.10
- #Provides: PolicyKit = 0.11
- %description
- PolicyKit is a toolkit for defining and handling authorizations.
- It is used for allowing unprivileged processes to speak to privileged
- processes.
- %package devel
- Summary: Development files for PolicyKit
- Summary(ja): PolicyKit の開発用ファイル
- Group: Development/Libraries
- Requires: %name = %{version}-%{release}
- Requires: %name-docs = %{version}-%{release}
- Requires: pkgconfig
- Requires: glib2-devel
- #Obsoletes: PolicyKit-devel <= 0.10
- #Provides: PolicyKit-devel = 0.11
- %description devel
- Development files for PolicyKit.
- %package docs
- Summary: Development documentation for PolicyKit
- Summary(ja): PolicyKit の開発用ドキュメント
- Group: Development/Libraries
- Requires: %name-devel = %{version}-%{release}
- Requires: gtk-doc
- #Obsoletes: PolicyKit-docs <= 0.10
- #Provides: PolicyKit-docs = 0.11
- %description docs
- Development documentation for PolicyKit.
- %package desktop-policy
- Summary: Roles and default policy for desktop usage
- Summary(ja): デスクトップ用途のロールとデフォルトポリシー
- Group: Development/Libraries
- #Requires: %name = %{version}-%{release}
- Requires(pre): /usr/sbin/groupadd
- Requires(preun): /usr/sbin/groupdel
- %description desktop-policy
- Roles and default policy for desktop usage.
- %prep
- %setup -q
- %build
- %configure --enable-gtk-doc --disable-static --libexecdir=%{_libexecdir}/polkit-1 --enable-introspection --enable-examples
- make
- %install
- rm -rf $RPM_BUILD_ROOT
- make install DESTDIR=$RPM_BUILD_ROOT
- rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
- rm -f $RPM_BUILD_ROOT%{_libdir}/polkit-1/extensions/*.la
- %find_lang polkit-1
- ###
- ### BEGIN DESKTOP POLICY CONFIGURATION ###
- ###
- cat > $RPM_BUILD_ROOT%{_sysconfdir}/polkit-1/localauthority.conf.d/60-desktop-policy.conf << EOF
- # This allows users in the desktop_admin_r group to authenticate as
- # the administrator.
- #
- # DO NOT EDIT THIS FILE, it will be overwritten on update.
- [Configuration]
- AdminIdentities=unix-group:desktop_admin_r
- EOF
- cat > $RPM_BUILD_ROOT%{_localstatedir}/lib/polkit-1/localauthority/10-vendor.d/10-desktop-policy.pkla << EOF
- # Authorizations/policy for the desktop_admin_r and desktop_user_r groups.
- #
- # DO NOT EDIT THIS FILE, it will be overwritten on update.
- # Allow "standard users" to do some things without being interrupted by
- # password dialogs (TODO: not complete)
- #
- [Desktop User Permissions]
- Identity=unix-group:desktop_user_r
- Action=org.gnome.clockapplet.mechanism.settimezone
- ResultAny=no
- ResultInactive=no
- ResultActive=yes
- # Allow "administrative users" to do a lot of things without being interrupted by
- # password dialogs (TODO: not complete)
- #
- [Desktop Administrator Permissions]
- Identity=unix-group:desktop_admin_r
- Action=org.gnome.clockapplet.mechanism.*;org.freedesktop.devicekit.disks.*;org.freedesktop.RealtimeKit1.*
- ResultAny=no
- ResultInactive=no
- ResultActive=yes
- EOF
- ###
- ### END DESKTOP POLICY CONFIGURATION
- ###
- %clean
- rm -rf $RPM_BUILD_ROOT
- %post -p /sbin/ldconfig
- %postun -p /sbin/ldconfig
- %pre desktop-policy
- /usr/sbin/groupadd -r desktop_admin_r 2> /dev/null || :
- /usr/sbin/groupadd -r desktop_user_r 2> /dev/null || :
- %files desktop-policy
- %{_sysconfdir}/polkit-1/localauthority.conf.d/60-desktop-policy.conf
- %{_localstatedir}/lib/polkit-1/localauthority/10-vendor.d/10-desktop-policy.pkla
- %files -f polkit-1.lang
- %defattr(-,root,root,-)
- %doc COPYING
- %{_libdir}/lib*.so.*
- %dir %{_libdir}/polkit-1
- %dir %{_libdir}/polkit-1/extensions
- %{_libdir}/polkit-1/extensions/*.so
- %{_datadir}/man/man1/*
- %{_datadir}/man/man8/*
- %{_datadir}/dbus-1/system-services/*
- %dir %{_datadir}/polkit-1/
- %dir %{_datadir}/polkit-1/actions
- %{_datadir}/polkit-1/actions/org.freedesktop.policykit.policy
- %{_sysconfdir}/dbus-1/system.d/org.freedesktop.PolicyKit1.conf
- %{_sysconfdir}/pam.d/polkit-1
- %{_sysconfdir}/polkit-1
- %{_bindir}/pkaction
- %{_bindir}/pkcheck
- %{_libexecdir}/polkit-1/polkitd
- %{_libdir}/girepository-1.0/*.typelib
- # see upstream docs for why these permissions are necessary
- %attr(4755,root,root) %{_bindir}/pkexec
- %attr(4755,root,root) %{_libexecdir}/polkit-1/polkit-agent-helper-1
- %attr(0700,root,root) %dir %{_localstatedir}/lib/polkit-1/
- %dir %{_localstatedir}/lib/polkit-1/localauthority
- %dir %{_localstatedir}/lib/polkit-1/localauthority/10-vendor.d
- %dir %{_localstatedir}/lib/polkit-1/localauthority/20-org.d
- %dir %{_localstatedir}/lib/polkit-1/localauthority/30-site.d
- %dir %{_localstatedir}/lib/polkit-1/localauthority/50-local.d
- %dir %{_localstatedir}/lib/polkit-1/localauthority/90-mandatory.d
- %files devel
- %defattr(-,root,root,-)
- %{_libdir}/lib*.so
- %{_libdir}/pkgconfig/*.pc
- %{_datadir}/gir-1.0/*.gir
- %{_includedir}/*
- %{_bindir}/pk-example-frobnicate
- %{_datadir}/polkit-1/actions/org.freedesktop.policykit.examples.pkexec.policy
- %files docs
- %defattr(-,root,root,-)
- %{_datadir}/gtk-doc/html/*
- %changelog
- * Mon Feb 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.96-1
- - update to 0.96
- - BR: eggdbus-devel >= 0.6
- * Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.95-0.2.git20090913
- - remove Obsoletes:/Provides: PolicyKit*
- * Sat Sep 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.95-0.1.git20090913
- - initial build for Vine Linux
- * Mon Sep 14 2009 David Zeuthen <davidz@redhat.com> - 0.95-0.git20090913.2
- - Refine how Obsolete: is used and also add Provides: (thanks Jesse
- Keating and nim-nim)
- * Mon Sep 14 2009 David Zeuthen <davidz@redhat.com> - 0.95-0.git20090913.1
- - Add bugfix for polkit_unix_process_new_full() (thanks Bastien Nocera)
- - Obsolete old PolicyKit packages
- * Sun Sep 13 2009 David Zeuthen <davidz@redhat.com> - 0.95-0.git20090913
- - Update to git snapshot
- - Drop upstreamed patches
- - Turn on GObject introspection
- - Don't delete desktop_admin_r and desktop_user_r groups when
- uninstalling polkit-desktop-policy
- * Fri Sep 11 2009 David Zeuthen <davidz@redhat.com> - 0.94-4
- - Add some patches from git master
- - Sort pkaction(1) output
- - Bug 23867 – UnixProcess vs. SystemBusName aliasing
- * Thu Aug 13 2009 David Zeuthen <davidz@redhat.com> - 0.94-3
- - Add desktop_admin_r and desktop_user_r groups along with a first cut
- of default authorizations for users in these groups.
- * Wed Aug 12 2009 David Zeuthen <davidz@redhat.com> - 0.94-2
- - Disable GObject Introspection for now as it breaks the build
- * Wed Aug 12 2009 David Zeuthen <davidz@redhat.com> - 0.94-1
- - Update to upstream release 0.94
- * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.93-3
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
- * Mon Jul 20 2009 David Zeuthen <davidz@redhat.com> - 0.93-2
- - Rebuild
- * Mon Jul 20 2009 David Zeuthen <davidz@redhat.com> - 0.93-1
- - Update to 0.93
- * Tue Jun 09 2009 David Zeuthen <davidz@redhat.com> - 0.92-3
- - Don't make docs noarch (I *heart* multilib)
- - Change license to LGPLv2+
- * Mon Jun 08 2009 David Zeuthen <davidz@redhat.com> - 0.92-2
- - Rebuild
- * Mon Jun 08 2009 David Zeuthen <davidz@redhat.com> - 0.92-1
- - Update to 0.92 release
- * Wed May 27 2009 David Zeuthen <davidz@redhat.com> - 0.92-0.git20090527
- - Update to 0.92 snapshot
- * Mon Feb 9 2009 David Zeuthen <davidz@redhat.com> - 0.91-1
- - Initial spec file.
|