123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107 |
- %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
- %{!?pyver: %define pyver %(%{__python} -c "import sys ; print sys.version[:3]")}
- %define pkg_release 2%{?_dist_release}
- Name: python-nose
- Version: 0.10.4
- Release: %{pkg_release}
- Summary: A discovery-based unittest extension for Python
- Summary(ja): Python 用の発見型ユニットテスト・エクステンション
- Group: Development/Languages
- License: LGPLv2
- URL: http://somethingaboutorange.com/mrl/projects/nose/
- Source0: http://somethingaboutorange.com/mrl/projects/nose/nose-%{version}.tar.gz
- BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
- BuildArch: noarch
- BuildRequires: python-devel, python-setuptools
- Requires: python-setuptools
- %description
- nose: a discovery-based unittest extension.
- nose provides an alternate test discovery and running process for unittest,
- one that is intended to mimic the behavior of py.test as much as is
- reasonably possible without resorting to too much magic.
- %prep
- %setup -q -n nose-%{version}
- %build
- CFLAGS="${RPM_OPT_FLAGS}" %{__python} setup.py build
- %install
- rm -rf ${RPM_BUILD_ROOT}
- %{__python} setup.py install -O1 --skip-build --root ${RPM_BUILD_ROOT} \
- --single-version-externally-managed --install-data=%{_datadir}
- %clean
- rm -rf ${RPM_BUILD_ROOT}
- %files
- %defattr(-,root,root,-)
- %doc AUTHORS CHANGELOG lgpl.txt NEWS README.txt
- %{_bindir}/nosetests
- %{_mandir}/man1/nosetests.1.gz
- %{python_sitelib}/nose-%{version}-py%{pyver}.egg-info
- %{python_sitelib}/nose
- %changelog
- * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.10.4-2
- - rebuild with python-2.6
- * Sat Dec 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.10.4-1
- - initial build for Vine Linux based on fedora package
- * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.10.4-1
- - Update to 0.10.4 to fix 2.6 issues
- * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.10.3-2
- - Rebuild for Python 2.6
- * Sat Aug 02 2008 Luke Macken <lmacken@redhat.com> 0.10.3-1
- - Update to 0.10.3
- * Thu Feb 28 2008 Luke Macken <lmacken@redhat.com> 0.10.1-1
- - Update to 0.10.1
- * Mon Dec 3 2007 Luke Macken <lmacken@redhat.com> 0.10.0-2
- - Add python-setuptools to Requires (Bug #408491)
- * Tue Nov 27 2007 Luke Macken <lmacken@redhat.com> 0.10.0-1
- - 0.10.0
- * Sun Sep 2 2007 Luke Macken <lmacken@redhat.com> 0.10.0-0.3.b1
- - Update for python-setuptools changes in rawhide
- * Tue Aug 21 2007 Luke Macken <lmacken@redhat.com> 0.10.0-0.2.b1
- - 0.10.0b1
- - Update license tag to LGPLv2
- * Fri Jun 20 2007 Luke Macken <lmacken@redhat.com> 0.10.0-0.1.a2
- - 0.10.0a2
- * Sat Jun 2 2007 Luke Macken <lmacken@redhat.com> 0.9.3-1
- - Latest upstream release
- - Remove python-nose-0.9.2-mandir.patch
- * Sat Mar 3 2007 Luke Macken <lmacken@redhat.com> 0.9.2-1
- - Add nosetests(1) manpage, and python-nose-0.9.2-mandir.patch to put it in
- the correct location.
- - 0.9.2
- * Sat Dec 9 2006 Luke Macken <lmacken@redhat.com> 0.9.1-2
- - Rebuild for python 2.5
- * Fri Nov 24 2006 Luke Macken <lmacken@redhat.com> 0.9.1-1
- - 0.9.1
- * Fri Sep 8 2006 Luke Macken <lmacken@redhat.com> 0.9.0-1
- - 0.9.0
- * Wed Apr 19 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 0.8.7.2-1
- - Initial RPM release
|