python-simplejson-vl.spec 4.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147
  1. %{!?pyver: %define pyver %(%{__python} -c "import sys ; print sys.version[:3]")}
  2. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  3. %define pkg_release 2%{?_dist_release}
  4. Name: python-simplejson
  5. Version: 2.0.3
  6. Release: %{pkg_release}
  7. Summary: Simple, fast, extensible JSON encoder/decoder for Python
  8. Summary(ja): Python 用のシンプルで速くて拡張可能な JSON エンコーダ/デコーダ
  9. Group: System Environment/Libraries
  10. License: MIT
  11. URL: http://undefined.org/python/#simplejson
  12. Source0: http://cheeseshop.python.org/packages/source/s/simplejson/simplejson-%{version}.tar.gz
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  14. BuildRequires: python-devel
  15. BuildRequires: python-setuptools
  16. BuildRequires: python-nose
  17. %description
  18. simplejson is a simple, fast, complete, correct and extensible
  19. JSON <http://json.org> encoder and decoder for Python 2.3+. It is
  20. pure Python code with no dependencies.
  21. simplejson was formerly known as simple_json, but changed its name to
  22. comply with PEP 8 module naming guidelines.
  23. The encoder may be subclassed to provide serialization in any kind of
  24. situation, without any special support by the objects to be serialized
  25. (somewhat like pickle).
  26. The decoder can handle incoming JSON strings of any specified encoding
  27. (UTF-8 by default).
  28. %prep
  29. %setup -q -n simplejson-%{version}
  30. %build
  31. %{__python} setup.py build
  32. %install
  33. %{__rm} -rf ${RPM_BUILD_ROOT}
  34. %{__python} setup.py install -O1 --skip-build --root=${RPM_BUILD_ROOT} \
  35. --single-version-externally-managed
  36. %check
  37. nosetests -q
  38. %clean
  39. rm -rf ${RPM_BUILD_ROOT}
  40. %files
  41. %defattr(-,root,root,-)
  42. %doc docs LICENSE.txt
  43. %dir %{python_sitearch}/simplejson
  44. %{python_sitearch}/simplejson-%{version}-py%{pyver}.egg-info
  45. %{python_sitearch}/simplejson/*.py*
  46. %{python_sitearch}/simplejson/tests/*.py*
  47. %{python_sitearch}/simplejson/_speedups.so
  48. %changelog
  49. * Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.0.3-2
  50. - rebuild with python-2.6.4
  51. * Sat Dec 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.3-1
  52. - initial build for Vine Linux based on fedora package
  53. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.0.3-3
  54. - Rebuild for Python 2.6
  55. * Thu Oct 23 2008 Luke Macken <lmacken@redhat.com> 2.0.3-2
  56. - Use nose to run the simplejson test suite
  57. * Mon Oct 20 2008 Tom "spot" Callaway <tcallawa@redhat.com> 2.0.3-1
  58. - update to 2.0.3
  59. * Wed Oct 01 2008 Luke Macken <lmacken@redhat.com> - 2.0.1-1
  60. - Update to 2.0.1, which contains many optimizations and bugfixes
  61. * Wed Sep 24 2008 Luke Macken <lmacken@redhat.com> - 1.9.3-1
  62. - Update to 1.9.3, which includes a significant decoding speed boost, and
  63. various bug fixes.
  64. * Tue May 06 2008 Luke Macken <lmacken@redhat.com> - 1.9.1-1
  65. - Update to 1.9.1
  66. * Wed Apr 02 2008 Luke Macken <lmacken@redhat.com> - 1.8.1-1
  67. - Update to 1.8.1
  68. * Thu Feb 28 2008 Luke Macken <lmacken@redhat.com> - 1.7.4-1
  69. - Update to 1.7.4
  70. * Fri Feb 8 2008 Luke Macken <lmacken@redhat.com> - 1.7.3-3
  71. - Rebuild for gcc 4.3
  72. * Wed Oct 24 2007 Luke Macken <lmacken@redhat.com> - 1.7.3-2
  73. - Include the LICENSE.txt
  74. * Wed Oct 3 2007 Luke Macken <lmacken@redhat.com> - 1.7.3-1
  75. - 1.7.3
  76. * Sun Sep 2 2007 Luke Macken <lmacken@redhat.com> - 1.7.1-3
  77. - Update for python-setuptools changes in rawhide
  78. * Tue Aug 21 2007 Luke Macken <lmacken@redhat.com> - 1.7.1-2
  79. - Rebuild
  80. * Sun Jul 8 2007 Luke Macken <lmacken@redhat.com> - 1.7.1-1
  81. - 1.7.1
  82. * Wed Mar 21 2007 Luke Macken <lmacken@redhat.com> - 1.7-2
  83. - Use python_sitearch instead of sitelib
  84. * Tue Mar 20 2007 Luke Macken <lmacken@redhat.com> - 1.7-1
  85. - 1.7 (Bug #233212)
  86. * Sat Mar 3 2007 Luke Macken <lmacken@redhat.com> - 1.5
  87. - 1.5
  88. * Sat Dec 9 2006 Luke Macken <lmacken@redhat.com> - 1.4-4
  89. - Add python-devel to BuildRequires
  90. * Sat Dec 9 2006 Luke Macken <lmacken@redhat.com> - 1.4-2
  91. - Rebuild for new python
  92. * Fri Nov 24 2006 Luke Macken <lmacken@redhat.com> - 1.4-1
  93. - 1.4
  94. * Sun Sep 3 2006 Luke Macken <lmacken@redhat.com> - 1.3-4
  95. - Rebuild for FC6
  96. * Mon Aug 14 2006 Luke Macken <lmacken@redhat.com> - 1.3-3
  97. - Include .pyo's instead of just ghosting them
  98. * Wed Jul 12 2006 Luke Macken <lmacken@redhat.com> - 1.3-2
  99. - Add --single-version-externally-managed flag to install
  100. * Mon Jul 10 2006 Luke Macken <lmacken@redhat.com> - 1.3-1
  101. - Initial package