git-vl.spec 21 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701
  1. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  2. %define emacsen_pkgdir /usr/lib/emacsen-common/packages
  3. # Pass --without docs to rpmbuild if you don't want the documentation
  4. Name: git
  5. Version: 1.6.3.3
  6. Release: 1%{?_dist_release}
  7. Summary: Core git tools
  8. Summary(ja): Core git ツール
  9. License: GPLv2
  10. Group: Development/Tools
  11. URL: http://git-scm.com/
  12. Source: http://kernel.org/pub/software/scm/git/%{name}-%{version}.tar.bz2
  13. Source1: git-init.el
  14. Source2: git.xinetd
  15. Source3: git.conf.httpd
  16. Source10: %{name}-install.sh
  17. Source11: %{name}-remove.sh
  18. Patch0: git-1.5-gitweb-home-link.patch
  19. # Patch10: git-1.6_git-daemon-fix.patch
  20. BuildRequires: zlib-devel >= 1.2, openssl-devel, curl-devel,
  21. BuildRequires: expat-devel, gettext, asciidoc
  22. BuildRequires: xmlto
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  24. Requires: perl-Git = %{version}-%{release}
  25. Requires: zlib
  26. Provides: git-core = %{version}-%{release}
  27. Obsoletes: git-core <= 1.5.4.3
  28. %description
  29. Git is a fast, scalable, distributed revision control system with an
  30. unusually rich command set that provides both high-level operations
  31. and full access to internals.
  32. The git rpm installs the core tools with minimal dependencies. To
  33. install all git packages, including tools for integrating with other
  34. SCMs, install the git-all meta-package.
  35. %package all
  36. Summary: Meta-package to pull in all git tools
  37. Summary(ja): すべての git ツール
  38. Group: Development/Tools
  39. Requires: git = %{version}-%{release}
  40. Requires: git-svn = %{version}-%{release}
  41. Requires: git-cvs = %{version}-%{release}
  42. %if "%{?_dist_release}" != "vl4"
  43. Requires: git-arch = %{version}-%{release}
  44. %endif
  45. Requires: git-email = %{version}-%{release}
  46. Requires: gitk = %{version}-%{release}
  47. Requires: git-gui = %{version}-%{release}
  48. Requires: perl-Git = %{version}-%{release}
  49. Requires: emacs-git = %{version}-%{release}
  50. Obsoletes: git <= 1.5.4.3
  51. %description all
  52. Git is a fast, scalable, distributed revision control system with an
  53. unusually rich command set that provides both high-level operations
  54. and full access to internals.
  55. This is a dummy package which brings in all subpackages.
  56. %package daemon
  57. Summary: Git protocol daemon
  58. Summary(ja): Git プロトコルデーモン
  59. Group: Development/Tools
  60. Requires: git = %{version}-%{release}
  61. %description daemon
  62. The git daemon for supporting git:// access to git repositories
  63. %package -n gitweb
  64. Summary: Simple web interface to git repositories
  65. Summary(ja): git リポジトリへのシンプルな Web インタフェース
  66. Group: Development/Tools
  67. Requires: git = %{version}-%{release}
  68. %description -n gitweb
  69. Simple web interface to track changes in git repositories
  70. %package svn
  71. Summary: Git tools for importing Subversion repositories
  72. Summary(ja): Subversion リポジトリを git へインポートするためのツール
  73. Group: Development/Tools
  74. Requires: git = %{version}-%{release}, subversion, perl(Term::ReadKey)
  75. Requires: perl(SVN::Core)
  76. %description svn
  77. Git tools for importing Subversion repositories.
  78. %package cvs
  79. Summary: Git tools for importing CVS repositories
  80. Summary(ja): CVS リポジトリを git へインポートするためのツール
  81. Group: Development/Tools
  82. Requires: git = %{version}-%{release}, cvs, cvsps
  83. %description cvs
  84. Git tools for importing CVS repositories.
  85. %if "%{?_dist_release}" != "vl4"
  86. %package arch
  87. Summary: Git tools for importing Arch repositories
  88. Summary(ja): Arch リポジトリを git へインポートするためのツール
  89. Group: Development/Tools
  90. Requires: git = %{version}-%{release}, tla
  91. %description arch
  92. Git tools for importing Arch repositories.
  93. %endif
  94. %package email
  95. Summary: Git tools for sending email
  96. Summary(ja): Eメールを送るための git ツール
  97. Group: Development/Tools
  98. Requires: git = %{version}-%{release}, perl-Git = %{version}-%{release}
  99. %description email
  100. Git tools for sending email.
  101. %package gui
  102. Summary: Git GUI tool
  103. Summary(ja): Git の GUI ツール
  104. Group: Development/Tools
  105. Requires: git = %{version}-%{release}, tk
  106. %description gui
  107. Git GUI tool.
  108. %package -n gitk
  109. Summary: Git revision tree visualiser
  110. Summary(ja): Git リビジョンツリー可視化ツール
  111. Group: Development/Tools
  112. Requires: git = %{version}-%{release}, tk
  113. %description -n gitk
  114. Git revision tree visualiser.
  115. %package -n perl-Git
  116. Summary: Perl interface to Git
  117. Summary(ja): Git の perl インタフェース
  118. Group: Development/Libraries
  119. Requires: git = %{version}-%{release}, perl(Error)
  120. %if "%{?_dist_release}" == "vl4"
  121. Requires: perl = %(rpm -q --qf '%%{epoch}:%%{version}' perl)
  122. %else
  123. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  124. %endif
  125. #BuildRequires: perl(Error), perl(ExtUtils::MakeMaker)
  126. %description -n perl-Git
  127. Perl interface to Git.
  128. %package -n emacs-git
  129. Summary: Git version control system support for Emacs
  130. Summary(ja): Emacs の Git サポート
  131. Group: Applications/Editors
  132. Requires: git = %{version}-%{release}, emacsen-common
  133. %description -n emacs-git
  134. %{summary}.
  135. %package devel
  136. Summary: Header files for git-core
  137. Summary(ja): git-core 用ヘッダファイル
  138. Group: Development/Libraries
  139. %description devel
  140. Header files for git-core.
  141. %prep
  142. %setup -q
  143. %patch0 -p1
  144. # %patch10 -p1 -b .git-daemon-fix
  145. %build
  146. make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" \
  147. ETC_GITCONFIG=/etc/gitconfig \
  148. prefix=%{_prefix} all %{!?_without_docs: doc}
  149. %install
  150. rm -rf $RPM_BUILD_ROOT
  151. make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" DESTDIR=$RPM_BUILD_ROOT \
  152. prefix=%{_prefix} mandir=%{_mandir} \
  153. ETC_GITCONFIG=/etc/gitconfig \
  154. INSTALLDIRS=vendor install %{!?_without_docs: install-doc}
  155. # perl-Git
  156. # Error.pm provide by perl-Error package
  157. rm -rf $RPM_BUILD_ROOT%{perl_vendorlib}/Error.pm
  158. # emacs-git
  159. mkdir -p $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git
  160. #mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/install
  161. #mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/remove
  162. mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/install
  163. mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/remove
  164. # install el files
  165. install -m644 contrib/emacs/*.el $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
  166. # install site-start file
  167. install -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
  168. # install script( bytecompile el and install elc , remove )
  169. %_installemacsenscript git %{SOURCE10}
  170. %_removeemacsenscript git %{SOURCE11}
  171. mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d
  172. install -m 644 %SOURCE2 $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d/git
  173. mkdir -p $RPM_BUILD_ROOT/var/www/git
  174. install -m 644 -t $RPM_BUILD_ROOT/var/www/git gitweb/*.png gitweb/*.css
  175. install -m 755 -t $RPM_BUILD_ROOT/var/www/git gitweb/gitweb.cgi
  176. mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d
  177. install -m 0644 %SOURCE3 $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d/git.conf
  178. find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
  179. find $RPM_BUILD_ROOT -type f -name '*.bs' -empty -exec rm -f {} ';'
  180. find $RPM_BUILD_ROOT -type f -name perllocal.pod -exec rm -f {} ';'
  181. (find $RPM_BUILD_ROOT%{_libexecdir} -type f | grep -vE "archimport|svn|cvs|email|gitk|git-gui|git-citooli|git-daemon" | sed -e s@^$RPM_BUILD_ROOT@@) > bin-man-doc-files
  182. (find $RPM_BUILD_ROOT%{perl_vendorlib} -type f | sed -e s@^$RPM_BUILD_ROOT@@) >> perl-files
  183. %if %{!?_without_docs:1}0
  184. (find $RPM_BUILD_ROOT%{_mandir} $RPM_BUILD_ROOT/Documentation -type f | grep -vE "archimport|svn|git-cvs|email|gitk|git-gui|git-citool" | sed -e s@^$RPM_BUILD_ROOT@@ -e 's/$/*/' ) >> bin-man-doc-files
  185. %else
  186. rm -rf $RPM_BUILD_ROOT%{_mandir}
  187. %endif
  188. mkdir -p $RPM_BUILD_ROOT/srv/git
  189. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
  190. install -m 644 -T contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/git
  191. # header files and lib
  192. install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
  193. install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
  194. install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
  195. install libgit.a $RPM_BUILD_ROOT%{_libdir}
  196. install xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
  197. %clean
  198. rm -rf $RPM_BUILD_ROOT
  199. %post -n emacs-git
  200. # bytecompile and install
  201. if [ "$1" = 2 ]; then
  202. %_emacsenPackageRemove git
  203. fi
  204. %_addemacsenlist git
  205. %_emacsenPackageInstall git
  206. %preun -n emacs-git
  207. if [ "$1" = 0 ]; then
  208. %_emacsenPackageRemove git
  209. %_removeemacsenlist git
  210. fi
  211. %files -f bin-man-doc-files
  212. %defattr(-,root,root)
  213. %{_bindir}/git
  214. %{_bindir}/git-receive-pack
  215. %{_bindir}/git-upload-archive
  216. %{_bindir}/git-upload-pack
  217. %{_bindir}/git-shell
  218. %{_datadir}/git-core/
  219. %doc README COPYING Documentation/*.txt contrib/hooks
  220. %{!?_without_docs: %doc Documentation/*.html Documentation/docbook-xsl.css}
  221. %{!?_without_docs: %doc Documentation/howto Documentation/technical}
  222. %{_sysconfdir}/bash_completion.d
  223. %files svn
  224. %defattr(-,root,root)
  225. %{_libexecdir}/git-core/*svn*
  226. %doc Documentation/*svn*.txt
  227. %{!?_without_docs: %{_mandir}/man1/*svn*.1*}
  228. %{!?_without_docs: %doc Documentation/*svn*.html }
  229. %files cvs
  230. %defattr(-,root,root)
  231. %doc Documentation/*git-cvs*.txt
  232. %{_bindir}/git-cvsserver
  233. %{_libexecdir}/git-core/*cvs*
  234. %{!?_without_docs: %{_mandir}/man1/*cvs*.1*}
  235. %{!?_without_docs: %doc Documentation/*git-cvs*.html }
  236. %if "%{?_dist_release}" != "vl4"
  237. %files arch
  238. %defattr(-,root,root)
  239. %doc Documentation/git-archimport.txt
  240. %{_libexecdir}/git-core/git-archimport
  241. %{!?_without_docs: %{_mandir}/man1/git-archimport.1*}
  242. %{!?_without_docs: %doc Documentation/git-archimport.html }
  243. %endif
  244. %files email
  245. %defattr(-,root,root)
  246. %doc Documentation/*email*.txt
  247. %{_libexecdir}/git-core/*email*
  248. %{!?_without_docs: %{_mandir}/man1/*email*.1*}
  249. %{!?_without_docs: %doc Documentation/*email*.html }
  250. %files gui
  251. %defattr(-,root,root)
  252. %{_libexecdir}/git-core/git-gui*
  253. %{_libexecdir}/git-core/git-citool
  254. %{_datadir}/git-gui/
  255. %{!?_without_docs: %{_mandir}/man1/git-gui.1*}
  256. %{!?_without_docs: %doc Documentation/git-gui.html}
  257. %{!?_without_docs: %{_mandir}/man1/git-citool.1*}
  258. %{!?_without_docs: %doc Documentation/git-citool.html}
  259. %files -n gitk
  260. %defattr(-,root,root)
  261. %doc Documentation/*gitk*.txt
  262. %{_bindir}/gitk
  263. %{_datadir}/gitk
  264. %{!?_without_docs: %{_mandir}/man1/*gitk*.1*}
  265. %{!?_without_docs: %doc Documentation/*gitk*.html }
  266. %files -n perl-Git -f perl-files
  267. %defattr(-,root,root)
  268. %files -n emacs-git
  269. %defattr(-,root,root)
  270. %{_datadir}/emacs/site-lisp/git
  271. #%{_libdir}/emacsen-common/packages/install/git
  272. #%{_libdir}/emacsen-common/packages/remove/git
  273. %{emacsen_pkgdir}/install/git
  274. %{emacsen_pkgdir}/remove/git
  275. %files daemon
  276. %defattr(-,root,root)
  277. %{_libexecdir}/git-core/git-daemon
  278. %config(noreplace)%{_sysconfdir}/xinetd.d/git
  279. /srv/git
  280. %files -n gitweb
  281. %defattr(-,root,root)
  282. /var/www/git/
  283. %config(noreplace)%{_sysconfdir}/httpd/conf.d/git.conf
  284. %files devel
  285. %defattr(644,root,root,755)
  286. %{_includedir}/git
  287. %{_libdir}/libgit.a
  288. %{_libdir}/libgit_xdiff.a
  289. %files all
  290. # No files for you!
  291. %changelog
  292. * Mon Jun 22 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.3-1
  293. - new upstream release with security fix
  294. - drop patch10 (included in new release)
  295. * Tue Jun 16 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.2-1
  296. - new upstream release
  297. - add patch10 git daemon extra arg parsing fix
  298. * Thu Apr 16 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-2
  299. - fix install script for Emacs Lisp: <BTS:VineLinux:685>
  300. - update git-install.sh (Source10) using contributed patch
  301. * Tue Apr 14 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-1
  302. - new upstream release
  303. * Sun Feb 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-3
  304. - delete arch sub package for Vine Linux 4.2: <BTS:VineLinux:667>
  305. - spec in EUC-JP for Vine Linux 4.2: <BTS:VineLinux:668>
  306. - fix summary and description in daemon sub package
  307. * Sun Feb 1 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-2
  308. - drop Error.pm: provide by perl-Error package
  309. * Thu Jan 29 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-1
  310. - new upstream relase
  311. - update URL tag
  312. - add Requires: perl(SVN::Core) for svn subpackage
  313. * Thu Jan 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1-3
  314. - add git-shell in git package
  315. - do not require perl(:MODULE_COMPAT_x.y.z) on Vine Linux 4.x
  316. * Mon Jan 5 2009 Shu KONNO <owa@bg.wakwak.com> - 1.6.1-2
  317. - added BuildRequires: xmlto
  318. * Mon Jan 5 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.6.1-1
  319. - new upstream release
  320. - add devel subpackage (see [wishes:0165])
  321. * Fri Oct 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.3-1
  322. - new upstream release
  323. * Mon Sep 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.2-1
  324. - new upstream release
  325. * Tue Aug 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.1-1
  326. - new upstream release
  327. * Mon Aug 25 2008 Shu KONNO <owa@bg.wakwak.com> 1.6.0-2
  328. - use %%emacsen_pkgdir macro
  329. * Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-1
  330. - new upstream release
  331. * Wed Aug 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6.4-1
  332. - initial build for Vine Linux
  333. * Thu Jul 24 2008 James Bowes <jbowes@redhat.com> 1.5.6-4
  334. - git-1.5.6.4
  335. * Thu Jun 19 2008 James Bowes <jbowes@redhat.com> 1.5.6-1
  336. - git-1.5.6
  337. * Tue Jun 3 2008 Stepan Kasal <skasal@redhat.com> 1.5.5.3-2
  338. - use tar.bz2 instead of tar.gz
  339. * Wed May 28 2008 James Bowes <jbowes@redhat.com> 1.5.5.3-1
  340. - git-1.5.5.3
  341. * Mon May 26 2008 James Bowes <jbowes@redhat.com> 1.5.5.2-1
  342. - git-1.5.5.2
  343. * Mon Apr 21 2008 James Bowes <jbowes@redhat.com> 1.5.5.1-1
  344. - git-1.5.5.1
  345. * Wed Apr 09 2008 James Bowes <jbowes@redhat.com> 1.5.5-1
  346. - git-1.5.5
  347. * Fri Apr 04 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-3
  348. - Remove the last two requires on git-core.
  349. * Wed Apr 02 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-2
  350. - Remove a patch that's already upstream.
  351. * Fri Mar 28 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-1
  352. - git-1.5.4.5
  353. * Wed Mar 26 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-4
  354. - Own /etc/bash_completion.d in case bash-completion isn't installed.
  355. * Tue Mar 25 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-3
  356. - Include the sample hooks from contrib/hooks as docs (bug 321151).
  357. - Install the bash completion script from contrib (bug 433255).
  358. - Include the html docs in the 'core' package again (bug 434271).
  359. * Wed Mar 19 2008 James Bowes 1.5.4.4-2
  360. - Obsolete git <= 1.5.4.3, to catch going from F8 to rawhide/F9
  361. * Thu Mar 13 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-1
  362. - git-1.5.4.4
  363. * Mon Mar 3 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4.3-3
  364. - rebuild for new perl (again)
  365. * Sun Feb 24 2008 Bernardo Innocenti <bernie@codewiz.org> 1.5.4.3-2
  366. - Do not silently overwrite /etc/httpd/conf.d/git.conf
  367. * Sat Feb 23 2008 James Bowes <jbowes@redhat.com> 1.5.4.3-1
  368. - git-1.5.4.3
  369. - Include Kristian Høgsberg's changes to rename git-core to
  370. git and git to git-all.
  371. * Sun Feb 17 2008 James Bowes <jbowes@redhat.com> 1.5.4.2-1
  372. - git-1.5.4.2
  373. * Mon Feb 11 2008 Jeremy Katz <katzj@redhat.com> - 1.5.4.1-2
  374. - Add upstream patch (e62a641de17b172ffc4d3a803085c8afbfbec3d1) to have
  375. gitweb rss feeds point be commitdiffs instead of commit
  376. * Sun Feb 10 2008 James Bowes <jbowes@redhat.com> 1.5.4.1-1
  377. - git-1.5.4.1
  378. * Tue Feb 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4-3
  379. - rebuild for new perl
  380. * Sun Feb 03 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
  381. - Add BuidRequires on gettext.
  382. * Sat Feb 02 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
  383. - git-1.5.4
  384. * Tue Jan 08 2008 James Bowes <jbowes@redhat.com> 1.5.3.8-1
  385. - git-1.5.3.8
  386. * Fri Dec 21 2007 James Bowes <jbowes@redhat.com> 1.5.3.7-2
  387. - Have git metapackage require explicit versions (bug 247214)
  388. * Mon Dec 03 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.7-1
  389. - git-1.5.3.7
  390. * Tue Nov 27 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.6-1
  391. - git-1.5.3.6
  392. - git-core requires perl(Error) (bug 367861)
  393. - git-svn requires perl(Term:ReadKey) (bug 261361)
  394. - git-email requires perl-Git (bug 333061)
  395. * Wed Oct 24 2007 Lubomir Kundrak <lkundrak@redhat.com> 1.5.3.4-2
  396. - git-Perl requires Error package
  397. * Tue Oct 09 2007 James Bowes <jbowes@redhat.com> 1.5.3.4-1
  398. - git-1.5.3.4
  399. * Sun Sep 30 2007 James Bowes <jbowes@redhat.com> 1.5.3.3-1
  400. - git-1.5.3.3
  401. * Wed Sep 26 2007 James Bowes <jbowes@redhat.com> 1.5.3.2-1
  402. - git-1.5.3.2
  403. * Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-2
  404. - Include git-gui and git-citool docs
  405. * Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-1
  406. - git-1.5.3.1-1
  407. * Thu Aug 23 2007 James Bowes <jbowes@redhat.com> 1.5.2.5-1
  408. - git-1.5.2.5-1
  409. * Fri Aug 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.4-1
  410. - git-1.5.2.4-1
  411. * Tue Jul 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-3
  412. - Add git-daemon and gitweb packages
  413. * Thu Jun 21 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-2
  414. - Add emacs-git package (#235431)
  415. * Mon Jun 18 2007 James Bowes <jbowes@redhat.com> 1.5.2.2-1
  416. - git-1.5.2.2
  417. * Fri Jun 08 2007 James Bowes <jbowes@redhat.com> 1.5.2.1-1
  418. - git-1.5.2.1
  419. * Tue May 13 2007 Quy Tonthat <qtonthat@gmail.com>
  420. - Added lib files for git-gui
  421. - Added Documentation/technical (As needed by Git Users Manual)
  422. * Tue May 8 2007 Quy Tonthat <qtonthat@gmail.com>
  423. - Added howto files
  424. * Fri Mar 30 2007 Chris Wright <chrisw@redhat.com> 1.5.0.6-1
  425. - git-1.5.0.6
  426. * Mon Mar 19 2007 Chris Wright <chrisw@redhat.com> 1.5.0.5-1
  427. - git-1.5.0.5
  428. * Tue Mar 13 2007 Chris Wright <chrisw@redhat.com> 1.5.0.3-1
  429. - git-1.5.0.3
  430. * Fri Mar 2 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-2
  431. - BuildRequires perl-devel as of perl-5.8.8-14 (bz 230680)
  432. * Mon Feb 26 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-1
  433. - git-1.5.0.2
  434. * Mon Feb 13 2007 Nicolas Pitre <nico@cam.org>
  435. - Update core package description (Git isn't as stupid as it used to be)
  436. * Mon Feb 12 2007 Junio C Hamano <junkio@cox.net>
  437. - Add git-gui and git-citool.
  438. * Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-2
  439. - no need to install manpages executable (bz 216790)
  440. - use bytes for git-cvsserver
  441. * Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-1
  442. - git-1.4.4.2
  443. * Mon Nov 6 2006 Jindrich Novy <jnovy@redhat.com> 1.4.2.4-2
  444. - rebuild against the new curl
  445. * Tue Oct 17 2006 Chris Wright <chrisw@redhat.com> 1.4.2.4-1
  446. - git-1.4.2.4
  447. * Wed Oct 4 2006 Chris Wright <chrisw@redhat.com> 1.4.2.3-1
  448. - git-1.4.2.3
  449. * Fri Sep 22 2006 Chris Wright <chrisw@redhat.com> 1.4.2.1-1
  450. - git-1.4.2.1
  451. * Mon Sep 11 2006 Chris Wright <chrisw@redhat.com> 1.4.2-1
  452. - git-1.4.2
  453. * Thu Jul 6 2006 Chris Wright <chrisw@redhat.com> 1.4.1-1
  454. - git-1.4.1
  455. * Tue Jun 13 2006 Chris Wright <chrisw@redhat.com> 1.4.0-1
  456. - git-1.4.0
  457. * Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.3-1
  458. - git-1.3.3
  459. - enable git-email building, prereqs have been relaxed
  460. * Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.2-1
  461. - git-1.3.2
  462. * Fri Apr 28 2006 Chris Wright <chrisw@redhat.com> 1.3.1-1
  463. - git-1.3.1
  464. * Wed Apr 19 2006 Chris Wright <chrisw@redhat.com> 1.3.0-1
  465. - git-1.3.0
  466. * Mon Apr 10 2006 Chris Wright <chrisw@redhat.com> 1.2.6-1
  467. - git-1.2.6
  468. * Wed Apr 5 2006 Chris Wright <chrisw@redhat.com> 1.2.5-1
  469. - git-1.2.5
  470. * Wed Mar 1 2006 Chris Wright <chrisw@redhat.com> 1.2.4-1
  471. - git-1.2.4
  472. * Wed Feb 22 2006 Chris Wright <chrisw@redhat.com> 1.2.3-1
  473. - git-1.2.3
  474. * Tue Feb 21 2006 Chris Wright <chrisw@redhat.com> 1.2.2-1
  475. - git-1.2.2
  476. * Thu Feb 16 2006 Chris Wright <chrisw@redhat.com> 1.2.1-1
  477. - git-1.2.1
  478. * Mon Feb 13 2006 Chris Wright <chrisw@redhat.com> 1.2.0-1
  479. - git-1.2.0
  480. * Tue Feb 1 2006 Chris Wright <chrisw@redhat.com> 1.1.6-1
  481. - git-1.1.6
  482. * Tue Jan 24 2006 Chris Wright <chrisw@redhat.com> 1.1.4-1
  483. - git-1.1.4
  484. * Sun Jan 15 2006 Chris Wright <chrisw@redhat.com> 1.1.2-1
  485. - git-1.1.2
  486. * Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.1-1
  487. - git-1.1.1
  488. * Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.0-1
  489. - Update to latest git-1.1.0 (drop git-email for now)
  490. - Now creates multiple packages:
  491. - git-core, git-svn, git-cvs, git-arch, gitk
  492. * Mon Nov 14 2005 H. Peter Anvin <hpa@zytor.com> 0.99.9j-1
  493. - Change subpackage names to git-<name> instead of git-core-<name>
  494. - Create empty root package which brings in all subpackages
  495. - Rename git-tk -> gitk
  496. * Thu Nov 10 2005 Chris Wright <chrisw@osdl.org> 0.99.9g-1
  497. - zlib dependency fix
  498. - Minor cleanups from split
  499. - Move arch import to separate package as well
  500. * Tue Sep 27 2005 Jim Radford <radford@blackbean.org>
  501. - Move programs with non-standard dependencies (svn, cvs, email)
  502. into separate packages
  503. * Tue Sep 27 2005 H. Peter Anvin <hpa@zytor.com>
  504. - parallelize build
  505. - COPTS -> CFLAGS
  506. * Fri Sep 16 2005 Chris Wright <chrisw@osdl.org> 0.99.6-1
  507. - update to 0.99.6
  508. * Fri Sep 16 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
  509. - Linus noticed that less is required, added to the dependencies
  510. * Sun Sep 11 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
  511. - Updated dependencies
  512. - Don't assume manpages are gzipped
  513. * Thu Aug 18 2005 Chris Wright <chrisw@osdl.org> 0.99.4-4
  514. - drop sh_utils, sh-utils, diffutils, mktemp, and openssl Requires
  515. - use RPM_OPT_FLAGS in spec file, drop patch0
  516. * Wed Aug 17 2005 Tom "spot" Callaway <tcallawa@redhat.com> 0.99.4-3
  517. - use dist tag to differentiate between branches
  518. - use rpm optflags by default (patch0)
  519. - own %{_datadir}/git-core/
  520. * Mon Aug 15 2005 Chris Wright <chrisw@osdl.org>
  521. - update spec file to fix Buildroot, Requires, and drop Vendor
  522. * Sun Aug 07 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
  523. - Redid the description
  524. - Cut overlong make line, loosened changelog a bit
  525. - I think Junio (or perhaps OSDL?) should be vendor...
  526. * Thu Jul 14 2005 Eric Biederman <ebiederm@xmission.com>
  527. - Add the man pages, and the --without docs build option
  528. * Wed Jul 7 2005 Chris Wright <chris@osdl.org>
  529. - initial git spec file