gnome-python-desktop-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417
  1. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  2. %define glib_version 2.20.0
  3. %define gtk_version 2.16.0
  4. %define pygtk_version 2.14.0
  5. %define gnome_python_version 2.28.0
  6. %define gnome_keyring_version 2.26.0
  7. %define gnome_panel_version 2.26.0
  8. %define gnome_desktop_version 2.26.0
  9. %define gtksourceview_version 1.1.90
  10. %define libgtop_version 2.26.0
  11. %define gnome_media_version 2.26.0
  12. %define metacity_version 2.26.0
  13. %define librsvg2_version 2.26.0
  14. %define totem_version 2.26.0
  15. %define libwnck_version 2.26.0
  16. %define bug_buddy_version 2.16.0
  17. ### Abstract ###
  18. Name: gnome-python-desktop
  19. Version: 2.28.0
  20. Release: 2%{?_dist_release}
  21. License: GPL/LGPL
  22. Group: Development/Libraries
  23. Summary: The sources for additional PyGNOME Python extension modules
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  25. Source: gnome-python-desktop-%{version}.tar.bz2
  26. ### Dependencies ###
  27. Requires: gnome-python >= %{gnome_python_version}
  28. ### Build Dependencies ###
  29. BuildRequires: glib2-devel >= %{glib_version}
  30. BuildRequires: gtk2-devel >= %{gtk_version}
  31. BuildRequires: python >= 2.4
  32. BuildRequires: pygtk2-devel >= %{pygtk_version}
  33. BuildRequires: gnome-python-devel >= %{gnome_python_version}
  34. BuildRequires: gnome-keyring-devel >= %{gnome_keyring_version}
  35. BuildRequires: gnome-panel-devel >= %{gnome_panel_version}
  36. BuildRequires: gnome-desktop-devel >= %{gnome_desktop_version}
  37. BuildRequires: libgnomeprint-devel
  38. BuildRequires: libgnomeprintui-devel
  39. BuildRequires: evince-devel
  40. BuildRequires: evolution-data-server >= 2.22.0
  41. BuildRequires: gtksourceview-devel >= %{gtksourceview_version}
  42. BuildRequires: libgtop2-devel >= %{libgtop_version}
  43. BuildRequires: gnome-media >= %{gnome_media_version}
  44. BuildRequires: metacity >= %{metacity_version}
  45. BuildRequires: brasero-devel
  46. BuildRequires: librsvg2-devel >= %{librsvg2_version}
  47. BuildRequires: pycairo-devel
  48. BuildRequires: totem-pl-parser-devel >= %{totem_version}
  49. BuildRequires: libwnck-devel >= %{libwnck_version}
  50. BuildRequires: bug-buddy >= %{bug_buddy_version}
  51. %description
  52. The gnome-python-desktop package contains the source packages for additional
  53. Python bindings for GNOME. It should be used together with gnome-python.
  54. %package -n gnome-python-applet
  55. Summary: Python bindings for GNOME Panel applets.
  56. Group: Development/Libraries
  57. Requires: %{name} = %{version}-%{release}
  58. # applets from GNOME 1.4 are no longer supported - we only have 1 panel
  59. Obsoletes: pygnome-applet
  60. %description -n gnome-python-applet
  61. This module contains a wrapper that allows GNOME Panel applets to be
  62. written in Python.
  63. %package -n gnome-python-bugbuddy
  64. Summary: Python bindings for interacting with bug-buddy
  65. Group: Development/Libraries
  66. Requires: %{name} = %{version}-%{release}
  67. Requires: bug-buddy >= %{bug_buddy_version}
  68. %description -n gnome-python-bugbuddy
  69. This module contains a wrapper that allows the use of bug-buddy via
  70. Python.
  71. %package -n gnome-python-evolution
  72. Summary: Python bindings for interacting with evolution
  73. Group: Development/Libraries
  74. Requires: %{name} = %{version}-%{release}
  75. Requires: evolution-data-server >= 2.22.0
  76. %description -n gnome-python-evolution
  77. This module contains a wrapper that allows the use of evolution via
  78. Python.
  79. %package -n gnome-python-gnomeprint
  80. Summary: Python bindings for interacting with libgnomeprint
  81. Group: Development/Libraries
  82. Requires: %{name} = %{version}-%{release}
  83. Requires: libgnomeprint
  84. Requires: libgnomeprintui
  85. %description -n gnome-python-gnomeprint
  86. This module contains a wrapper that allows the use of libgnomeprint via
  87. Python.
  88. %package -n gnome-python-gtksourceview
  89. Summary: Python bindings for interacting with the gtksourceview library
  90. Group: Development/Libraries
  91. Requires: %{name} = %{version}-%{release}
  92. Requires: gtksourceview >= %{gtksourceview_version}
  93. Requires: gnome-python-gnomeprint
  94. %description -n gnome-python-gtksourceview
  95. This module contains a wrapper that allows the use of gtksourceview via
  96. Python.
  97. %package -n gnome-python-libwnck
  98. Summary: Python bindings for interacting with libwnck
  99. Group: Development/Libraries
  100. Requires: libwnck >= %{libwnck_version}
  101. %description -n gnome-python-libwnck
  102. This module contains a wrapper that allows the use of libwnck via
  103. Python.
  104. %package -n gnome-python-libgtop2
  105. Summary: Python bindings for interacting with libgtop
  106. Group: Development/Libraries
  107. Requires: %{name} = %{version}-%{release}
  108. Requires: libgtop2 >= %{libgtop_version}
  109. %description -n gnome-python-libgtop2
  110. This module contains a wrapper that allows the use of libgtop via
  111. Python.
  112. %package -n gnome-python-brasero
  113. Summary: Python bindings for interacting with brasero
  114. Group: Development/Libraries
  115. Requires: %{name} = %{version}-%{release}
  116. Requires: brasero-libs
  117. %description -n gnome-python-brasero
  118. This module contains a wrapper that allows the use of brasero
  119. via Python.
  120. %package -n gnome-python-metacity
  121. Summary: Python bindings for interacting with metacity
  122. Group: Development/Libraries
  123. Requires: %{name} = %{version}-%{release}
  124. Requires: metacity >= %{metacity_version}
  125. %description -n gnome-python-metacity
  126. This module contains a wrapper that allows the use of metacity
  127. via Python.
  128. %package -n gnome-python-totem
  129. Summary: Python bindings for interacting with totem
  130. Group: Development/Libraries
  131. Requires: %{name} = %{version}-%{release}
  132. Requires: totem >= %{totem_version}
  133. %description -n gnome-python-totem
  134. This module contains a wrapper that allows the use of totem
  135. via Python.
  136. %package -n gnome-python-rsvg
  137. Summary: Python bindings for interacting with librsvg
  138. Group: Development/Libraries
  139. Requires: librsvg2 >= %{librsvg2_version}
  140. Requires: pycairo
  141. %description -n gnome-python-rsvg
  142. This module contains a wrapper that allows the use of librsvg
  143. via Python.
  144. %package -n gnome-python-gnomedesktop
  145. Summary: Python bindings for interacting with gnome-desktop
  146. Group: Development/Libraries
  147. Requires: %{name} = %{version}-%{release}
  148. Requires: gnome-desktop >= %{gnome_desktop_version}
  149. %description -n gnome-python-gnomedesktop
  150. This module contains a wrapper that allows the use of gnome-desktop
  151. via Python.
  152. %package -n gnome-python-gnomekeyring
  153. Summary: Python bindings for interacting with gnome-keyring
  154. Group: Development/Libraries
  155. Requires: %{name} = %{version}-%{release}
  156. Requires: gnome-keyring >= %{gnome_keyring_version}
  157. %description -n gnome-python-gnomekeyring
  158. This module contains a wrapper that allows the use of gnome-keyring
  159. via Python.
  160. %package -n gnome-python-evince
  161. Summary: Python bindings for interacting with evince
  162. Group: Development/Libraries
  163. Requires: %{name} = %{version}-%{release}
  164. Requires: evince
  165. %description -n gnome-python-evince
  166. This module contains a wrapper that allows the use of evince
  167. via Python.
  168. %prep
  169. %setup -q -n gnome-python-desktop-%{version}
  170. %build
  171. ./waf configure --prefix=%{_prefix} --libdir=%{_libdir} --enable-metacity
  172. ./waf build %{?_smp_mflags}
  173. %install
  174. rm -rf $RPM_BUILD_ROOT
  175. ./waf install --destdir=$RPM_BUILD_ROOT
  176. find $RPM_BUILD_ROOT -name '*.la' -exec rm {} \;
  177. rm -rf $RPM_BUILD_ROOT/%{_libdir}/python*/site-packages/gtk-2.0/gksu
  178. %clean
  179. rm -rf $RPM_BUILD_ROOT
  180. %files
  181. %defattr(-,root,root,-)
  182. %doc AUTHORS ChangeLog NEWS
  183. %{_libdir}/pkgconfig/gnome-python-desktop-2.0.pc
  184. %{_datadir}/pygtk
  185. %files -n gnome-python-applet
  186. %defattr(-,root,root,-)
  187. %{python_sitearch}/gtk-2.0/gnomeapplet.so
  188. %defattr(644,root,root,755)
  189. %doc ../gnome-python-desktop-%{version}/examples/applet/*
  190. %files -n gnome-python-bugbuddy
  191. %defattr(-,root,root,-)
  192. %{python_sitearch}/gtk-2.0/bugbuddy.py*
  193. %files -n gnome-python-evolution
  194. %defattr(-,root,root,-)
  195. %dir %{python_sitearch}/gtk-2.0/evolution/
  196. %{python_sitearch}/gtk-2.0/evolution/*
  197. %files -n gnome-python-gnomeprint
  198. %defattr(-,root,root,-)
  199. %{python_sitearch}/gtk-2.0/gnomeprint/
  200. %{_datadir}/gtk-doc/html/pygnomeprint
  201. %{_datadir}/gtk-doc/html/pygnomeprintui
  202. %defattr(644,root,root,755)
  203. %doc ../gnome-python-desktop-%{version}/examples/gnomeprint/*
  204. %files -n gnome-python-gtksourceview
  205. %defattr(-,root,root,-)
  206. %{python_sitearch}/gtk-2.0/gtksourceview.so
  207. %{_datadir}/gtk-doc/html/pygtksourceview
  208. %defattr(644,root,root,755)
  209. %doc ../gnome-python-desktop-%{version}/examples/gtksourceview/*
  210. %files -n gnome-python-libwnck
  211. %defattr(-,root,root,-)
  212. %{python_sitearch}/gtk-2.0/wnck.so
  213. %defattr(644,root,root,755)
  214. %doc ../gnome-python-desktop-%{version}/examples/wnck_example.py
  215. %files -n gnome-python-libgtop2
  216. %defattr(-,root,root,-)
  217. %{python_sitearch}/gtk-2.0/gtop.so
  218. %files -n gnome-python-brasero
  219. %defattr(-,root,root,-)
  220. %{python_sitearch}/gtk-2.0/braseroburn.so
  221. %{python_sitearch}/gtk-2.0/braseromedia.so
  222. %defattr(644,root,root,755)
  223. %doc ../gnome-python-desktop-%{version}/examples/braseroburn/*
  224. %doc ../gnome-python-desktop-%{version}/examples/braseromedia/*
  225. %files -n gnome-python-metacity
  226. %defattr(-,root,root,-)
  227. %{python_sitearch}/gtk-2.0/metacity.so
  228. %files -n gnome-python-totem
  229. %defattr(-,root,root,-)
  230. %{python_sitearch}/gtk-2.0/mediaprofiles.so
  231. %{python_sitearch}/gtk-2.0/totem
  232. %files -n gnome-python-rsvg
  233. %{python_sitearch}/gtk-2.0/rsvg.so
  234. %defattr(644,root,root,755)
  235. %doc ../gnome-python-desktop-%{version}/examples/rsvg/*
  236. %files -n gnome-python-gnomedesktop
  237. %{python_sitearch}/gtk-2.0/gnomedesktop
  238. %files -n gnome-python-gnomekeyring
  239. %{python_sitearch}/gtk-2.0/gnomekeyring.so
  240. %defattr(644,root,root,755)
  241. %doc ../gnome-python-desktop-%{version}/examples/keyring*.py
  242. %files -n gnome-python-evince
  243. %{python_sitearch}/gtk-2.0/evince.so
  244. %changelog
  245. * Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.0-2
  246. - rebuild for python-2.6
  247. * Sat Nov 7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
  248. - new upstream release
  249. - added gnome-python-brasero, gnome-python-evince package
  250. - remove gnome-python-nautilus-cd-burner package
  251. - used waf instead of configure script
  252. * Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
  253. - new upstream release
  254. * Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.24.0-1
  255. - new upstream release
  256. - added BuildRequires: pycairo-devel
  257. * Wed Jul 23 2008 Shu KONNO <owa@bg.wakwak.com> - 2.20.0-3
  258. - rebuilt with python-2.5.2
  259. * Wed Apr 16 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.20.0-2
  260. - re-enable BuildRequires: gnome-python-devel
  261. * Mon Apr 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.22.0-1vl5
  262. - new upstream release
  263. - added gnome-python-evolution subpackage
  264. * Wed Jan 9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.20.0-0vl1
  265. - new upstream release
  266. * Sun Jul 08 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.18.0-1vl2
  267. - add BuildRequires: gnome-media
  268. * Sat Jul 7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.18.0-1vl1
  269. - initial build for Vine Linux
  270. * Mon Mar 12 2007 Matthew Barnes <mbarnes@redhat.com> - 2.18.0-1.fc7
  271. - Update to 2.18.0
  272. * Wed Feb 28 2007 Matthias Clasen <mclasen@redhat.com> - 2.17.93-1
  273. - Update to 2.17.93
  274. * Sun Feb 25 2007 Matthew Barnes <mbarnes@redhat.com> - 2.17.92-1.fc7
  275. - Update to 2.17.92
  276. - Remove patch for GNOME bug #401760 (fixed upstream).
  277. * Mon Feb 05 2007 Matthew Barnes <mbarnes@redhat.com> - 2.17.3-3.fc7
  278. - Add patch for GNOME bug #401760 (plparser fails to build).
  279. * Mon Feb 05 2007 Matthew Barnes <mbarnes@redhat.com> - 2.17.3-2.fc7
  280. - Rename spec file to gnome-python2-desktop.spec (RH bug #225832).
  281. * Mon Jan 08 2007 Matthew Barnes <mbarnes@redhat.com> - 2.17.3-1
  282. - Update to 2.17.3
  283. * Sun Jan 07 2007 Matthew Barnes <mbarnes@redhat.com> - 2.17.2-1
  284. - Update to 2.17.2
  285. - New gnome-python2-bugbuddy subpackage.
  286. - Update version requirements to match configure.ac.
  287. - Use python_sitearch macro for installing libraries.
  288. * Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 2.17.1-2
  289. - rebuild for python 2.5
  290. - BR gnome-python2-devel
  291. * Sat Oct 21 2006 Matthias Clasen <mclasen@redhat.com> - 2.17.1-1
  292. - Update to 2.17.1
  293. * Tue Sep 5 2006 Matthias Clasen <mclasen@redhat.com> - 2.16.0-1.fc6
  294. - Update to 2.16.0
  295. * Tue Aug 22 2006 Dan Williams <dcbw@redhat.com> - 2.15.90-2.fc6
  296. - Remove unecessary dependencies on gnome-python2-desktop from
  297. -libwnck and -rsvg subpackages (OLPC)
  298. * Fri Aug 4 2006 Matthias Clasen <mclasen@redhat.com> - 2.15.90-1.fc6
  299. - Update to 2.15.90
  300. * Thu Jul 20 2006 Matthias Clasen <mclasen@redhat.com> - 2.15.4-2
  301. - Rebuild against dbus
  302. * Thu Jul 13 2006 Matthias Clasen <mclasen@redhat.com> - 2.15.4-1
  303. - Update to 2.15.4
  304. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.15.3-4.1
  305. - rebuild
  306. * Thu Jun 15 2006 Jesse Keating <jkeating@redhat.com> - 2.15.3-4
  307. - Create gnomekeyring subpackage
  308. - block out the nautilus-cd stuff
  309. * Thu Jun 15 2006 Jesse Keating <jkeating@redhat.com> - 2.15.3-2
  310. - Bump for new nautilus-cd-burner
  311. * Tue Jun 13 2006 Matthias Clasen <mclasen@redhat.com> - 2.15.3-1
  312. - Update to 2.15.3
  313. * Tue May 30 2006 Matthias Clasen <mclasen@redhat.com> - 2.15.2-1
  314. - Update to 2.15.2
  315. - Add subpackages gnome-python2-rsvg and gnome-python2-gnomedesktop
  316. * Wed May 24 2006 John (J5) Palmieri <johnp@redhat.com> - 2.14.0-2
  317. - Add pygtk2 BR
  318. * Mon Mar 13 2006 Ray Strode <rstrode@redhat.de> 2.14.0-1
  319. - Update to 2.14.0
  320. * Tue Feb 28 2006 Karsten Hopp <karsten@redhat.de> 2.13.3-2
  321. - Buildrequires: python-devel
  322. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.13.3-1.1
  323. - bump again for double-long bug on ppc(64)
  324. * Mon Feb 6 2006 John (J5) Palmieri <johnp@redhat.com> - 2.13.3-1
  325. - Initial build.