gnome-shell-vl.spec 3.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126
  1. %define pkg_version 2.28.0
  2. %define pkg_release 1%{?_dist_release}
  3. Summary: Window management and application launching for GNOME
  4. Name: gnome-shell
  5. Version: %{pkg_version}
  6. Release: %{pkg_release}
  7. Source0: %{name}-%{version}.tar.bz2
  8. License: GPLv2+
  9. Group: User Interface/Desktops
  10. URL: http://live.gnome.org/GnomeShell
  11. Requires(post,postun): scrollkeeper >= 0.1.4
  12. Requires(post,pre,preun): GConf2 >= 2.14
  13. BuildRequires: gnome-common
  14. BuildRequires: libtool
  15. BuildRequires: automake
  16. BuildRequires: autoconf
  17. BuildRequires: pkgconfig
  18. BuildRequires: gtk2-devel
  19. BuildRequires: clutter-devel
  20. BuildRequires: mutter-devel
  21. BuildRequires: gjs-devel
  22. BuildRequires: gnome-desktop-devel
  23. BuildRequires: gnome-menus-devel
  24. BuildRequires: libSM-devel
  25. BuildRequires: libffi-devel
  26. BuildRequires: GConf2-devel
  27. BuildRequires: startup-notification-devel
  28. BuildRequires: gnome-doc-utils
  29. BuildRequires: desktop-file-utils
  30. BuildRequires: xulrunner-devel
  31. BuildRequires: libcroco-devel
  32. BuildRequires: librsvg2-devel
  33. BuildRequires: gir-repository-devel
  34. BuildRequires: gobject-introspection-devel
  35. BuildRequires: gstreamer-devel
  36. BuildRequires: dbus-glib-devel
  37. BuildRequires: intltool
  38. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  39. Vendor: Project Vine
  40. Distribution: Vine Linux
  41. Packager: Takemikaduchi
  42. %description
  43. GNOME Shell is the defining technology of the GNOME 3 desktop user experience. It provides core interface functions like switching to windows and launching applications. GNOME Shell takes advantage of the capabilities of modern graphics hardware and introduces innovative user interface concepts to provide a delightful and easy to use experience.
  44. %prep
  45. %setup -q
  46. %build
  47. %configure --disable-static
  48. %{__make} %{?_smp_mflags}
  49. %install
  50. %{__rm} -rf ${RPM_BUILD_ROOT}
  51. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  52. %find_lang %{name}
  53. %{__rm} -rf $RPM_BUILD_ROOT%{_libdir}/*.la
  54. %clean
  55. %{__rm} -rf ${RPM_BUILD_ROOT}
  56. %post
  57. /sbin/ldconfig
  58. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  59. gconftool-2 --makefile-install-rule \
  60. %{_sysconfdir}/gconf/schemas/gnome-shell.schemas \
  61. > /dev/null || :
  62. /sbin/ldconfig
  63. touch --no-create %{_datadir}/icons/hicolor
  64. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  65. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  66. fi
  67. %pre
  68. if [ "$1" -gt 1 ]; then
  69. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  70. gconftool-2 --makefile-uninstall-rule \
  71. %{_sysconfdir}/gconf/schemas/gnome-shell.schemas \
  72. > /dev/null || :
  73. fi
  74. %preun
  75. if [ "$1" -eq 0 ]; then
  76. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  77. gconftool-2 --makefile-uninstall-rule \
  78. %{_sysconfdir}/gconf/schemas/gnome-shell.schemas \
  79. > /dev/null || :
  80. fi
  81. %postun
  82. scrollkeeper-update -q || :
  83. /sbin/ldconfig
  84. touch --no-create %{_datadir}/icons/hicolor
  85. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  86. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  87. fi
  88. %files -f %{name}.lang
  89. %defattr(-,root,root)
  90. %doc COPYING ChangeLog NEWS README
  91. %{_bindir}/gnome-shell
  92. %{_libdir}/gnome-shell/*
  93. %{_libdir}/mutter/plugins/*
  94. %{_datadir}/applications/*
  95. %{_datadir}/gnome-shell/*
  96. %{_sysconfdir}/gconf/schemas/*
  97. %changelog
  98. * Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
  99. - initial build for Vine Linux