openssh-vl.spec 27 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787
  1. %define ver 5.2p1
  2. %define rel 1%{_dist_release}
  3. # SELinux
  4. %define WITH_SELINUX 0
  5. # OpenSSH privilege separation requires a user & group ID
  6. %define sshd_uid 74
  7. %define sshd_gid 74
  8. # Version of ssh-askpass
  9. %define aversion 1.2.4.1
  10. # Do we want to disable building of x11-askpass? (1=yes 0=no)
  11. %define no_x11_askpass 0
  12. # Do we want to disable building of gnome-askpass? (1=yes 0=no)
  13. %define no_gnome_askpass 0
  14. # Use GTK2 for gnome-ssh-askpass
  15. %define gtk2 1
  16. # Build position-independent executables (requires toolchain support)?
  17. %define pie 1
  18. # Do we want to link against a static libcrypto? (1=yes 0=no)
  19. %define static_libcrypto 0
  20. # Do we want smartcard support (1=yes 0=no)
  21. %define scard 0
  22. # Disable IPv6 (avoids DNS hangs on some glibc versions)
  23. %define noip6 0
  24. # Do we want kerberos5 support (1=yes 0=no)
  25. %define kerberos5 0
  26. # Reserve options to override askpass settings with:
  27. # rpm -ba|--rebuild --define 'skip_xxx 1'
  28. %{?skip_x11_askpass:%define no_x11_askpass 1}
  29. %{?skip_gnome_askpass:%define no_gnome_askpass 1}
  30. # Options for static OpenSSL link:
  31. # rpm -ba|--rebuild --define "static_openssl 1"
  32. %{?static_openssl:%define static_libcrypto 1}
  33. # Options for Smartcard support: (needs libsectok and openssl-engine)
  34. # rpm -ba|--rebuild --define "smartcard 1"
  35. %{?smartcard:%define scard 1}
  36. # Option to disable ipv6
  37. # rpm -ba|--rebuild --define "noipv6 1"
  38. %{?noipv6:%define noip6 1}
  39. # Is this a build for the rescue CD (without PAM)? (1=yes 0=no)
  40. %define rescue 0
  41. %{?build_rescue:%define rescue 1}
  42. # Turn off some stuff for resuce builds
  43. %if %{rescue}
  44. %define kerberos5 0
  45. %endif
  46. Summary: The OpenSSH implementation of SSH.
  47. Summary(ja): OpenSSH - フリーの Secure Shell (SSH) の実装
  48. Name: openssh
  49. Version: %{ver}
  50. Release: %{rel}
  51. URL: http://www.openssh.com/portable.html
  52. Source0: ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-%{version}.tar.gz
  53. Source1: http://www.pobox.com/~jmknoble/software/x11-ssh-askpass/x11-ssh-askpass-%{aversion}.tar.gz
  54. Patch0: openssh-5.2p1-vine.patch
  55. Patch2: openssh-3.8.1p1-skip-initial.patch
  56. Patch3: openssh-3.8.1p1-krb5-config.patch
  57. Patch4: openssh-5.2p1-vendor.patch
  58. Patch5: openssh-3.9p1-noinitlog.patch
  59. Patch12: openssh-selinux.patch
  60. Patch20: openssh-3.9p1-gssapimitm.patch
  61. Patch21: openssh-3.9p1-safe-stop.patch
  62. Patch22: openssh-3.9p1-askpass-keep-above.patch
  63. Patch24: openssh-4.3p1-fromto-remote.patch
  64. Patch26: openssh-5.2p1-pam-no-stack.patch
  65. Patch27: openssh-5.1p1-log-in-chroot.patch
  66. Patch30: openssh-4.0p1-exit-deadlock.patch
  67. # Patch31: openssh-3.9p1-skip-used.patch
  68. Patch35: openssh-4.2p1-askpass-progress.patch
  69. # Vine Patch
  70. Patch100: openssh-norootlogin.patch
  71. #Patch110: openssh-3.4p1-mmap-fallback.diff
  72. Patch120: openssh-4.7p1-sshd.init.patch
  73. License: BSD
  74. Group: Applications/Internet
  75. BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
  76. Obsoletes: ssh
  77. PreReq: initscripts >= 5.20
  78. BuildRequires: perl, openssl-devel, sharutils, tcp_wrappers
  79. BuildRequires: util-linux
  80. BuildRequires: db4-devel
  81. BuildRequires: pam-devel
  82. BuildRequires: zlib-devel
  83. %if ! %{no_x11_askpass}
  84. BuildRequires: libX11-devel, libSM-devel, libXt-devel, libICE-devel
  85. %endif
  86. %if ! %{no_gnome_askpass}
  87. BuildRequires: libX11-devel
  88. BuildRequires: gtk2-devel
  89. %endif
  90. Vendor: Project Vine
  91. Distribution: Vine Linux
  92. %package clients
  93. Summary: OpenSSH clients.
  94. Summary(ja): OpenSSH Secure Shell プロトコルクライアント
  95. Requires: openssh = %{version}-%{release}
  96. Group: Applications/Internet
  97. Obsoletes: ssh-clients
  98. %package server
  99. Summary: The OpenSSH server daemon.
  100. Summary(ja): OpenSSH Secure Shell プロトコルサーバ (sshd)
  101. Group: System Environment/Daemons
  102. Obsoletes: ssh-server
  103. PreReq: openssh = %{version}-%{release}, chkconfig >= 0.9
  104. Requires: pam
  105. %package askpass
  106. Summary: A passphrase dialog for OpenSSH and X.
  107. Summary(ja): OpenSSH X11 パスフレーズ入力ダイアログ
  108. Group: Applications/Internet
  109. Requires: openssh = %{version}-%{release}
  110. Obsoletes: ssh-extras
  111. %package askpass-gnome
  112. Summary: A passphrase dialog for OpenSSH, X, and GNOME.
  113. Summary(ja): OpenSSH GNOME パスフレーズ入力ダイアログ
  114. Group: Applications/Internet
  115. Requires: openssh = %{version}-%{release}
  116. Obsoletes: ssh-extras
  117. %package contrib
  118. Summary: addons for OpenSSH
  119. Summary(ja): OpenSSH のためのアドオン
  120. Group: Applications/Internet
  121. Requires: openssh-clients = %{version}-%{release}
  122. %description
  123. SSH (Secure SHell) is a program for logging into and executing
  124. commands on a remote machine. SSH is intended to replace rlogin and
  125. rsh, and to provide secure encrypted communications between two
  126. untrusted hosts over an insecure network. X11 connections and
  127. arbitrary TCP/IP ports can also be forwarded over the secure channel.
  128. OpenSSH is OpenBSD's version of the last free version of SSH, bringing
  129. it up to date in terms of security and features, as well as removing
  130. all patented algorithms to separate libraries.
  131. This package includes the core files necessary for both the OpenSSH
  132. client and server. To make this package useful, you should also
  133. install openssh-clients, openssh-server, or both.
  134. #'
  135. %description -l ja
  136. OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
  137. Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
  138. するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
  139. ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
  140. 可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
  141. な通信路の中を通すことができます。
  142. OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
  143. 最新のセキュリティと機能を提供しています。またすべての特許がからむ
  144. アルゴリズムは分割したライブラリにわかれています。
  145. このパッケージは OpenSSH のクライアントとサーバの両方で必要とされる
  146. コアのファイルを含んでいます。実際に使用するにはこのパッケージの他に
  147. openssh-clients および/または openssh-server が必要です。
  148. %description clients
  149. OpenSSH is a free version of SSH (Secure SHell), a program for logging
  150. into and executing commands on a remote machine. This package includes
  151. the clients necessary to make encrypted connections to SSH servers.
  152. You'll also need to install the openssh package on OpenSSH clients.
  153. #'
  154. %description -l ja clients
  155. OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
  156. Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
  157. するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
  158. ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
  159. 可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
  160. な通信路の中を通すことができます。
  161. OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
  162. 最新のセキュリティと機能を提供しています。またすべての特許がからむ
  163. アルゴリズムは分割したライブラリにわかれています。
  164. このパッケージは OpenSSH をクライアントとして使用する場合に
  165. 必要なものを含んでいます。
  166. %description server
  167. OpenSSH is a free version of SSH (Secure SHell), a program for logging
  168. into and executing commands on a remote machine. This package contains
  169. the secure shell daemon (sshd). The sshd daemon allows SSH clients to
  170. securely connect to your SSH server. You also need to have the openssh
  171. package installed.
  172. %description -l ja server
  173. OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
  174. Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
  175. するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
  176. ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
  177. 可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
  178. な通信路の中を通すことができます。
  179. OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
  180. 最新のセキュリティと機能を提供しています。またすべての特許がからむ
  181. アルゴリズムは分割したライブラリにわかれています。
  182. このパッケージは OpenSSH をサーバとして使用する場合に必要な
  183. デーモンなどを含んでいます。
  184. %description askpass
  185. OpenSSH is a free version of SSH (Secure SHell), a program for logging
  186. into and executing commands on a remote machine. This package contains
  187. an X11 passphrase dialog for OpenSSH.
  188. %description -l ja askpass
  189. OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
  190. Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
  191. するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
  192. ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
  193. 可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
  194. な通信路の中を通すことができます。
  195. OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
  196. 最新のセキュリティと機能を提供しています。またすべての特許がからむ
  197. アルゴリズムは分割したライブラリにわかれています。
  198. このパッケージは Jim Knoble <jmknoble@jmknoble.cx> による X11 上の
  199. パスフレーズ入力ダイアログを含んでいます。
  200. %description askpass-gnome
  201. OpenSSH is a free version of SSH (Secure SHell), a program for logging
  202. into and executing commands on a remote machine. This package contains
  203. an X11 passphrase dialog for OpenSSH and the GNOME GUI desktop
  204. environment.
  205. %description -l ja askpass-gnome
  206. OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
  207. Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
  208. するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
  209. ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
  210. 可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
  211. な通信路の中を通すことができます。
  212. OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
  213. 最新のセキュリティと機能を提供しています。またすべての特許がからむ
  214. アルゴリズムは分割したライブラリにわかれています。
  215. このパッケージは GNOME 用のパスフレーズ入力ダイアログを含んでいます。
  216. %description contrib
  217. addons for OpenSSH
  218. %description -l ja contrib
  219. OpenSSH のためのアドオン
  220. %prep
  221. %if ! %{no_x11_askpass}
  222. %setup -q -a 1
  223. %else
  224. %setup -q
  225. %endif
  226. %patch0 -p1 -b .vine
  227. %patch2 -p1 -b .skip-initial
  228. %patch3 -p1 -b .krb5-config
  229. %patch4 -p1 -b .vendor
  230. %patch5 -p1 -b .noinitlog
  231. %if %{WITH_SELINUX}
  232. #SELinux
  233. %patch12 -p1 -b .selinux
  234. %endif
  235. #%patch20 -p0 -b .gssapimitm
  236. %patch21 -p1 -b .safe-stop
  237. %patch22 -p1 -b .keep-above
  238. %patch24 -p1 -b .fromto-remote
  239. %patch26 -p1 -b .stack
  240. %patch27 -p1 -b .log-chroot
  241. %patch30 -p1 -b .exit-deadlock
  242. # %patch31 -p1 -b .skip-used
  243. %patch35 -p1 -b .progress
  244. %patch100 -p1 -b .norootlogin
  245. %patch120 -p1 -b .localtime
  246. autoreconf
  247. %build
  248. CFLAGS="$RPM_OPT_FLAGS"; export CFLAGS
  249. %if %{rescue}
  250. CFLAGS="$RPM_OPT_FLAGS -Os"; export CFLAGS
  251. %endif
  252. %if %{pie}
  253. %ifarch s390 s390x sparc sparc64
  254. CFLAGS="$CFLAGS -fPIE"
  255. %else
  256. CFLAGS="$CFLAGS -fpie"
  257. %endif
  258. export CFLAGS
  259. LDFLAGS="$LDFLAGS -pie"; export LDFLAGS
  260. %endif
  261. %configure \
  262. --sysconfdir=%{_sysconfdir}/ssh \
  263. --libexecdir=%{_libexecdir}/openssh \
  264. --datadir=%{_datadir}/openssh \
  265. --with-tcp-wrappers \
  266. --with-rsh=%{_bindir}/rsh \
  267. --with-default-path=/usr/local/bin:/bin:/usr/bin \
  268. --with-superuser-path=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin \
  269. --with-privsep-path=%{_var}/empty/sshd \
  270. --enable-vendor-patchlevel="VL-%{version}-%{release}" \
  271. %if %{scard}
  272. --with-smartcard \
  273. %endif
  274. %if %{noip6}
  275. --with-ipv4-default \
  276. %endif
  277. %if %{rescue}
  278. --without-pam --with-md5-passwords
  279. %else
  280. --with-pam
  281. %endif
  282. %if %{static_libcrypto}
  283. perl -pi -e "s|-lcrypto|%{_libdir}/libcrypto.a|g" Makefile
  284. %endif
  285. make
  286. %if ! %{no_x11_askpass}
  287. pushd x11-ssh-askpass-%{aversion}
  288. %configure --libexecdir=%{_libexecdir}/openssh
  289. xmkmf -a
  290. make
  291. popd
  292. %endif
  293. %if %{gtk2}
  294. gtk2=yes
  295. %else
  296. gtk2=no
  297. %endif
  298. %if ! %{no_gnome_askpass}
  299. pushd contrib
  300. if [ $gtk2 = yes ]; then
  301. make gnome-ssh-askpass2
  302. mv gnome-ssh-askpass2 gnome-ssh-askpass
  303. else
  304. make gnome-ssh-askpass1
  305. mv gnome-ssh-askpass1 gnome-ssh-askpass
  306. fi
  307. popd
  308. %endif
  309. %install
  310. rm -rf $RPM_BUILD_ROOT
  311. mkdir -p -m755 $RPM_BUILD_ROOT%{_sysconfdir}/ssh
  312. mkdir -p -m755 $RPM_BUILD_ROOT%{_libexecdir}/openssh
  313. mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd
  314. mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd/etc
  315. make install DESTDIR=$RPM_BUILD_ROOT
  316. touch $RPM_BUILD_ROOT%{_var}/empty/sshd/etc/localtime
  317. install -d $RPM_BUILD_ROOT/etc/pam.d/
  318. install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
  319. install -d $RPM_BUILD_ROOT%{_libexecdir}/openssh
  320. install -m644 contrib/redhat/sshd.pam $RPM_BUILD_ROOT/etc/pam.d/sshd
  321. install -m755 contrib/redhat/sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
  322. %if ! %{no_x11_askpass}
  323. install -s x11-ssh-askpass-%{aversion}/x11-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/x11-ssh-askpass
  324. ln -s x11-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/ssh-askpass
  325. %endif
  326. %if ! %{scard}
  327. rm -f $RPM_BUILD_ROOT%{_datadir}/openssh/Ssh.bin
  328. %endif
  329. %if ! %{no_gnome_askpass}
  330. install -s contrib/gnome-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/gnome-ssh-askpass
  331. install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
  332. install -m 755 contrib/redhat/gnome-ssh-askpass.{sh,csh} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
  333. %endif
  334. %if %{no_gnome_askpass}
  335. rm -f $RPM_BUILD_ROOT/etc/profile.d/gnome-ssh-askpass.*
  336. %endif
  337. # for contrib package
  338. install -m 0755 contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
  339. install -m 0644 contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
  340. mv contrib/README contrib/README.contrib
  341. perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT%{_mandir}/man*/*
  342. %clean
  343. rm -rf $RPM_BUILD_ROOT
  344. %triggerun server -- ssh-server
  345. if [ "$1" != 0 -a -r /var/run/sshd.pid ] ; then
  346. touch /var/run/sshd.restart
  347. fi
  348. %triggerun server -- openssh-server < 2.5.0p1
  349. # Count the number of HostKey and HostDsaKey statements we have.
  350. gawk 'BEGIN {IGNORECASE=1}
  351. /^hostkey/ || /^hostdsakey/ {sawhostkey = sawhostkey + 1}
  352. END {exit sawhostkey}' /etc/ssh/sshd_config
  353. # And if we only found one, we know the client was relying on the old default
  354. # behavior, which loaded the the SSH2 DSA host key when HostDsaKey wasn't
  355. # specified. Now that HostKey is used for both SSH1 and SSH2 keys, specifying
  356. # one nullifies the default, which would have loaded both.
  357. if [ $? -eq 1 ] ; then
  358. echo HostKey /etc/ssh/ssh_host_rsa_key >> /etc/ssh/sshd_config
  359. echo HostKey /etc/ssh/ssh_host_dsa_key >> /etc/ssh/sshd_config
  360. fi
  361. %triggerpostun server -- ssh-server
  362. if [ "$1" != 0 ] ; then
  363. /sbin/chkconfig --add sshd
  364. if test -f /var/run/sshd.restart ; then
  365. rm -f /var/run/sshd.restart
  366. # /sbin/service sshd start > /dev/null 2>&1 || :
  367. /sbin/service sshd start
  368. fi
  369. fi
  370. %pre server
  371. %{_sbindir}/groupadd -r -g %{sshd_gid} sshd 2>/dev/null || :
  372. %{_sbindir}/useradd -d /var/empty/sshd -s /bin/false -u %{sshd_uid} \
  373. -g sshd -M -r sshd 2>/dev/null || :
  374. %post server
  375. /sbin/chkconfig --add sshd
  376. %postun server
  377. # /sbin/service sshd condrestart > /dev/null 2>&1 || :
  378. /sbin/service sshd condrestart
  379. %preun server
  380. if [ "$1" = 0 ]
  381. then
  382. /sbin/service sshd stop > /dev/null 2>&1 || :
  383. /sbin/chkconfig --del sshd
  384. fi
  385. %files
  386. %defattr(-,root,root)
  387. %doc CREDITS ChangeLog INSTALL LICENCE OVERVIEW README* RFC* TODO WARNING*
  388. %attr(0755,root,root) %{_bindir}/scp
  389. %attr(0644,root,root) %{_mandir}/man1/scp.1*
  390. %attr(0755,root,root) %dir %{_sysconfdir}/ssh
  391. %attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/moduli
  392. %attr(644,root,root) %{_mandir}/man5/moduli.5*
  393. %if ! %{rescue}
  394. %attr(0755,root,root) %{_bindir}/ssh-keygen
  395. %attr(0644,root,root) %{_mandir}/man1/ssh-keygen.1*
  396. %attr(0755,root,root) %dir %{_libexecdir}/openssh
  397. %attr(4711,root,root) %{_libexecdir}/openssh/ssh-keysign
  398. %attr(0644,root,root) %{_mandir}/man8/ssh-keysign.8*
  399. %endif
  400. %if %{scard}
  401. %attr(0755,root,root) %dir %{_datadir}/openssh
  402. %attr(0644,root,root) %{_datadir}/openssh/Ssh.bin
  403. %endif
  404. %files clients
  405. %defattr(-,root,root)
  406. %attr(0755,root,root) %{_bindir}/ssh
  407. %attr(0644,root,root) %{_mandir}/man1/ssh.1*
  408. %attr(0644,root,root) %{_mandir}/man5/ssh_config.5*
  409. %attr(0644,root,root) %{_mandir}/man1/slogin.1*
  410. %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/ssh/ssh_config
  411. %attr(-,root,root) %{_bindir}/slogin
  412. %if ! %{rescue}
  413. %attr(0755,root,root) %{_bindir}/ssh-agent
  414. %attr(0755,root,root) %{_bindir}/ssh-add
  415. %attr(0755,root,root) %{_bindir}/ssh-keyscan
  416. %attr(0755,root,root) %{_bindir}/sftp
  417. %attr(0644,root,root) %{_mandir}/man1/ssh-agent.1*
  418. %attr(0644,root,root) %{_mandir}/man1/ssh-add.1*
  419. %attr(0644,root,root) %{_mandir}/man1/ssh-keyscan.1*
  420. %attr(0644,root,root) %{_mandir}/man1/sftp.1*
  421. %endif
  422. %if ! %{rescue}
  423. %files server
  424. %defattr(-,root,root)
  425. %dir %attr(0711,root,root) %{_var}/empty/sshd
  426. %dir %attr(0755,root,root) %{_var}/empty/sshd/etc
  427. %ghost %verify(not md5 size mtime) %{_var}/empty/sshd/etc/localtime
  428. %attr(0755,root,root) %{_sbindir}/sshd
  429. %attr(0755,root,root) %{_libexecdir}/openssh/sftp-server
  430. %attr(0644,root,root) %{_mandir}/man5/sshd_config.5*
  431. %attr(0644,root,root) %{_mandir}/man8/sshd.8*
  432. %attr(0644,root,root) %{_mandir}/man8/sftp-server.8*
  433. %attr(0755,root,root) %dir %{_sysconfdir}/ssh
  434. %attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/sshd_config
  435. %attr(0600,root,root) %config(noreplace) /etc/pam.d/sshd
  436. %attr(0755,root,root) %config /etc/rc.d/init.d/sshd
  437. %endif
  438. %if ! %{no_x11_askpass}
  439. %files askpass
  440. %defattr(-,root,root)
  441. %doc x11-ssh-askpass-%{aversion}/README
  442. %doc x11-ssh-askpass-%{aversion}/ChangeLog
  443. %doc x11-ssh-askpass-%{aversion}/SshAskpass*.ad
  444. %attr(0755,root,root) %{_libexecdir}/openssh/ssh-askpass
  445. %attr(0755,root,root) %{_libexecdir}/openssh/x11-ssh-askpass
  446. %endif
  447. %if ! %{no_gnome_askpass}
  448. %files askpass-gnome
  449. %defattr(-,root,root)
  450. %attr(0755,root,root) %config %{_sysconfdir}/profile.d/gnome-ssh-askpass.*
  451. %attr(0755,root,root) %{_libexecdir}/openssh/gnome-ssh-askpass
  452. %endif
  453. %files contrib
  454. %defattr(-,root,root)
  455. %doc contrib/README.contrib
  456. %{_bindir}/ssh-copy-id
  457. %{_mandir}/man1/ssh-copy-id.1*
  458. %changelog
  459. * Tue Feb 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2p1-1
  460. - new upstream release
  461. * Tue Jul 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.1p1-1
  462. - new upstream release
  463. * Thu May 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0p1-2
  464. - rebuild with xorg-x11-7.3
  465. * Fri Apr 04 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.0p1-1
  466. - new upstream release with security fix (CVE-2008-1483)
  467. - drop patch31 which is included in new release (This was for CVE-2008-1483)
  468. * Tue Apr 01 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.9p1-1
  469. - new upstream release with security fix ("ForceCommand" Directive)
  470. - turn on daemon restart message
  471. - new versioning policy
  472. * Mon Nov 26 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.7p1-0vl2
  473. - add /var/empty/sshd/etc/localtime to fix secure log bad timestamps
  474. * Tue Nov 13 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.7p1-0vl1
  475. - new upstream release
  476. * Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6p1-0vl2
  477. - build with -fpie/-pie by default.
  478. - enable ipv6 by default.
  479. * Fri May 04 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6p1-0vl1
  480. - new upstream release
  481. * Wed Nov 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.5p1-0vl1
  482. - new upstream release
  483. * Fri Sep 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4p1-0vl1
  484. - new upstream release
  485. * Thu Jul 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3p2-0vl1
  486. - new upstream release
  487. * Mon Apr 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3p1-0vl1
  488. - new upstream release
  489. - remove build6x stuff
  490. - remove libgnome-devel from BuildRequires
  491. - cleanup BuildRequires
  492. - drop Patch200, it is merged in upstream.
  493. - import patches(25-35) from FC-devel
  494. * Mon Apr 10 2006 IWAI, Masaharu <iwai@alib.jp> 4.2p1-0vl3
  495. - SECURITY FIX: CVE-2006-0225
  496. - add scp no system patch ( Patch200 ): from Fedora Core 4 4.2p1-fc4.10
  497. - update BuildPreReq: s/XFree86-devel/XOrg-devel/
  498. - fix BuildPreReq for GNOME: gnome-libs-devel ( GNOME1 ) was always used
  499. - When GNOME2 is used, using libgnome-devel
  500. - add BuildPreReq: gtk2-devel for GNOME2
  501. * Sat Sep 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2p1-0vl2
  502. - rebuild with gtk+-2.8 final
  503. * Sun Sep 4 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2p1-0vl1
  504. - new upstream release
  505. - build with gtk+-2.7
  506. * Sun May 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1p1-0vl1
  507. - new upstream release
  508. * Fri Apr 01 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 4.0p1-0vl2
  509. - cleanup obsolete patches and added patches from fedora
  510. * Wed Mar 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0p1-0vl1
  511. - new upstream release
  512. * Thu Aug 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9pl1-0vl1
  513. - new upstream release
  514. * Wed Apr 21 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8.1p1-0vl1
  515. - new upstream release
  516. * Fri Mar 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8p1-0vl2
  517. - rebuild with openssl-0.9.7d
  518. * Fri Feb 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8p1-0vl1
  519. - new upstream release
  520. * Thu Oct 2 2003 IWAI, Masaharu <iwai@alib.jp> 3.7.1p2-0vl2
  521. - create contrib package
  522. * Wed Sep 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1p2-0vl1
  523. - new upstream release
  524. - fix security issue: http://www.openssh.com/txt/sshpam.adv
  525. * Wed Sep 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1p1-0vl1
  526. - new upstream release
  527. - fix security issue: http://www.openssh.com/txt/buffer.adv
  528. * Wed Sep 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7p1-0vl1
  529. - new upstream release
  530. * Thu May 1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6.1p2-0vl1.1
  531. - rebuild with gtk2
  532. * Thu May 1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6.1p2-0vl1
  533. - new upstream release
  534. * Sat Apr 13 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.5p1-0vl2
  535. - rebuild with new tool chain
  536. * Tue Oct 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.5p1-0vl1
  537. - new upstream release
  538. - merge with upstream spec (drop anonymous mmap patch, suid of ssh)
  539. * Tue Aug 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl3
  540. - change some defines in spec files
  541. * Wed Jun 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl2
  542. - add patch110 ( 3.4p1 does not include mmap-fallback patch )
  543. * Wed Jun 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl1
  544. - new upstream release
  545. - security fix
  546. - drop patch10
  547. * Wed Jun 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3p1-0vl2
  548. - add patch from Solar Designer to make privsep work with a 2.2 kernel.
  549. * Sun Jun 23 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3p1-0vl1
  550. - new upstream release
  551. - add {sshd,ssh}_config.5 manpages
  552. - add ssh-keysign
  553. * Sun May 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.3p1-0vl1
  554. - new upstream release
  555. * Sat May 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.2p1-0vl1
  556. - new upstream release
  557. - drop patch1
  558. * Fri Mar 08 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1p1-2vl1
  559. - new upstream release
  560. - merged with rawhide release.
  561. - drop Patch101 (merged in upstream)
  562. * Fri Mar 08 2002 Toru Sagami <sagami@vinelinux.org> 3.0.2p1-2vl2
  563. - seurity patch for off-by-one bug
  564. * Wed Jan 30 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.0.2p-2vl1
  565. - merged with Rawhide 3.0.2p1-2
  566. * Sun Dec 02 2001 Toru Sagami <sagami@vinelinux.org>
  567. - updated to 3.0.2p1
  568. * Mon Nov 19 2001 Toru Sagami <sagami@vinelinux.org>
  569. - updated to 3.0.1p1
  570. * Thu Nov 08 2001 Toru Sagami <sagami@vinelinux.org> 3.0p1-0vl0
  571. - updated to 3.0p1
  572. * Sun Sep 30 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.9p2-0vl2
  573. - add japanese summery and descriptions.
  574. - update x11-askpass 1.2.5
  575. * Sun Sep 30 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.9p2-0vl1
  576. - update to openssh-2.9.9p2
  577. * Mon Jul 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org> 2.5.2p2-0vl3
  578. - rebuilt with openssl-0.9.6b
  579. * Tue Mar 27 2001 Jun Nishii <jun@vinelinux.org> 2.5.2p2-0vl2
  580. - do not Permit RootLogin
  581. * Tue Mar 27 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2p2-0vl1
  582. - update to openssh-2.5.2p2
  583. * Wed Mar 21 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2p1-0vl1
  584. - update to openssh-2.5.2p1
  585. * Thu Mar 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p2-0vl1
  586. - update to openssh-2.5.1p2
  587. * Thu Mar 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p2-0vl1
  588. - update to openssh-2.5.1p1
  589. * Wed Feb 21 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p1-0vl1
  590. - update to openssh-2.5.1p1
  591. * Thu Dec 28 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0p1-0vl4
  592. - remove suid bit from ssh
  593. * Tue Dec 19 2000 Satoshi MACHINO <machino@vinelinux.org> 2.3.0p1-0vl3
  594. - moved man dir to /usr/share/man
  595. * Wed Dec 06 2000 Satoshi MACHINO <machino@vinelinux.org> 2.3.0p1-0vl2
  596. - fixed askpass's link in ssh-add
  597. - partially used rpmmacros
  598. * Fri Nov 10 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0p1-0vl1
  599. - update to 2.3.0p1
  600. - update x11-askpass 1.0.3
  601. * Mon Oct 18 2000 Damien Miller <djm@mindrot.org>
  602. - Merge some of Nalin Dahyabhai <nalin@redhat.com> changes from the
  603. Redhat 7.0 spec file
  604. * Sat Oct 14 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0p2-2vl1
  605. - rebuild for Vine Linux
  606. * Tue Sep 05 2000 Damien Miller <djm@mindrot.org>
  607. - Use RPM configure macro
  608. * Tue Aug 08 2000 Damien Miller <djm@mindrot.org>
  609. - Some surgery to sshd.init (generate keys at runtime)
  610. - Cleanup of groups and removal of keygen calls
  611. * Wed Jul 12 2000 Damien Miller <djm@mindrot.org>
  612. - Make building of X11-askpass and gnome-askpass optional
  613. * Mon Jun 12 2000 Damien Miller <djm@mindrot.org>
  614. - Glob manpages to catch compressed files
  615. * Wed Mar 15 2000 Damien Miller <djm@ibs.com.au>
  616. - Updated for new location
  617. - Updated for new gnome-ssh-askpass build
  618. * Sun Dec 26 1999 Damien Miller <djm@mindrot.org>
  619. - Added Jim Knoble's <jmknoble@pobox.com> askpass
  620. * Mon Nov 15 1999 Damien Miller <djm@mindrot.org>
  621. - Split subpackages further based on patch from jim knoble <jmknoble@pobox.com>
  622. * Sat Nov 13 1999 Damien Miller <djm@mindrot.org>
  623. - Added 'Obsoletes' directives
  624. * Tue Nov 09 1999 Damien Miller <djm@ibs.com.au>
  625. - Use make install
  626. - Subpackages
  627. * Mon Nov 08 1999 Damien Miller <djm@ibs.com.au>
  628. - Added links for slogin
  629. - Fixed perms on manpages
  630. * Sat Oct 30 1999 Damien Miller <djm@ibs.com.au>
  631. - Renamed init script
  632. * Fri Oct 29 1999 Damien Miller <djm@ibs.com.au>
  633. - Back to old binary names
  634. * Thu Oct 28 1999 Damien Miller <djm@ibs.com.au>
  635. - Use autoconf
  636. - New binary names
  637. * Wed Oct 27 1999 Damien Miller <djm@ibs.com.au>
  638. - Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.