bash-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576
  1. %define bashversion 5.1
  2. %define patchlevel 8
  3. Summary: The GNU Bourne Again shell (bash).
  4. Summary(ja): GNU Bourne Again シェル (bash).
  5. Name: bash
  6. Version: %{bashversion}.%{patchlevel}
  7. Release: 1%{?_dist_release}
  8. Group: system
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. Packager: daisuke
  12. License: GPLv3+
  13. Source0: http://ftp.gnu.org/pub/gnu/bash/bash-%{bashversion}.tar.gz
  14. Source10: bashrc-vine
  15. # Official upstream patches
  16. Patch1: https://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash51-001
  17. Patch2: https://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash51-002
  18. Patch3: https://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash51-003
  19. Patch4: https://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash51-004
  20. Patch5: https://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash51-005
  21. Patch6: https://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash51-006
  22. Patch7: https://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash51-007
  23. Patch8: https://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash51-008
  24. # Other patches
  25. Patch102: bash-2.03-paths.patch
  26. Patch103: bash-2.03-profile.patch
  27. Patch104: bash-2.05a-interpreter.patch
  28. Patch105: bash-2.05b-debuginfo.patch
  29. Patch107: bash-2.05b-pgrp_sync.patch
  30. Patch110: bash-3.2-audit.patch
  31. Patch111: bash-3.2-ssh_source_bash.patch
  32. Patch113: bash-infotags.patch
  33. Patch114: bash-requires.patch
  34. Patch115: bash-setlocale.patch
  35. Patch116: bash-tty-tests.patch
  36. # 484809, check if interp section is NOBITS
  37. Patch117: bash-4.0-nobits.patch
  38. # Do the same CFLAGS in generated Makefile in examples
  39. Patch118: bash-4.1-examples.patch
  40. # Builtins like echo and printf won't report errors
  41. # when output does not succeed due to EPIPE
  42. Patch119: bash-4.1-broken_pipe.patch
  43. # Enable system-wide .bash_logout for login shells
  44. Patch120: bash-4.2-rc2-logout.patch
  45. # Static analyzis shows some issues in bash-2.05a-interpreter.patch
  46. Patch121: bash-4.2-coverity.patch
  47. # 799958, updated info about trap
  48. Patch123: bash-4.2-manpage_trap.patch
  49. # https://www.securecoding.cert.org/confluence/display/seccode/INT32-C.+Ensure+that+operations+on+signed+integers+do+not+result+in+overflow
  50. Patch125: bash-4.2-size_type.patch
  51. # 1112710 - mention ulimit -c and -f POSIX block size
  52. Patch128: bash-4.3-man-ulimit.patch
  53. # 1102815 - fix double echoes in vi visual mode
  54. Patch135: bash-4.3-noecho.patch
  55. #1241533,1224855 - bash leaks memory when LC_ALL set
  56. Patch138: bash-4.3-memleak-lc_all.patch
  57. # bash-4.4 builds loadable builtin examples by default
  58. # this patch disables it
  59. Patch140: bash-4.4-no-loadable-builtins.patch
  60. Buildroot: %{_tmppath}/%{name}-%{version}-root
  61. BuildRequires: texinfo, bison, ncurses-devel, autoconf, gettext
  62. Obsoletes: bash <= 1.14.7
  63. Obsoletes: bash2
  64. %description
  65. Bash is a GNU project sh-compatible shell or command language
  66. interpreter. Bash (Bourne Again shell) incorporates useful features
  67. from the Korn shell (ksh) and the C shell (csh). Most sh scripts
  68. can be run by bash without modification.
  69. Bash offers several improvements over sh, including command line
  70. editing, unlimited size command history, job control, shell
  71. functions and aliases, indexed arrays of unlimited size and
  72. integer arithmetic in any base from two to 64. Bash is ultimately
  73. intended to conform to the IEEE POSIX P1003.2/ISO 9945.2 Shell and
  74. Tools standard.
  75. %package doc
  76. Summary: Documentation for the GNU Bourne Again shell (bash).
  77. Summary(ja): GNU Bourne Again シェル向けドキュメント
  78. Group: documentation
  79. Requires: %{name} = %{version}-%{release}
  80. Obsoletes: bash2-doc
  81. %description doc
  82. This is a separate documentation package for the GNU Bourne
  83. Again shell.
  84. %debug_package
  85. %prep
  86. %setup -q -n %{name}-%{bashversion}
  87. # Official upstream patches
  88. %patch1 -p0 -b .001
  89. %patch2 -p0 -b .002
  90. %patch3 -p0 -b .003
  91. %patch4 -p0 -b .004
  92. %patch5 -p0 -b .005
  93. %patch6 -p0 -b .006
  94. %patch7 -p0 -b .007
  95. %patch8 -p0 -b .008
  96. # Other patches
  97. %patch102 -p1 -b .paths
  98. %patch103 -p1 -b .profile
  99. %patch104 -p1 -b .interpreter
  100. %patch105 -p1 -b .debuginfo
  101. %patch107 -p1 -b .pgrp_sync
  102. %patch110 -p1 -b .audit
  103. %patch111 -p1 -b .ssh_source_bash
  104. %patch113 -p1 -b .infotags
  105. %patch114 -p1 -b .requires
  106. %patch115 -p1 -b .setlocale
  107. %patch116 -p1 -b .tty_tests
  108. %patch117 -p1 -b .nobits
  109. %patch118 -p1 -b .examples
  110. %patch119 -p1 -b .broken_pipe
  111. %patch120 -p1 -b .logout
  112. %patch121 -p1 -b .coverity
  113. %patch123 -p1
  114. %patch125 -p1 -b .size_type
  115. %patch128 -p1 -b .ulimit
  116. %patch135 -p1 -b .noecho
  117. %patch138 -p1 -b .lc_all
  118. %patch140 -p1 -b .no_loadable_builtin
  119. echo %{version} > _distribution
  120. echo %{release} |sed 's/vl.*//' > _patchlevel
  121. %build
  122. %configure --with-bash-malloc=no
  123. make CPPFLAGS="-D_GNU_SOURCE -DRECYCLES_PIDS `getconf LFS_CFLAGS`"
  124. %install
  125. rm -rf %{buildroot}
  126. # Fix bug #83776
  127. perl -pi -e 's,bashref\.info,bash.info,' doc/bashref.info
  128. make DESTDIR=$RPM_BUILD_ROOT install
  129. pushd $RPM_BUILD_ROOT
  130. mkdir ./bin
  131. mv ./usr/bin/bash ./bin/bash
  132. ln -s bash ./bin/sh
  133. rm -f .%{_infodir}/dir
  134. popd
  135. ln -s bash.1 %{buildroot}%{_mandir}/man1/sh.1
  136. # make manpages for bash builtins as per suggestion in DOC/README
  137. pushd doc
  138. sed -e '
  139. /^\.SH NAME/, /\\- bash built-in commands, see \\fBbash\\fR(1)$/{
  140. /^\.SH NAME/d
  141. s/^bash, //
  142. s/\\- bash built-in commands, see \\fBbash\\fR(1)$//
  143. s/,//g
  144. b
  145. }
  146. d
  147. ' builtins.1 > man.pages
  148. for i in echo pwd test kill; do
  149. perl -pi -e "s,$i,,g" man.pages
  150. perl -pi -e "s, , ,g" man.pages
  151. done
  152. install -c -m 644 builtins.1 %{buildroot}%{_mandir}/man1/builtins.1
  153. for i in `cat man.pages` ; do
  154. echo .so man1/builtins.1 > %{buildroot}%{_mandir}/man1/$i.1
  155. chmod 0644 ${RPM_BUILD_ROOT}%{_mandir}/man1/$i.1
  156. done
  157. mkdir -p $RPM_BUILD_ROOT/etc/profile.d/
  158. install -m 644 %{SOURCE10} $RPM_BUILD_ROOT/etc/bashrc
  159. # Not for printf, false and true (conflict with coreutils)
  160. rm -f $RPM_BUILD_ROOT%{_mandir}/man1/printf.1
  161. rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/true.1
  162. rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/false.1
  163. popd
  164. %find_lang %{name}
  165. rm -rf $RPM_BUILD_ROOT/%{_docdir}/bash
  166. %clean
  167. rm -rf %{buildroot}
  168. # ***** bash doesn't use install-info. It's always listed in %{_infodir}/dir
  169. # to prevent prereq loops
  170. # post is in lua so that we can run it without any external deps. Helps
  171. # for bootstrapping a new install.
  172. # Jesse Keating 2009-01-29 (code from Ignacio Vazquez-Abrams)
  173. %post -p <lua>
  174. bashfound = false;
  175. shfound = false;
  176. f = io.open("/etc/shells", "r");
  177. if f == nil
  178. then
  179. f = io.open("/etc/shells", "w");
  180. else
  181. repeat
  182. t = f:read();
  183. if t == "/bin/bash"
  184. then
  185. bashfound = true;
  186. end
  187. if t == "/bin/sh"
  188. then
  189. shfound = true;
  190. end
  191. until t == nil;
  192. end
  193. f:close()
  194. f = io.open("/etc/shells", "a");
  195. if not bashfound
  196. then
  197. f:write("/bin/bash\n")
  198. end
  199. if not shfound
  200. then
  201. f:write("/bin/sh\n")
  202. end
  203. f:close()
  204. %files -f %{name}.lang
  205. %defattr(-,root,root)
  206. %license COPYING
  207. %doc CHANGES
  208. %doc examples
  209. %config(noreplace) /etc/bashrc
  210. /bin/bash
  211. /bin/sh
  212. %{_infodir}/bash.info*
  213. %{_mandir}/*/*
  214. %{_mandir}/*/..1*
  215. %{_bindir}/bashbug
  216. %files doc
  217. %defattr(-,root,root)
  218. %doc COMPAT NEWS NOTES POSIX RBASH
  219. %doc examples/functions/ examples/misc/
  220. %doc examples/scripts*/
  221. %doc examples/startup-files/ examples/complete/ examples/loadables/
  222. %doc doc/*.ps doc/*.0 doc/*.html doc/article.txt
  223. %doc doc/FAQ doc/INTRO doc/article.ms doc/README
  224. %changelog
  225. * Thu Sep 02 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.8-1
  226. - updated to 5.1 patch level 8.
  227. - updated patches.
  228. * Sat Sep 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.18-1
  229. - updated to 5.0 patch level 18.
  230. * Sat Feb 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.16-1
  231. - updated to 5.0 patch level 16.
  232. * Thu Sep 12 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.11-1
  233. - updated to 5.0 patch level 11.
  234. * Thu Aug 29 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.9-1
  235. - updated to 5.0 patch level 9.
  236. - dropped Patch101, 106, 108, 109, 112, 122, 134, 137 and 139.
  237. - imported Patch140 from rawhide.
  238. * Tue Jul 5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.46-1
  239. - updated to 4.3 patch level 46.
  240. * Sat Sep 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.42-1
  241. - updated to 4.3 patch level 42.
  242. - imported patch 128-139 from RawHide.
  243. * Fri Oct 3 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.29-1
  244. - updated to 4.3 patch level 29.
  245. - removed patch1000 (included in 4.3.26).
  246. * Thu Sep 25 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.25-2
  247. - added patch1000 to fix CVE-2014-7169.
  248. * Thu Sep 25 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.25-1
  249. - updated to 4.3 patch level 25.
  250. * Tue Jun 10 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3.18-1
  251. - update to 4.3 patch level 18
  252. * Wed May 14 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3.11-1
  253. - update to 4.3 patch level 11
  254. * Mon Mar 18 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.45-1
  255. - update to 4.2 patch level 45
  256. - import some patch from fedora package (122-127)
  257. - patch122: Don't call malloc in signal handler
  258. - patch123: #799958, updated info about trap
  259. - patch124: #695656, block the signal and unblock it after the
  260. new handler is installed
  261. - patch125: Use unsigned type for size
  262. https://www.securecoding.cert.org/confluence/display/seccode/INT32-C.+Ensure+that+operations+on+signed+integers+do+not+result+in+overflow
  263. - patch126: #903833, Fix missing close(), fixes fd leaks
  264. * Sat Oct 6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.2.37-2
  265. - remove postun lua script because bash will be never uninstalled
  266. * Mon Sep 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.37-1
  267. - update to 4.2 patch level 37
  268. * Fri Feb 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.20-1
  269. - update to 4.2 patch level 20
  270. * Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.8-1
  271. - update to 4.2 patch level 8
  272. - use lua script in post/postun
  273. - update patches from fedora
  274. * Fri Sep 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1-1
  275. - update to 4.1 patch level 7
  276. * Fri Mar 5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-9
  277. - check if /bin/grep exists on %%post script
  278. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-8
  279. - rebuilt with gcc-4.4.3-3 on ppc
  280. * Tue Feb 2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-7
  281. - rebuilt with new toolchain
  282. * Fri Dec 4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-6
  283. - revert changes on 3.2-5 (avoid a nasty dependency loop on bootstrapping)
  284. * Fri Dec 4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-5
  285. - add Requires(post): grep
  286. * Sat Oct 24 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-4
  287. - remove obsolete /bin/bash2 entry from /etc/shells
  288. * Mon Apr 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-3
  289. - add Requires(post): ncurses (should be added by find-requires..)
  290. * Sun Mar 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-2
  291. - add upstream patch (from 040 to 048)
  292. - build against ncurses-devel (libtinfo)
  293. - spec in utf-8
  294. * Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2-1vl5
  295. - added upstream patch (from 026 to 039)
  296. - added Japanese summary
  297. - applied new versioning policy
  298. * Fri Jan 18 2008 Shu KONNO <owa@bg.wakwak.com> 3.2-0vl2
  299. - rebuilt with libtermcap-devel
  300. * Fri Oct 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-0vl1
  301. - new upstream release
  302. - add upstream patch (from 001 to 025)
  303. - remove Provides: bash2
  304. * Wed May 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.05b-0vl4
  305. - rebuilt with new toolchain
  306. * Mon Sep 11 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.05b-0vl3
  307. - change doc Group to Applications/Documentation. <BTS:VineLinux:163>
  308. - quote CPPFLAGS to avoid configure error. <BTS:VineLinux:173>
  309. * Mon Jun 28 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.05b-0vl2
  310. - Don't read /etc/profile.d/*.sh in /etc/bashrc; done in /etc/profile
  311. * Wed Mar 10 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.05b-0vl1
  312. - update to 2.05b
  313. - rebuild with new toolchains
  314. - add make check
  315. - add %postun script based on Fedora development
  316. - README file moved doc package
  317. - update Patch5 and Patch8 from Fedora development
  318. - change Patch6
  319. - remove Patch2 and Patch100 (bash-2.05b supports multibyte string)
  320. - add Patch11--39 from Fedora development 2.05b-36
  321. * Tim Waugh <twaugh@redhat.com>
  322. - Fix parameter expansion in multibyte locales (bug #112657).
  323. - Speed up UTF-8 command-line redrawing in the common case (bug #102353,
  324. bug #110777).
  325. - Apply upstream patches (bug #109269 among others).
  326. - Fix bash.info (bug #83776).
  327. - Add bash205b-007 patch to fix bug #106876.
  328. - Avoid crashing on multibyte input when locale is set incorrectly
  329. (bug #74266).
  330. - LFS support (bug #103627).
  331. - Fix completion display when multibyte or control characters are to be
  332. shown (bug #90201).
  333. - Fix a warning message (bug #79629).
  334. - Don't build with AFS support (bug #86514).
  335. - Don't explicitly strip binaries (bug #85995).
  336. - Really fix bug #83331 for good.
  337. - Fix builtins.1.
  338. - Actually apply the patch (bug #83331).
  339. - Fix history/UTF-8 bug (bug #83331).
  340. - More tab-completion fixing (bug #72512).
  341. - Force pgrp synchronization (bug #81653).
  342. - Prevent prompt overwriting output (bug #74383).
  343. - Fix '-rbash' (bug #78455).
  344. - Add readline-init patch (bug #74925).
  345. - Add the (4) patches from ftp.gnu.org (bug #75888, bug #72512).
  346. - Ship '.' man page, which doesn't get picked up by glob.
  347. - Locale shell variables fix (bug #74701).
  348. * Elliot Lee <sopwith@redhat.com>
  349. - (patch26) Don't call 'size' in makefile. Pointless, and interferes with
  350. cross compiles.
  351. * Wed Oct 9 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.05-0vl1
  352. - update to 2.05
  353. - add README.jpatch to %doc
  354. - remove patch4 (bash2): revert command name in man pages to "bash"
  355. - fix perl command to remove man pages conflict with sh-utils
  356. - remove section of config.h.in from patch0 to prevent remake of configure
  357. - change patch9: define in config-top.h to avoid conflict with patch100
  358. - remove patches 7, 10 & 101
  359. * Mon Apr 8 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.04-1vl14
  360. - made a link for man sh
  361. * Thu Nov 15 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.04-1vl13
  362. - added missing %%post and %%triggerpostun section
  363. * Sun Jul 15 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  364. - 2.04-1vl12
  365. - now bash2 is finally bash
  366. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.04-1vl11
  367. - build for Playstation2
  368. * Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  369. - 2.04-1vl10
  370. - Provides: bash = %%{version}
  371. * Thu Jun 07 2001 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl9
  372. - added Provides: bash
  373. * Thu Jun 07 2001 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl8
  374. - Obsoletes: bash
  375. - changed Copyright to License
  376. * Fri Dec 29 2000 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
  377. - 2.04-1vl7
  378. - deleted: /etc/profile.d/alias.sh (which we have in /etc/skel/.bashrc)
  379. - corrected: bashrc-vine -> bashrc
  380. * Sat Dec 16 2000 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl6
  381. - combined bash-1.x and bash-2.x packages
  382. - added some patches from bash-2.04-13mdk
  383. * Sun Dec 10 2000 Jun Nishii <jun@vinelinux.org> 2.04-1vl5
  384. - fix spec macros
  385. - added tests
  386. * Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl5
  387. - build with gcc-2.95.3
  388. - partially used rpmmacros
  389. * Fri Sep 8 2000 Jun Nishii <jun@vinelinux.org>
  390. - minor bug fix in spec file
  391. * Sun Aug 27 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  392. - 2.04-1vl3
  393. - modified %install and %files section to handle compressed man page(s)
  394. * Thu Mar 23 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  395. - added pcomplete patch to fix complete if the candidate list is NULL.
  396. * Wed Mar 22 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  397. - updated to 2.04
  398. * Tue Sep 14 1999 Dale Lovelace <dale@redhat.com>
  399. - Remove annoying ^H's from documentation
  400. * Fri Jul 16 1999 Ken Estes <kestes@staff.mail.com>
  401. - patch to detect what executables are required by a script.
  402. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  403. - auto rebuild in the new build environment (release 4)
  404. * Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
  405. - strip binaries.
  406. - include bash-doc correctly.
  407. * Thu Mar 18 1999 Preston Brown <pbrown@redhat.com>
  408. - fixed post/postun /etc/shells work.
  409. * Thu Mar 18 1999 Cristian Gafton <gafton@redhat.com>
  410. - updated again text in the spec file
  411. * Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
  412. - updated text in spec file.
  413. - update to 2.03.
  414. * Fri Feb 12 1999 Cristian Gafton <gafton@redhat.com>
  415. - build it as bash2 instead of bash
  416. * Tue Feb 9 1999 Bill Nottingham <notting@redhat.com>
  417. - set 'NON_INTERACTIVE_LOGIN_SHELLS' so profile gets read
  418. * Thu Jan 14 1999 Jeff Johnson <jbj@redhat.com>
  419. - rename man pages in bash-doc to avoid packaging conflicts (#606).
  420. * Wed Dec 02 1998 Cristian Gafton <gafton@redhat.com>
  421. - patch for the arm
  422. - use $RPM_ARCH-redhat-linux as the build target
  423. * Tue Oct 6 1998 Bill Nottingham <notting@redhat.com>
  424. - rewrite %pre, axe %postun (to avoid prereq loops)
  425. * Wed Aug 19 1998 Jeff Johnson <jbj@redhat.com>
  426. - resurrect for RH 6.0.
  427. * Sun Jul 26 1998 Jeff Johnson <jbj@redhat.com>
  428. - update to 2.02.1
  429. * Thu Jun 11 1998 Jeff Johnson <jbj@redhat.com>
  430. - Package for 5.2.
  431. * Mon Apr 20 1998 Ian Macdonald <ianmacd@xs4all.nl>
  432. - added POSIX.NOTES doc file
  433. - some extraneous doc files removed
  434. - minor .spec file changes
  435. * Sun Apr 19 1998 Ian Macdonald <ianmacd@xs4all.nl>
  436. - upgraded to version 2.02
  437. - Alpha, MIPS & Sparc patches removed due to lack of test platforms
  438. - glibc & signal patches no longer required
  439. - added documentation subpackage (doc)
  440. * Fri Nov 07 1997 Donnie Barnes <djb@redhat.com>
  441. - added signal handling patch from Dean Gaudet <dgaudet@arctic.org> that
  442. is based on a change made in bash 2.0. Should fix some early exit
  443. problems with suspends and fg.
  444. * Mon Oct 20 1997 Donnie Barnes <djb@redhat.com>
  445. - added %clean
  446. * Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
  447. - added comment explaining why install-info isn't used
  448. - added mips patch
  449. * Fri Oct 17 1997 Donnie Barnes <djb@redhat.com>
  450. - added BuildRoot
  451. * Tue Jun 03 1997 Erik Troan <ewt@redhat.com>
  452. - built against glibc