curl-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
  3. Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
  4. Name: curl
  5. Version: 7.77.0
  6. Release: 1%{?_dist_release}
  7. Group: internet
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. Packager: daisuke
  11. License: MIT
  12. URL: https://curl.haxx.se/
  13. Source: https://curl.haxx.se/download/%{name}-%{version}.tar.xz
  14. # patch making libcurl multilib ready
  15. Patch101: 0101-curl-7.73.0-multilib.patch
  16. # prevent configure script from discarding -g in CFLAGS (#496778)
  17. Patch102: 0102-curl-7.36.0-debug.patch
  18. # prevent valgrind from reporting false positives on x86_64
  19. Patch105: 0105-curl-7.63.0-lib1560-valgrind.patch
  20. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  21. BuildRequires: brotli-devel
  22. BuildRequires: gnutls-devel
  23. BuildRequires: libidn2-devel
  24. BuildRequires: libnghttp2-devel
  25. BuildRequires: libpsl-devel
  26. BuildRequires: libssh2-devel
  27. BuildRequires: openldap-devel
  28. BuildRequires: openssh-server
  29. BuildRequires: openssh-clients
  30. BuildRequires: openssl-devel
  31. BuildRequires: pkgconfig
  32. BuildRequires: zlib-devel
  33. Requires: ca-certificates
  34. %description
  35. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  36. Dict servers, using any of the supported protocols. cURL is designed
  37. to work without user interaction or any kind of interactivity. cURL
  38. offers many useful capabilities, like proxy support, user
  39. authentication, FTP upload, HTTP post, and file transfer resume.
  40. %package devel
  41. Summary: Files needed for building applications with libcurl.
  42. Group: programming
  43. Requires: %{name} = %{version}-%{release}
  44. Requires: openssl-devel libidn-devel zlib-devel
  45. %description devel
  46. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  47. Dict servers, using any of the supported protocols. The curl-devel
  48. package includes files needed for developing applications which can
  49. use cURL's capabilities internally.
  50. #'
  51. ## to build compat32 for x86_64 architecture support
  52. %package -n compat32-%{name}
  53. Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
  54. Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
  55. Group: system,legacy
  56. %description -n compat32-%{name}
  57. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  58. Dict servers, using any of the supported protocols. cURL is designed
  59. to work without user interaction or any kind of interactivity. cURL
  60. offers many useful capabilities, like proxy support, user
  61. authentication, FTP upload, HTTP post, and file transfer resume.
  62. %package -n compat32-%{name}-devel
  63. Summary: Files needed for building applications with libcurl.
  64. Group: programming,legacy
  65. %description -n compat32-%{name}-devel
  66. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  67. Dict servers, using any of the supported protocols. The curl-devel
  68. package includes files needed for developing applications which can
  69. use cURL's capabilities internally.
  70. #'
  71. %debug_package
  72. %prep
  73. %setup -q
  74. %autopatch -p1
  75. # disable test 1112 (#565305), test 1455 (occasionally fails with 'bind failed
  76. # with errno 98: Address already in use' in Koji environment), and test 1801
  77. # <https://github.com/bagder/curl/commit/21e82bd6#commitcomment-12226582>
  78. # and test 1900, which is flaky and covers a deprecated feature of libcurl
  79. # <https://github.com/curl/curl/pull/2705>
  80. printf "1112\n1455\n1801\n1900\n" >> tests/data/DISABLED
  81. # disable test 1319 on ppc64 (server times out)
  82. %ifarch ppc64
  83. echo "1319" >> tests/data/DISABLED
  84. %endif
  85. # temporarily disable test 582 on s390x (client times out)
  86. %ifarch s390x
  87. echo "582" >> tests/data/DISABLED
  88. %endif
  89. # adapt test 323 for updated OpenSSL
  90. sed -e 's/^35$/35,52/' -i tests/data/test323
  91. # use localhost6 instead of ip6-localhost in the curl test-suite
  92. (
  93. # avoid glob expansion in the trace output of `bash -x`
  94. { set +x; } 2>/dev/null
  95. cmd="sed -e 's|ip6-localhost|localhost6|' -i tests/data/test[0-9]*"
  96. printf "+ %s\n" "$cmd" >&2
  97. eval "$cmd"
  98. )
  99. # regenerate the configure script and Makefile.in files
  100. autoreconf -fiv
  101. %build
  102. %configure \
  103. --disable-static \
  104. --enable-hidden-symbols \
  105. --enable-ipv6 \
  106. --enable-ldap \
  107. --enable-ldaps \
  108. --enable-threaded-resolver \
  109. --with-brotli \
  110. --with-libidn2 \
  111. --with-libpsl \
  112. --with-libssh2 \
  113. --with-nghttp2 \
  114. --with-ssl --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
  115. %{nil}
  116. make %{?_smp_mflags}
  117. %install
  118. rm -rf $RPM_BUILD_ROOT
  119. make DESTDIR=$RPM_BUILD_ROOT install
  120. rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
  121. %clean
  122. rm -rf $RPM_BUILD_ROOT
  123. %files
  124. %defattr(-,root,root)
  125. %{!?_licensedir:%global license %%doc}
  126. %license COPYING
  127. %doc CHANGES README
  128. %doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
  129. %doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
  130. %doc docs/TheArtOfHttpScripting docs/TODO
  131. %{_bindir}/curl
  132. #{_datadir}/curl/*
  133. %{_libdir}/*.so.*
  134. %{_mandir}/man1/*.1*
  135. %files devel
  136. %defattr(-,root,root)
  137. %{_bindir}/curl-config
  138. %{_includedir}/curl
  139. %{_libdir}/*.so
  140. %{_libdir}/pkgconfig/*.pc
  141. %{_mandir}/man1/curl-config.1*
  142. %{_mandir}/man3/*
  143. %{_datadir}/aclocal/libcurl.m4
  144. ## to build compat32 for x86_64 architecture support
  145. %if %{build_compat32}
  146. %files -n compat32-%{name}
  147. %defattr(-,root,root)
  148. %{_libdir}/*.so.*
  149. %files -n compat32-%{name}-devel
  150. %defattr(-,root,root)
  151. %{_libdir}/*.so
  152. %endif
  153. %changelog
  154. * Wed Jun 23 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.77.0-1
  155. - new upstream release.
  156. * Wed Apr 21 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.76.1-1
  157. - new upstream release.
  158. * Wed Apr 07 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.76.0-1
  159. - new upstream release.
  160. - dropped ldconfig scriptlets.
  161. - dropped Patch2, 102-104.
  162. * Sat Feb 20 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.75.0-1
  163. - new upstream release.
  164. * Wed Dec 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.74.0-1
  165. - new upstream release.
  166. * Tue Nov 03 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.73.0-1
  167. - new upstream release.
  168. - updated Patch0101 and Patch0104.
  169. * Fri Jul 10 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.71.1-1
  170. - new upstream release.
  171. * Tue Jun 09 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.70.0-1
  172. - new upstream release.
  173. * Sun Feb 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.68.0-1
  174. - new upstream release.
  175. * Sat Sep 21 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.66.0-1
  176. - new upstream release.
  177. - dropped Patch1 and 2: fixed in upstream.
  178. * Thu Aug 29 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.65.3-1
  179. - new upstream release.
  180. - updated patches.
  181. - imported Patch1, 103 and 105 from rawhide.
  182. * Sat Nov 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.62.0-1
  183. - new upstream release.
  184. - imported patches from rawhide.
  185. * Fri Apr 13 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.59.0-1
  186. - new upstream release.
  187. - imported Patch1 and 103 from rawhide.
  188. * Wed Feb 7 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.58.0-1
  189. - new upstream release with security fix
  190. - update patch101
  191. * Thu Jan 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.57.0-1
  192. - new upstream release.
  193. - updated Patch101-104.
  194. - dropped Patch107.
  195. * Mon May 1 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.54.0-1
  196. - new upstream release.
  197. * Thu Mar 16 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.53.1-1
  198. - new upstream release.
  199. * Wed Dec 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.51.0-1
  200. - new upstream release.
  201. * Fri Jul 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.50.0-1
  202. - new upstream release.
  203. - disabled HTTP/2 on Vine6.
  204. * Sat Jul 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-2
  205. - added HTTP/2 support.
  206. * Tue Jun 28 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-1
  207. - new upstream release with security fix.
  208. * Sat May 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.0-1
  209. - new upstream release.
  210. * Sat Mar 12 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.47.1-1
  211. - new upstream release
  212. - built with openssl 1.0.2g
  213. * Fri Jun 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.43.0-1
  214. - new upstream release with security fix .
  215. - removed Patch108 (fixed in upstream).
  216. * Sun Nov 9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.39.0-1
  217. - new upstream release with security fix
  218. * Sun Jan 19 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 7.34.0-1
  219. - new upstream release
  220. - add libcurl.m4 to -devel package
  221. * Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 7.32.0-1
  222. - new upstream release
  223. - import upstream/fedora patches
  224. - disable libssh2 on Vine Linux 6
  225. * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.1-1
  226. - new upstream reelase
  227. * Sun Oct 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.0-1
  228. - update to 7.28.0
  229. - add configure options
  230. - --enable-ssh2, --enable-threaded-resolver, --enable-ldaps
  231. - add BR: libssh2-devel, openssh-clients, openssh-server, pkgconfig
  232. - use ca-certificates package
  233. - --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt
  234. - R: ca-certificates
  235. * Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 7.24.0-1
  236. - new upstream release
  237. * Sun Jul 3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-4
  238. - add patch100 for fix CVE-2011-2192 (gssapi)
  239. - add Vendor/Distri tags
  240. * Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
  241. - rebuild with openssl-1.0.0c
  242. * Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
  243. - rebuilt with rpm-4.8.1 for pkg-config
  244. * Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
  245. - new upstream release
  246. * Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
  247. - new upstream release with security fix
  248. * Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
  249. - added compat32 subpackages
  250. * Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
  251. - new upstream release
  252. - use "_smp_mflags" flag
  253. * Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
  254. - rebuild with openldap-2.4.11
  255. - add BR: openldap-devel
  256. - remove static library
  257. * Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
  258. - new upstream release with security fix (CVE-2009-0037)
  259. * Sun Jul 6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
  260. - new upstream release
  261. * Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
  262. - new upstream release
  263. * Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
  264. - new upstream release
  265. * Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
  266. - new upstream release
  267. * Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
  268. - new upstream release
  269. * Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
  270. - rebuilt with openssl-0.9.8e
  271. * Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
  272. - new upstream release
  273. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
  274. - new upstream release
  275. * Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
  276. - new upstream release
  277. - add pkgconfig file to devel package
  278. * Wed Dec 7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
  279. - new upstream release
  280. * Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
  281. - new upstream release
  282. * Fri Sep 2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
  283. - new upstream release
  284. * Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
  285. - added libidn, zlib in Requires
  286. - added libidn-devel, zlib-devel in BuildPrereq
  287. - added zlib-devel in curl-devel's Requires
  288. * Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
  289. - added openssl-devel, libidn-devel in curl-devel's Requires
  290. * Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
  291. - new upstream release
  292. * Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
  293. - new upstream release
  294. - rebuild with openssl-0.9.7d
  295. * Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
  296. - upstream release
  297. * Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
  298. - add %%{_datadir}/curl/* to %%files section
  299. * Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
  300. - source upgrade
  301. * Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
  302. - source upgrade
  303. - add PreReq: ldconfig
  304. - add %%{_libdir}/*.la to %%files devel section
  305. * Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
  306. - build for VineSeed
  307. - add Requires: openssl
  308. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  309. - automated rebuild
  310. * Wed Jan 9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
  311. - 7.9.2
  312. * Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
  313. - include curl-config in curl-devel
  314. - update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
  315. * Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
  316. - added openssl-devel build req
  317. * Mon May 21 2001 Tim Powers <timp@redhat.com>
  318. - built for the distro
  319. * Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
  320. - upgrade to curl-7.7.2.
  321. - enable IPv6.
  322. * Fri Mar 2 2001 Tim Powers <timp@redhat.com>
  323. - rebuilt against openssl-0.9.6-1
  324. * Thu Jan 4 2001 Tim Powers <timp@redhat.com>
  325. - fixed mising ldconfigs
  326. - updated to 7.5.2, bug fixes
  327. * Mon Dec 11 2000 Tim Powers <timp@redhat.com>
  328. - updated to 7.5.1
  329. * Mon Nov 6 2000 Tim Powers <timp@redhat.com>
  330. - update to 7.4.1 to fix bug #20337, problems with curl -c
  331. - not using patch anymore, it's included in the new source. Keeping
  332. for reference
  333. * Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
  334. - fix bogus req in -devel package
  335. * Fri Oct 20 2000 Tim Powers <timp@redhat.com>
  336. - devel package needed defattr so that root owns the files
  337. * Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
  338. - update to 7.3
  339. - apply vsprintf/vsnprintf patch from Colin Phipps via Debian
  340. * Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
  341. - enable SSL support
  342. - fix packager tag
  343. - move buildroot to %%{_tmppath}
  344. * Tue Aug 1 2000 Tim Powers <timp@redhat.com>
  345. - fixed vendor tag for bug #15028
  346. * Mon Jul 24 2000 Prospector <prospector@redhat.com>
  347. - rebuilt
  348. * Tue Jul 11 2000 Tim Powers <timp@redhat.com>
  349. - workaround alpha build problems with optimizations
  350. * Mon Jul 10 2000 Tim Powers <timp@redhat.com>
  351. - rebuilt
  352. * Mon Jun 5 2000 Tim Powers <timp@redhat.com>
  353. - put man pages in correct place
  354. - use %%makeinstall
  355. * Mon Apr 24 2000 Tim Powers <timp@redhat.com>
  356. - updated to 6.5.2
  357. * Wed Nov 3 1999 Tim Powers <timp@redhat.com>
  358. - updated sources to 6.2
  359. - gzip man page
  360. * Mon Aug 30 1999 Tim Powers <timp@redhat.com>
  361. - changed group
  362. * Thu Aug 26 1999 Tim Powers <timp@redhat.com>
  363. - changelog started
  364. - general cleanups, changed prefix to /usr, added manpage to files section
  365. - including in Powertools