djvulibre-vl.spec 8.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255
  1. Summary: DjVu viewers, encoders and utilities.
  2. Summary(ja): DjVu 画像形式ファイル操作用ライブラリ、ツール
  3. Name: djvulibre
  4. Version: 3.5.28
  5. Release: 2%{?_dist_release}
  6. Group: graphics
  7. Distribution: Project Vine
  8. Vendor: Vine Linux
  9. Packager: owa
  10. License: GPLv2
  11. URL: http://djvu.sourceforge.net
  12. Source0: http://prdownloads.sourceforge.net/djvu/djvulibre-%{version}.tar.gz
  13. Patch1000: 0001-Reviewed-Fedora-patches-and-adopted-some-of-them-or-.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: libtiff-devel
  16. BuildRequires: libjpeg-devel
  17. BuildRequires: glibc-devel
  18. BuildRequires: inkscape
  19. BuildRequires: xdg-utils chrpath
  20. BuildRequires: hicolor-icon-theme
  21. Requires(post): xdg-utils
  22. Requires(preun): xdg-utils
  23. %description
  24. DjVu is a web-centric format and software platform for distributing documents
  25. and images. DjVu content downloads faster, displays and renders faster, looks
  26. nicer on a screen, and consume less client resources than competing formats.
  27. DjVu was originally developed at AT&T Labs-Research by Leon Bottou, Yann
  28. LeCun, Patrick Haffner, and many others. In March 2000, AT&T sold DjVu to
  29. LizardTech Inc. who now distributes Windows/Mac plug-ins, and commercial
  30. encoders (mostly on Windows)
  31. In an effort to promote DjVu as a Web standard, the LizardTech management was
  32. enlightened enough to release the reference implementation of DjVu under the
  33. GNU GPL in October 2000. DjVuLibre (which means free DjVu), is an enhanced
  34. version of that code maintained by the original inventors of DjVu. It is
  35. compatible with version 3.5 of the LizardTech DjVu software suite.
  36. DjVulibre-3.5 contains:
  37. - a standalone DjVu viewer based on the Qt library.
  38. - A browser plugin that works with most Unix browsers.
  39. - A full-fledged wavelet-based compressor for pictures.
  40. - A simple compressor for bitonal (black and white) scanned pages.
  41. - A compressor for palettized images (a la GIF/PNG).
  42. - A set of utilities to manipulate and assemble DjVu images and documents.
  43. - A set of decoders to convert DjVu to a number of other formats.
  44. - An up-to-date version of the C++ DjVu Reference Library.
  45. %package libs
  46. Summary: Library files for DjVuLibre
  47. Group: programming
  48. %description libs
  49. Library files for DjVuLibre.
  50. %package devel
  51. Summary: The libraries and header files needed for djvulibre development.
  52. Group: programming
  53. Requires: %{name}-libs = %{version}-%{release}
  54. %description devel
  55. DjVulibre libraries and header files for development.
  56. %debug_package
  57. %prep
  58. %setup -q -n %{name}-%{version}
  59. %autopatch -p1
  60. %build
  61. %configure --enable-threads
  62. make %{?_smp_mflags} V=1
  63. %install
  64. rm -rf %{buildroot}
  65. make DESTDIR=%{buildroot} install
  66. # fix to stop ldconfig from complaining
  67. find %{buildroot}%{_libdir} -name "*.so*" -exec chmod 755 {} \;
  68. # Remove rpath
  69. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/djvutoxml
  70. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/djvused
  71. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/cjb2
  72. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/csepdjvu
  73. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/djvuserve
  74. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/djvm
  75. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/djvuxmlparser
  76. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/djvutxt
  77. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/ddjvu
  78. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/djvumake
  79. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/cpaldjvu
  80. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/djvuextract
  81. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/c44
  82. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/djvups
  83. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/djvudump
  84. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/djvmcvt
  85. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/bzz
  86. # This XML file does not differentiate between DjVu Image and DjVu Document
  87. # MIME types, the default one in shared-mime-info does.
  88. rm -f $RPM_BUILD_ROOT%{_datadir}/mime/packages/djvulibre-mime.xml
  89. # MIME types (icons and desktop file) - this installs icon files under
  90. # /usr/share/icons/hicolor/ and an xml file under /usr/share/mime/image/
  91. # Taken from {_datadir}/djvu/osi/desktop/register-djvu-mime install
  92. # See also the README file in the desktopfiles directory of the source distribution
  93. pushd desktopfiles
  94. for i in 22 32 48 64 ; do
  95. install -d $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/${i}x${i}/mimetypes/
  96. cp -a ./prebuilt-hi${i}-djvu.png $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/${i}x${i}/mimetypes/image-vnd.djvu.mime.png
  97. # cp -a ./hi${i}-djvu.png $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/${i}x${i}/mimetypes/gnome-mime-image-vnd.djvu.png
  98. done
  99. popd
  100. %clean
  101. rm -rf %{buildroot}
  102. %files
  103. %defattr(-, root, root)
  104. %license COPYRIGHT COPYING
  105. %doc README NEWS
  106. %{_bindir}/*
  107. %exclude %{_datadir}/djvu/osi/de/*
  108. %exclude %{_datadir}/djvu/osi/fr/*
  109. %exclude %{_datadir}/djvu/osi/zh/*
  110. %dir %{_datadir}/djvu
  111. %{_datadir}/djvu/pubtext
  112. %dir %{_datadir}/djvu/osi
  113. %{_datadir}/djvu/osi/languages.xml
  114. %{_datadir}/djvu/osi/en
  115. %{_datadir}/djvu/osi/cs
  116. %lang(ja) %{_datadir}/djvu/osi/ja*
  117. %{_datadir}/icons/hicolor/*/mimetypes/*
  118. %{_mandir}/man?
  119. %files libs
  120. %license COPYRIGHT COPYING
  121. %doc README NEWS
  122. %{_libdir}/*.so.*
  123. %files devel
  124. %defattr(-, root, root)
  125. %doc doc
  126. %{_includedir}/libdjvu
  127. %{_libdir}/lib*.so
  128. %exclude %{_libdir}/*.la
  129. %{_libdir}/pkgconfig/ddjvuapi.pc
  130. %changelog
  131. * Tue Jun 29 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.28-2
  132. - import Patch1000 from upstream to fix CVE-2021-{3500,32490,32491,32492,32493}.
  133. - dropped Patch0 and 6: Patch1000 includes them.
  134. - dropped ldconfig scriptlets.
  135. * Wed Mar 03 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.28-1
  136. - new upstream release.
  137. - added a subpackage: djvulibre-libs.
  138. - dropped Patch2-5 and 7: fixed in upstream.
  139. * Tue Aug 04 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.27-1
  140. - new upstream release.
  141. * Fri Jul 1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.25.3-3
  142. - rebuilt with new toolchain.
  143. * Thu Feb 26 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.5.25.3-2
  144. - rebuilt on current VineSeed
  145. - moved %{_libdir}/lib*.so to devel subpackage
  146. * Sun Jul 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.25.3-1
  147. - update to 3.5.25.3
  148. - remove BuildRequires: qt-devel
  149. - add BuildRequires: inkscape
  150. * Sun May 01 2011 Shu KONNO <owa@bg.wakwak.com> 3.5.24-1
  151. - updated djvulibre to 3.5.24
  152. - obsoletes djvulibre-plugin (new is djview-plugin)
  153. * Sat Apr 30 2011 Shu KONNO <owa@bg.wakwak.com> 3.5.22-4
  154. - installed djview3.png
  155. * Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 3.5.22-3
  156. - rebuilt with rpm-4.8.1 for pkg-config
  157. * Wed Jul 01 2009 Shu KONNO <owa@bg.wakwak.com> 3.5.22-2
  158. - rebuilt with new toolchain
  159. * Wed Jul 01 2009 Shu KONNO <owa@bg.wakwak.com> 3.5.22-1
  160. - updated djvulibre to 3.5.22
  161. * Tue Dec 30 2008 Shu KONNO <owa@bg.wakwak.com> 3.5.21-1
  162. - initial build for VineSeed
  163. - spec in utf-8, and applied vine versioning policy
  164. - updated djvulibre to 3.5.21
  165. - added CXXFLAG="-march=i686" if i386
  166. - added djview desktop file
  167. * Tue Apr 03 2007 Shu KONNO <owa@bg.wakwak.com> 3.5.19-uvl1
  168. - updated djvulibre to 3.5.19
  169. - added scripts to alternative djview at %%post, %%preun
  170. * Thu Dec 01 2005 Shu KONNO <owa@bg.wakwak.com> 3.5.16-uvl1
  171. - updated djvulibre to 3.5.16
  172. - changed suffix
  173. - divided into djvulibre, djvulibre-devel, djvulibre-plugin
  174. * Tue Nov 09 2004 Shu KONNO <owa@bg.wakwak.com> 3.5.14-uvl2
  175. - updated djvulibre to 3.5.14 (realese 2)
  176. * Thu Jun 17 2004 Leon Bottou <leon@bottou.org> 3.5.13-4
  177. - changed runtime generation of file list.
  178. * Mon May 31 2004 Leon Bottou <leon@bottou.org> 3.5.13-3
  179. - removed 'make install-desktop-files'
  180. * Wed May 5 2004 Leon Bottou <leon@bottou.org> 3.5.13-2
  181. * Fri Apr 9 2004 Leon Bottou <leon@bottou.org> 3.5.13-1
  182. - added runtime generation of file list.
  183. - using DESTDIR instead of %makeinstall.
  184. - added 'make install-desktop-files'
  185. * Wed Nov 5 2003 Leon Bottou <leon@bottou.org> 3.5.12-3
  186. - added support for i18n
  187. - renamed symlink in mozilla plugin dirs.
  188. * Mon Jul 7 2003 Leon Bottou <leon@bottou.org> 3.5.12-1
  189. * Thu Apr 24 2003 Leon Bottou <leon@bottou.org> 3.5.11-1
  190. * Thu Feb 6 2003 Leon Bottou <leon@bottou.org> 3.5.10-2
  191. * Fri Jan 24 2003 Leon Bottou <leon@bottou.org> 3.5.10-1
  192. * Wed Oct 9 2002 Leon Bottou <leonb@users.sourceforge.net> 3.5.9-2
  193. - fixed logic for uninstalling nsdejavu links.
  194. - learned a few tricks from the freshrpms spec file.
  195. * Sun Oct 6 2002 Leon Bottou <leonb@users.sourceforge.net> 3.5.9-1
  196. - added logic to install nsdejavu for mozilla.
  197. * Wed May 29 2002 Leon Bottou <leonb@users.sourceforge.net> 3.5.6-1
  198. * Mon Apr 1 2002 Leon Bottou <leonb@users.sourceforge.net> 3.5.5-2
  199. - changed group to Applications/Publishing.
  200. * Mon Mar 25 2002 Leon Bottou <leonb@users.sourceforge.net> 3.5.5-2
  201. * Tue Jan 22 2002 Leon Bottou <leonb@users.sourceforge.net> 3.5.4-2
  202. - added macros to locate man directory.
  203. * Wed Jan 16 2002 Leon Bottou <leonb@users.sourceforge.net> 3.5.3-1
  204. * Fri Dec 7 2001 Leon Bottou <leonb@users.sourceforge.net> 3.5.2-1
  205. * Wed Dec 5 2001 Leon Bottou <leonb@users.sourceforge.net> 3.5.1-1
  206. - created initial file.