123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391 |
- Summary: A set of system configuration and setup files.
- Summary(ja): システム設定およびセットアップファイル一式
- Name: setup
- Version: 2.8.31
- Release: 1%{?_dist_release}
- License: Public Domain
- Group: System Environment/Base
- URL: https://fedorahosted.org/setup/
- Source: setup-%{version}.tar.bz2
- Patch: setup-2.8.1-vine.patch
- Buildroot: %{_tmppath}/%{name}-%{version}-root
- BuildArch: noarch
- Conflicts: initscripts < 4.26, bash <= 2.0.4-21
- %description
- The setup package contains a set of important system configuration and
- setup files, such as passwd, group, and profile.
- %description -l ja
- このsetupパッケージには、passwd, group, profile などの、
- 重要なシステム設定ファイルが含まれてます。
- %prep
- %setup -q
- %patch -p1
- ./shadowconvert.sh
- %install
- rm -rf %{buildroot}
- mkdir -p %{buildroot}/etc/profile.d
- cp -ar * %{buildroot}/etc
- rm -f %{buildroot}/etc/uidgid
- rm -f %{buildroot}/etc/COPYING
- mkdir -p %{buildroot}/var/log
- touch %{buildroot}/etc/{shadow,gshadow}
- touch %{buildroot}/var/log/lastlog
- touch %{buildroot}/etc/environment
- chmod 0644 %{buildroot}/etc/environment
- chmod 0400 %{buildroot}/etc/{shadow,gshadow}
- chmod 0644 %{buildroot}/var/log/lastlog
- touch %{buildroot}/etc/fstab
- # remove unpackaged files
- rm -f %{buildroot}/etc/Makefile
- rm -f %{buildroot}/etc/services.orig
- rm -f %{buildroot}/etc/serviceslint
- rm -f %{buildroot}/etc/uidgidlint
- rm -f %{buildroot}/etc/shadowconvert.sh
- rm -f %{buildroot}/etc/setup.spec
- rm -f $RPM_BUILD_ROOT/etc/{bashrc,aliases}
- %clean
- rm -rf %{buildroot}
- #throw away useless and dangerous update stuff until rpm will be able to
- #handle it ( http://rpm.org/ticket/6 )
- %post -p <lua>
- for i, name in ipairs({"passwd", "shadow", "group", "gshadow"}) do
- os.remove("/etc/"..name..".rpmnew")
- end
- %files
- %defattr(-,root,root)
- %doc uidgid COPYING
- %verify(not md5 size mtime) %config(noreplace) /etc/passwd
- %verify(not md5 size mtime) %config(noreplace) /etc/group
- %verify(not md5 size mtime) %config(noreplace,missingok) /etc/shadow
- %verify(not md5 size mtime) %config(noreplace,missingok) /etc/gshadow
- %verify(not md5 size mtime) %config(noreplace) /etc/services
- %verify(not md5 size mtime) %config(noreplace) /etc/exports
- %config(noreplace) /etc/environment
- %config(noreplace) /etc/filesystems
- %config(noreplace) /etc/host.conf
- %verify(not md5 size mtime) %config(noreplace) /etc/hosts
- %verify(not md5 size mtime) %config(noreplace) /etc/hosts.allow
- %verify(not md5 size mtime) %config(noreplace) /etc/hosts.deny
- %verify(not md5 size mtime) %config(noreplace) /etc/motd
- %config(noreplace) /etc/printcap
- %verify(not md5 size mtime) %config(noreplace) /etc/inputrc
- # config(noreplace) /etc/bashrc
- %config(noreplace) /etc/profile
- %verify(not md5 size mtime) %config(noreplace) /etc/protocols
- %attr(0600,root,root) %config(noreplace,missingok) /etc/securetty
- %config(noreplace) /etc/csh.login
- %config(noreplace) /etc/csh.cshrc
- %dir /etc/profile.d
- %config(noreplace) %verify(not md5 size mtime) /etc/shells
- %ghost %attr(0644,root,root) %verify(not md5 size mtime) /var/log/lastlog
- %ghost %verify(not md5 size mtime) %config(noreplace,missingok) /etc/fstab
- %changelog
- * Thu Apr 14 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.31-1
- - update to 2.8.31
- - use <lua> for post scriptlet
- * Sat Mar 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-1
- - update to 2.8.1
- - spec in utf-8
- - new versioning policy
- - add %%postun to remove dangerous .rpmnew files
- * Sat May 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.7-2vl5
- - add /etc/environment
- - add /etc/{fstab,mtab} as %%ghost
- - add console to /etc/securetty
- - import /etc/services from FC
- - set mark-symlinked-directories in /etc/inputrc
- - add /sbin/nologin to /etc/shells
- * Fri Mar 04 2005 Satoshi MACHINO <machino@vinelinux.org> 2.5.7-2vl4
- - updated setup-2.5.7-vine.patch
- -- changed /etc/printcap for using cups
- * Mon Jun 28 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.5.7-2vl3
- - source /etc/profile.d/*.sh in /etc/profile
- * Sun Feb 24 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.7-2vl1
- - merge with new upstream version
- * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
- - automated rebuild
- * Mon Aug 27 2001 Preston Brown <pbrown@redhat.com>
- - add ext3 to /etc/filesystems
- * Mon Aug 20 2001 Bill Nottingham <notting@redhat.com>
- - change FTP user's home dir to /var/ftp (#52091)
- - %%ghost /etc/shadow, /etc/gshadow
- * Fri Aug 17 2001 Bill Nottingham <notting@redhat.com>
- - add /etc/shells to filelist (#51813)
- * Mon Aug 13 2001 Bill Nottingham <notting@redhat.com>
- - put lock in /etc/group (#51654)
- * Wed Aug 8 2001 Bill Nottingham <notting@redhat.com>
- - lock only needs to be a gid
- - don't set dspmbyte=euc here; do it in lang.csh, and only if necessary (#50318)
- * Mon Aug 6 2001 Jeff Johnson <jbj@redhat.com>
- - add lock.lock uid/gid 54 to own /var/lock directory.
- * Thu Jul 19 2001 Bill Nottingham <notting@redhat.com>
- - add forward/backward-word mappings (#48783)
- - add pgpkeyserver port to /etc/services (#49407)
- * Thu Jul 19 2001 Preston Brown <pbrown@redhat.com>
- - core files disabled by default. Developers can enable them.
- * Fri Jul 13 2001 Bill Nottingham <notting@redhat.com> 2.5.1-1
- - revert news user back to no shell (#48701)
- * Tue Jul 10 2001 Bill Nottingham <notting@redhat.com> 2.5.0-1
- - move profile.d parsing from csh.cshrc to csh.login (#47417)
- * Sat Jul 7 2001 Nalin Dahyabhai <nalin@redhat.com> 2.4.15-1
- - reorder /etc/services to match comments again
- - protocol 118 is stp, not st
- - update URLs in /etc/protocols and /etc/services
- * Thu Jul 5 2001 Preston Brown <pbrown@redhat.com> 2.4.14-1
- - put */sbin in path if user ID is 0.
- * Mon Jun 25 2001 Bill Nottingham <notting@redhat.com>
- - add an entry to /etc/services for ssh X11 forwarding (#44944)
- * Wed Jun 13 2001 Bill Nottingham <notting@redhat.com>
- - take ttyS0 out of securetty on main tree
- * Tue Jun 12 2001 Philip Copeland <bryce@redhat.com>
- - added ttyS0 to securetty for serial console usage
- * Tue Jun 12 2001 Bill Nottingham <notting@redhat.com>
- - add rndc to /etc/services (#40265)
- - test for read bit, not execute bit, for profile.d (#35714)
- * Sun Jun 03 2001 Florian La Roche <Florian.LaRoche@redhat.de>
- - add "canna" entry to /etc/services
- * Mon May 21 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.4.10-1
- - Fix bugs #24159 and #30634 again; whoever moved bashrc from bash
- to setup used an old version. :((
- * Wed May 2 2001 Preston Brown <pbrown@redhat.com> 2.4.9-1
- - bashrc moved here from bash package
- - set umask in bashrc, so it applies for ALL shells.
- * Fri Apr 27 2001 Preston Brown <pbrown@redhat.com> 2.4.8-1
- - /sbin/nologin for accounts that aren't "real."
- * Sat Apr 7 2001 Preston Brown <pbrown@redhat.com>
- - revert control-arrow forward/backward word (broken)
- * Tue Mar 27 2001 Preston Brown <pbrown@redhat.com>
- - fix japanese input with tcsh (#33211)
- * Tue Mar 6 2001 Bill Nottingham <notting@redhat.com>
- - fix some weirdness with rxvt (#30799)
- * Wed Feb 28 2001 Bill Nottingham <notting@redhat.com>
- - add SKK input method (#29759)
- * Fri Feb 23 2001 Preston Brown <pbrown@redhat.com>
- * Wed Feb 21 2001 Bill Nottingham <notting@redhat.com>
- - fix inputrc, Yet Again. (#28617)
- * Thu Feb 15 2001 Bill Nottingham <notting@redhat.com>
- - add in uidgid file, put it in %doc
- * Wed Feb 7 2001 Adrian Havill <havill@redhat.com>
- - bindkey for delete in the case of tcsh
- * Wed Feb 7 2001 Bill Nottingham <notting@redhat.com>
- - add some more stuff to /etc/services (#25396, patch from
- <pekkas@netcore.fi>)
- * Tue Feb 6 2001 Nalin Dahyabhai <nalin@redhat.com>
- - add gii/tcp = 616 for gated
- * Tue Jan 30 2001 Bill Nottingham <notting@redhat.com>
- - wrap some inputrc settings with tests for mode, term (#24117)
- * Mon Jan 29 2001 Bill Nottingham <notting@redhat.com>
- - overhaul /etc/protocols (#18530)
- - add port 587 to /etc/services (#25001)
- - add corbaloc (#19581)
- - don't set /usr/X11R6/bin in $PATH if it's already set (#19968)
- * Fri Dec 1 2000 Nalin Dahyabhai <nalin@redhat.com>
- - Clean up /etc/services, separating registered numbers from unregistered
- ("squatted") numbers, and adding some.
- * Mon Nov 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
- - Add smtps (465/tcp) and submission (587/tcp) to /etc/services for TLS
- support (postfix >= 20001030-2)
- * Mon Nov 6 2000 Kazuhisa TAKEI <takei@vinelinux.org>
- - rebuild in rpm 3.0.6
- * Wed Oct 11 2000 Jun Nishii <jun@vinelinux.org>
- - remove reading profile.d process from /etc/profile
- the process moved to /etc/bashrc...
- * Thu Sep 07 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
- - 2.2.1-1vl2
- - removed /etc/filesystems in %files section
- * Sun Aug 6 2000 Bill Nottingham <notting@redhat.com>
- - /var/log/lastlog is %config(noreplace) (#15412)
- - some of the various %verify changes (#14819)
- * Thu Aug 3 2000 Nalin Dahyabhai <nalin@redhat.com>
- - linuxconf should be 98, not 99
- * Tue Jul 25 2000 Bill Nottingham <notting@redhat.com>
- - fix some of the csh stuff (#14622)
- * Sun Jul 23 2000 Nalin Dahyabhai <nalin@redhat.com>
- - stop setting "multi on" in /etc/host.conf
- * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
- - automatic rebuild
- * Tue Jun 27 2000 Bill Nottingham <notting@redhat.com>
- - add hfs filesystem
- * Wed Jun 21 2000 Preston Brown <pbrown@redhat.com>
- - printcap is a noreplace file now
- * Sun Jun 18 2000 Bill Nottingham <notting@redhat.com>
- - fix typo
- * Tue Jun 13 2000 Lisa Sagami <czs14350@nifty.ne.jp>
- - merged RH 2.2.1-1 and Vine 2.0.5-1vl3
- * Tue Jun 13 2000 Nalin Dahyabhai <nalin@redhat.com>
- - add linuxconf/tcp = 99 to /etc/services
- * Sat Jun 10 2000 Bill Nottingham <notting@redhat.com>
- - add some stuff to /etc/services
- - tweak ulimit call again
- * Tue Jun 6 2000 Bernhard Rosenkraenzer <bero@redhat.com>
- - homedir of ftp is now /var/ftp
- * Sun May 14 2000 Nalin Dahyabhai <nalin@redhat.com>
- - move profile.d logic in csh.login to csh.cshrc
- * Tue Apr 18 2000 Nalin Dahyabhai <nalin@redhat.com>
- - redirect ulimit -S -c to /dev/null to avoid clutter
- * Thu Apr 13 2000 Bernhard Rosenkraenzer <bero@redhat.com>
- - s/ulimit -c/ulimit -S -c/ - bash 2.x adaption
- * Mon Apr 03 2000 Nalin Dahyabhai <nalin@redhat.com>
- - Add more of the kerberos-related services from IANA's registry and krb5
- * Wed Mar 29 2000 Bernhard Rosenkraenzer <bero@redhat.com>
- - Add 2.4'ish vc/* devices to securetty
- * Thu Feb 17 2000 Preston Brown <pbrown@redhat.com>
- - add /etc/filesystems with sane defaults
- * Wed Feb 16 2000 Bill Nottingham <notting@redhat.com>
- - don't set prompt in /etc/profile (it's done in /etc/bashrc)
- * Fri Feb 5 2000 Bill Nottingham <notting@redhat.com>
- - yet more inputrc tweaks from Hans de Goede (hans@highrise.nl)
- * Sun Jan 30 2000 Bill Nottingham <notting@redhat.com>
- - yet more inputrc tweaks from Hans de Goede (hans@highrise.nl)
- * Sun Jan 23 2000 Bill Nottingham <notting@redhat.com>
- - fix mailq line. (#7140)
- * Fri Jan 21 2000 Bill Nottingham <notting@redhat.com>
- - add ldap to /etc/services
- * Tue Jan 18 2000 Bill Nottingham <notting@redhat.com>
- - kill HISTFILESIZE, it's broken
- * Tue Jan 18 2000 Preston Brown <pbrown@redhat.com>
- - some inputrc tweaks
- * Wed Jan 12 2000 Bill Nottingham <notting@redhat.com>
- - make some more stuff noreplace
- * Fri Nov 19 1999 Bill Nottingham <notting@redhat.com>
- - fix mailq line. (#7140)
- * Fri Oct 29 1999 Bill Nottingham <notting@redhat.com>
- - split csh.login into csh.login and csh.cshrc (#various)
- - fix pop service names (#6206)
- - fix ipv6 protocols entries (#6219)
- * Thu Sep 2 1999 Jeff Johnson <jbj@redhat.com>
- - rename /etc/csh.cshrc to /etc/csh.login (#2931).
- - (note: modified /etc/csh.cshrc should end up in /etc/csh.cshrc.rpmsave)
- * Fri Aug 20 1999 Jeff Johnson <jbj@redhat.com>
- - add defattr.
- - fix limit command in /etc/csh.cshrc (#4582).
- * Thu Jul 8 1999 Bill Nottingham <notting@redhat.com>
- - move /etc/inputrc here.
- * Mon Apr 19 1999 Bill Nottingham <notting@redhat.com>
- - always use /etc/inputrc
- * Wed Mar 31 1999 Preston Brown <pbrown@redhat.com>
- - added alias pointing to imap from imap2
- * Tue Mar 23 1999 Preston Brown <pbrown@redhat.com>
- - updated protocols/services from debian to comply with more modern
- - IETF/RFC standards
- * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
- - auto rebuild in the new build environment (release 4)
- * Thu Feb 18 1999 Jeff Johnson <jbj@redhat.com>
- - unset variables used in /etc/csh.cshrc (#1212)
- * Mon Jan 18 1999 Jeff Johnson <jbj@redhat.com>
- - compile for Raw Hide.
- * Tue Oct 13 1998 Cristian Gafton <gafton@redhat.com>
- - fix the csh.cshrc re: ${PATH} undefined
- * Mon Apr 27 1998 Prospector System <bugs@redhat.com>
- - translations modified for de, fr, tr
- * Fri Dec 05 1997 Erik Troan <ewt@redhat.com>
- - /etc/profile uses $i, which needs to be unset
- * Mon Nov 03 1997 Donnie Barnes <djb@redhat.com>
- - made /etc/passwd and /etc/group %config(noreplace)
- * Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
- - removed /etc/inetd.conf, /etc/rpc
- - flagged /etc/securetty as missingok
- - fixed buildroot stuff in spec file
- * Thu Jul 31 1997 Erik Troan <ewt@redhat.com>
- - made a noarch package
- * Wed Apr 16 1997 Erik Troan <ewt@redhat.com>
- - Don't verify md5sum, size, or timestamp of /var/log/lastlog, /etc/passwd,
- or /etc/group.
|