gdb-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443
  1. Summary: A GNU source-level debugger for C, C++ and other languages.
  2. Summary(ja): C, C++ その他の言語用 GNU ソースレベルデバッガ
  3. Name: gdb
  4. Version: 11.1
  5. Release: 1%{?_dist_release}
  6. Group: programming
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: GPL
  10. URL: https://www.gnu.org/software/gdb/
  11. Source: https://ftp.gnu.org/gnu/gdb/gdb-%{version}.tar.xz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: ncurses-devel glibc-devel gcc make gzip texinfo expat-devel
  14. BuildRequires: python3-devel python3-rpm-macros
  15. BuildRequires: gmp-devel
  16. BuildRequires: zlib-devel
  17. Requires: install-info
  18. %description
  19. GDB, the GNU debugger, allows you to debug programs written in C, C++,
  20. and other languages, by executing them in a controlled fashion and
  21. printing their data.
  22. %description -l ja
  23. GDB (GNU デバッガ) は C, C++ その他の言語で書かれたプログラムのデバッグに
  24. 使うツールです.プログラムの実行を制御し,データを出力することができます.
  25. %debug_package
  26. %prep
  27. %setup -q
  28. %build
  29. rm -fr dejagnu tcl expect
  30. mkdir -p build
  31. cd build
  32. %define _configure ../configure
  33. %configure \
  34. --with-python=%{__python3} \
  35. --disable-libctf \
  36. %{_target_platform}
  37. make %{?_smp_mflags}
  38. make %{?_smp_mflags} info
  39. %install
  40. rm -rf $RPM_BUILD_ROOT
  41. cd build
  42. %make_install
  43. # The above is broken, do this for now:
  44. #mkdir -p $RPM_BUILD_ROOT/%{_infodir}
  45. #cp `find -name "*.info*"` $RPM_BUILD_ROOT/%{_infodir}
  46. # These are part of binutils
  47. #rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  48. #rm -f $RPM_BUILD_ROOT%{_infodir}/dir.info*
  49. rm -f $RPM_BUILD_ROOT%{_infodir}/bfd*
  50. rm -f $RPM_BUILD_ROOT%{_infodir}/configure*
  51. rm -f $RPM_BUILD_ROOT%{_infodir}/standard*
  52. rm -r $RPM_BUILD_ROOT%{_libdir}/lib{bfd*,opcodes*}
  53. rm -f $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd.mo,opcodes.mo}
  54. rm -rf $RPM_BUILD_ROOT%{_includedir}
  55. %clean
  56. rm -rf $RPM_BUILD_ROOT
  57. %files
  58. %defattr(-,root,root)
  59. %license COPYING COPYING.LIB
  60. %doc README gdb/NEWS
  61. %{_bindir}/*
  62. %{_mandir}/*/*
  63. %dir %{_datadir}/gdb
  64. %{_datadir}/gdb/syscalls
  65. %dir %{_datadir}/gdb/python
  66. %{_datadir}/gdb/python/gdb
  67. %dir %{_datadir}/gdb/system-gdbinit
  68. %{_datadir}/gdb/system-gdbinit/elinos.py
  69. %{_datadir}/gdb/system-gdbinit/wrs-linux.py
  70. %{_infodir}/annotate.info*
  71. %{_infodir}/gdb.info*
  72. %{_infodir}/stabs.info*
  73. %exclude %{_infodir}/dir
  74. %ifarch %{ix86} x86_64
  75. %{_libdir}/libinproctrace.so
  76. %endif
  77. ## don't include the files in include, they are part of binutils
  78. #%{_includedir}/*
  79. #%{_infodir}/bfd.info*
  80. #%{_infodir}/configure.info*
  81. #%{_infodir}/standard.info*
  82. #%{_libdir}/*
  83. #%{_datadir}/locale/*/LC_MESSAGES/bfd.mo
  84. #%{_datadir}/locale/*/LC_MESSAGES/opcode.mo
  85. %changelog
  86. * Tue Sep 14 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 11.1-1
  87. - new upstream release.
  88. - dropped install-info scriptlets.
  89. * Thu Aug 05 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.2-2
  90. - rebuilt with gcc-11.2.
  91. * Fri May 07 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.2-1
  92. - new upstream release.
  93. * Wed Feb 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1-1
  94. - new upstream release.
  95. * Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.2-1
  96. - new upstream release.
  97. * Fri Mar 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.1-1
  98. - new upstream release.
  99. * Wed Jan 23 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.2.1-1
  100. - new upstream release.
  101. * Fri Jul 22 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.11.1-1
  102. - new upstream release
  103. * Sun Apr 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.11-1
  104. - new upstream release
  105. * Sun Oct 11 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.10-1
  106. - new upstream release
  107. * Mon Jul 06 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.9.1-1
  108. - new upstream release
  109. * Sun Feb 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.9-1
  110. - new upstream release
  111. * Sun Dec 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.8.1-1
  112. - new upstream release
  113. * Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.8-1
  114. - new upstream release
  115. * Sun Nov 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6.1-1
  116. - new upstream release
  117. * Mon Oct 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-1
  118. - new upstream release
  119. * Tue May 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.4.1-1
  120. - new upstream release
  121. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.4-1
  122. - new upstream release
  123. * Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.2-2
  124. - add BuildRequires: python-devel, zlib-devel
  125. - fix %%files
  126. * Thu Apr 28 2011 Shu KONNO <owa@bg.wakwak.com> 7.2-1
  127. - updated gdb to 7.2
  128. * Wed Feb 17 2010 Shu KONNO <owa@bg.wakwak.com> 7.0.1-1
  129. - updated gdb to 7.0.1
  130. - rebuilt with new environment
  131. * Sat Sep 13 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-1vl5
  132. - applied new versioning policy, spec in utf-8
  133. * Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.7.1-0vl4
  134. - rebuild with expat-2.0.1
  135. - add BuildRequires: expat-devel
  136. * Sun Jan 27 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl3
  137. - dropt %%{_localedir}/*/LC_MESSAGES/*.mo conflicts with binutils
  138. * Fri Jan 04 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl2
  139. - dropt %%{_libdir}/lib{bfd*,iberty*,opcodes*} conflicts with binutils-devel
  140. * Mon Dec 31 2007 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl1
  141. - new upstream release
  142. * Wed Jul 12 2006 Shu KONNO <owa@bg.wakwak.com> 6.4.90-0vl1
  143. - new upstream release
  144. * Sat Dec 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.0-0vl1
  145. - new upstream release
  146. * Thu Nov 28 2002 KAZUKI SHIMURA <rito@pos.to> 5.2.1-4vl2
  147. - Oops, spec was written in Shift-JIS. Fixed.
  148. * Mon Nov 11 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.2.1-4vl1
  149. - based on 5.2.1-4 from Rawhide and built for Vine Linux
  150. * Fri Aug 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
  151. - added mainframe patch from developerworks
  152. * Wed Aug 21 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-3
  153. - Add changelogs to the previous patch
  154. * Wed Aug 14 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-2
  155. - Add some patches from Elena Zannoni <ezannoni@redhat.com>
  156. * Tue Jul 23 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-1
  157. - 5.2.1
  158. * Mon Jul 22 2002 Florian La Roche <Florian.LaRoche@redhat.de>
  159. - compile on mainframe
  160. * Mon Jul 8 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-3
  161. - Rebuild
  162. * Tue May 7 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-2
  163. - Rebuild
  164. * Mon Apr 29 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-1
  165. - 5.2
  166. * Mon Apr 29 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.92-1
  167. - 5.1.92. Hopefully identical to 5.2 final
  168. * Mon Apr 22 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.91-1
  169. - 5.1.91. 5.2 expected in a week
  170. * Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-5
  171. - Update to current
  172. * Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-4
  173. - Update to current
  174. * Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-3
  175. - Update to current
  176. * Wed Mar 20 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-2
  177. - Update to current
  178. * Wed Mar 13 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-1
  179. - Update to current 5.2 branch
  180. * Thu Jan 24 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.1-1
  181. - 5.1.1
  182. - add URL
  183. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  184. - automated rebuild
  185. * Mon Dec 10 2001 Trond Eivind Glomsr <teg@redhat.com> 5.1-2
  186. - Fix some thread+fpu problems
  187. * Mon Nov 26 2001 Trond Eivind Glomsr <teg@redhat.com> 5.1-1
  188. - 5.1
  189. * Mon Nov 19 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.94-0.71
  190. - 5.0.94. Almost there....
  191. * Mon Nov 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.93-2
  192. - Add patch from jakub@redhat.com to improve handling of DWARF
  193. * Mon Nov 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.93-1
  194. - 5.0.93
  195. - handle missing info pages in post/pre scripts
  196. * Wed Oct 31 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.92-1
  197. - 5.0.92
  198. * Fri Oct 26 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.91rh-1
  199. - New snapshot
  200. - Use the 5.0.91 versioning from the snapshot
  201. * Wed Oct 17 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-17
  202. - New snapshot
  203. * Thu Sep 27 2001 Trond Eivind Glomsr <teg@redhat.com>
  204. - New snapshot
  205. * Wed Sep 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-16
  206. - New snapshot
  207. * Mon Aug 13 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-15
  208. - Don't buildrequire compat-glibc (#51690)
  209. * Thu Aug 9 2001 Trond Eivind Glomsr <teg@redhat.com>
  210. - New snapshot, from the stable branch eventually leading to gdb 5.1
  211. * Mon Jul 30 2001 Trond Eivind Glomsr <teg@redhat.com>
  212. - s/Copyright/License/
  213. - Add texinfo to BuildRequires
  214. * Mon Jun 25 2001 Trond Eivind Glomsr <teg@redhat.com>
  215. - New snapshot
  216. * Fri Jun 15 2001 Trond Eivind Glomsr <teg@redhat.com>
  217. - New snapshot
  218. - Add ncurses-devel to buildprereq
  219. - Remove perl from buildprereq, as gdb changed the way
  220. version strings are generated
  221. * Thu Jun 14 2001 Trond Eivind Glomsr <teg@redhat.com>
  222. - New snapshot
  223. * Wed May 16 2001 Trond Eivind Glomsr <teg@redhat.com>
  224. - New snapshot - this had thread fixes for curing #39070
  225. - New way of specifying version
  226. * Tue May 1 2001 Trond Eivind Glomsr <teg@redhat.com>
  227. - New tarball
  228. - Kevin's patch is now part of gdb
  229. * Mon Apr 9 2001 Trond Eivind Glomsr <teg@redhat.com>
  230. - Add patch from kevinb@redhat.com to fix floating point + thread
  231. problem (#24310)
  232. - remove old workarounds
  233. - new snapshot
  234. * Thu Apr 5 2001 Trond Eivind Glomsr <teg@redhat.com>
  235. - New snapshot
  236. * Sat Mar 17 2001 Bill Nottingham <notting@redhat.com>
  237. - on ia64, there are no old headers :)
  238. * Fri Mar 16 2001 Trond Eivind Glomsr <teg@redhat.com>
  239. - build with old headers, new compiler
  240. * Fri Mar 16 2001 Trond Eivind Glomsr <teg@redhat.com>
  241. - new snapshot
  242. * Mon Feb 26 2001 Trond Eivind Glomsr <teg@redhat.com>
  243. - new snapshot which should fix some more IA64 problems (#29151)
  244. - remove IA64 patch, it's now integrated
  245. * Wed Feb 21 2001 Trond Eivind Glomsr <teg@redhat.com>
  246. - add IA64 and Alpha patches from Kevin Buettner <kevinb@redhat.com>
  247. - use perl instead of patch for fixing the version string
  248. * Tue Feb 20 2001 Trond Eivind Glomsr <teg@redhat.com>
  249. - don't use kgcc anymore
  250. - mark it as our own version
  251. - new snapshot
  252. * Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  253. - Link with ncurses 5.x even though we're using kgcc.
  254. No need to drag in requirements on ncurses4 (Bug #24445)
  255. * Fri Jan 19 2001 Trond Eivind Glomsr <teg@redhat.com>
  256. - new snapshot
  257. * Wed Dec 20 2000 Trond Eivind Glomsr <teg@redhat.com>
  258. - new snapshot
  259. * Mon Dec 04 2000 Trond Eivind Glomsr <teg@redhat.com>
  260. - new snapshot
  261. - new alpha patch - it now compiles everywhere. Finally.
  262. * Fri Dec 01 2000 Trond Eivind Glomsr <teg@redhat.com>
  263. - new snapshot
  264. * Mon Nov 20 2000 Trond Eivind Glomsr <teg@redhat.com>
  265. - new CVS snapshot
  266. - disable the patches
  267. - don't use %%configure, as it confuses the autoconf script
  268. - enable SPARC, disable Alpha
  269. * Wed Aug 09 2000 Trond Eivind Glomsr <teg@redhat.com>
  270. - added patch from GDB team for C++ symbol handling
  271. * Tue Jul 25 2000 Trond Eivind Glomsr <teg@redhat.com>
  272. - upgrade to CVS snapshot
  273. - excludearch SPARC, build on IA61
  274. * Wed Jul 19 2000 Trond Eivind Glomsr <teg@redhat.com>
  275. - rebuild
  276. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  277. - automatic rebuild
  278. * Sun Jul 02 2000 Trond Eivind Glomsr <teg@redhat.com>
  279. - rebuild
  280. * Thu Jun 08 2000 Trond Eivind Glomsr <teg@redhat.com>
  281. - use %%configure, %%makeinstall, %%{_infodir}, %%{_mandir},
  282. and %%{_tmppath}
  283. - the install scripts for info are broken(they don't care about
  284. you specify in the installstep), work around that.
  285. - don't build for IA64
  286. * Mon May 22 2000 Trond Eivind Glomsr <teg@redhat.com>
  287. - upgraded to 5.0 - dump all patches. Reapply later if needed.
  288. - added the NEWS file to the %%doc files
  289. - don't delete files which doesn't get installed (readline, texinfo)
  290. - let build system handle stripping and gzipping
  291. - don't delete libmmalloc
  292. - apply patch from jakub@redhat.com to make it build on SPARC
  293. * Fri Apr 28 2000 Matt Wilson <msw@redhat.com>
  294. - rebuilt against new ncurses
  295. * Tue Mar 7 2000 Jeff Johnson <jbj@redhat.com>
  296. - rebuild for sparc baud rates > 38400.
  297. * Tue Feb 8 2000 Jakub Jelinek <jakub@redhat.com>
  298. - fix core file handling on i386 with glibc 2.1.3 headers
  299. * Fri Jan 14 2000 Jakub Jelinek <jakub@redhat.com>
  300. - fix reading registers from core on sparc.
  301. - hack around build problems on i386 with glibc 2.1.3 headers
  302. * Thu Oct 7 1999 Jim Kingdon
  303. - List files to install in /usr/info specifically (so we don't pick up
  304. things like info.info from GDB snapshots).
  305. * Thu Oct 7 1999 Jim Kingdon
  306. - Update GDB to 19991004 snapshot. This eliminates the need for the
  307. sigtramp, sparc, xref, and threads patches. Update sparcmin patch.
  308. * Mon Aug 23 1999 Jim Kingdon
  309. - Omit readline manpage.
  310. * Sat Aug 7 1999 Jim Kingdon
  311. - Remove H.J. Lu's patches (they had been commented out).
  312. - Add sigtramp patch (from gdb.cygnus.com) and threads patch (adapted
  313. from code fusion CD-ROM).
  314. * Wed Apr 14 1999 Jeff Johnson <jbj@redhat.com>
  315. - merge H.J. Lu's patches into 4.18.
  316. * Mon Apr 05 1999 Cristian Gafton <gafton@redhat.com>
  317. - updated the kern22 patch with stuff from davem
  318. * Thu Apr 1 1999 Jeff Johnson <jbj@redhat.com>
  319. - sparc with 2.2 kernels no longer uses sunos ptrace (davem)
  320. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  321. - auto rebuild in the new build environment (release 3)
  322. * Mon Mar 8 1999 Jeff Johnson <jbj@redhat.com>
  323. - Sparc fiddles for Red Hat 6.0.