file-roller-vl.spec 9.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307
  1. %define glib2_version 2.28.6
  2. %define gtk2_version 2.24.4
  3. %define gconf2_version 2.32.1
  4. %define nautilus_version 2.32.1
  5. %define desktop_file_utils_version 0.16
  6. %define gnome_doc_utils_version 0.3.2
  7. Summary: File Roller is a tool for viewing and creating archives.
  8. Summary(ja): File Roller - アーカイブの表示・作成ツール
  9. Name: file-roller
  10. Version: 2.32.2
  11. Release: 2%{?_dist_release}
  12. License: GPL
  13. Group: Applications/Archiving
  14. Source0: http://ftp.gnome.org/pub/GNOME/sources/file-roller/2.32/%{name}-%{version}.tar.bz2
  15. Source1: file-roller.help.Makefile.am
  16. Source2: file-roller.help.gnome-2-30.ja.po
  17. Source3: file-roller-ja-figures.tar.bz2
  18. Source4: file-roller-2.32.2-ja.po
  19. # i18n fix for ui strings
  20. # refer https://bugzilla.gnome.org/show_bug.cgi?id=649159
  21. # and also http://git.gnome.org/browse/file-roller/commit/src/ui.h?id=c5f7cb8dab9740ff10b46c2dc9a2d2970b2f7cfe
  22. Patch1: file-roller-2.32.2-i18n-fix.patch
  23. URL: http://ftp.gnome.org/pub/gnome/sources/file-roller/
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  25. Requires(post,postun): scrollkeeper >= 0.3.11
  26. Requires(post,postun): desktop-file-utils >= %{desktop_file_utils_version}
  27. Requires(post,pre,preun): GConf2
  28. BuildRequires: glib2-devel >= %{glib2_version}
  29. BuildRequires: gtk2-devel >= %{gtk2_version}
  30. BuildRequires: GConf2-devel >= %{gconf2_version}
  31. BuildRequires: nautilus >= %{nautilus_version}
  32. BuildRequires: nautilus-devel >= %{nautilus_version}
  33. BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
  34. BuildRequires: gnome-doc-utils >= %{gnome_doc_utils_version}
  35. BuildRequires: libSM-devel
  36. BuildRequires: docbook-dtds
  37. %description
  38. File Roller is an application for creating and viewing archives files,
  39. such as tar files.
  40. %description -l ja
  41. File Roller は tar ファイルのようなアーカイブの表示や作成をするための
  42. アプリケーションです。
  43. %prep
  44. %setup -q
  45. %patch1 -p1 -b .i18n-fix
  46. ## # add Japanese help
  47. ## cp -f %{SOURCE1} help/Makefile.am
  48. ## mkdir help/ja
  49. ## cp -f %{SOURCE2} help/ja/ja.po
  50. ## (cd help/ja && tar jxf %{SOURCE3})
  51. # update Japanese interface
  52. cp -f %{SOURCE4} po/ja.po
  53. # regenerate to fix path
  54. rm -f src/fr-enum-types.c
  55. %build
  56. %configure --disable-scrollkeeper
  57. export tagname=CC
  58. make %{?_smp_mflags} LIBTOOL=/usr/bin/libtool
  59. %install
  60. rm -rf $RPM_BUILD_ROOT
  61. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  62. export tagname=CC
  63. make install DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool
  64. unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
  65. # temporary hack to add missing semicolon, fix sent upstream
  66. #perl -pi -e 's/Categories=Application;Utility$/Categories=Application;Utility;/' $RPM_BUILD_ROOT%{_datadir}/applications/*
  67. desktop-file-install --vendor gnome --delete-original \
  68. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  69. --add-only-show-in GNOME \
  70. $RPM_BUILD_ROOT%{_datadir}/applications/*
  71. rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
  72. rm -f $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-2.0/lib*.*a
  73. rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
  74. %find_lang %{name} --all-name --with-gnome
  75. %clean
  76. rm -rf $RPM_BUILD_ROOT
  77. %post
  78. update-desktop-database %{_datadir}/applications >& /dev/null ||:
  79. scrollkeeper-update > /dev/null 2>&1 || :
  80. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  81. gconftool-2 --makefile-install-rule \
  82. %{_sysconfdir}/gconf/schemas/file-roller.schemas > /dev/null
  83. touch --no-create %{_datadir}/icons/hicolor
  84. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  85. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
  86. fi
  87. %pre
  88. if [ "$1" -gt 1 ]; then
  89. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  90. gconftool-2 --makefile-uninstall-rule \
  91. %{_sysconfdir}/gconf/schemas/file-roller.schemas > /dev/null
  92. fi
  93. %preun
  94. if [ "$1" -eq 0 ]; then
  95. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  96. gconftool-2 --makefile-uninstall-rule \
  97. %{_sysconfdir}/gconf/schemas/file-roller.schemas > /dev/null
  98. fi
  99. %postun
  100. update-desktop-database %{_datadir}/applications >& /dev/null ||:
  101. scrollkeeper-update > /dev/null 2>&1 || :
  102. touch --no-create %{_datadir}/icons/hicolor
  103. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  104. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
  105. fi
  106. %files -f %{name}.lang
  107. %defattr(-, root, root)
  108. %doc README COPYING ChangeLog NEWS AUTHORS
  109. %{_sysconfdir}/gconf/schemas/*.schemas
  110. %{_bindir}/*
  111. %{_datadir}/applications/*
  112. %{_datadir}/file-roller
  113. %{_datadir}/icons/hicolor/*
  114. %{_libexecdir}/file-roller
  115. %{_libdir}/nautilus/extensions-2.0/libnautilus-fileroller.so
  116. %changelog
  117. * Fri Jul 15 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 2.32.2-2
  118. - add Patch1 to fix non-translatable string
  119. - update Source4: file-roller-2-32.2-ja.po
  120. * Thu May 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
  121. - new upstream release
  122. * Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
  123. - new upstream release
  124. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
  125. - new upstream release
  126. - remove Patch
  127. - drop Source1, Source2, Source3
  128. * Mon Aug 23 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.30.2-3
  129. - add Source1-4
  130. * Sat Aug 21 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.30.2-2
  131. - add patch from https://bugzilla.gnome.org/show_bug.cgi?id=627387
  132. * Tue Jun 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
  133. - new upstream release
  134. - add BuildRequires: docbook-dtds
  135. * Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
  136. - new upstream release
  137. * Sun Apr 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  138. - new upstream release
  139. * Sat Mar 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
  140. - new upstream release
  141. - add BuildRequires: nautilus-devel, gnome-doc-utils, libSM-devel
  142. * Sun Nov 1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
  143. - new upstream release
  144. * Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
  145. - new upstream release
  146. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
  147. - new upstream release
  148. * Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
  149. - new upstream release
  150. * Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
  151. - new upstream release
  152. - remove BR: libgnomeprint-devel, libgnomeprintui-devel
  153. * Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.3-1
  154. - new upstream release
  155. * Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
  156. - new upstream release
  157. * Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
  158. - new upstream release
  159. * Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
  160. - new upstream release
  161. * Sun Apr 6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
  162. - new upstream release
  163. * Sun Dec 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
  164. - new upstream release
  165. * Sun Aug 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.4-0vl1
  166. - new upstream release
  167. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
  168. - new upstream release
  169. * Sat Jun 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl1
  170. - new upstream release
  171. * Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
  172. - new upstream release
  173. * Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
  174. - new upstream release
  175. * Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl1
  176. - new upstream release
  177. * Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
  178. - new upstream release
  179. * Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
  180. - new upstream release
  181. * Tue Mar 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
  182. - new upstream version
  183. * Sun Feb 27 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.4-0vl1
  184. - new upsteram release
  185. * Thu Nov 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-0vl1
  186. - new upsteram release
  187. * Sun Jul 11 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.4.4-0vl3
  188. - fix typo
  189. * Sun Feb 15 2004 Tomoya TAKA <taka@vinelinux.org> 2.4.4-0vl2
  190. - add Patch0 to fix segfaults on 64-bit architectures.
  191. * Sat Jan 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4-0vl1
  192. - new upstream release
  193. * Wed Dec 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
  194. - rebuild with new toolchain
  195. * Tue Dec 09 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
  196. - new upstream release
  197. * Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
  198. - new upstream release
  199. * Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.6-0vl1
  200. - new upstream release
  201. * Tue Jun 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl1
  202. - revert version to 2.2.4
  203. * Tue Jun 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl2
  204. - rebuilt
  205. * Wed Jun 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl2
  206. - new upstream release
  207. * Thu Jan 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
  208. - new upstream release
  209. * Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
  210. - new upstream release
  211. * Fri Jan 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
  212. - new upstream release
  213. * Thu Jan 9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
  214. - new upstream release
  215. * Mon Dec 9 2002 Alexander Larsson <alexl@redhat.com> 2.1.3-3
  216. - fix server file path
  217. * Mon Dec 9 2002 Alexander Larsson <alexl@redhat.com> 2.1.3-2
  218. - Remove unpackaged files
  219. * Mon Dec 9 2002 Alexander Larsson <alexl@redhat.com> 2.1.3-1
  220. - Update to 2.1.3
  221. * Fri Dec 6 2002 Havoc Pennington <hp@redhat.com>
  222. - 2.1.2
  223. - fix unpackaged files
  224. * Wed Jul 31 2002 Havoc Pennington <hp@redhat.com>
  225. - fix URL field
  226. - put icon in file list
  227. - 2.0.0 stable release
  228. * Fri Jun 21 2002 Havoc Pennington <hp@redhat.com>
  229. - initial build