123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187 |
- %bcond_with test
- Summary: Lossless compression algorithm
- Summary(ja): ロスレス圧縮アルゴリズム
- Name: brotli
- Version: 1.0.9
- Release: 2%{?_dist_release}
- Group: system
- Vendor: Project Vine
- Distribution: Vine Linux
- License: MIT
- URL: https://github.com/google/brotli
- Source0: https://github.com/google/brotli/archive/v%{version}.tar.gz
- # fix *.pc
- Patch0: 09b0992b6acb7faa6fd3b23f9bc036ea117230fc.patch
- BuildRequires: cmake
- BuildRequires: python3-devel python-rpm-macros python3-rpm-macros
- %description
- Brotli is a generic-purpose lossless compression algorithm that compresses
- data using a combination of a modern variant of the LZ77 algorithm, Huffman
- coding and 2nd order context modeling, with a compression ratio comparable
- to the best currently available general-purpose compression methods.
- It is similar in speed with deflate but offers more dense compression.
- %package -n python3-%{name}
- Summary: Lossless compression algorithm (python 3)
- Group: programming
- %{?python_provide:%python_provide python3-%{name}}
- Requires: python3
- %description -n python3-%{name}
- Brotli is a generic-purpose lossless compression algorithm that compresses
- data using a combination of a modern variant of the LZ77 algorithm, Huffman
- coding and 2nd order context modeling, with a compression ratio comparable
- to the best currently available general-purpose compression methods.
- It is similar in speed with deflate but offers more dense compression.
- This package installs a Python 3 module.
- %package -n %{name}-devel
- Summary: Lossless compression algorithm (development files)
- Group: programming
- Requires: %{name}%{?_isa} = %{version}-%{release}
- %description -n %{name}-devel
- Brotli is a generic-purpose lossless compression algorithm that compresses
- data using a combination of a modern variant of the LZ77 algorithm, Huffman
- coding and 2nd order context modeling, with a compression ratio comparable
- to the best currently available general-purpose compression methods.
- It is similar in speed with deflate but offers more dense compression.
- This package installs the development files
- %debug_package
- %prep
- %autosetup -p1
- # fix permissions for -debuginfo
- # rpmlint will complain if I create an extra %%files section for
- # -debuginfo for this so we'll put it here instead
- %{__chmod} 644 c/enc/*.[ch]
- %{__chmod} 644 c/include/brotli/*.h
- %{__chmod} 644 c/tools/brotli.c
- %build
- %cmake \
- -DCMAKE_INSTALL_PREFIX="%{_prefix}" \
- -DCMAKE_INSTALL_LIBDIR="%{_libdir}"
- %cmake_build
- %py3_build
- %install
- %cmake_install
- # I couldn't find the option to not build the static libraries
- %__rm "%{buildroot}%{_libdir}/"*.a
- %py3_install
- %{__install} -dm755 "%{buildroot}%{_mandir}/man3"
- cd docs
- for i in *.3;do
- %{__install} -m644 "$i" "%{buildroot}%{_mandir}/man3/${i}brotli"
- done
- %if %{with test}
- %check
- %ctest
- %{__python3} setup.py test
- %endif
- %files
- %license LICENSE
- %{_bindir}/brotli
- %{_libdir}/*.so.*
- # Note that there is no %%files section for the unversioned python module
- # if we are building for several python runtimes
- %files -n python3-%{name}
- %license LICENSE
- %{python3_sitearch}/*
- %files -n %{name}-devel
- %{_includedir}/*
- %{_libdir}/*.so
- %{_libdir}/pkgconfig/*
- %{_mandir}/man3/*
- %changelog
- * Fri Apr 02 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.9-2
- - imported Patch0 from upstream to fix *.pc.
- - dropped ldconfig scriptlets.
- * Tue Sep 22 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.9-1
- - nre upstream release.
- * Mon Aug 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.7-5
- - rebuilt with python-3.8.
- * Tue Aug 04 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.0.7-4
- - rebuilt with current environment.
- * Thu Jan 03 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.0.7-3
- - initial build for Vine Linux.
- * Sun Dec 09 2018 Miro Hrončok <mhroncok@redhat.com> - 1.0.7-2
- - Remove last python2 bits
- * Wed Nov 28 2018 Travis Kendrick pouar@pouar.net> - 1.0.7-1
- - Update to 1.0.7
- * Wed Nov 28 2018 Travis Kendrick pouar@pouar.net> - 1.0.5-2
- - remove Python 2 support https://fedoraproject.org/wiki/Changes/Mass_Python_2_Package_Removal
- * Fri Jul 13 2018 Travis Kendrick pouar@pouar.net> - 1.0.5-1
- - update to 1.0.5
- * Thu Jul 12 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.4-4
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
- * Mon Jun 18 2018 Miro Hrončok <mhroncok@redhat.com> - 1.0.4-3
- - Rebuilt for Python 3.7
- * Wed Apr 18 2018 Travis Kendrick pouar@pouar.net> - 1.0.4-2
- - update to 1.0.4
- * Sat Mar 03 2018 Travis Kendrick <pouar@pouar.net> - 1.0.3-1
- - update to 1.0.3
- * Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.1-3
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
- * Sat Feb 03 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.0.1-2
- - Switch to %%ldconfig_scriptlets
- * Fri Sep 22 2017 Travis Kendrick <pouar@pouar.net> - 1.0.1-1
- - update to 1.0.1
- * Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.0-6
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
- * Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.0-5
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
- * Tue May 23 2017 Travis Kendrick <pouar@pouar.net> - 0.6.0-4
- - add man pages
- * Sun May 14 2017 Travis Kendrick <pouar@pouar.net> - 0.6.0-3
- - wrong directory for ctest
- - LICENSE not needed in -devel
- - fix "spurious-executable-perm"
- - rpmbuild does the cleaning for us, so 'rm -rf %%{buildroot}' isn't needed
- * Sat May 13 2017 Travis Kendrick <pouar@pouar.net> - 0.6.0-2
- - include libraries and development files
- * Sat May 06 2017 Travis Kendrick <pouar@pouar.net> - 0.6.0-1
- - Initial build
|