totem-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571
  1. # define versions
  2. %define _glib_ver 2.44.0
  3. %define _gtk_ver 3.16.0
  4. %define _gnomeicon_ver 3.12.0
  5. %define _gnome_doc_utils_ver 0.20.0
  6. %define _dbus_ver 1.6.0
  7. %define _gst_ver 1.2.0
  8. %define _gstpb_ver 1.2.0
  9. %define _gstpg_ver 1.2.0
  10. %define _gstpbad_ver 1.2.0
  11. %define _xulrunner_ver 1.9
  12. %define _nautilus_ver 3.16.0
  13. %define _shared_mime_info_ver 0.17
  14. %define _unique_ver 1.0
  15. %define _totem_pl_parser_ver 3.4.4
  16. %define nautilus_extdir %{_libdir}/nautilus/extensions-3.0
  17. Summary: Movie player for GNOME 3
  18. Summary(ja): GNOME3 用動画プレイヤー
  19. Name: totem
  20. Version: 3.16.1
  21. Release: 1%{?_dist_release}
  22. License: GPL
  23. Group: Applications/Multimedia
  24. URL: http://www.gnome.org/projects/totem/
  25. Source0: http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.16/%{name}-%{version}.tar.xz
  26. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  27. Vendor: Project Vine
  28. Distribution: Vine Linux
  29. Packager: Takemikaduchi
  30. BuildRequires: gtk3-devel >= %{_gtk_ver}, glib2-devel >= %{_glib_ver}
  31. BuildRequires: gnome-icon-theme >= %{_gnomeicon_ver}
  32. BuildRequires: dbus-devel >= %{_dbus_ver}
  33. BuildRequires: nautilus-devel >= %{_nautilus_ver}
  34. BuildRequires: gnome-desktop3-devel
  35. BuildRequires: gettext
  36. BuildRequires: perl-XML-Parser
  37. BuildRequires: iso-codes
  38. BuildRequires: yelp-tools
  39. BuildRequires: totem-pl-parser-devel >= %{_totem_pl_parser_ver}
  40. BuildRequires: grilo-devel
  41. BuildRequires: bluez-libs-devel >= 4.15
  42. BuildRequires: lirc
  43. BuildRequires: unique-devel >= %{_unique_ver}
  44. BuildRequires: python-devel
  45. BuildRequires: pylint
  46. BuildRequires: pygobject3-devel
  47. BuildRequires: libpeas-devel
  48. BuildRequires: libXtst-devel
  49. BuildRequires: gsettings-desktop-schemas-devel
  50. BuildRequires: gnome-doc-utils >= %{_gnome_doc_utils_ver}
  51. BuildRequires: vala
  52. BuildRequires: gstreamer1-devel >= %{_gst_ver}
  53. BuildRequires: gstreamer1-plugins-base-devel >= %{_gstpb_ver}
  54. BuildRequires: gstreamer1-plugins-good >= %{_gstpg_ver}
  55. BuildRequires: gstreamer1-plugins-bad-free-devel >= %{_gstpbad_ver}
  56. BuildRequires: clutter-gtk-devel
  57. BuildRequires: clutter-gst3-devel
  58. BuildRequires: nautilus-devel >= %{_nautilus_ver}
  59. BuildRequires: shared-mime-info >= %{_shared_mime_info_ver}
  60. Requires: gstreamer1 >= %{_gst_ver}
  61. Requires: gstreamer1-plugins-base >= %{_gstpb_ver}
  62. Requires: gstreamer1-plugins-good >= %{_gstpg_ver}
  63. Requires: gstreamer1-plugins-bad-free >= %{_gstpbad_ver}
  64. Requires: iso-codes
  65. Obsoletes: nautilus-media
  66. Obsoletes: %{name}-gstreamer < 2.30.1-2
  67. Obsoletes: %{name}-xine < 2.30.1-2
  68. Obsoletes: %{name}-common < 2.30.1-3
  69. Obsoletes: %{name}-mozilla < 3.14.0
  70. Provides: nautilus-media
  71. Provides: %{name}-common = %{version}-%{release}
  72. Requires(post): ldconfig, desktop-file-utils
  73. Requires(postun): ldconfig, desktop-file-utils
  74. %description
  75. Totem is simple movie player for the Gnome desktop. It features a
  76. simple playlist, a full-screen mode, seek and volume controls, as well as
  77. a pretty complete keyboard navigation.
  78. %package devel
  79. Summary: Plugin writer's documentation for totem
  80. Group: Development/Libraries
  81. Requires: %{name} = %{version}-%{release}
  82. %description devel
  83. The %{name}-devel package contains API documentation for
  84. developing developing plugins for %{name}.
  85. %prep
  86. %setup -q
  87. %build
  88. #DBUS_FATAL_WARNINGS=0 /usr/bin/gst-inspect-1.0 --print-all > /dev/null
  89. #export MOZILLA_PLUGINDIR=%{mozplug_dir}
  90. %configure \
  91. --enable-python \
  92. --enable-vala \
  93. --enable-nautilus
  94. make %{?_smp_mflags}
  95. %install
  96. rm -rf $RPM_BUILD_ROOT
  97. make install DESTDIR=$RPM_BUILD_ROOT
  98. # remove unneeded files
  99. %__rm -f %{buildroot}%{_libdir}/totem/plugins/*/*.{a,la}
  100. %__rm -f %{buildroot}%{_libdir}/*.{a,la}
  101. %__rm -f %{buildroot}%{_datadir}/pixmaps/vanity.png
  102. %__rm -f %{buildroot}%{nautilus_extdir}/*.{a,la}
  103. %__rm -f %{buildroot}%{mozplug_dir}/*.{a,la}
  104. %__rm -f %{buildroot}%{_datadir}/icons/hicolor/icon-theme.cache
  105. %__rm -rf %{buildroot}%{_libdir}/totem/plugins/bemused/
  106. # remove unused file
  107. %__rm -f %{buildroot}%{_datadir}/GConf/gsettings/pythonconsole.convert
  108. %__rm -f %{buildroot}%{_libexecdir}/%{name}/totem-bugreport.py
  109. %find_lang %{name} --with-gnome
  110. # save space by linking identical images in translated docs
  111. helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
  112. for f in $helpdir/C/figures/*.png; do
  113. b="$(basename $f)"
  114. for d in $helpdir/*; do
  115. if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
  116. g="$d/figures/$b"
  117. if [ -f "$g" ]; then
  118. if cmp -s $f $g; then
  119. rm "$g"; ln -s "../../C/figures/$b" "$g"
  120. fi
  121. fi
  122. fi
  123. done
  124. done
  125. %clean
  126. %__rm -rf %{buildroot}
  127. %post
  128. %{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
  129. touch %{_datadir}/icons/hicolor
  130. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  131. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  132. fi
  133. %postun
  134. %{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
  135. touch %{_datadir}/icons/hicolor
  136. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  137. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  138. fi
  139. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  140. %posttrans
  141. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  142. %files -f %{name}.lang
  143. %defattr(-,root,root,-)
  144. %doc AUTHORS COPYING ChangeLog NEWS README TODO
  145. %{_bindir}/totem
  146. %{_bindir}/totem-audio-preview
  147. %{_bindir}/totem-video-thumbnailer
  148. %{_datadir}/GConf/gsettings/opensubtitles.convert
  149. #%{_datadir}/GConf/gsettings/pythonconsole.convert
  150. %{_datadir}/GConf/gsettings/totem.convert
  151. %{_datadir}/appdata/org.gnome.Totem.appdata.xml
  152. %{_datadir}/applications/org.gnome.Totem.desktop
  153. %{_datadir}/dbus-1/services/org.gnome.Totem.service
  154. %{_datadir}/glib-2.0/schemas/*.xml
  155. %{_datadir}/icons/*/*/*/*
  156. %{_datadir}/thumbnailers/totem.thumbnailer
  157. %{_datadir}/%{name}
  158. %{_datadir}/gtk-doc/html/totem
  159. %{_libdir}/libtotem.so.*
  160. %{_libdir}/girepository-1.0/*.typelib
  161. %dir %{_libdir}/totem
  162. %dir %{_libdir}/totem/plugins
  163. %{_libdir}/totem/plugins/apple-trailers/
  164. %{_libdir}/totem/plugins/autoload-subtitles
  165. %{_libdir}/totem/plugins/brasero-disc-recorder
  166. %{_libdir}/totem/plugins/dbus
  167. %{_libdir}/totem/plugins/gromit
  168. %{_libdir}/totem/plugins/im-status/libtotem-im-status.so
  169. %{_libdir}/totem/plugins/im-status/totem-im-status.plugin
  170. %{_libdir}/totem/plugins/lirc
  171. %{_libdir}/totem/plugins/media-player-keys
  172. %{_libdir}/totem/plugins/ontop
  173. %{_libdir}/totem/plugins/opensubtitles
  174. %{_libdir}/totem/plugins/properties
  175. %{_libdir}/totem/plugins/pythonconsole
  176. %{_libdir}/totem/plugins/recent
  177. %{_libdir}/totem/plugins/rotation
  178. %{_libdir}/totem/plugins/screensaver
  179. %{_libdir}/totem/plugins/screenshot
  180. %{_libdir}/totem/plugins/skipto
  181. %{_libdir}/totem/plugins/save-file/libsave-file.so
  182. %{_libdir}/totem/plugins/save-file/save-file.plugin
  183. %{_libdir}/totem/plugins/vimeo
  184. %{_libdir}/nautilus/extensions-3.0/*.so*
  185. %{_mandir}/man1/*
  186. %files devel
  187. %defattr(-, root, root,-)
  188. %{_includedir}/totem
  189. %{_libdir}/libtotem.so
  190. %{_libdir}/pkgconfig/totem.pc
  191. %{_datadir}/gir-1.0/Totem-1.0.gir
  192. %{_datadir}/gtk-doc/html/totem
  193. %changelog
  194. * Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
  195. - new upstream release
  196. * Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
  197. - new upstream release
  198. - change BuildRequires: clutter-gst3-devel instead of clutter-gst-devel
  199. * Sun Feb 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
  200. - new upstream release
  201. * Tue Nov 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1-1
  202. - new upstream release
  203. * Tue Oct 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.0-1
  204. - new upstream release
  205. - add BuildRequires: gnome-desktop3-devel
  206. - remove BuildRequires: xulrunner-devel
  207. - remove %%{name}-mozilla subpackage
  208. * Thu Aug 21 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
  209. - new upstream release
  210. * Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
  211. - new upstream release
  212. * Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
  213. - new upstream release
  214. * Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-2
  215. - rebuild with VineSeed environment
  216. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
  217. - new upstream release
  218. * Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
  219. - new upstream release
  220. * Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.0-1
  221. - new upstream release
  222. - add BuildRequires: yelp-tools, vala
  223. - change configure option (--enable-vala)
  224. * Thu Nov 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
  225. - new upstream release
  226. * Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
  227. - new upstream release
  228. - change BuildRequires: gstreamer1-plugins-bad-free-devel instead of gstreamer1-plugins-bad-free
  229. * Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
  230. - new upstream release
  231. - add BuildRequires: gsettings-desktop-schemas-devel, gstreamer1-plugins-bad-free, grilo-devel
  232. * Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
  233. - new upstream release
  234. * Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
  235. - add configure option (--disable-vegas-plugin)
  236. * Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
  237. - new upstream release
  238. * Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
  239. - new upstream release
  240. - add BuildRequires: pylint
  241. - remove BuildRequires: libgdata-devel
  242. * Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
  243. - new upstream release
  244. * Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
  245. - new upstream release
  246. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
  247. - new upstream release
  248. - change BuildRequires: pygobject3-devel instead of pygobject-devel
  249. * Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
  250. - new upstream release
  251. - change BuildRequires: gtk3-devel instead of gtk2-devel
  252. - add BuildRequires: libpeas-devel, libXtst-devel, pygobject-devel, clutter-gtk-devel,
  253. clutter-gst-devel, libmx-devel
  254. - change configure option (--disable-vala)
  255. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
  256. - new upstream release
  257. - fix %files
  258. * Tue Jun 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
  259. - new upstream release
  260. * Mon May 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-3
  261. - clean up spec file
  262. - remove totem-common and merged to totem main package.
  263. - add Obsoletes: totem-common
  264. - remove unneeded BR: and R:
  265. - gnome-vfs2, libgnomeui, libgnome, gnome-desktop-libs
  266. - libmusicbrainz, alternatives
  267. - remove explicit dependency
  268. - gtk2, glib2, dbus
  269. - add R: pygtk2, pyxdg, python-Coherence for python plugins
  270. - add R: gstreamer-plugins-good
  271. * Sun May 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
  272. - rebuild with libgdata (add youtube plugin)
  273. - add BuildRequires: libgdata-devel, python-devel, pygtk2-devel
  274. - add Obsolete: totem-gstreamer, totem-xine)
  275. * Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
  276. - new upstream release
  277. - chagnge _gst_ver from 0.10.19 to 0.10.29
  278. * Wed Apr 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  279. - new upstream release
  280. - drop totem-tracker package
  281. - add BuildRequires: unique-devel
  282. - remove BuildRequires: hal-devel
  283. - remove unrecognized options (--disable-lirc, --disable-vanity, --disable-nvtv, --enable-xine, --disable-xine, --enable-gstreamer, --disable-gstreamer, --enable-mozilla, --with-mozilla, --disable-mozilla, --enable-basic-plugin, --enable-complex-plugin)
  284. * Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-2
  285. - remove unneeded autoreconf
  286. - add BR: lirc
  287. * Thu Jul 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
  288. - new upstream release
  289. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
  290. - remove bemused plugin
  291. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
  292. - new upstream release
  293. * Thu Apr 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.1-2
  294. - added tracker video search sub-package
  295. * Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
  296. - new upstream release
  297. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
  298. - new upstream release
  299. * Fri Mar 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.3-2
  300. - remove libxine dependency from totem-common
  301. - build xine backend with minimum dependency
  302. * Thu Oct 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-3
  303. - add BR: bluez-libs-devel >= 4.15
  304. - fix typo in %%postun xine
  305. * Thu Oct 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.24.2-2
  306. - rebuild with bluez-libs-devel-4.15
  307. * Sat Oct 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-1
  308. - new upstream release
  309. * Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
  310. - new upstream release
  311. * Mon Jul 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
  312. - new upstream release
  313. - add patch1 to build with xulrunner-1.9
  314. * Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
  315. - new upstream release
  316. * Mon Apr 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
  317. - new upstream release
  318. - disabled devel package (replaced by totem-pl-parser-devel)
  319. * Sat Aug 11 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 2.18.2-0vl1
  320. - new upstream release
  321. - update version macros
  322. - enable browser plugins on x86_64
  323. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
  324. - new upstream release
  325. * Sun Mar 25 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.6-0vl1
  326. - upstream release
  327. - drop obsolete ja.po.patch (patch0)
  328. - revert change of 1.4.4-0vl2
  329. * Wed Jan 31 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.5-0vl1
  330. - upstream release
  331. - enable browser plugins (exclude x86_64 arch)
  332. * Fri Dec 01 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.4-0vl1
  333. - upstream release
  334. * Mon Nov 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl3
  335. - update configure options
  336. - add -mozilla-{gstreamer,xine,common} sub-packages (disabled by default)
  337. * Sat Nov 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl2
  338. - fix mistranslation (patch0)
  339. - add icon symlink
  340. - add BuildRequires: gstreamer-plugins-good
  341. * Fri Nov 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl1
  342. - upstream release
  343. - update %%_glib_ver, %%_xine_ver
  344. - add BuildRequires: hal
  345. - update %%configure options
  346. - update %%files
  347. * Wed Sep 13 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
  348. - upstream release
  349. * Fri Sep 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl2
  350. - fix macro name (%%gnome_desktop_ver -> %%gnomedesktop_ver)
  351. * Mon Aug 07 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl1
  352. - upstream release
  353. - drop obsolete patch0
  354. * Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.3-0vl1
  355. - upstream release
  356. - add patch0 to build with intltool-0.35
  357. * Sun Jun 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.2-0vl1
  358. - upstream release
  359. * Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-0vl1
  360. - upstream release
  361. - update alternatives entry
  362. * Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.0-0vl1
  363. - upstream release
  364. - drop fix-sort-function.patch (was merged to upstream, #331426)
  365. * Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.91-0vl2
  366. - rebuild with gnome-2.14rc
  367. * Tue Feb 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.91-0vl1
  368. - upstream release
  369. - add macros
  370. - _gtk_ver, _glib_ver
  371. - _gnomevfs_ver, _gnomeui_ver, _gnomeicon_ver, _gnome_desktop_ver
  372. - _dbus_ver
  373. - _gst_ver, gstpb_ver, _xine_ver
  374. - add fix-sort-function.patch to build with glib < 2.9.1
  375. * Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.1-0vl1
  376. - upstream release
  377. - add BuildRequires:
  378. - gtk2-devel >= 2.5.6, glib2-devel >= 2.6.3
  379. - gnome-vfs2-devel >= 2.9.92
  380. - dbus-devel >= 0.35
  381. - use gstreamer-0.10 as backend for totem-gstreamer
  382. * Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl2
  383. - use gstreamer08 instead of gstreamer
  384. * Sat Dec 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl1
  385. - upstream release
  386. * Sun Oct 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl2
  387. - fix missing links
  388. - update file list
  389. - update update-alternatives scripts
  390. - fix totem-gstreamer's %%postun script
  391. * Wed Sep 21 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl1
  392. - upstream release
  393. - add BuildRequires: iso-codes, libmusicbrainz-devel
  394. - add Requires: iso-codes, libmusicbrains to -common package
  395. - remove BuildRequires: nautilus-cd-burner
  396. - remove Requires: nautilus-cd-burner from -common package
  397. * Wed Aug 03 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl2
  398. - totem-gstreamer obsoletes nautilus-media
  399. * Thu Jun 23 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl1
  400. - upstream release
  401. - add Requires(post,postun): alternatives for gstreamer,xine
  402. - add Requires(postun,triggers): alternatives for common
  403. * Mon May 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.3-0vl1
  404. - upstream release
  405. * Sun May 08 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
  406. - build xine backend
  407. - move common files to common package
  408. - move GStreamer related files to gstreamer package
  409. - install xine related files to xine package
  410. - fix scripts
  411. * Sun May 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
  412. - upstream release
  413. - update URL
  414. - move *.{a,la} to devel package
  415. * Mon Apr 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-1vl1
  416. - fix %%{post,preun} script (video-thumbnail.schemas)
  417. - sync with Fedora Core's 1.0.1-1
  418. * Tue Feb 29 2005 John (J5) Palmieri <johnp@redhat.com> - 1.0.1-1
  419. - Update to upstream version 1.0.1
  420. - Break out devel package
  421. * Thu Mar 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl2
  422. - add %%{post,pre}un script
  423. * Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl1
  424. - initial build for Vine Linux
  425. * Mon Feb 21 2005 Bill Nottingham <notting@redhat.com> - 0.101-4
  426. - fix %%post
  427. * Wed Feb 2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-3
  428. - Obsolete nautilus-media
  429. - Install property page and thumbnailer
  430. * Wed Feb 2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-2
  431. - Update to 0.101
  432. * Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-2
  433. - Grab patch totem-0.100-desktopfile.patch from CVS to fix
  434. missing menu entry (144088)
  435. - Remove workaround for desktop file being misinstalled, fixed
  436. by above patch
  437. * Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-1
  438. - New upstream version 0.100
  439. * Sun Dec 5 2004 Bill Nottingham <notting@redhat.com> - 0.99.22-1
  440. - update to 0.99.22
  441. * Thu Oct 28 2004 Colin Walters <walters@redhat.com> - 0.99.19-2
  442. - Add patch to remove removed items from package from help
  443. * Thu Oct 14 2004 Colin Walters <walters@redhat.com> - 0.99.19-1
  444. - New upstream 0.99.19
  445. - Fixes crasher with CD playback (see NEWS)
  446. * Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-2
  447. - Call update-desktop-database in post
  448. * Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-1
  449. - update to 0.99.18
  450. * Wed Oct 6 2004 Alexander Larsson <alexl@redhat.com> -
  451. - Initial version, based on specfile by Matthias Saou <http://freshrpms.net/>