webkitgtk4-vl.spec 7.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227
  1. ## NOTE: Lots of files in various subdirectories have the same name (such as
  2. ## "LICENSE") so this short macro allows us to distinguish them by using their
  3. ## directory names (from the source tree) as prefixes for the files.
  4. %global add_to_license_files() \
  5. mkdir -p _license_files ; \
  6. cp -p %1 _license_files/$(echo '%1' | sed -e 's!/!.!g')
  7. Name: webkitgtk4
  8. Version: 2.8.2
  9. Release: 1%{?_dist_release}
  10. Summary: GTK+ Web content engine library
  11. License: LGPLv2
  12. Group: Development/Libraries
  13. URL: http://www.webkitgtk.org/
  14. Source0: http://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
  15. Patch0: webkitgtk-2.7.4-nspluginwrapper.patch
  16. Patch2: webkitgtk-2.5.90-cloop_fix.patch
  17. Patch3: webkitgtk-2.5.2-commit_align.patch
  18. BuildRequires: at-spi2-core-devel
  19. BuildRequires: bison
  20. BuildRequires: cairo-devel
  21. BuildRequires: cmake
  22. BuildRequires: enchant-devel
  23. BuildRequires: flex
  24. BuildRequires: fontconfig-devel
  25. BuildRequires: freetype-devel
  26. BuildRequires: geoclue2-devel
  27. BuildRequires: gettext
  28. BuildRequires: glib2-devel
  29. BuildRequires: gobject-introspection-devel
  30. BuildRequires: gperf
  31. BuildRequires: gstreamer1-devel
  32. BuildRequires: gstreamer1-plugins-base-devel
  33. BuildRequires: gtk2-devel
  34. BuildRequires: gtk3-devel
  35. BuildRequires: harfbuzz-icu-devel
  36. BuildRequires: libicu-devel
  37. BuildRequires: libjpeg-turbo-devel
  38. BuildRequires: libpng-devel
  39. BuildRequires: libsecret-devel
  40. BuildRequires: libsoup-devel
  41. BuildRequires: libwebp-devel
  42. BuildRequires: libxslt-devel
  43. BuildRequires: libXt-devel
  44. BuildRequires: mesa-libGL-devel
  45. BuildRequires: pcre-devel
  46. BuildRequires: ruby
  47. BuildRequires: sqlite3-devel
  48. %ifarch ppc
  49. BuildRequires: libatomic
  50. %endif
  51. Requires: geoclue2
  52. # Obsolete libwebkit2gtk from the webkitgtk3 package
  53. Obsoletes: libwebkit2gtk < 2.4.5-3
  54. Provides: libwebkit2gtk = %{version}-%{release}
  55. # Filter out provides for private libraries
  56. %global __provides_exclude_from ^%{_libdir}/webkit2gtk-4\\.0/.*\\.so$
  57. %description
  58. WebKitGTK+ is the port of the portable web rendering engine WebKit to the
  59. GTK+ platform.
  60. This package contains WebKitGTK+ for GTK+ 3.
  61. %package devel
  62. Summary: Development files for %{name}
  63. Group: Development/Libraries
  64. Requires: %{name} = %{version}-%{release}
  65. %description devel
  66. The %{name}-devel package contains libraries, build data, and header
  67. files for developing applications that use %{name}.
  68. %prep
  69. %setup -q -n webkitgtk-%{version}
  70. %patch0 -p1 -b .nspluginwrapper
  71. #%patch2 -p1 -b .cloop_fix
  72. %ifarch %{power64} aarch64 ppc
  73. %patch3 -p1 -b .commit_align
  74. %endif
  75. # Remove bundled libraries
  76. rm -rf Source/ThirdParty/leveldb/
  77. rm -rf Source/ThirdParty/gtest/
  78. rm -rf Source/ThirdParty/qunit/
  79. %build
  80. # binutils-2.23 doesn't support "reduce-memory-overheads"
  81. # Use linker flags to reduce memory consumption
  82. # global optflags %{optflags} -Wl,--no-keep-memory -Wl,--reduce-memory-overheads
  83. %ifarch s390 %{arm}
  84. # Decrease debuginfo verbosity to reduce memory consumption even more
  85. %global optflags %(echo %{optflags} | sed 's/-g /-g1 /')
  86. %endif
  87. %ifarch ppc
  88. # Use linker flag -relax to get WebKit build under ppc(32) with JIT disabled
  89. %global optflags %{optflags} -Wl,-relax -latomic
  90. %endif
  91. %global optflags %{optflags} -DENABLE_YARR_JIT=0
  92. mkdir -p %{_target_platform}
  93. pushd %{_target_platform}
  94. %cmake \
  95. -DPORT=GTK \
  96. -DCMAKE_BUILD_TYPE=Release \
  97. -DENABLE_JIT=OFF \
  98. -DENABLE_LLINT_C_LOOP=ON \
  99. ..
  100. popd
  101. make %{?_smp_mflags} -C %{_target_platform}
  102. %install
  103. %make_install -C %{_target_platform}
  104. %find_lang WebKit2GTK-4.0
  105. # Finally, copy over and rename various files for %%license inclusion
  106. %add_to_license_files Source/JavaScriptCore/COPYING.LIB
  107. %add_to_license_files Source/JavaScriptCore/icu/LICENSE
  108. %add_to_license_files Source/ThirdParty/ANGLE/LICENSE
  109. %add_to_license_files Source/ThirdParty/ANGLE/src/third_party/compiler/LICENSE
  110. %add_to_license_files Source/ThirdParty/ANGLE/src/third_party/murmurhash/LICENSE
  111. %add_to_license_files Source/WebCore/icu/LICENSE
  112. %add_to_license_files Source/WebCore/LICENSE-APPLE
  113. %add_to_license_files Source/WebCore/LICENSE-LGPL-2
  114. %add_to_license_files Source/WebCore/LICENSE-LGPL-2.1
  115. %add_to_license_files Source/WebInspectorUI/UserInterface/External/CodeMirror/LICENSE
  116. %add_to_license_files Source/WebInspectorUI/UserInterface/External/Esprima/LICENSE
  117. %add_to_license_files Source/WTF/icu/LICENSE
  118. %add_to_license_files Source/WTF/wtf/dtoa/COPYING
  119. %add_to_license_files Source/WTF/wtf/dtoa/LICENSE
  120. %post -p /sbin/ldconfig
  121. %postun -p /sbin/ldconfig
  122. %files -f WebKit2GTK-4.0.lang
  123. %license _license_files/*
  124. %{_libdir}/libjavascriptcoregtk-4.0.so.*
  125. %{_libdir}/libwebkit2gtk-4.0.so.*
  126. %{_libdir}/girepository-1.0/JavaScriptCore-4.0.typelib
  127. %{_libdir}/girepository-1.0/WebKit2-4.0.typelib
  128. %{_libdir}/girepository-1.0/WebKit2WebExtension-4.0.typelib
  129. %{_libdir}/webkit2gtk-4.0/
  130. %{_libexecdir}/webkit2gtk-4.0/
  131. %files devel
  132. %{_bindir}/jsc
  133. %{_includedir}/webkitgtk-4.0/
  134. %{_libdir}/libjavascriptcoregtk-4.0.so
  135. %{_libdir}/libwebkit2gtk-4.0.so
  136. %{_libdir}/pkgconfig/javascriptcoregtk-4.0.pc
  137. %{_libdir}/pkgconfig/webkit2gtk-4.0.pc
  138. %{_libdir}/pkgconfig/webkit2gtk-web-extension-4.0.pc
  139. %{_datadir}/gir-1.0/JavaScriptCore-4.0.gir
  140. %{_datadir}/gir-1.0/WebKit2-4.0.gir
  141. %{_datadir}/gir-1.0/WebKit2WebExtension-4.0.gir
  142. %changelog
  143. * Fri May 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.2-1
  144. - new upstream release
  145. * Wed Apr 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.1-1
  146. - new upstream release
  147. * Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-1
  148. - new upstream release
  149. - update Patch0
  150. * Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.5-1
  151. - new upstream release
  152. * Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-2
  153. - add Group tag
  154. * Mon Nov 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-1
  155. - new upstream release
  156. * Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.3-1
  157. - new upstream release
  158. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.2-1
  159. - initial build for Vine Linux
  160. * Thu Sep 25 2014 Tomas Popela <tpopela@redhat.com> - 2.6.0-1
  161. - Add the wrongly removed CLoop patch and remove the one that was upstreamed
  162. * Wed Sep 24 2014 Kalev Lember <kalevlember@gmail.com> - 2.6.0-1
  163. - Update to 2.6.0
  164. * Mon Sep 22 2014 Tomas Popela <tpopela@redhat.com> - 2.5.90-1
  165. - Update to 2.5.90
  166. * Tue Aug 26 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-7
  167. - Obsolete libwebkit2gtk from the webkitgtk3 package
  168. * Tue Aug 26 2014 David Tardon <dtardon@redhat.com> - 2.5.3-6
  169. - rebuild for ICU 53.1
  170. * Mon Aug 25 2014 Tomas Popela <tpopela@redhat.com> - 2.5.3-5
  171. - Add support for secondary arches
  172. * Fri Aug 22 2014 Michael Catanzaro <mcatanzaro@gnome.org> - 2.5.3-4
  173. - Add webkitgtk-2.5.3-toggle-buttons.patch
  174. * Thu Aug 21 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-3
  175. - More package review fixes (#1131284)
  176. - Correct the license tag to read LGPLv2
  177. - Filter out provides for private libraries
  178. * Tue Aug 19 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-2
  179. - Remove bundled leveldb, gtest, qunit in %%prep (#1131284)
  180. * Fri Aug 15 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-1
  181. - Update to 2.5.3
  182. * Fri Aug 01 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.1-1
  183. - Initial Fedora packaging, based on the webkitgtk3 package