Cython-vl.spec 3.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112
  1. Summary: A language for writing Python extension modules
  2. Summary(ja): Python 拡張モジュールを簡単に作成するためのプログラミング言語
  3. Name: Cython
  4. Version: 0.29.21
  5. Release: 1%{?_dist_release}
  6. Group: programming
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: Apache
  10. URL: https://cython.org/
  11. Source0: https://github.com/cython/cython/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: python-rpm-macros
  14. BuildRequires: python-devel
  15. BuildRequires: python-setuptools
  16. BuildRequires: python2-rpm-macros
  17. %description
  18. Cython is a language that makes writing C extensions for the Python language as easy as Python itself. Cython is based on the well-known Pyrex, but supports more cutting edge functionality and optimizations.
  19. The Cython language is very close to the Python language, but Cython additionally supports calling C functions and declaring C types on variables and class attributes.
  20. This allows the compiler to generate very efficient C code from Cython code.
  21. The generated C code compiles with Python 2.4 and later (including Python 3).
  22. This makes Cython the ideal language for wrapping external C libraries, and for fast C modules that speed up the execution of Python code.
  23. %package -n python3-Cython
  24. Summary: A language for writing Python extension modules
  25. Summary(ja): Python 拡張モジュールを簡単に作成するためのプログラミング言語
  26. Group: programming
  27. BuildRequires: python3-devel
  28. BuildRequires: python3-setuptools
  29. BuildRequires: python3-rpm-macros
  30. %description -n python3-Cython
  31. Cython is a language that makes writing C extensions for the Python language as easy as Python itself. Cython is based on the well-known Pyrex, but supports more cutting edge functionality and optimizations.
  32. The Cython language is very close to the Python language, but Cython additionally supports calling C functions and declaring C types on variables and class attributes.
  33. This allows the compiler to generate very efficient C code from Cython code.
  34. The generated C code compiles with Python 2.4 and later (including Python 3).
  35. This makes Cython the ideal language for wrapping external C libraries, and for fast C modules that speed up the execution of Python code.
  36. %prep
  37. %setup -q -n cython-%{version}
  38. %build
  39. %{py2_build}
  40. %{py3_build}
  41. %install
  42. rm -rf $RPM_BUILD_ROOT
  43. %{py2_install}
  44. %{py3_install}
  45. %clean
  46. rm -rf $RPM_BUILD_ROOT
  47. %files
  48. %defattr(-,root,root,-)
  49. %license COPYING.txt LICENSE.txt
  50. %doc README.txt USAGE.txt
  51. #{_bindir}/cygdb
  52. #{_bindir}/cython
  53. #{_bindir}/cythonize
  54. %{python_sitearch}/Cython
  55. %{python_sitearch}/pyximport
  56. %{python_sitearch}/Cython-%{version}-*-info
  57. %{python_sitearch}/cython.*
  58. %files -n python3-Cython
  59. %license COPYING.txt LICENSE.txt
  60. %doc README.txt USAGE.txt
  61. %{_bindir}/cygdb
  62. %{_bindir}/cython
  63. %{_bindir}/cythonize
  64. %{python3_sitearch}/*
  65. %changelog
  66. * Sat Aug 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.29.21-1
  67. - new upstream release.
  68. * Fri Oct 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.29.13-1
  69. - new upstream release.
  70. * Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.23.4-1
  71. - new upstream release
  72. * Sun Jul 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22.1-1
  73. - new upstream release
  74. * Wed Feb 4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.21.2-1
  75. - new upstream release
  76. - moved to Development/Languages Group
  77. * Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.19.2-1
  78. - new upstream release
  79. * Thu Mar 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.18-1
  80. - new upstream release
  81. * Sun Apr 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.15.1-1
  82. - initial build for Vine Linux