gdb-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451
  1. Summary: A GNU source-level debugger for C, C++ and other languages.
  2. Summary(ja): C, C++ その他の言語用 GNU ソースレベルデバッガ
  3. Name: gdb
  4. Version: 9.2
  5. Release: 1%{?_dist_release}
  6. Group: programming
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: GPL
  10. URL: https://www.gnu.org/software/gdb/
  11. Source: https://ftp.gnu.org/gnu/gdb/gdb-%{version}.tar.xz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: ncurses-devel glibc-devel gcc make gzip texinfo expat-devel
  14. BuildRequires: python3-devel python3-rpm-macros
  15. BuildRequires: zlib-devel
  16. Requires: install-info
  17. %description
  18. GDB, the GNU debugger, allows you to debug programs written in C, C++,
  19. and other languages, by executing them in a controlled fashion and
  20. printing their data.
  21. %description -l ja
  22. GDB (GNU デバッガ) は C, C++ その他の言語で書かれたプログラムのデバッグに
  23. 使うツールです.プログラムの実行を制御し,データを出力することができます.
  24. %prep
  25. %setup -q
  26. %build
  27. export CFLAGS="$RPM_OPT_FLAGS"
  28. rm -fr dejagnu tcl expect
  29. mkdir -p build
  30. cd build
  31. ../configure \
  32. --prefix=%{_prefix} \
  33. --sysconfdir=%{_sysconfdir} \
  34. --mandir=%{_mandir} \
  35. --infodir=%{_infodir} \
  36. --with-python=%{__python3} \
  37. %{_target_platform}
  38. make %{?_smp_mflags}
  39. make %{?_smp_mflags} info
  40. %install
  41. rm -rf $RPM_BUILD_ROOT
  42. cd build
  43. %makeinstall infodir=$RPM_BUILD_ROOT%{_infodir} prefix=$RPM_BUILD_ROOT%{_prefix}
  44. # The above is broken, do this for now:
  45. #mkdir -p $RPM_BUILD_ROOT/%{_infodir}
  46. #cp `find -name "*.info*"` $RPM_BUILD_ROOT/%{_infodir}
  47. # These are part of binutils
  48. #rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  49. #rm -f $RPM_BUILD_ROOT%{_infodir}/dir.info*
  50. rm -f $RPM_BUILD_ROOT%{_infodir}/bfd*
  51. rm -f $RPM_BUILD_ROOT%{_infodir}/configure*
  52. rm -f $RPM_BUILD_ROOT%{_infodir}/standard*
  53. rm -r $RPM_BUILD_ROOT%{_libdir}/lib{bfd*,opcodes*}
  54. rm -f $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd.mo,opcodes.mo}
  55. rm -rf $RPM_BUILD_ROOT%{_includedir}
  56. %clean
  57. rm -rf $RPM_BUILD_ROOT
  58. %post
  59. [ -f %{_infodir}/annotate.info ] && /sbin/install-info %{_infodir}/annotate.info %{_infodir}/dir || :
  60. [ -f %{_infodir}/annotate.info.gz ] && /sbin/install-info %{_infodir}/annotate.info.gz %{_infodir}/dir || :
  61. [ -f %{_infodir}/gdb.info ] && /sbin/install-info %{_infodir}/gdb.info %{_infodir}/dir || :
  62. [ -f %{_infodir}/gdb.info.gz ] && /sbin/install-info %{_infodir}/gdb.info.gz %{_infodir}/dir || :
  63. [ -f %{_infodir}/stabs.info ] && /sbin/install-info %{_infodir}/stabs.info %{_infodir}/dir || :
  64. [ -f %{_infodir}/stabs.info.gz ] && /sbin/install-info %{_infodir}/stabs.info.gz %{_infodir}/dir || :
  65. %preun
  66. if [ $1 = 0 ]; then
  67. [ -f %{_infodir}/annotate.info ] && /sbin/install-info --delete %{_infodir}/annotate.info %{_infodir}/dir || :
  68. [ -f %{_infodir}/annotate.info.gz ] && /sbin/install-info --delete %{_infodir}/annotate.info.gz %{_infodir}/dir || :
  69. [ -f %{_infodir}/gdb.info ] && /sbin/install-info --delete %{_infodir}/gdb.info %{_infodir}/dir || :
  70. [ -f %{_infodir}/gdb.info.gz ] && /sbin/install-info --delete %{_infodir}/gdb.info.gz %{_infodir}/dir || :
  71. [ -f %{_infodir}/gdbint.info ] && /sbin/install-info --delete %{_infodir}/gdbint.info %{_infodir}/dir || :
  72. [ -f %{_infodir}/gdbint.info.gz ] && /sbin/install-info --delete %{_infodir}/gdbint.info.gz %{_infodir}/dir || :
  73. [ -f %{_infodir}/stabs.info ] && /sbin/install-info --delete %{_infodir}/stabs.info %{_infodir}/dir || :
  74. [ -f %{_infodir}/stabs.info.gz ] && /sbin/install-info --delete %{_infodir}/stabs.info.gz %{_infodir}/dir || :
  75. fi
  76. %files
  77. %defattr(-,root,root)
  78. %license COPYING COPYING.LIB
  79. %doc README gdb/NEWS
  80. %{_bindir}/*
  81. %{_mandir}/*/*
  82. %dir %{_datadir}/gdb
  83. %{_datadir}/gdb/syscalls
  84. %dir %{_datadir}/gdb/python
  85. %{_datadir}/gdb/python/gdb
  86. %dir %{_datadir}/gdb/system-gdbinit
  87. %{_datadir}/gdb/system-gdbinit/elinos.py
  88. %{_datadir}/gdb/system-gdbinit/wrs-linux.py
  89. %{_infodir}/annotate.info*
  90. %{_infodir}/gdb.info*
  91. %{_infodir}/stabs.info*
  92. %exclude %{_infodir}/dir
  93. %ifarch %{ix86} x86_64
  94. %{_libdir}/libinproctrace.so
  95. %endif
  96. ## don't include the files in include, they are part of binutils
  97. #%{_includedir}/*
  98. #%{_infodir}/bfd.info*
  99. #%{_infodir}/configure.info*
  100. #%{_infodir}/standard.info*
  101. #%{_libdir}/*
  102. #%{_datadir}/locale/*/LC_MESSAGES/bfd.mo
  103. #%{_datadir}/locale/*/LC_MESSAGES/opcode.mo
  104. %changelog
  105. * Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.2-1
  106. - new upstream release.
  107. * Fri Mar 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.1-1
  108. - new upstream release.
  109. * Wed Jan 23 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.2.1-1
  110. - new upstream release.
  111. * Fri Jul 22 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.11.1-1
  112. - new upstream release
  113. * Sun Apr 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.11-1
  114. - new upstream release
  115. * Sun Oct 11 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.10-1
  116. - new upstream release
  117. * Mon Jul 06 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.9.1-1
  118. - new upstream release
  119. * Sun Feb 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.9-1
  120. - new upstream release
  121. * Sun Dec 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.8.1-1
  122. - new upstream release
  123. * Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.8-1
  124. - new upstream release
  125. * Sun Nov 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6.1-1
  126. - new upstream release
  127. * Mon Oct 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-1
  128. - new upstream release
  129. * Tue May 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.4.1-1
  130. - new upstream release
  131. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.4-1
  132. - new upstream release
  133. * Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.2-2
  134. - add BuildRequires: python-devel, zlib-devel
  135. - fix %%files
  136. * Thu Apr 28 2011 Shu KONNO <owa@bg.wakwak.com> 7.2-1
  137. - updated gdb to 7.2
  138. * Wed Feb 17 2010 Shu KONNO <owa@bg.wakwak.com> 7.0.1-1
  139. - updated gdb to 7.0.1
  140. - rebuilt with new environment
  141. * Sat Sep 13 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-1vl5
  142. - applied new versioning policy, spec in utf-8
  143. * Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.7.1-0vl4
  144. - rebuild with expat-2.0.1
  145. - add BuildRequires: expat-devel
  146. * Sun Jan 27 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl3
  147. - dropt %%{_localedir}/*/LC_MESSAGES/*.mo conflicts with binutils
  148. * Fri Jan 04 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl2
  149. - dropt %%{_libdir}/lib{bfd*,iberty*,opcodes*} conflicts with binutils-devel
  150. * Mon Dec 31 2007 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl1
  151. - new upstream release
  152. * Wed Jul 12 2006 Shu KONNO <owa@bg.wakwak.com> 6.4.90-0vl1
  153. - new upstream release
  154. * Sat Dec 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.0-0vl1
  155. - new upstream release
  156. * Thu Nov 28 2002 KAZUKI SHIMURA <rito@pos.to> 5.2.1-4vl2
  157. - Oops, spec was written in Shift-JIS. Fixed.
  158. * Mon Nov 11 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.2.1-4vl1
  159. - based on 5.2.1-4 from Rawhide and built for Vine Linux
  160. * Fri Aug 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
  161. - added mainframe patch from developerworks
  162. * Wed Aug 21 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-3
  163. - Add changelogs to the previous patch
  164. * Wed Aug 14 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-2
  165. - Add some patches from Elena Zannoni <ezannoni@redhat.com>
  166. * Tue Jul 23 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-1
  167. - 5.2.1
  168. * Mon Jul 22 2002 Florian La Roche <Florian.LaRoche@redhat.de>
  169. - compile on mainframe
  170. * Mon Jul 8 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-3
  171. - Rebuild
  172. * Tue May 7 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-2
  173. - Rebuild
  174. * Mon Apr 29 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-1
  175. - 5.2
  176. * Mon Apr 29 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.92-1
  177. - 5.1.92. Hopefully identical to 5.2 final
  178. * Mon Apr 22 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.91-1
  179. - 5.1.91. 5.2 expected in a week
  180. * Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-5
  181. - Update to current
  182. * Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-4
  183. - Update to current
  184. * Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-3
  185. - Update to current
  186. * Wed Mar 20 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-2
  187. - Update to current
  188. * Wed Mar 13 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-1
  189. - Update to current 5.2 branch
  190. * Thu Jan 24 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.1-1
  191. - 5.1.1
  192. - add URL
  193. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  194. - automated rebuild
  195. * Mon Dec 10 2001 Trond Eivind Glomsr <teg@redhat.com> 5.1-2
  196. - Fix some thread+fpu problems
  197. * Mon Nov 26 2001 Trond Eivind Glomsr <teg@redhat.com> 5.1-1
  198. - 5.1
  199. * Mon Nov 19 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.94-0.71
  200. - 5.0.94. Almost there....
  201. * Mon Nov 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.93-2
  202. - Add patch from jakub@redhat.com to improve handling of DWARF
  203. * Mon Nov 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.93-1
  204. - 5.0.93
  205. - handle missing info pages in post/pre scripts
  206. * Wed Oct 31 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.92-1
  207. - 5.0.92
  208. * Fri Oct 26 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.91rh-1
  209. - New snapshot
  210. - Use the 5.0.91 versioning from the snapshot
  211. * Wed Oct 17 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-17
  212. - New snapshot
  213. * Thu Sep 27 2001 Trond Eivind Glomsr <teg@redhat.com>
  214. - New snapshot
  215. * Wed Sep 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-16
  216. - New snapshot
  217. * Mon Aug 13 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-15
  218. - Don't buildrequire compat-glibc (#51690)
  219. * Thu Aug 9 2001 Trond Eivind Glomsr <teg@redhat.com>
  220. - New snapshot, from the stable branch eventually leading to gdb 5.1
  221. * Mon Jul 30 2001 Trond Eivind Glomsr <teg@redhat.com>
  222. - s/Copyright/License/
  223. - Add texinfo to BuildRequires
  224. * Mon Jun 25 2001 Trond Eivind Glomsr <teg@redhat.com>
  225. - New snapshot
  226. * Fri Jun 15 2001 Trond Eivind Glomsr <teg@redhat.com>
  227. - New snapshot
  228. - Add ncurses-devel to buildprereq
  229. - Remove perl from buildprereq, as gdb changed the way
  230. version strings are generated
  231. * Thu Jun 14 2001 Trond Eivind Glomsr <teg@redhat.com>
  232. - New snapshot
  233. * Wed May 16 2001 Trond Eivind Glomsr <teg@redhat.com>
  234. - New snapshot - this had thread fixes for curing #39070
  235. - New way of specifying version
  236. * Tue May 1 2001 Trond Eivind Glomsr <teg@redhat.com>
  237. - New tarball
  238. - Kevin's patch is now part of gdb
  239. * Mon Apr 9 2001 Trond Eivind Glomsr <teg@redhat.com>
  240. - Add patch from kevinb@redhat.com to fix floating point + thread
  241. problem (#24310)
  242. - remove old workarounds
  243. - new snapshot
  244. * Thu Apr 5 2001 Trond Eivind Glomsr <teg@redhat.com>
  245. - New snapshot
  246. * Sat Mar 17 2001 Bill Nottingham <notting@redhat.com>
  247. - on ia64, there are no old headers :)
  248. * Fri Mar 16 2001 Trond Eivind Glomsr <teg@redhat.com>
  249. - build with old headers, new compiler
  250. * Fri Mar 16 2001 Trond Eivind Glomsr <teg@redhat.com>
  251. - new snapshot
  252. * Mon Feb 26 2001 Trond Eivind Glomsr <teg@redhat.com>
  253. - new snapshot which should fix some more IA64 problems (#29151)
  254. - remove IA64 patch, it's now integrated
  255. * Wed Feb 21 2001 Trond Eivind Glomsr <teg@redhat.com>
  256. - add IA64 and Alpha patches from Kevin Buettner <kevinb@redhat.com>
  257. - use perl instead of patch for fixing the version string
  258. * Tue Feb 20 2001 Trond Eivind Glomsr <teg@redhat.com>
  259. - don't use kgcc anymore
  260. - mark it as our own version
  261. - new snapshot
  262. * Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  263. - Link with ncurses 5.x even though we're using kgcc.
  264. No need to drag in requirements on ncurses4 (Bug #24445)
  265. * Fri Jan 19 2001 Trond Eivind Glomsr <teg@redhat.com>
  266. - new snapshot
  267. * Wed Dec 20 2000 Trond Eivind Glomsr <teg@redhat.com>
  268. - new snapshot
  269. * Mon Dec 04 2000 Trond Eivind Glomsr <teg@redhat.com>
  270. - new snapshot
  271. - new alpha patch - it now compiles everywhere. Finally.
  272. * Fri Dec 01 2000 Trond Eivind Glomsr <teg@redhat.com>
  273. - new snapshot
  274. * Mon Nov 20 2000 Trond Eivind Glomsr <teg@redhat.com>
  275. - new CVS snapshot
  276. - disable the patches
  277. - don't use %%configure, as it confuses the autoconf script
  278. - enable SPARC, disable Alpha
  279. * Wed Aug 09 2000 Trond Eivind Glomsr <teg@redhat.com>
  280. - added patch from GDB team for C++ symbol handling
  281. * Tue Jul 25 2000 Trond Eivind Glomsr <teg@redhat.com>
  282. - upgrade to CVS snapshot
  283. - excludearch SPARC, build on IA61
  284. * Wed Jul 19 2000 Trond Eivind Glomsr <teg@redhat.com>
  285. - rebuild
  286. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  287. - automatic rebuild
  288. * Sun Jul 02 2000 Trond Eivind Glomsr <teg@redhat.com>
  289. - rebuild
  290. * Thu Jun 08 2000 Trond Eivind Glomsr <teg@redhat.com>
  291. - use %%configure, %%makeinstall, %%{_infodir}, %%{_mandir},
  292. and %%{_tmppath}
  293. - the install scripts for info are broken(they don't care about
  294. you specify in the installstep), work around that.
  295. - don't build for IA64
  296. * Mon May 22 2000 Trond Eivind Glomsr <teg@redhat.com>
  297. - upgraded to 5.0 - dump all patches. Reapply later if needed.
  298. - added the NEWS file to the %%doc files
  299. - don't delete files which doesn't get installed (readline, texinfo)
  300. - let build system handle stripping and gzipping
  301. - don't delete libmmalloc
  302. - apply patch from jakub@redhat.com to make it build on SPARC
  303. * Fri Apr 28 2000 Matt Wilson <msw@redhat.com>
  304. - rebuilt against new ncurses
  305. * Tue Mar 7 2000 Jeff Johnson <jbj@redhat.com>
  306. - rebuild for sparc baud rates > 38400.
  307. * Tue Feb 8 2000 Jakub Jelinek <jakub@redhat.com>
  308. - fix core file handling on i386 with glibc 2.1.3 headers
  309. * Fri Jan 14 2000 Jakub Jelinek <jakub@redhat.com>
  310. - fix reading registers from core on sparc.
  311. - hack around build problems on i386 with glibc 2.1.3 headers
  312. * Thu Oct 7 1999 Jim Kingdon
  313. - List files to install in /usr/info specifically (so we don't pick up
  314. things like info.info from GDB snapshots).
  315. * Thu Oct 7 1999 Jim Kingdon
  316. - Update GDB to 19991004 snapshot. This eliminates the need for the
  317. sigtramp, sparc, xref, and threads patches. Update sparcmin patch.
  318. * Mon Aug 23 1999 Jim Kingdon
  319. - Omit readline manpage.
  320. * Sat Aug 7 1999 Jim Kingdon
  321. - Remove H.J. Lu's patches (they had been commented out).
  322. - Add sigtramp patch (from gdb.cygnus.com) and threads patch (adapted
  323. from code fusion CD-ROM).
  324. * Wed Apr 14 1999 Jeff Johnson <jbj@redhat.com>
  325. - merge H.J. Lu's patches into 4.18.
  326. * Mon Apr 05 1999 Cristian Gafton <gafton@redhat.com>
  327. - updated the kern22 patch with stuff from davem
  328. * Thu Apr 1 1999 Jeff Johnson <jbj@redhat.com>
  329. - sparc with 2.2 kernels no longer uses sunos ptrace (davem)
  330. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  331. - auto rebuild in the new build environment (release 3)
  332. * Mon Mar 8 1999 Jeff Johnson <jbj@redhat.com>
  333. - Sparc fiddles for Red Hat 6.0.