libtdb-vl.spec 7.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304
  1. %bcond_with python2
  2. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  3. Summary: The tdb library
  4. Summary(ja): TDB ライブラリ
  5. Name: libtdb
  6. Version: 1.4.3
  7. Release: 2%{?_dist_release}
  8. Group: system
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. License: LGPLv3+
  12. URL: https://tdb.samba.org/
  13. Source: https://samba.org/ftp/tdb/tdb-%{version}.tar.gz
  14. BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
  15. BuildRequires: autoconf
  16. BuildRequires: libxslt
  17. BuildRequires: docbook-style-xsl
  18. %if %{with python2}
  19. BuildRequires: python-devel python-rpm-macros
  20. %endif
  21. BuildRequires: python3-devel python3-rpm-macros
  22. BuildRequires: libtirpc-devel
  23. %description
  24. A library that implements a trivial database.
  25. %package devel
  26. Summary: Header files need to link the Tdb library
  27. Group: programming
  28. Requires: libtdb = %{version}-%{release}
  29. Requires: pkgconfig
  30. %description devel
  31. Header files needed to develop programs that link against the Tdb library.
  32. %package -n tdb-tools
  33. Summary: Tools to manipulate tdb files
  34. Summary(ja): TDB ファイルを処理するためのツール集
  35. Group: admin-tools
  36. Requires: libtdb = %{version}-%{release}
  37. %description -n tdb-tools
  38. Tools to manage Tdb files
  39. %if %{with python2}
  40. %package -n python-tdb
  41. Summary: Python bindings for the Tdb library
  42. Summary(ja): TDB ライブラリの python バインディング
  43. Group: programming
  44. Requires: libtdb = %{version}-%{release}
  45. %description -n python-tdb
  46. Python bindings for libtdb
  47. %endif
  48. %package -n python3-tdb
  49. Summary: Python3 bindings for the Tdb library
  50. Group: programming
  51. Requires: libtdb = %{version}-%{release}
  52. %{?python_provide:%python_provide python3-tdb}
  53. %if %{without python2}
  54. Obsoletes: python-tdb < %{version}
  55. %endif
  56. %description -n python3-tdb
  57. Python3 bindings for libtdb
  58. %if %{build_compat32}
  59. %package -n compat32-libtdb
  60. Summary: The TDB library
  61. Summary(ja): TDB ライブラリ
  62. Group: system
  63. Requires: libtdb = %{version}-%{release}
  64. %description -n compat32-libtdb
  65. A library that implements a trivial database.
  66. %endif
  67. %prep
  68. %setup -q -n tdb-%{version}
  69. %build
  70. #./autogen.sh
  71. %if %{without python2}
  72. export PYTHON=%{__python3}
  73. %endif
  74. %configure --disable-rpath \
  75. %if %{with python2}
  76. --extra-python=%{__python3} \
  77. %endif
  78. --bundled-libraries=NONE \
  79. --builtin-libraries=replace
  80. make %{?_smp_mflags} V=1
  81. %install
  82. rm -rf $RPM_BUILD_ROOT
  83. make install DESTDIR=$RPM_BUILD_ROOT
  84. # Shared libraries need to be marked executable for
  85. # rpmbuild to strip them and include them in debuginfo
  86. find $RPM_BUILD_ROOT -name "*.so*" -exec chmod -c +x {} \;
  87. rm -f $RPM_BUILD_ROOT%{_libdir}/libtdb.a
  88. %clean
  89. rm -rf $RPM_BUILD_ROOT
  90. %files
  91. %defattr(-,root,root,-)
  92. %{_libdir}/libtdb.so.*
  93. %files devel
  94. %defattr(-,root,root)
  95. %{_includedir}/tdb.h
  96. %{_libdir}/libtdb.so
  97. %{_libdir}/pkgconfig/tdb.pc
  98. %files -n tdb-tools
  99. %defattr(-,root,root,-)
  100. %{_bindir}/tdbbackup
  101. %{_bindir}/tdbdump
  102. %{_bindir}/tdbtool
  103. %{_bindir}/tdbrestore
  104. %{_mandir}/man8/tdbbackup.8*
  105. %{_mandir}/man8/tdbdump.8*
  106. %{_mandir}/man8/tdbtool.8*
  107. %{_mandir}/man8/tdbrestore.8*
  108. %if %{with python2}
  109. %files -n python-tdb
  110. %defattr(-,root,root,-)
  111. %{python_sitearch}/*
  112. %endif
  113. %files -n python3-tdb
  114. %{python3_sitearch}/*
  115. %if %{build_compat32}
  116. %files -n compat32-libtdb
  117. %attr(755,root,root) %{_libdir}/libtdb.so.*
  118. %endif
  119. %post -p /sbin/ldconfig
  120. %postun -p /sbin/ldconfig
  121. %if %{with python2}
  122. %post -n python-tdb -p /sbin/ldconfig
  123. %postun -n python-tdb -p /sbin/ldconfig
  124. %endif
  125. %post -n python3-tdb -p /sbin/ldconfig
  126. %postun -n python3-tdb -p /sbin/ldconfig
  127. %if %build_compat32
  128. %post -n compat32-libtdb -p /sbin/ldconfig
  129. %postun -n compat32-libtdb -p /sbin/ldconfig
  130. %endif
  131. %changelog
  132. * Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.3-2
  133. - rebuilt with python-3.8.
  134. * Tue Mar 31 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.3-1
  135. - new upstream release.
  136. * Sat May 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.18-1
  137. - new upstream release.
  138. - disabled python2.
  139. - added BR:libtirpc-devel.
  140. * Fri Nov 30 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.16-1
  141. - new upstream release.
  142. * Tue Feb 27 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.15-1
  143. - new upstream release.
  144. - dropped Patch1.
  145. - enabled python3 modules.
  146. * Sat Jul 15 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.14-1
  147. - new upstream release.
  148. * Mon May 1 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.13-1
  149. - new upstream release.
  150. * Sun Dec 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.12-1
  151. - new upstream release.
  152. * Wed Apr 13 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.9-1
  153. - new upstream release.
  154. * Wed Dec 2 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.8-1
  155. - new upstream release.
  156. * Fri Jul 24 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.7-1
  157. - new upstream release.
  158. * Sat Jun 13 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.6-1
  159. - new upstream release.
  160. * Mon Jan 12 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.4-1
  161. - new upstream release.
  162. * Wed Dec 3 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.3-1
  163. - new upstream release.
  164. * Sat Oct 4 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.3.0-2
  165. - moved python-tdb to System Environment/Libraries Group
  166. - moved tdb-tool to Applications/System Group
  167. * Tue Aug 19 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.0-1
  168. - new upstream release.
  169. * Wed Jan 08 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.12-2
  170. - rebuilt with current environment.
  171. * Tue Oct 08 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.12-1
  172. - new upstream release.
  173. * Mon Dec 17 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.11-1
  174. - new upstream release.
  175. * Sat Apr 14 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.10-1
  176. - new upstream release.
  177. - updated Patch0001.
  178. * Thu Feb 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.9-11
  179. - rebuild with python-2.7.2
  180. * Thu Mar 24 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.9-10
  181. - initial build for Vine Linux.
  182. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.9-9
  183. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  184. * Fri Jan 14 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.2.9-8
  185. - Actually fix the verbosity
  186. * Fri Jan 14 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.2.9-7
  187. - Let rpmbuild strip binaries, make build more verbose.
  188. - Original patch by Ville Skyttä <ville.skytta@iki.fi>
  189. * Wed Jan 12 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.2.9-6
  190. - Install python bindings into the correct location
  191. * Tue Jan 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.2.9-5
  192. - Run ldconfig on python-tdb
  193. * Tue Jan 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.2.9-4
  194. - Do not delete a necessary file during %%install
  195. * Tue Jan 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.2.9-3
  196. - Bump release to rebuild with the correct sources in place
  197. * Tue Jan 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.2.9-2
  198. - Bump build to rebuild with sources in place
  199. * Tue Jan 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.2.9-1
  200. - New upstream bugfix release
  201. - Adds a new tdbrestore utility
  202. - Convert to new WAF build-system
  203. - Add python bindings in new python-tdb subpackage
  204. * Wed Feb 24 2010 Simo Sorce <ssorce@redhat.com> - 1.2.1-3
  205. - add missing build require
  206. * Wed Feb 24 2010 Simo Sorce <ssorce@redhat.com> - 1.2.1-2
  207. - Fix spec file
  208. - Package manpages too
  209. * Wed Feb 24 2010 Simo Sorce <ssorce@redhat.com> - 1.2.1-1
  210. - New upstream bugfix release
  211. * Tue Dec 15 2009 Simo Sorce <ssorce@redhat.com> - 1.2.0-1
  212. - New upstream release
  213. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.5-2
  214. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  215. * Wed Jun 17 2009 Simo Sorce <ssorce@redhat.com> - 1.1.5-1
  216. - Original tarballs had a screw-up, rebuild with new fixed tarballs from
  217. upstream.
  218. * Tue Jun 16 2009 Simo Sorce <ssorce@redhat.com> - 1.1.5-0
  219. - New upstream release
  220. * Wed May 6 2009 Simo Sorce <ssorce@redhat.com> - 1.1.3-15
  221. - First public independent release from upstream