numpy-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357
  1. %bcond_with check
  2. # eval to 2.3 if python isn't yet present, workaround for no python in fc4 minimal buildroot
  3. %{!?python_version: %define python_version %(%{__python} -c 'import sys; print sys.version.split(" ")[0]' || echo "2.3")}
  4. Name: numpy
  5. Summary: A fast multidimensional array facility for Python
  6. Version: 1.19.1
  7. Release: 1%{?_dist_release}
  8. Group: programming
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. License: BSD and Python and ASL 2.0
  12. URL: https://www.numpy.org/
  13. Source0: https://github.com/%{name}/%{name}/releases/download/v%{version}/%{name}-%{version}.tar.gz
  14. Source1: https://docs.scipy.org/doc/numpy/numpy-html-1.17.0.zip
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: gcc-gfortran gcc
  17. BuildRequires: lapack-devel
  18. BuildRequires: openblas-devel
  19. BuildRequires: python-rpm-macros
  20. BuildRequires: python3-devel
  21. BuildRequires: python3-rpm-macros
  22. BuildRequires: python3-setuptools
  23. %if %{with check}
  24. BuildRequires: python3-pytest
  25. %endif
  26. BuildRequires: python3-Cython
  27. %description
  28. NumPy is a general-purpose array-processing package designed to
  29. efficiently manipulate large multi-dimensional arrays of arbitrary
  30. records without sacrificing too much speed for small multi-dimensional
  31. arrays. NumPy is built on the Numeric code base and adds features
  32. introduced by numarray as well as an extended C-API and the ability to
  33. create arrays of arbitrary type.
  34. There are also basic facilities for discrete fourier transform,
  35. basic linear algebra and random number generation. Also included in
  36. this package is a version of f2py that works properly with NumPy.
  37. %package -n python3-numpy
  38. Summary: A fast multidimensional array facility for Python
  39. Group: programming
  40. License: BSD
  41. %{?python_provide:%python_provide python3-numpy}
  42. Provides: libnpymath-static = %{version}-%{release}
  43. Provides: libnpymath-static%{?_isa} = %{version}-%{release}
  44. Obsoletes: numpy-common < 1.19.0
  45. Conflicts: numpy-common < 1.19.0
  46. %description -n python3-numpy
  47. NumPy is a general-purpose array-processing package designed to
  48. efficiently manipulate large multi-dimensional arrays of arbitrary
  49. records without sacrificing too much speed for small multi-dimensional
  50. arrays. NumPy is built on the Numeric code base and adds features
  51. introduced by numarray as well as an extended C-API and the ability to
  52. create arrays of arbitrary type.
  53. There are also basic facilities for discrete fourier transform,
  54. basic linear algebra and random number generation. Also included in
  55. this package is a version of f2py that works properly with NumPy.
  56. %package -n python3-numpy-f2py
  57. Summary: f2py for numpy
  58. Group: programming
  59. Requires: python3-numpy%{?_isa} = %{version}-%{release}
  60. Requires: python3-devel
  61. Provides: python3-f2py = %{version}-%{release}
  62. %{?python_provide:%python_provide python3-numpy-f2py}
  63. %description -n python3-numpy-f2py
  64. This package includes a version of f2py that works properly with NumPy.
  65. %package -n python3-numpy-doc
  66. Summary: Documentation for numpy
  67. Group: documentation
  68. Requires: python3-numpy = %{version}-%{release}
  69. BuildArch: noarch
  70. %description -n python3-numpy-doc
  71. This package provides the complete documentation for NumPy.
  72. %prep
  73. %setup -q -n %{name}-%{version}
  74. # Force re-cythonization (ifed for PKG-INFO presence in setup.py)
  75. rm -f PKG-INFO
  76. # Use openblas pthreads as recommended by upstream (see comment in site.cfg.example)
  77. cat >> site.cfg <<EOF
  78. [openblas]
  79. libraries = openblasp
  80. library_dirs = %{_libdir}
  81. EOF
  82. %build
  83. env OPENBLAS=%{_libdir} \
  84. BLAS=%{_libdir} \
  85. LAPACK=%{_libdir} CFLAGS="%{optflags}" \
  86. %{__python3} setup.py build
  87. %install
  88. rm -rf %{buildroot}
  89. mkdir docs
  90. pushd docs
  91. unzip %{SOURCE1}
  92. popd
  93. env OPENBLAS=%{_libdir} \
  94. FFTW=%{_libdir} BLAS=%{_libdir} \
  95. LAPACK=%{_libdir} CFLAGS="%{optflags}" \
  96. %{__python3} setup.py install --root %{buildroot}
  97. pushd %{buildroot}%{_bindir} &> /dev/null
  98. ln -s f2py3 f2py.numpy
  99. popd &> /dev/null
  100. #symlink for includes, BZ 185079
  101. mkdir -p %{buildroot}%{_includedir}
  102. ln -s %{python3_sitearch}/%{name}/core/include/numpy/ %{buildroot}%{_includedir}/numpy
  103. %if %{with check}
  104. %check
  105. python3 runtests.py
  106. %endif
  107. %clean
  108. rm -rf $RPM_BUILD_ROOT
  109. %pretrans -n python3-numpy -p <lua>
  110. -- Define the path to directory being replaced below.
  111. -- DO NOT add a trailing slash at the end.
  112. path = "%{_includedir}/numpy"
  113. st = posix.stat(path)
  114. if st and st.type == "directory" then
  115. status = os.rename(path, path .. ".rpmmoved")
  116. if not status then
  117. suffix = 0
  118. while not status do
  119. suffix = suffix + 1
  120. status = os.rename(path .. ".rpmmoved", path .. ".rpmmoved." .. suffix)
  121. end
  122. os.rename(path, path .. ".rpmmoved")
  123. end
  124. end
  125. %files -n python3-numpy
  126. %license LICENSE.txt
  127. %doc THANKS.txt site.cfg.example
  128. %dir %{python3_sitearch}/%{name}
  129. %{python3_sitearch}/%{name}/*.py*
  130. %{python3_sitearch}/%{name}/__pycache__
  131. %{python3_sitearch}/%{name}/core
  132. %{python3_sitearch}/%{name}/distutils
  133. %{python3_sitearch}/%{name}/doc
  134. %{python3_sitearch}/%{name}/fft
  135. %{python3_sitearch}/%{name}/lib
  136. %{python3_sitearch}/%{name}/linalg
  137. %{python3_sitearch}/%{name}/ma
  138. %{python3_sitearch}/%{name}/random
  139. %{python3_sitearch}/%{name}/testing
  140. %{python3_sitearch}/%{name}/tests
  141. %{python3_sitearch}/%{name}/compat
  142. %{python3_sitearch}/%{name}/matrixlib
  143. %{python3_sitearch}/%{name}/polynomial
  144. %{python3_sitearch}/%{name}-*.egg-info
  145. %exclude %{python3_sitearch}/%{name}/LICENSE.txt
  146. %{_includedir}/numpy
  147. %{python3_sitearch}/%{name}/__init__.pxd
  148. %files -n python3-numpy-f2py
  149. %{_bindir}/f2py
  150. %{_bindir}/f2py3
  151. %{_bindir}/f2py.numpy
  152. %{_bindir}/f2py%{python3_version}
  153. %{python3_sitearch}/%{name}/f2py
  154. %files -n python3-numpy-doc
  155. %doc docs/*
  156. %changelog
  157. * Sat Aug 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.19.1-1
  158. - new upstream release.
  159. - built with python3 only.
  160. * Wed Oct 23 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.16.5-1
  161. - new upstream release: this version is not newest but final version to suppot python2.
  162. - added python3 support.
  163. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.4.1-9
  164. - rebuild with python-2.7.2
  165. * Wed Aug 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.4.1-8
  166. - add Patch3(changeset_r8510.diff) and Patch4(changeset_r8511.diff) from debian
  167. * Fri Aug 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4.1-7
  168. - Initial build for Vine Linux
  169. * Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 1:1.4.1-6
  170. - actually add the patch this time
  171. * Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 1:1.4.1-5
  172. - fix segfault within %check on 2.7 (patch 2)
  173. * Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 1:1.4.1-4
  174. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  175. * Sun Jul 18 2010 Dan Horák <dan[at]danny.cz> 1.4.1-3
  176. - ignore the "Ticket #1299 second test" failure on s390(x)
  177. * Thu Jun 24 2010 Jef Spaleta <jspaleta@fedoraprject.org> 1.4.1-2
  178. - source commit fix
  179. * Thu Jun 24 2010 Jef Spaleta <jspaleta@fedoraprject.org> 1.4.1-1
  180. - New upstream release. Include backported doublefree patch
  181. * Mon Apr 26 2010 Jon Ciesla <limb@jcomserv.net> 1.3.0-8
  182. - Moved distutils back to the main package, BZ 572820.
  183. * Thu Apr 08 2010 Jon Ciesla <limb@jcomserv.net> 1.3.0-7
  184. - Reverted to 1.3.0 after upstream pulled 1.4.0, BZ 579065.
  185. * Tue Mar 02 2010 Jon Ciesla <limb@jcomserv.net> 1.4.0-5
  186. - Linking /usr/include/numpy to .h files, BZ 185079.
  187. * Tue Feb 16 2010 Jon Ciesla <limb@jcomserv.net> 1.4.0-4
  188. - Re-enabling atlas BR, dropping lapack Requires.
  189. * Wed Feb 10 2010 Jon Ciesla <limb@jcomserv.net> 1.4.0-3
  190. - Since the previous didn't work, Requiring lapack.
  191. * Tue Feb 09 2010 Jon Ciesla <limb@jcomserv.net> 1.4.0-2
  192. - Temporarily dropping atlas BR to work around 562577.
  193. * Fri Jan 22 2010 Jon Ciesla <limb@jcomserv.net> 1.4.0-1
  194. - 1.4.0.
  195. - Dropped ARM patch, ARM support added upstream.
  196. * Tue Nov 17 2009 Jitesh Shah <jiteshs@marvell.com> - 1.3.0-6.fa1
  197. - Add ARM support
  198. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-6
  199. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  200. * Thu Jun 11 2009 Jon Ciesla <limb@jcomserv.net> 1.3.0-5
  201. - Fixed atlas BR, BZ 505376.
  202. * Fri Apr 17 2009 Jon Ciesla <limb@jcomserv.net> 1.3.0-4
  203. - EVR bump for pygame chainbuild.
  204. * Fri Apr 17 2009 Jon Ciesla <limb@jcomserv.net> 1.3.0-3
  205. - Moved linalg, fft back to main package.
  206. * Tue Apr 14 2009 Jon Ciesla <limb@jcomserv.net> 1.3.0-2
  207. - Split out f2py into subpackage, thanks Peter Robinson pbrobinson@gmail.com.
  208. * Tue Apr 07 2009 Jon Ciesla <limb@jcomserv.net> 1.3.0-1
  209. - Update to latest upstream.
  210. - Fixed Source0 URL.
  211. * Thu Apr 02 2009 Jon Ciesla <limb@jcomserv.net> 1.3.0-0.rc1
  212. - Update to latest upstream.
  213. * Thu Mar 05 2009 Jon Ciesla <limb@jcomserv.net> 1.2.1-3
  214. - Require python-devel, BZ 488464.
  215. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.1-2
  216. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  217. * Fri Dec 19 2008 Jon Ciesla <limb@jcomserv.net> 1.2.1-1
  218. - Update to 1.2.1.
  219. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.2.0-2
  220. - Rebuild for Python 2.6
  221. * Tue Oct 07 2008 Jon Ciesla <limb@jcomserv.net> 1.2.0-1
  222. - New upstream release, added python-nose BR. BZ 465999.
  223. - Using atlas blas, not blas-devel. BZ 461472.
  224. * Wed Aug 06 2008 Jon Ciesla <limb@jcomserv.net> 1.1.1-1
  225. - New upstream release
  226. * Thu May 29 2008 Jarod Wilson <jwilson@redhat.com> 1.1.0-1
  227. - New upstream release
  228. * Tue May 06 2008 Jarod Wilson <jwilson@redhat.com> 1.0.4-1
  229. - New upstream release
  230. * Mon Feb 11 2008 Jarod Wilson <jwilson@redhat.com> 1.0.3.1-2
  231. - Add python egg to %%files on f9+
  232. * Wed Aug 22 2007 Jarod Wilson <jwilson@redhat.com> 1.0.3.1-1
  233. - New upstream release
  234. * Wed Jun 06 2007 Jarod Wilson <jwilson@redhat.com> 1.0.3-1
  235. - New upstream release
  236. * Mon May 14 2007 Jarod Wilson <jwilson@redhat.com> 1.0.2-2
  237. - Drop BR: atlas-devel, since it just provides binary-compat
  238. blas and lapack libs. Atlas can still be optionally used
  239. at runtime. (Note: this is all per the atlas maintainer).
  240. * Mon May 14 2007 Jarod Wilson <jwilson@redhat.com> 1.0.2-1
  241. - New upstream release
  242. * Tue Apr 17 2007 Jarod Wilson <jwilson@redhat.com> 1.0.1-4
  243. - Update gfortran patch to recognize latest gfortran f95 support
  244. - Resolves rhbz#236444
  245. * Fri Feb 23 2007 Jarod Wilson <jwilson@redhat.com> 1.0.1-3
  246. - Fix up cpuinfo bug (#229753). Upstream bug/change:
  247. http://projects.scipy.org/scipy/scipy/ticket/349
  248. * Thu Jan 04 2007 Jarod Wilson <jwilson@redhat.com> 1.0.1-2
  249. - Per discussion w/Jose Matos, Obsolete/Provide f2py, as the
  250. stand-alone one is no longer supported/maintained upstream
  251. * Wed Dec 13 2006 Jarod Wilson <jwilson@redhat.com> 1.0.1-1
  252. - New upstream release
  253. * Tue Dec 12 2006 Jarod Wilson <jwilson@redhat.com> 1.0-2
  254. - Rebuild for python 2.5
  255. * Wed Oct 25 2006 Jarod Wilson <jwilson@redhat.com> 1.0-1
  256. - New upstream release
  257. * Wed Sep 06 2006 Jarod Wilson <jwilson@redhat.com> 0.9.8-1
  258. - New upstream release
  259. * Wed Apr 26 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 0.9.6-1
  260. - Upstream update
  261. * Thu Feb 16 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 0.9.5-1
  262. - Upstream update
  263. * Mon Feb 13 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 0.9.4-2
  264. - Rebuild for Fedora Extras 5
  265. * Thu Feb 2 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 0.9.4-1
  266. - Initial RPM release
  267. - Added gfortran patch from Neal Becker