opencv-vl.spec 23 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720
  1. %bcond_with test
  2. %bcond_without gstreamer
  3. #global indice a
  4. Name: opencv
  5. Version: 4.4.0
  6. Release: 1%{?_dist_release}
  7. Summary: Collection of algorithms for computer vision
  8. Summary(ja): コンピュータビジョン用のアルゴリズム集
  9. Group: graphics
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. # This is normal three clause BSD.
  13. License: BSD
  14. URL: https://opencv.org
  15. # RUN opencv-clean.sh TO PREPARE TARBALLS
  16. #
  17. # Need to remove copyrighted lena.jpg images from tarball (rhbz#1295173)
  18. # and SIFT/SURF from tarball, due to legal concerns.
  19. #
  20. #Source0: https://github.com/opencv/opencv/archive/%{version}.tar.gz
  21. Source0: %{name}-clean-%{version}.tar.gz
  22. Source1: %{name}_contrib-clean-%{version}.tar.gz
  23. Source2: %{name}_extra-clean-%{version}.tar.gz
  24. Source3: face_landmark_model.dat.xz
  25. # from https://github.com/opencv/ade/archive/v0.1.1f.zip
  26. Source4: b624b995ec9c439cbc2e9e6ee940d3a2-v0.1.1f.zip
  27. Source5: xorg.conf
  28. Source100: opencv-clean.sh
  29. Patch0: opencv-4.1.0-install_3rdparty_licenses.patch
  30. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  31. BuildRequires: libtool
  32. BuildRequires: cmake >= 2.6.3
  33. BuildRequires: chrpath
  34. BuildRequires: eigen3-devel
  35. BuildRequires: libtheora-devel
  36. BuildRequires: libvorbis-devel
  37. #BuildRequires: libraw1394-devel
  38. #BuildRequires: libdc1394-devel
  39. BuildRequires: jasper-devel
  40. BuildRequires: libpng-devel
  41. BuildRequires: libjpeg-devel
  42. BuildRequires: libtiff-devel
  43. BuildRequires: libv4l-devel
  44. BuildRequires: libwebp-devel
  45. BuildRequires: mesa-libGL-devel
  46. BuildRequires: OpenEXR-devel
  47. #ifarch %{ix86} x86_64
  48. #BuildRequires: openni-devel
  49. #BuildRequires: openni-primesense
  50. #endif
  51. BuildRequires: tbb-devel
  52. BuildRequires: qt5-qtbase-devel
  53. BuildRequires: freetype2-devel
  54. BuildRequires: harfbuzz-devel
  55. BuildRequires: zlib-devel pkgconfig
  56. BuildRequires: python3-devel
  57. BuildRequires: python3-setuptools
  58. BuildRequires: python3-rpm-macros
  59. BuildRequires: python3-numpy
  60. BuildRequires: swig >= 1.3.24
  61. #BuildRequires: python-sphinx
  62. #BuildRequires: ffmpeg-devel >= 0.4.9
  63. BuildRequires: gstreamer1-devel
  64. BuildRequires: gstreamer1-plugins-base-devel
  65. #BuildRequires: xine-lib-devel
  66. #BuildRequires: opencl-headers
  67. BuildRequires: vulkan-headers
  68. BuildRequires: mesa-dri-drivers
  69. BuildRequires: xorg-x11-drv-dummy
  70. Requires: opencv-core = %{version}-%{release}
  71. %description
  72. OpenCV means Intel® Open Source Computer Vision Library. It is a collection of
  73. C functions and a few C++ classes that implement some popular Image Processing
  74. and Computer Vision algorithms.
  75. %package core
  76. Summary: OpenCV core libraries
  77. Summary(ja): OpenCV コアライブラリ
  78. Group: graphics
  79. Obsoletes: %{name}-python < %{version}-%{release}
  80. %description core
  81. This package contains the OpenCV C/C++ core libraries.
  82. %package devel
  83. Summary: Development files for using the OpenCV library
  84. Summary(ja): OpenCV ライブラリを使用するための開発用ファイル
  85. Group: programming
  86. Requires: opencv = %{version}-%{release}
  87. %description devel
  88. This package contains the OpenCV C/C++ library and header files, as well as
  89. documentation. It should be installed if you want to develop programs that
  90. will use the OpenCV library. You should consider installing opencv-devel-docs
  91. package.
  92. %package -n python3-opencv
  93. Summary: Python bindings for apps which use OpenCV
  94. Summary(ja): OpenCV を使用するアプリケーション用の Python バインディング
  95. Group: programming
  96. Requires: opencv = %{version}-%{release}
  97. Requires: python3-numpy
  98. %description -n python3-opencv
  99. This package contains Python bindings for the OpenCV library.
  100. %package contrib
  101. Summary: OpenCV contributed functionality
  102. Summary(ja): 寄付された OpenCV の追加機能
  103. Group: graphics
  104. %description contrib
  105. This package is intended for development of so-called "extra" modules, contribut
  106. ed
  107. functionality. New modules quite often do not have stable API, and they are not
  108. well-tested. Thus, they shouldn't be released as a part of official OpenCV
  109. distribution, since the library maintains binary compatibility, and tries
  110. to provide decent performance and stability.
  111. %debug_package
  112. %prep
  113. %setup -q -a1 -a2
  114. # we don't use pre-built contribs except quirc
  115. pushd 3rdparty
  116. shopt -s extglob
  117. rm -r !(openexr|openvx|quirc)
  118. shopt -u extglob
  119. popd &>/dev/null
  120. %patch0 -p1 -b .install_3rdparty_licenses
  121. # Install ADE, needed for opencv_gapi
  122. mkdir -p .cache/ade
  123. install -pm 0644 %{SOURCE4} .cache/ade/
  124. %build
  125. # enabled by default if libraries are presents at build time:
  126. # GTK, GSTREAMER, 1394, V4L
  127. # non available on Fedora: FFMPEG, XINE
  128. mkdir -p build
  129. pushd build
  130. rm -rf share/opencv4/testdata/cv/face
  131. mkdir -p share/opencv4/testdata/cv/face
  132. install -pm 0644 %{SOURCE3} share/opencv4/testdata/cv/face
  133. pushd share/opencv4/testdata/cv/face
  134. xz -d face_landmark_model.dat.xz
  135. popd
  136. # disabling IPP because it is closed source library from intel
  137. %cmake CMAKE_VERBOSE=1 \
  138. -DWITH_IPP=OFF \
  139. -DWITH_ITT=OFF \
  140. -DWITH_QT=ON \
  141. -DWITH_OPENGL=ON \
  142. -DOpenGL_GL_PREFERENCE=GLVND \
  143. -DWITH_GDAL=ON \
  144. -DWITH_OPENEXR=ON \
  145. -DWITH_UNICAP=ON \
  146. -DCMAKE_SKIP_RPATH=ON \
  147. -DWITH_CAROTENE=OFF \
  148. %ifnarch x86_64 ia64
  149. -DENABLE_SSE=0 \
  150. -DENABLE_SSE2=0 \
  151. %else
  152. -DCPU_BASELINE=SSE2 \
  153. %endif
  154. -DENABLE_PRECOMPILED_HEADERS=OFF \
  155. -DCMAKE_BUILD_TYPE=ReleaseWithDebInfo \
  156. -DBUILD_opencv_java=OFF \
  157. %{?with_tbb: -DWITH_TBB=ON } \
  158. %{!?with_gstreamer: -DWITH_GSTREAMER=OFF } \
  159. -DWITH_FFMPEG=OFF \
  160. %{?with_openni: -DWITH_OPENNI=ON } \
  161. -DWITH_XINE=OFF \
  162. -DBUILD_DOCS=OFF \
  163. -DBUILD_EXAMPLES=OFF \
  164. -DBUILD_opencv_python2=OFF \
  165. -DINSTALL_C_EXAMPLES=OFF \
  166. -DINSTALL_PYTHON_EXAMPLES=OFF \
  167. -DPYTHON3_EXECUTABLE=%{__python3} \
  168. -DPYTHON3_PACKAGES_PATH=%{python3_sitearch} \
  169. -DENABLE_PYLINT=ON \
  170. -DBUILD_PROTOBUF=OFF \
  171. -DPROTOBUF_UPDATE_FILES=ON \
  172. -DWITH_OPENCL=OFF \
  173. -DOPENCV_SKIP_PYTHON_LOADER=ON \
  174. -DOPENCV_EXTRA_MODULES_PATH=../opencv_contrib-%{version}/modules \
  175. -DWITH_LIBV4L=ON \
  176. -DWITH_OPENMP=ON \
  177. -DOPENCV_CONFIG_INSTALL_PATH=%{_lib}/cmake/OpenCV \
  178. -DOPENCV_GENERATE_PKGCONFIG=ON \
  179. -DOPENCV_TEST_DATA_PATH=opencv_extra-%{version}/testdata \
  180. %{?with_gdcm: -DWITH_GDCM=ON } \
  181. %{?with_libmfx: -DWITH_MFX=ON } \
  182. %{?with_clp: -DWITH_CLP=ON } \
  183. %{?with_va: -DWITH_VA=ON } \
  184. -DWITH_VTK=OFF \
  185. -DWITH_TBB=1 -DTBB_LIB_DIR=%{_libdir} \
  186. -DWITH_VULKAN=ON -DVULKAN_INCLUDE_DIRS=%{_includedir}/vulkan \
  187. ..
  188. make VERBOSE=1 %{?_smp_mflags}
  189. popd
  190. %install
  191. rm -rf %{buildroot}
  192. %make_install -C build
  193. find %{buildroot} -name '*.la' -delete
  194. rm -rf %{buildroot}%{_datadir}/OpenCV/licenses/
  195. %if %{with test}
  196. %check
  197. # Check fails since we don't support most video
  198. # read/write capability and we don't provide a display
  199. # ARGS=-V increases output verbosity
  200. pushd build
  201. cp %SOURCE5 .
  202. if [ -x /usr/libexec/Xorg ]; then
  203. Xorg=/usr/libexec/Xorg
  204. else
  205. Xorg=/usr/libexec/Xorg.bin
  206. fi
  207. $Xorg -noreset +extension GLX +extension RANDR +extension RENDER -logfile ./xorg.log -config ./xorg.conf -configdir . :99 &
  208. export DISPLAY=:99
  209. LD_LIBRARY_PATH=%{_builddir}/%{name}-%{version}/build/lib:$LD_LIBARY_PATH make test ARGS=-V || :
  210. popd
  211. %endif
  212. %clean
  213. rm -rf %{buildroot}
  214. %post core -p /sbin/ldconfig
  215. %postun core -p /sbin/ldconfig
  216. %post -p /sbin/ldconfig
  217. %postun -p /sbin/ldconfig
  218. %post contrib -p /sbin/ldconfig
  219. %postun contrib -p /sbin/ldconfig
  220. %files
  221. %doc README.md
  222. %{_bindir}/opencv_*
  223. %dir %{_datadir}/opencv4
  224. %{_datadir}/opencv4/haarcascades
  225. %{_datadir}/opencv4/lbpcascades
  226. %{_datadir}/opencv4/valgrind*
  227. %{_datadir}/opencv4/quality
  228. %files core
  229. %license LICENSE
  230. %{_datadir}/licenses/opencv4/
  231. %{_libdir}/libopencv_alphamat.so.*
  232. %{_libdir}/libopencv_core.so.*
  233. %{_libdir}/libopencv_cvv.so.*
  234. %{_libdir}/libopencv_features2d.so.*
  235. %{_libdir}/libopencv_flann.so.*
  236. %{_libdir}/libopencv_gapi.so.*
  237. %{_libdir}/libopencv_hfs.so.*
  238. %{_libdir}/libopencv_highgui.so.*
  239. %{_libdir}/libopencv_imgcodecs.so.*
  240. %{_libdir}/libopencv_imgproc.so.*
  241. %{_libdir}/libopencv_intensity_transform.so.*
  242. %{_libdir}/libopencv_ml.so.*
  243. %{_libdir}/libopencv_objdetect.so.*
  244. %{_libdir}/libopencv_photo.so.*
  245. %{_libdir}/libopencv_rapid.so.*
  246. %{_libdir}/libopencv_shape.so.*
  247. %{_libdir}/libopencv_stitching.so.*
  248. %{_libdir}/libopencv_superres.so.*
  249. %{_libdir}/libopencv_video.so.*
  250. %{_libdir}/libopencv_videoio.so.*
  251. %{_libdir}/libopencv_videostab.so.*
  252. %files devel
  253. %dir %{_includedir}/opencv4
  254. %{_includedir}/opencv4/opencv2
  255. %{_libdir}/lib*.so
  256. %{_libdir}/pkgconfig/opencv*.pc
  257. %{_libdir}/cmake/OpenCV/*.cmake
  258. %files -n python3-opencv
  259. %exclude %{_bindir}/setup_vars_opencv4.sh
  260. %{python3_sitearch}/cv2.cpython-3*.so
  261. %files contrib
  262. %{_libdir}/libopencv_aruco.so.*
  263. %{_libdir}/libopencv_bgsegm.so.*
  264. %{_libdir}/libopencv_bioinspired.so.*
  265. %{_libdir}/libopencv_calib3d.so.*
  266. %{_libdir}/libopencv_ccalib.so.*
  267. %{_libdir}/libopencv_datasets.so.*
  268. # needs protobuf
  269. #{_libdir}/libopencv_dnn.so.*
  270. #{_libdir}/libopencv_dnn_objdetect.so.*
  271. #{_libdir}/libopencv_dnn_superres.so.*
  272. %{_libdir}/libopencv_dpm.so.*
  273. %{_libdir}/libopencv_face.so.*
  274. %{_libdir}/libopencv_freetype.so.*
  275. %{_libdir}/libopencv_fuzzy.so.*
  276. # needs hdf5
  277. #{_libdir}/libopencv_hdf.so.*
  278. %{_libdir}/libopencv_img_hash.so.*
  279. %{_libdir}/libopencv_line_descriptor.so.*
  280. %{_libdir}/libopencv_optflow.so.*
  281. %{_libdir}/libopencv_phase_unwrapping.so.*
  282. %{_libdir}/libopencv_plot.so.*
  283. %{_libdir}/libopencv_reg.so.*
  284. %{_libdir}/libopencv_rgbd.so.*
  285. %{_libdir}/libopencv_quality.so.*
  286. %{_libdir}/libopencv_saliency.so.*
  287. %{_libdir}/libopencv_stereo.so.*
  288. %{_libdir}/libopencv_structured_light.so.*
  289. %{_libdir}/libopencv_surface_matching.so.*
  290. # needs tesseract
  291. #{_libdir}/libopencv_text.so.*
  292. %{_libdir}/libopencv_tracking.so.*
  293. %{_libdir}/libopencv_ximgproc.so.*
  294. %{_libdir}/libopencv_xobjdetect.so.*
  295. %{_libdir}/libopencv_xphoto.so.*
  296. %changelog
  297. * Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.4.0-1
  298. - new upstream release.
  299. - enabled vulkan compute backend
  300. * Tue Jun 30 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.0-1
  301. - new upstream release.
  302. * Mon Mar 27 2017 Daisuke SUZUKI <daisuke@vinelinux.org> 2.4.9-8
  303. - use eigen2 on Vine Linux 6.x
  304. - disable tbb/v4l on Vine Linux 6.x
  305. * Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> 2.4.9-7
  306. - rebuild with gcc-5.4.0
  307. * Wed Mar 4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.4.9-6
  308. - built with tbb
  309. - moved main package to System Environment/Libraries Group
  310. * Fri Feb 20 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.4.9-5
  311. - Initial build for Vine Linux
  312. * Tue Nov 25 2014 Rex Dieter <rdieter@fedoraproject.org> 2.4.9-4
  313. - rebuild (openexr)
  314. * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.9-3
  315. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  316. * Fri Jul 25 2014 Rex Dieter <rdieter@fedoraproject.org> 2.4.9-2
  317. - backport support for GStreamer 1 (#1123078)
  318. * Thu Jul 03 2014 Nicolas Chauvet <kwizart@gmail.com> - 2.4.9-1
  319. - Update to 2.4.9
  320. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.7-7
  321. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  322. * Sat Apr 26 2014 Rex Dieter <rdieter@fedoraproject.org> 2.4.7-6
  323. - revert pkgcmake2 patch (#1070428)
  324. * Fri Jan 17 2014 Nicolas Chauvet <kwizart@gmail.com> - 2.4.7-5
  325. - Fix opencv_ocl isn't part of -core
  326. * Thu Jan 16 2014 Christopher Meng <rpm@cicku.me> - 2.4.7-4
  327. - Enable OpenCL support.
  328. - SPEC small cleanup.
  329. * Wed Nov 27 2013 Rex Dieter <rdieter@fedoraproject.org> 2.4.7-3
  330. - rebuild (openexr)
  331. * Mon Nov 18 2013 Rex Dieter <rdieter@fedoraproject.org> 2.4.7-2
  332. - OpenCV cmake configuration broken (#1031312)
  333. * Wed Nov 13 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.7-1
  334. - Update to 2.4.7
  335. * Sun Sep 08 2013 Rex Dieter <rdieter@fedoraproject.org> 2.4.6.1-2
  336. - rebuild (openexr)
  337. * Wed Jul 24 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.6.1-1
  338. - Update to 2.4.6.1
  339. * Thu May 23 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.5-1
  340. - Update to 2.4.5-clean
  341. - Spec file clean-up
  342. - Split core libraries into a sub-package
  343. * Sat May 11 2013 François Cami <fcami@fedoraproject.org> - 2.4.4-3
  344. - change project URL.
  345. * Tue Apr 02 2013 Tom Callaway <spot@fedoraproject.org> - 2.4.4-2
  346. - make clean source without SIFT/SURF
  347. * Sat Mar 23 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.4-1
  348. - Update to 2.4.4a
  349. - Fix ttb-devel architecture conditionals
  350. * Sun Mar 10 2013 Rex Dieter <rdieter@fedoraproject.org> 2.4.4-0.2.beta
  351. - rebuild (OpenEXR)
  352. * Mon Feb 18 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.4-0.1.beta
  353. - Update to 2.4.4 beta
  354. - Drop python-imaging also from requires
  355. - Drop merged patch for additionals codecs
  356. - Disable the java binding for now (untested)
  357. * Fri Jan 25 2013 Honza Horak <hhorak@redhat.com> - 2.4.3-7
  358. - Do not build with 1394 libs in rhel
  359. * Mon Jan 21 2013 Adam Tkac <atkac redhat com> - 2.4.3-6
  360. - rebuild due to "jpeg8-ABI" feature drop
  361. * Sun Jan 20 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.3-5
  362. - Add more FourCC for gstreamer - rhbz#812628
  363. - Allow to use python-pillow - rhbz#895767
  364. * Mon Nov 12 2012 Nicolas Chauvet <kwizart@gmail.com> - 2.4.3-3
  365. - Switch Build Type to ReleaseWithDebInfo to avoid -03
  366. * Sun Nov 04 2012 Nicolas Chauvet <kwizart@gmail.com> - 2.4.3-2
  367. - Disable SSE3 and allow --with sse3 build conditional.
  368. - Disable gpu module as we don't build cuda
  369. - Update to 2.4.3
  370. * Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.2-2
  371. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  372. * Mon Jul 09 2012 Honza Horak <hhorak@redhat.com> - 2.4.2-1
  373. - Update to 2.4.2
  374. * Fri Jun 29 2012 Honza Horak <hhorak@redhat.com> - 2.4.1-2
  375. - Fixed cmake script for generating opencv.pc file
  376. - Fixed OpenCVConfig script file
  377. * Mon Jun 04 2012 Nicolas Chauvet <kwizart@gmail.com> - 2.4.1-1
  378. - Update to 2.4.1
  379. - Rework dependencies - rhbz#828087
  380. Re-enable using --with tbb,opennpi,eigen2,eigen3
  381. * Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.1-8
  382. - Rebuilt for c++ ABI breakage
  383. * Mon Jan 16 2012 Nicolas Chauvet <kwizart@gmail.com> - 2.3.1-7
  384. - Update gcc46 patch for ARM FTBFS
  385. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.1-6
  386. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  387. * Mon Dec 05 2011 Adam Jackson <ajax@redhat.com> 2.3.1-5
  388. - Rebuild for new libpng
  389. * Thu Oct 20 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.3.1-4
  390. - Rebuilt for tbb silent ABI change
  391. * Mon Oct 10 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.3.1-3
  392. - Update to 2.3.1a
  393. * Mon Sep 26 2011 Dan Horák <dan[at]danny.cz> - 2.3.1-2
  394. - openni is exclusive for x86/x86_64
  395. * Fri Aug 19 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.3.1-1
  396. - Update to 2.3.1
  397. - Add BR openni-devel python-sphinx
  398. - Remove deprecated cmake options
  399. - Add --with cuda conditional (wip)
  400. - Disable make test (unavailable)
  401. * Thu May 26 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.2.0-6
  402. - Backport fixes from branch 2.2 to date
  403. * Tue May 17 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.2.0-5
  404. - Re-enable v4l on f15
  405. - Remove unused cmake options
  406. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.0-3
  407. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  408. * Wed Feb 02 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.2.0-2
  409. - Fix with gcc46
  410. - Disable V4L as V4L1 is disabled for Fedora 15
  411. * Thu Jan 06 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.2.0-1
  412. - Update to 2.2.0
  413. - Disable -msse and -msse2 on x86_32
  414. * Wed Aug 25 2010 Rex Dieter <rdieter@fedoraproject.org> - 2.1.0-5
  415. - -devel: include OpenCVConfig.cmake (#627359)
  416. * Thu Jul 22 2010 Dan Horák <dan[at]danny.cz> - 2.1.0-4
  417. - TBB is available only on x86/x86_64 and ia64
  418. * Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 2.1.0-3
  419. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  420. * Fri Jun 25 2010 Nicolas Chauvet <kwizart@gmail.com> - 2.1.0-2
  421. - Move samples from main to -devel
  422. - Fix spurious permission
  423. - Add BR tbb-devel
  424. - Fix CFLAGS
  425. * Fri Apr 23 2010 Nicolas Chauvet <kwizart@fedoraproject.org> - 2.1.0-1
  426. - Update to 2.1.0
  427. - Update libdir patch
  428. * Tue Apr 13 2010 Karel Klic <kklic@redhat.com> - 2.0.0-10
  429. - Fix nonstandard executable permissions
  430. * Tue Mar 09 2010 Karel Klic <kklic@redhat.com> - 2.0.0-9
  431. - apply the previously added patch
  432. * Mon Mar 08 2010 Karel Klic <kklic@redhat.com> - 2.0.0-8
  433. - re-enable testing on CMake build system
  434. - fix memory corruption in the gaussian random number generator
  435. * Sat Feb 27 2010 Haïkel Guémar <karlthered@gmail.com> - 2.0.0-7
  436. - replaced BR unicap-devel by libucil-devel (unicap split)
  437. * Thu Feb 25 2010 Haïkel Guémar <karlthered@gmail.com> - 2.0.0-6
  438. - use cmake build system
  439. - applications renamed to opencv_xxx instead of opencv-xxx
  440. - add devel-docs subpackage #546605
  441. - add OpenCVConfig.cmake
  442. - enable openmp build
  443. - enable old SWIG based python wrappers
  444. - opencv package is a good boy and use global instead of define
  445. * Tue Feb 16 2010 Karel Klic <kklic@redhat.com> - 2.0.0-5
  446. - Set CXXFLAXS without -match=i386 for i386 architecture #565074
  447. * Sat Jan 09 2010 Rakesh Pandit <rakesh@fedoraproject.org> - 2.0.0-4
  448. - Updated opencv-samples-Makefile (Thanks Scott Tsai) #553697
  449. * Wed Jan 06 2010 Karel Klic <kklic@redhat.com> - 2.0.0-3
  450. - Fixed spec file issues detected by rpmlint
  451. * Sun Dec 06 2009 Haïkel Guémar <karlthered@gmail.com> - 2.0.0-2
  452. - Fix autotools scripts (missing LBP features) - #544167
  453. * Fri Nov 27 2009 Haïkel Guémar <karlthered@gmail.com> - 2.0.0-1
  454. - Updated to 2.0.0
  455. - Removed upstream-ed patches
  456. - Ugly hack (added cvconfig.h)
  457. - Disable %%check on ppc64
  458. * Thu Sep 10 2009 Karsten Hopp <karsten@redhat.com> - 1.1.0-0.7.pre1
  459. - fix build on s390x where we don't have libraw1394 and devel
  460. * Thu Jul 30 2009 Haïkel Guémar <karlthered@gmail.com> - 1.1.0.0.6.pre1
  461. - Fix typo I introduced that prevented build on i386/i586
  462. * Thu Jul 30 2009 Haïkel Guémar <karlthered@gmail.com> - 1.1.0.0.5.pre1
  463. - Added 1394 libs and unicap support
  464. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-0.4.pre1
  465. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  466. * Thu Jul 16 2009 kwizart < kwizart at gmail.com > - 1.1.0-0.3.pre1
  467. - Build with gstreamer support - #491223
  468. - Backport gcc43 fix from trunk
  469. * Thu Jul 16 2009 kwizart < kwizart at gmail.com > - 1.1.0-0.2.pre1
  470. - Fix FTBFS #511705
  471. * Fri Apr 24 2009 kwizart < kwizart at gmail.com > - 1.1.0-0.1.pre1
  472. - Update to 1.1pre1
  473. - Disable CXXFLAGS hardcoded optimization
  474. - Add BR: python-imaging, numpy
  475. - Disable make check failure for now
  476. * Wed Apr 22 2009 kwizart < kwizart at gmail.com > - 1.0.0-14
  477. - Fix for gcc44
  478. - Enable BR jasper-devel
  479. - Disable ldconfig run on python modules (uneeded)
  480. - Prevent timestamp change on install
  481. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.0-13
  482. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  483. * Mon Dec 29 2008 Rakesh Pandit <rakesh@fedoraproject.org> - 1.0.0-12
  484. - fix URL field
  485. * Fri Dec 19 2008 Ralf Corsépius <corsepiu@fedoraproject.org> - 1.0.0-11
  486. - Adopt latest python spec rules.
  487. - Rebuild for Python 2.6 once again.
  488. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.0.0-10
  489. - Rebuild for Python 2.6
  490. * Thu May 22 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.0.0-9
  491. - fix license tag
  492. * Sun May 11 2008 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-8
  493. - Adjust library order in opencv.pc.in (BZ 445937).
  494. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.0-7
  495. - Autorebuild for GCC 4.3
  496. * Sun Feb 10 2008 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-6
  497. - Rebuild for gcc43.
  498. * Tue Aug 28 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 1.0.0-5
  499. - Rebuild for selinux ppc32 issue.
  500. * Wed Aug 22 2007 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-4
  501. - Mass rebuild.
  502. * Thu Mar 22 2007 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-3
  503. - Fix %%{_datadir}/opencv/samples ownership.
  504. - Adjust timestamp of cvconfig.h.in to avoid re-running autoheader.
  505. * Thu Mar 22 2007 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-2
  506. - Move all of the python module to pyexecdir (BZ 233128).
  507. - Activate the testsuite.
  508. * Mon Dec 11 2006 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-1
  509. - Upstream update.
  510. * Mon Dec 11 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.9-4
  511. - Remove python-abi.
  512. * Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 0.9.9-3
  513. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  514. * Thu Sep 21 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.9-2
  515. - Stop configure.in from hacking CXXFLAGS.
  516. - Activate testsuite.
  517. - Let *-devel require pkgconfig.
  518. * Thu Sep 21 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.9-1
  519. - Upstream update.
  520. - Don't BR: autotools.
  521. - Install samples' Makefile as GNUmakefile.
  522. * Thu Sep 21 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.7-18
  523. - Un'%%ghost *.pyo.
  524. - Separate %%{pythondir} from %%{pyexecdir}.
  525. * Thu Sep 21 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.7-17
  526. - Rebuild for FC6.
  527. - BR: libtool.
  528. * Fri Mar 17 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-16
  529. - Rebuild.
  530. * Wed Mar 8 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-15
  531. - Force a re-run of Autotools by calling autoreconf.
  532. * Wed Mar 8 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-14
  533. - Added build dependency on Autotools.
  534. * Tue Mar 7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-13
  535. - Changed intrinsics patch so that it matches upstream.
  536. * Tue Mar 7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-12
  537. - More intrinsics patch fixing.
  538. * Tue Mar 7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-11
  539. - Don't do "make check" because it doesn't run any tests anyway.
  540. - Back to main intrinsics patch.
  541. * Tue Mar 7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-10
  542. - Using simple intrinsincs patch.
  543. * Tue Mar 7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-9
  544. - Still more fixing of intrinsics patch for Python bindings on x86_64.
  545. * Tue Mar 7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-8
  546. - Again fixed intrinsics patch so that Python modules build on x86_64.
  547. * Tue Mar 7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-7
  548. - Fixed intrinsics patch so that it works.
  549. * Tue Mar 7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-6
  550. - Fixed Python bindings location on x86_64.
  551. * Mon Mar 6 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-5
  552. - SSE2 support on x86_64.
  553. * Mon Mar 6 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-4
  554. - Rebuild
  555. * Sun Oct 16 2005 Simon Perreault <nomis80@nomis80.org> - 0.9.7-3
  556. - Removed useless sample compilation makefiles/project files and replaced them
  557. with one that works on Fedora Core.
  558. - Removed shellbang from Python modules.
  559. * Mon Oct 10 2005 Simon Perreault <nomis80@nomis80.org> - 0.9.7-2
  560. - Made FFMPEG dependency optional (needs to be disabled for inclusion in FE).
  561. * Mon Oct 10 2005 Simon Perreault <nomis80@nomis80.org> - 0.9.7-1
  562. - Initial package.