qjson-vl.spec 4.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139
  1. Name: qjson
  2. Summary: A qt-based library that maps JSON data to QVariant objects
  3. Summary(ja): JSON データ を QVariant Object にマッピングするためのライブラリ
  4. Version: 0.7.1
  5. Release: 6%{?_dist_release}
  6. Group: System Environment/Libraries
  7. License: GPLv2+
  8. URL: http://sourceforge.net/projects/qjson/
  9. Source0: http://downloads.sourceforge.net/project/qjson/qjson/0.7.1/%{name}-%{version}.tar.bz2
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. BuildRequires: cmake >= 2.6
  12. BuildRequires: qt4-devel
  13. BuildRequires: doxygen
  14. %description
  15. JSON is a lightweight data-interchange format. It can represents integer, real
  16. number, string, an ordered sequence of value, and a collection of
  17. name/value pairs.QJson is a qt-based library that maps JSON data to
  18. QVariant objects.
  19. %package devel
  20. Summary: Development files for qjson
  21. Summary(ja): qjson の開発用ファイル
  22. Group: Development/Libraries
  23. Requires: %{name} = %{version}-%{release}
  24. Requires: qt4-devel
  25. %description devel
  26. The %{name}-devel package contains the libraries and header files required for
  27. developing applications that use %{name}.
  28. %prep
  29. %setup -qn qjson
  30. %build
  31. mkdir -p %{_target_platform}
  32. pushd %{_target_platform}
  33. %cmake -DQJSON_BUILD_TESTS=1 \
  34. -DCMAKE_MODULES_INSTALL_DIR=%{_datadir}/cmake/Modules/ \
  35. ..
  36. cd %{_builddir}/%{buildsubdir}/doc
  37. doxygen
  38. popd
  39. sed -i -e 's/-fno-exceptions -fno-check-new -fno-common//' \
  40. -e 's/-fno-threadsafe-statics -fvisibility=hidden -fvisibility-inlines-hidden//' \
  41. -e 's/-ansi//' %{_target_platform}/src/CMakeFiles/qjson.dir/flags.make
  42. make %{?_smp_mflags} -C %{_target_platform}
  43. %install
  44. rm -rf %{buildroot}
  45. make install DESTDIR=%{buildroot} -C %{_target_platform}
  46. %check
  47. LD_PRELOAD=%{_target_platform}/%{_lib}/libqjson.so \
  48. %{_target_platform}/tests/testparser
  49. LD_PRELOAD=%{_target_platform}/%{_lib}/libqjson.so \
  50. %{_target_platform}/tests/testserializer
  51. %clean
  52. rm -rf %{buildroot}
  53. %post -p /sbin/ldconfig
  54. %postun -p /sbin/ldconfig
  55. %files
  56. %defattr(-,root,root,-)
  57. %doc COPYING
  58. %{_libdir}/*.so.*
  59. %files devel
  60. %defattr(-,root,root,-)
  61. %doc doc/html
  62. %{_includedir}/qjson/
  63. %{_libdir}/pkgconfig/*.pc
  64. %{_datadir}/cmake/Modules/FindQJSON.cmake
  65. %{_libdir}/*.so
  66. %changelog
  67. * Thu Jan 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.1-6
  68. - added Japanese summary
  69. * Mon Sep 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.1-5
  70. - rebuilt with rpm-4.8.1
  71. * Sun Aug 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.1-4
  72. - re-fixed CMAKE_MODULES_INSTALL_DIR
  73. * Tue Aug 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.1-3
  74. - fixed CMAKE_MODULES_INSTALL_DIR
  75. * Sun Aug 15 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.1-2
  76. - initial build for Vine Linux
  77. * Sat Dec 12 2009 Eli Wapniarski <eli@orbsky.homelinux.org> 0.7.1-1
  78. -0.7.1
  79. - Version upgrade
  80. - Fixed doxygen documentation (Thanks again Orcan)
  81. * Tue Dec 8 2009 Eli Wapniarski <eli@orbsky.homelinux.org> 0.6.3-6
  82. -0.6.3
  83. - Fixed capitalization of the summary
  84. * Tue Dec 8 2009 Eli Wapniarski <eli@orbsky.homelinux.org> 0.6.3-5
  85. -0.6.3
  86. - Moved Doxygen docs to the development package.
  87. - Corrected placement of the cmake project file (Thanks Orcan)
  88. - Fixed the running of the build tests
  89. - Corrected column length of the descriptions
  90. - Changed description of the devlepment package
  91. * Sun Dec 6 2009 Eli Wapniarski <eli@orbsky.homelinux.org> 0.6.3-4
  92. -0.6.3
  93. - Additional placment of library files fix
  94. * Fri Dec 4 2009 Eli Wapniarski <eli@orbsky.homelinux.org> 0.6.3-3
  95. -0.6.3
  96. - Fixed placment of library files
  97. - Activated build tests
  98. - Corrected ownership of include directory
  99. - Corrected dependacies
  100. - Added doxygen documentation
  101. - Fixed reported version in the changelogs
  102. * Sun Nov 22 2009 Eli Wapniarski <eli@orbsky.homelinux.org> 0.6.3-2
  103. -0.6.3
  104. - Split off development libraries to its own package
  105. - Modified licensing in spec file to reflect GPL2 code though docs state that qjson
  106. - licensed under LPGL
  107. - Uncommeted and corrected sed line in this spec file
  108. * Sun Nov 22 2009 Eli Wapniarski <eli@orbsky.homelinux.org> 0.6.3-1
  109. -0.6.3
  110. - Initial Build