WMSoundSet-vl.spec 6.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252
  1. %define pversion 1.1.1
  2. %define sversion 0.4.0
  3. %define wsprefs WSoundPrefs-%{pversion}
  4. %define wmsound WSoundServer-%{sversion}
  5. Summary: Sound tools for WindowMaker
  6. Summary(ja): Window Maker 用のサウンド・ツール
  7. Name: WMSoundSet
  8. Version: %{pversion}
  9. License: GPL2 & OPL
  10. Release: 2%{?_dist_release}
  11. Group: User Interface/Desktops
  12. Source0: %{wsprefs}.tar.bz2
  13. Source1: %{wmsound}.tar.bz2
  14. Source2: wmsdefault.tar.gz
  15. Source3: VineSounds.tar.gz
  16. Source5: WSoundPrefs-%{pversion}.ja.po
  17. Patch0: patch-af
  18. Patch1: WSoundServer-0.4.0-WM-0.92.patch
  19. Patch2: WSoundServer-0.4.0-config.x86_64.patch
  20. Patch10: WSoundPrefs-%{pversion}-nls.vine.patch
  21. Patch11: WSoundPrefs-1.1.1-wsound.patch
  22. Patch12: WSoundPrefs-1.1.1-fix.patch
  23. Patch13: WSoundPrefs-1.1.1-WM-0.92.patch
  24. BuildRequires: xorg-x11-devel imake
  25. BuildRequires: WindowMaker-devel >= 0.92.0
  26. BuildRequires: audiofile-devel
  27. Requires: WindowMaker >= 0.92.0
  28. Buildroot: %{_tmppath}/%{name}-%{version}-root
  29. %description
  30. Sound tools for WindowMaker:
  31. WSoundPrefs-%{pversion}
  32. WSoundServer-%{sversion}
  33. wmsdefault (default sound set)
  34. %description -l ja
  35. Window Maker で 効果音の設定等を可能にするツール集です.
  36. 以下を収録しています.
  37. WSoundPrefs-%{pversion}
  38. WSoundServer-%{sversion}
  39. wmsdefault (wmsoundデフォルトの音源)
  40. WindowMaker-0.92 以上に対応しています.
  41. %prep
  42. %setup -q -a 1 -a 3 -c -n WMSoundSet
  43. cd %{wmsound}
  44. %patch0 -p0 -b .patch-af
  45. %patch1 -p0 -b .WM-0.92~
  46. %patch2 -p0 -b .x86_64~
  47. cd ..
  48. cd %{wsprefs}
  49. %patch10 -p1 -b .nls.vine
  50. %patch11 -p0 -b .wsound
  51. %patch12 -p1 -b .fix
  52. %patch13 -p1 -b .WM-0.92
  53. cp %SOURCE5 po/ja.po
  54. cd ..
  55. %build
  56. # make WSoundServer
  57. pushd %{wmsound}
  58. %configure --x-libraries=%{_libdir} --x-includes=%{_includedir}/X11
  59. make
  60. popd
  61. # make WSoundPrefs
  62. pushd %{wsprefs}
  63. cp ../%{wmsound}/wslib/{get-wsound-flags,wsound.h} src/
  64. IMAKEINCLUDE="-I%{_datadir}/X11/config" xmkmf -a
  65. touch src/WSoundPrefs.man
  66. PATH=$PATH:. make\
  67. PREFIX=%{_libdir}\
  68. EXTRA_DEFINES="-DI18N -DHAVE_LIBINTL_H"\
  69. EXTRA_INCLUDES=-I../../%{wmsound}/wslib\
  70. EXTRA_LIBRARIES=-L../../%{wmsound}/wslib/.libs/
  71. make -C po
  72. popd
  73. %install
  74. %define SYSDEFDIR $RPM_BUILD_ROOT/etc/X11/WindowMaker
  75. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  76. # Install WSoundPrefs
  77. cd %{wsprefs}
  78. make install PREFIX=$RPM_BUILD_ROOT%{_prefix}/lib/GNUstep
  79. mkdir -p $RPM_BUILD_ROOT%{_localedir}/ja/LC_MESSAGES/
  80. make nlsdir=$RPM_BUILD_ROOT%{_localedir} -C po install
  81. cd ..
  82. # Install wmsound
  83. cd %{wmsound}
  84. %makeinstall
  85. cd ..
  86. # Install default sounds
  87. mkdir -p $RPM_BUILD_ROOT%{_datadir}/WindowMaker
  88. tar xzvf %{SOURCE2} -C $RPM_BUILD_ROOT%{_datadir}/WindowMaker
  89. # install configurations
  90. mkdir -p %{SYSDEFDIR}
  91. mkdir -p $RPM_BUILD_ROOT%{_datadir}/WindowMaker/{Sounds,SoundSets}
  92. (
  93. cd VineSounds
  94. for i in Sounds SoundSets ; do
  95. cp $i/* $RPM_BUILD_ROOT%{_datadir}/WindowMaker/$i/
  96. done
  97. cd Defaults
  98. cp * %{SYSDEFDIR}
  99. )
  100. # prepare documents with preserving time stamps
  101. mkdir -p doc/WSoundPrefs
  102. cp -p %{wsprefs}/{AUTHORS,ChangeLog,COPYING*,INSTALL} doc/WSoundPrefs
  103. mkdir -p doc/WSoundServer
  104. cp -p %{wmsound}/{AUTHORS,COPYING,ChangeLog,INSTALL,NEWS,README} doc/WSoundServer
  105. # remove files
  106. rm -f $RPM_BUILD_ROOT%{_libdir}/libwsound.la
  107. %clean
  108. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  109. %files
  110. %defattr(-,root,root)
  111. %doc doc/*
  112. %{_sysconfdir}/X11/WindowMaker/*
  113. %{_prefix}/lib/GNUstep/Applications/WSoundPrefs.app/
  114. %{_includedir}/wsound.h
  115. %{_libdir}/libwsound.a
  116. %{_libdir}/libwsound.so*
  117. #%{_libdir}/libwsound.la
  118. %{_localedir}/ja/LC_MESSAGES/WSoundPrefs.mo
  119. %{_datadir}/WindowMaker/Sounds/
  120. %{_datadir}/WindowMaker/SoundSets/
  121. %{_bindir}/get-wsound-flags
  122. %{_bindir}/wsoundserver
  123. %{_bindir}/wsoundplay
  124. %{_bindir}/getsoundset
  125. %{_bindir}/setsoundset
  126. %{_mandir}/man1/get-wsound-flags.1x*
  127. %{_mandir}/man1/getsoundset.1x*
  128. %{_mandir}/man1/setsoundset.1x*
  129. %{_mandir}/man1/wsoundplay.1x*
  130. %{_mandir}/man1/wsoundserver.1x*
  131. %changelog
  132. * Mon Feb 22 2010 Shu KONNO <owa@bg.wakwak.com> 1.1.1-2
  133. - added BR: audiofile-devel
  134. - rebuilt with new environment
  135. * Tue Jun 03 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.1-1vl5
  136. - applied new versioning policy and utf-8
  137. - added BuildRequires: xorg-x11-devel imake
  138. - set IMAKEINCLUDE to xmkmf
  139. * Wed Aug 02 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.1-0vl9
  140. - changed Group to User Interface/Desktops
  141. * Tue Mar 07 2006 Shu KONNO <owa@bg.wakwak.com> 1.1.1-0vl8
  142. - added WSoundServer-0.4.0-config.x86_64.patch
  143. - rebuilt for x86_64 architecture support
  144. * Sat Feb 25 2006 Shu KONNO <owa@bg.wakwak.com> 1.1.1-0vl7
  145. - rebuilt for VineSeed
  146. * Sun Nov 13 2005 Shu KONNO <owa@bg.wakwak.com> 1.1.1-0vl6
  147. - added WSoundServer-0.4.0.WM-0.92.patch
  148. - added WSoundPrefs-1.1.1.WM-0.92.patch
  149. - added %{_mandir}/man1/get-wsound-flags.1x*
  150. - changed encoding to utf-8 of WSoundPrefs-1.1.1.ja.po
  151. - changed app path with '/usr/X11R6/lib/GNUstep/Applications/WSoundPrefs.app'
  152. - rebuilt for WindowMaker-0.92.0
  153. * Fri Dec 20 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.1-0vl5
  154. - rebuilt for VineSeed
  155. * Fri Dec 20 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.1-0vl4.2
  156. - added Patch3 for better compatibility with WindowMaker-0.80.2
  157. * Fri Dec 20 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.1-0vl4.1
  158. - rebuilt with WindowMaker-0.80.2
  159. * Wed Jul 18 2001 <sagami@vinelinux.org>
  160. - 1.1.1-0vl4: erase unneeded files in %%doc and minor spec fixes
  161. - added patch to build with current audiofile.h in audiofile-0.2.1
  162. - added patch to include wsound.h correctly
  163. * Tue Jan 23 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  164. - 1.1.1-0vl3
  165. - use better macros
  166. - added forgotten %%clean section
  167. * Fri Sep 08 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  168. - 1.1.1-0vl2
  169. - modified %files section to handle compressed man page(s)
  170. * Sun Apr 2 2000 Jun Nishii <jun@vinelinux.org>
  171. - WMSoundSet-1.1.1
  172. - WSoundPrefs-1.1.1, WSoundServer-0.4.0
  173. - requires WindowMaker >= 0.62.1
  174. * Thu Oct 14 1999 Jun Nishii <jun@vinelinux.org>
  175. - WMSoundSet-1.0-1
  176. - build for Vine-1.9
  177. - WSoundPrefs-1.1.0, WSoundServer-0.2.1
  178. - requires WindowMaker >= 0.61.1
  179. * Sat Mar 27 1999 Jun Nishii <jun@vinelinux.org>
  180. - added new sounds and use them as a default set
  181. * Sun Mar 14 1999 Jun Nishii <jun@vinelinux.org>
  182. - remove requires WindowMaker >= 0.51.2
  183. * Sun Mar 14 1999 Jun Nishii <jun@vinelinux.org>
  184. - updated WSoundPrefs to 0.9.3
  185. * Sun Mar 7 1999 Jun Nishii <jun@vinelinux.org>
  186. - updated WSoundPrefs to 0.9.2
  187. - updated wmsound to 0.9.3
  188. * Tue Feb 24 1999 Jun Nishii <jun@vinelinux.org>
  189. - updated wmsound to 0.9.2
  190. - added Japanese summary and description
  191. - change Group name
  192. * Tue Feb 2 1999 Jun Nishii <jun@vinelinux.org>
  193. - updated to 0.9.1
  194. * Sat Dec 19 1998 Jun Nishii <jun@vinelinux.org>
  195. - modify ja.po
  196. * Thu Dec 17 1998 Jun Nishii <jun@vinelinux.org>
  197. - merge ja.po
  198. * Sat Dec 12 1998 Jun Nishii <jun@vinelinux.org>
  199. - use /dev/dsp as a default audio device