nemiver-vl.spec 5.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166
  1. %define build_vine5 0
  2. %if "%{?_dist_release}" == "vl5"
  3. %define build_vine5 1
  4. %endif
  5. Summary: Standalone graphical debugger for GNOME
  6. Summary(ja): GNOME 向けの GUI デバッガ
  7. Name: nemiver
  8. Version: 0.8.0
  9. Release: 1%{?_dist_release}
  10. Source0: %{name}-%{version}.tar.bz2
  11. Patch0: nemiver-0.8.0-below-gtkmm2.18.0.patch
  12. License: GPLv2
  13. Group: Applications/Development
  14. URL: http://projects.gnome.org/nemiver/
  15. Requires: gdb
  16. Requires: ghex > 2.21.4
  17. Requires(pre): GConf2
  18. Requires(post): GConf2, desktop-file-utils, scrollkeeper
  19. Requires(postun):GConf2, desktop-file-utils, scrollkeeper
  20. BuildRequires: ghex > 2.21.4
  21. BuildRequires: gdb
  22. BuildRequires: gnome-doc-utils >= 0.3.2
  23. BuildRequires: gtkmm2-devel >= 2.14.0
  24. BuildRequires: gtksourceviewmm-devel >= 1.9.4
  25. BuildRequires: libgtop2-devel >= 2.14
  26. BuildRequires: vte-devel >= 0.12.0
  27. BuildRequires: GConf2-devel >= 2.14.0
  28. BuildRequires: sqlite3-devel >= 3.0
  29. BuildRequires: libboost-devel >= 1.33.1
  30. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  31. Packager: kazutaka
  32. %description
  33. Nemiver is a standalone graphical debugger that integrates well in the
  34. GNOME desktop environment. It currently features a backend which uses
  35. the GNU debugger GDB for debugging C/C++ programs.
  36. %description -l ja
  37. Nemiver は GNOME デスクトップ向けのスタンドアローンな GUI デバッガです。
  38. C/C++ プログラムのデバッグのバックエンドには GDB (GNU デバッガ)を利用
  39. しています。
  40. %package devel
  41. Summary: Libraries and headers for %{name}
  42. Summary(ja): %{name} 用の開発ライブラリおよびヘッダファイル
  43. Group: Development/Libraries
  44. Requires: %{name} = %{version}
  45. %description devel
  46. This package includes the files needed for developing and compiling
  47. applications which use the %{name} library.
  48. You should install the %{name}-devel package if you would like to
  49. develop applications using %{name}.
  50. %description devel -l ja
  51. このパッケージは %{name} ライブラリを使用するアプリケーションを開発
  52. するのに必要なライブラリやヘッダファイルを含んでいます。
  53. %{name} を使用したアプリケーションを開発するなら、このパッケージ
  54. をインストールしてください。
  55. %prep
  56. %setup -q
  57. %if %{build_vine5}
  58. %patch0 -p1 -b .below-gtkmm218
  59. %endif
  60. %build
  61. %configure --disable-static \
  62. --disable-scrollkeeper \
  63. --disable-schemas-install
  64. %{__make} %{?_smp_mflags}
  65. %install
  66. %{__rm} -rf $RPM_BUILD_ROOT
  67. %{__make} install DESTDIR=$RPM_BUILD_ROOT
  68. %find_lang %{name}
  69. # remove unnecessary files
  70. find $RPM_BUILD_ROOT/%{_libdir} -name "*.la" -exec %{__rm} -f "{}" \;
  71. %clean
  72. %{__rm} -rf $RPM_BUILD_ROOT
  73. %pre
  74. # uninstall old schemas before update
  75. if [ "$1" -gt 1 ]; then
  76. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  77. SCHEMAS="nemiver-dbgperspective.schemas nemiver-workbench.schemas"
  78. for S in $SCHEMAS; do
  79. echo %{_sysconfdir}/gconf/schemas/$S ; done \
  80. | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null ||:
  81. fi
  82. %post
  83. update-desktop-database %{_datadir}/applications >& /dev/null ||:
  84. scrollkeeper-update > /dev/null 2>&1 || :
  85. touch --no-create %{_datadir}/icons/hicolor
  86. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  87. /usr/bin/gtk-update-icon-cache -q %{_datadir}/icons/hicolor ||:
  88. fi
  89. # install schemas after install/update
  90. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  91. SCHEMAS="nemiver-dbgperspective.schemas nemiver-workbench.schemas"
  92. for S in $SCHEMAS; do
  93. echo %{_sysconfdir}/gconf/schemas/$S ; done \
  94. | xargs gconftool-2 --makefile-install-rule >& /dev/null ||:
  95. %preun
  96. # uninstall schemas before clean remove
  97. if [ "$1" -eq 0 ]; then
  98. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  99. SCHEMAS="nemiver-dbgperspective.schemas nemiver-workbench.schemas"
  100. for S in $SCHEMAS; do
  101. echo %{_sysconfdir}/gconf/schemas/$S ; done \
  102. | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null ||:
  103. fi
  104. %postun
  105. update-desktop-database %{_datadir}/applications >& /dev/null ||:
  106. scrollkeeper-update > /dev/null 2>&1 || :
  107. touch --no-create %{_datadir}/icons/hicolor
  108. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  109. /usr/bin/gtk-update-icon-cache -q %{_datadir}/icons/hicolor ||:
  110. fi
  111. %files -f %{name}.lang
  112. %defattr(-,root,root)
  113. %doc AUTHORS COPYING COPYRIGHT ChangeLog INSTALL NEWS
  114. %doc README TODO
  115. %{_bindir}/%{name}
  116. %{_libdir}/%{name}
  117. %{_datadir}/%{name}
  118. %{_datadir}/applications/%{name}.desktop
  119. %{_datadir}/icons/hicolor/16x16/apps/%{name}.png
  120. %{_datadir}/icons/hicolor/22x22/apps/%{name}.png
  121. %{_datadir}/icons/hicolor/24x24/apps/%{name}.png
  122. %{_datadir}/icons/hicolor/32x32/apps/%{name}.png
  123. %{_datadir}/icons/hicolor/48x48/apps/%{name}.png
  124. %{_datadir}/icons/hicolor/scalable/apps/%{name}.svg
  125. %{_datadir}/gnome/help/%{name}
  126. %{_datadir}/omf/%{name}
  127. %{_mandir}/man1/nemiver.1*
  128. %{_sysconfdir}/gconf/schemas/nemiver-dbgperspective.schemas
  129. %{_sysconfdir}/gconf/schemas/nemiver-workbench.schemas
  130. %files devel
  131. %{_includedir}/%{name}
  132. %changelog
  133. * Sun Oct 24 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 0.8.0-1
  134. - initial build for Vine Linux
  135. - add patch0 to fix compile error with gtkmm-2.14 (for Vine Linux 5)