newt-vl.spec 10.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  3. Summary: A development library for text mode user interfaces.
  4. Summary(ja): テキストモードインターフェースのための開発ライブラリ
  5. Name: newt
  6. Version: 0.52.10
  7. Release: 6%{?_dist_release}
  8. License: LGPL
  9. Group: System Environment/Libraries
  10. URL: https://fedorahosted.org/newt/
  11. Source: https://fedorahosted.org/releases/n/e/newt/newt-%{version}.tar.gz
  12. # Security fix
  13. Patch100: newt-0.52.10-reflowbuffer.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. Vendor: Project Vine
  16. Distribution: Vine Linux
  17. Packager: Daisuke SUZUKI <daisuke@linux.or.jp>
  18. BuildRequires: python-devel, popt-devel, slang-devel
  19. Provides: snack = %{version}-%{release}
  20. %description
  21. Newt is a programming library for color text mode, widget based user
  22. interfaces. Newt can be used to add stacked windows, entry widgets,
  23. checkboxes, radio buttons, labels, plain text fields, scrollbars,
  24. etc., to text mode user interfaces. This package also contains the
  25. shared library needed by programs built with newt, as well as a
  26. /usr/bin/dialog replacement called whiptail. Newt is based on the
  27. slang library.
  28. %package devel
  29. Summary: Newt windowing toolkit development files.
  30. Summary(ja): Newt ウィンドウツールキット開発ファイル集
  31. Requires: slang-devel %{name} = %{version}
  32. Group: Development/Libraries
  33. %description devel
  34. The newt-devel package contains the header files and libraries
  35. necessary for developing applications which use newt. Newt is a
  36. development library for text mode user interfaces. Newt is based on
  37. the slang library.
  38. Install newt-devel if you want to develop applications which will use
  39. newt.
  40. ## to build compat32 for x86_64 architecture support
  41. %package -n compat32-%{name}
  42. Summary: A development library for text mode user interfaces.
  43. Group: System Environment/Libraries
  44. %description -n compat32-%{name}
  45. Newt is a programming library for color text mode, widget based user
  46. interfaces. Newt can be used to add stacked windows, entry widgets,
  47. checkboxes, radio buttons, labels, plain text fields, scrollbars,
  48. etc., to text mode user interfaces. This package also contains the
  49. shared library needed by programs built with newt, as well as a
  50. /usr/bin/dialog replacement called whiptail. Newt is based on the
  51. slang library.
  52. %package -n compat32-%{name}-devel
  53. Summary: Newt windowing toolkit development files.
  54. Group: Development/Libraries
  55. Requires: compat32-%{name} = %{version}
  56. %description -n compat32-%{name}-devel
  57. The newt-devel package contains the header files and libraries
  58. necessary for developing applications which use newt. Newt is a
  59. development library for text mode user interfaces. Newt is based on
  60. the slang library.
  61. Install newt-devel if you want to develop applications which will use
  62. newt.
  63. %prep
  64. %setup -q -n %{name}-%{version}
  65. %patch100 -p1 -b .CVE-2009-2905
  66. %build
  67. %if %{build_compat32}
  68. export CC='gcc -m32'
  69. %configure --without-tcl
  70. make CC='gcc -m32'
  71. #make CC='gcc -m32' shared
  72. %else
  73. %configure --without-tcl
  74. make
  75. make shared
  76. %endif
  77. chmod 0644 peanuts.py popcorn.py
  78. %install
  79. rm -rf $RPM_BUILD_ROOT
  80. make instroot=$RPM_BUILD_ROOT install
  81. %find_lang %{name}
  82. %post -p /sbin/ldconfig
  83. %postun -p /sbin/ldconfig
  84. %if %{build_compat32}
  85. %post -n compat32-%{name} -p /sbin/ldconfig
  86. %postun -n compat32-%{name} -p /sbin/ldconfig
  87. %endif
  88. %clean
  89. rm -rf $RPM_BUILD_ROOT
  90. %files -f %{name}.lang
  91. %defattr (-,root,root)
  92. %doc CHANGES COPYING
  93. %{_libdir}/libnewt.so.*
  94. %{_bindir}/whiptail
  95. %{python_sitearch}/*.py*
  96. %{python_sitearch}/*.so
  97. %{_mandir}/man1/whiptail.1*
  98. %files devel
  99. %defattr (-,root,root)
  100. %doc tutorial.sgml peanuts.py popcorn.py
  101. %{_includedir}/newt.h
  102. %{_libdir}/libnewt.a
  103. %{_libdir}/libnewt.so
  104. %if %{build_compat32}
  105. %files -n compat32-%{name}
  106. %defattr (-,root,root)
  107. %{_libdir}/libnewt.so.*
  108. %{python_sitearch}/*.py*
  109. %{python_sitearch}/*.so
  110. %files -n compat32-%{name}-devel
  111. %defattr (-,root,root)
  112. %{_libdir}/libnewt.a
  113. %{_libdir}/libnewt.so
  114. %endif
  115. %changelog
  116. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.52.10-6
  117. - rebuilt with gcc-4.4.3-3 on ppc
  118. * Fri Feb 5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.52.10-5
  119. - rebuilt with rpm-4.8.0-3 (on ppc)
  120. * Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.52.10-4
  121. - rebuilt with python-2.6.4
  122. * Thu Oct 8 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.52.10-3
  123. - fix build_compat32 if-endif
  124. * Sat Sep 26 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.52.10-2
  125. - add patch100 for fix CVE-2009-2905 (textbox BoF) from fc10
  126. * Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.52.10-1
  127. - new upstream release
  128. - use %%python_sitearch macro
  129. - remove --with-gpm-support
  130. - drop obsolete patches
  131. * Sun Aug 20 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.50.35-0vl6
  132. - rebuild to fix dependency problem on x86_64 architecture
  133. * Thu Feb 16 2006 Shu KONNO <owa@bg.wakwak.com> 0.50.35-0vl5
  134. - added BuildRequires: slang-devel
  135. - added newt-0.50.35-Makefile.in.patch
  136. - updated newt-0.50.35-make.patch
  137. - changed /usr/lib to %%{_libdir}
  138. - added compat32-* packages for x86_64 architecture support
  139. * Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 0.50.35-0vl4
  140. - rebuild with python-2.4.1-0vl1
  141. * Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 0.50.35-0vl3
  142. - rebuild with python-2.3.3-0vl1
  143. * Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 0.50.35-0vl2.1
  144. - rebuild with python-2.3.3-0vl0.3 (for TestPkg)
  145. * Wed Jan 29 2003 Tomoya TAKA <taka@vinelinux.org> 0.50.35-0vl2
  146. - build against python-2.2
  147. - drop Patch20
  148. * Thu Oct 10 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.50.35-0vl1
  149. - updated to new upstream release 0.50.35
  150. - updated Patch11 and added Patch20
  151. (Patch20 is for python 1.5: REMOVE IT WHEN WE DECIDED TO GO WITH PYTHON2)
  152. * Sat Mar 09 2002 Tomoya TAKA <taka@vinelinux.org> 0.50.33-0vl1
  153. - update to new upstream release
  154. * Mon Jul 2 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp>
  155. - 0.50.22-0vl1
  156. - updated to 0.50.22
  157. - use Release No for Vine Linux
  158. - use better macros
  159. - bytecompile the snack python module
  160. * Wed Sep 29 1999 Norihito Ohmori <ohmori@flatout.rog>
  161. - fix spec file
  162. * Sun Sep 11 1999 Norihito Ohmori <ohmori@flatout.org>
  163. - added Japanese support patch
  164. * Wed Sep 01 1999 Erik Troan <ewt@redhat.com>
  165. - added suspend/resume to snack
  166. * Tue Aug 31 1999 Matt Wilson <msw@redhat.com>
  167. - enable gpm support
  168. * Fri Aug 27 1999 Matt Wilson <msw@redhat.com>
  169. - added hotkey assignment for gridforms, changed listbox.setcurrent to
  170. take the item key
  171. * Wed Aug 25 1999 Matt Wilson <msw@redhat.com>
  172. - fixed snack callback function refcounts, as well as optional data args
  173. - fixed suspend callback ref counts
  174. * Mon Aug 23 1999 Matt Wilson <msw@redhat.com>
  175. - added buttons argument to entrywindow
  176. * Thu Aug 12 1999 Bill Nottingham <notting@redhat.com>
  177. - multi-state checkboxtrees. Woohoo.
  178. * Mon Aug 9 1999 Matt Wilson <msw@redhat.com>
  179. - added snack wrappings for checkbox flag setting
  180. * Thu Aug 5 1999 Matt Wilson <msw@redhat.com>
  181. - added snack bindings for setting current listbox selection
  182. - added argument to set default selection in snack ListboxChoiceWindow
  183. * Mon Aug 2 1999 Matt Wilson <msw@redhat.com>
  184. - added checkboxtree
  185. - improved snack binding
  186. * Fri Apr 9 1999 Matt Wilson <msw@redhat.com>
  187. - fixed a glibc related bug in reflow that was truncating all text to 1000
  188. chars
  189. * Fri Apr 09 1999 Matt Wilson <msw@redhat.com>
  190. - fixed bug that made newt apps crash when you hit <insert> followed by lots
  191. of keys
  192. * Mon Mar 15 1999 Matt Wilson <msw@redhat.com>
  193. - fix from Jakub Jelinek for listbox keypresses
  194. * Fri Feb 27 1999 Matt Wilson <msw@redhat.com>
  195. - fixed support for navigating listboxes with alphabetical keypresses
  196. * Thu Feb 25 1999 Matt Wilson <msw@redhat.com>
  197. - updated descriptions
  198. - added support for navigating listboxes with alphabetical keypresses
  199. * Mon Feb 8 1999 Matt Wilson <msw@redhat.com>
  200. - made grid wrapped windows at least the size of their title bars
  201. * Fri Feb 5 1999 Matt Wilson <msw@redhat.com>
  202. - Function to set checkbox flags. This will go away later when I have
  203. a generic flag setting function and signals to comps to go insensitive.
  204. * Tue Jan 19 1999 Matt Wilson <msw@redhat.com>
  205. - Stopped using libgpm, internalized all gpm calls. Still need some cleanups.
  206. * Thu Jan 7 1999 Matt Wilson <msw@redhat.com>
  207. - Added GPM mouse support
  208. - Moved to autoconf to allow compiling without GPM support
  209. - Changed revision to 0.40
  210. * Wed Oct 21 1998 Bill Nottingham <notting@redhat.com>
  211. - built against slang-1.2.2
  212. * Wed Aug 19 1998 Bill Nottingham <notting@redhat.com>
  213. - bugfixes for text reflow
  214. - added docs
  215. * Fri May 01 1998 Cristian Gafton <gafton@redhat.com>
  216. - devel package moved to Development/Libraries
  217. * Thu Apr 30 1998 Erik Troan <ewt@redhat.com>
  218. - removed whiptcl.so -- it should be in a separate package
  219. * Mon Feb 16 1998 Erik Troan <ewt@redhat.com>
  220. - added newtWinMenu()
  221. - many bug fixes in grid code
  222. * Wed Jan 21 1998 Erik Troan <ewt@redhat.com>
  223. - removed newtWinTernary()
  224. - made newtWinChoice() return codes consistent with newtWinTernary()
  225. * Fri Jan 16 1998 Erik Troan <ewt@redhat.com>
  226. - added changes from Bruce Perens
  227. - small cleanups
  228. - lets whiptail automatically resize windows
  229. - the order of placing a grid and adding components to a form no longer
  230. matters
  231. - added newtGridAddComponentsToForm()
  232. * Wed Oct 08 1997 Erik Troan <ewt@redhat.com>
  233. - added newtWinTernary()
  234. * Tue Oct 07 1997 Erik Troan <ewt@redhat.com>
  235. - made Make/spec files use a buildroot
  236. - added grid support (for newt 0.11 actually)
  237. * Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
  238. - Added patched from Clarence Smith for setting the size of a listbox
  239. - Version 0.9
  240. * Tue May 28 1997 Elliot Lee <sopwith@redhat.com> 0.8-2
  241. - Touchups on Makefile
  242. - Cleaned up NEWT_FLAGS_*
  243. * Tue Mar 18 1997 Erik Troan <ewt@redhat.com>
  244. - Cleaned up listbox
  245. - Added whiptail
  246. - Added newtButtonCompact button type and associated colors
  247. - Added newtTextboxGetNumLines() and newtTextboxSetHeight()
  248. * Tue Feb 25 1997 Erik Troan <ewt@redhat.com>
  249. - Added changes from sopwith for C++ cleanliness and some listbox fixes.