mjpegtools-vl.spec 8.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269
  1. # -*- coding: utf-8-unix -*-
  2. Name: mjpegtools
  3. Version: 1.9.0
  4. Release: 1%{?_dist_release}
  5. Summary: Tools to manipulate MPEG data
  6. Summary(ja): MPEG データを操作するツール集
  7. Group: Applications/Multimedia
  8. License: GPLv2
  9. URL: http://mjpeg.sourceforge.net/
  10. Source0: http://downloads.sourceforge.net/mjpeg/%{name}-%{version}.tar.gz
  11. Patch0: mjpegtools-1.9.0rc1-anytovcd-ffmpegver.patch
  12. Patch1: mjpegtools-1.9.0-gcc44.patch
  13. Patch2: mjpegtools-1.9.0-png-memleak.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: libjpeg-devel
  16. BuildRequires: nasm
  17. BuildRequires: libdv-devel
  18. BuildRequires: SDL-devel >= 1.1.3
  19. BuildRequires: SDL_gfx-devel
  20. #BuildRequires: libquicktime-devel >= 0.9.8
  21. #BuildRequires: self-build-libquicktime >= 0.9.8
  22. BuildRequires: libpng-devel
  23. BuildRequires: gtk2-devel >= 2.4.0
  24. # mencoder for lav2avi.sh
  25. #Requires: mencoder
  26. #Requires: self-build-mplayer
  27. # ffmpeg main package, y4mscaler and which for anytovcd.sh
  28. #Requires: ffmpeg
  29. #Requires: self-build-ffmpeg
  30. #Requires: y4mscaler
  31. Requires: which
  32. Requires(post): /sbin/install-info
  33. Requires(preun): /sbin/install-info
  34. %description
  35. The mjpeg programs are a set of tools that can do recording of videos
  36. and playback, simple cut-and-paste editing and the MPEG compression of
  37. audio and video under Linux.
  38. %description -l ja
  39. mjpegtools は、Linux 上で
  40. ビデオ録画や再生、
  41. 簡単なカット&ペーストの編集、
  42. オーディオやビデオの MPEG 圧縮
  43. ができるツール集です。
  44. %package devel
  45. Summary: Development files for mjpegtools libraries
  46. Group: Development/Libraries
  47. Requires: %{name} = %{version}-%{release}
  48. Requires: pkgconfig
  49. %description devel
  50. The mjpeg programs are a set of tools that can do recording of videos
  51. and playback, simple cut-and-paste editing and the MPEG compression of
  52. audio and video under Linux. This package contains development files
  53. for building applications that use mjpegtools libraries.
  54. %prep
  55. %setup -q
  56. %patch0 -p1
  57. %patch1 -p1
  58. %patch2 -p1
  59. %__sed -i -e 's/ARCHFLAGS=.*/ARCHFLAGS=/' configure*
  60. %__sed -i -e 's|/lib /usr/lib|/%{_lib} %{_libdir}|' configure # lib64 rpaths
  61. for f in docs/yuvfps.1 ; do
  62. iconv -f iso-8859-1 -t utf-8 $f > $f.utf8 ; mv $f.utf8 $f
  63. done
  64. %build
  65. %configure --disable-dependency-tracking --disable-static
  66. %__make # %{?_smp_mflags}
  67. %install
  68. %__rm -rf $RPM_BUILD_ROOT
  69. %__make install DESTDIR=$RPM_BUILD_ROOT
  70. %__rm -f $RPM_BUILD_ROOT{%{_infodir}/dir,%{_libdir}/lib*.la}
  71. # too broken/outdated to be useful in 1.[89].0 (and would come with dep chain)
  72. %__rm -f $RPM_BUILD_ROOT%{_bindir}/mpegtranscode
  73. %clean
  74. %__rm -rf $RPM_BUILD_ROOT
  75. %post
  76. /sbin/ldconfig
  77. /sbin/install-info %{_infodir}/mjpeg-howto.info %{_infodir}/dir || :
  78. %postun
  79. /sbin/ldconfig
  80. %preun
  81. [ $1 -eq 0 ] && \
  82. /sbin/install-info --delete %{_infodir}/mjpeg-howto.info %{_infodir}/dir || :
  83. %files
  84. %defattr(-,root,root,-)
  85. %doc COPYING CHANGES ChangeLog AUTHORS BUGS README.lavpipe NEWS TODO
  86. %{_bindir}/*
  87. %{_mandir}/man1/*.1*
  88. %{_mandir}/man5/yuv4mpeg.5*
  89. %{_infodir}/mjpeg-howto.info*
  90. ## gui
  91. %doc README.glav
  92. %{_bindir}/glav
  93. # lavplay and yuvplay won't save -libs/console util users from X11 and SDL
  94. # dependencies as long as liblavplay is in -libs, but they're inherently
  95. # GUI tools -> include them here
  96. %{_bindir}/lavplay
  97. %{_bindir}/y4mhist
  98. %{_bindir}/yuvplay
  99. %{_mandir}/man1/lavplay.1*
  100. %{_mandir}/man1/yuvplay.1*
  101. ## libs
  102. %{_libdir}/lib*.so.*
  103. %files devel
  104. %defattr(-,root,root,-)
  105. %{_includedir}/%{name}
  106. %{_libdir}/lib*.so
  107. %{_libdir}/pkgconfig/%{name}.pc
  108. %changelog
  109. * Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.0-1
  110. - new upstream release
  111. * Fri Sep 3 2010 Hans de Goede <j.w.r.degoede@hhs.nl> 1.9.0-2
  112. - Fix a memleak which is causing issues for LiVES
  113. * Wed Apr 15 2009 Hans de Goede <j.w.r.degoede@hhs.nl> 1.9.0-1
  114. - Update to upstream 1.9.0 final release
  115. * Sun Mar 29 2009 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info> - 1.9.0-0.7.rc3
  116. - rebuild for new F11 features
  117. * Sat Dec 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.9.0-1.rc3
  118. - initial build
  119. * Fri Jul 25 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 1.9.0-0.6.rc3
  120. - Release bump for rpmfusion
  121. - Sync with freshrpms (no changes)
  122. * Tue Apr 22 2008 Ville Skyttä <ville.skytta at iki.fi> - 1.9.0-0.5.rc3
  123. - Apply patch from Gentoo to fix build with GCC 4.3 (#1941).
  124. * Tue Dec 4 2007 Ville Skyttä <ville.skytta at iki.fi> - 1.9.0-0.4.rc3
  125. - 1.9.0rc3.
  126. * Sat Sep 29 2007 Ville Skyttä <ville.skytta at iki.fi> - 1.9.0-0.4.rc2
  127. - Requires: which
  128. * Wed Aug 22 2007 Ville Skyttä <ville.skytta at iki.fi> - 1.9.0-0.3.rc2
  129. - License: GPLv2
  130. * Thu Jun 21 2007 Ville Skyttä <ville.skytta at iki.fi> - 1.9.0-0.2.rc2
  131. - Rebuild.
  132. * Fri Jun 8 2007 Ville Skyttä <ville.skytta at iki.fi> - 1.9.0-0.1.rc2
  133. - 1.9.0rc2.
  134. * Sat Nov 25 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.8.0-7
  135. - Split GUI utilities into -gui subpackage.
  136. - Don't ship mpegtranscode, it's broken/outdated.
  137. - Require mencoder for lav2avi.sh.
  138. * Fri Oct 06 2006 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info> 1.8.0-6
  139. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  140. * Sun Sep 24 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.8.0-5
  141. - Specfile cleanup.
  142. * Sun Jun 4 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.8.0-4
  143. - Get rid of undefined non-weak symbols in liblav*.
  144. - Apply upstream fix for compiling with libquicktime 0.9.8.
  145. * Thu Mar 09 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  146. - switch to new release field
  147. * Tue Feb 28 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  148. - add dist
  149. * Sat Jan 21 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.8.0-0.lvn.3
  150. - Include license text in -libs, it can be installed without the main package.
  151. - Convert yuvfps man page to UTF-8.
  152. - Fix -devel Group tag.
  153. * Thu Jan 19 2006 Adrian Reber <adrian@lisas.de> - 1.8.0-0.lvn.2
  154. - Added patch to compile with gcc 4.1
  155. - Dropped 0 Epoch
  156. * Mon Sep 19 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.8.0-0.lvn.1
  157. - 1.8.0.
  158. * Sat Aug 27 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.6.3-0.lvn.0.1.rc3
  159. - 1.6.3-rc3, Altivec fixes applied upstream.
  160. * Fri Aug 12 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.6.3-0.lvn.0.1.rc2
  161. - 1.6.3-rc2, clean up obsolete pre-FC2 stuff.
  162. - Fix Altivec build, kudos to upstream.
  163. * Thu May 26 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.6,3-0.lvn.0.1.rc1
  164. - 1.6.3-rc1 (1.7.0 snapshot package not released, so no Epoch bump).
  165. * Sun May 22 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.7.0-0.lvn.0.2.cvs20050521
  166. - PPC: disable Altivec due to gcc4 build failure, honor $RPM_OPT_FLAGS.
  167. * Sat May 21 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.7.0-0.lvn.0.1.cvs20050521
  168. - Pre-1.7.0 snapshot as of today, all patches applied or obsoleted upstream.
  169. - Require pkgconfig in -devel.
  170. * Wed Feb 2 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.6.2-0.lvn.7
  171. - Add corrected -fPIC tweak from Thorsten.
  172. * Mon Jan 31 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.6.2-0.lvn.6
  173. - Include PNG input support.
  174. - Remove no-op $RPM_OPT_FLAGS setting from %%build.
  175. - Remove bogus optimization settings from configure script.
  176. * Fri Dec 31 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:1.6.2-0.lvn.5
  177. - CFLAGS="$CFLAGS -fPIC" on non x86; Fixes build error on x86_64; The
  178. option --with-pic is not enough
  179. * Sat Dec 18 2004 Dams <anvil[AT]livna.org> - 0:1.6.2-0.lvn.4
  180. - Disabling static libraries building
  181. * Tue Dec 14 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.6.2-0.lvn.3
  182. - Include quicktime support.
  183. - Apply patch from ALT Linux to fix info pages, fix typo in %%post.
  184. - Require /sbin/install-info.
  185. - Add "--without static" rpmbuild option to work around an issue with FC3 strip
  186. - Always enable SIMD accelerations, CPU capabilities detected at runtime.
  187. - Always disable use of cmov.
  188. * Thu Nov 11 2004 Dams <anvil[AT]livna.org> 0:1.6.2-0.lvn.2
  189. - Added patch to fix gcc3.4 build
  190. - Detected race condition in Makefiles (disabling _smp_mflags use)
  191. - Added info files & scriptlets
  192. - Dropped patch0 and patch1
  193. * Tue Jun 8 2004 Dams <anvil[AT]livna.org> 0:1.6.2-0.lvn.1
  194. - Updated to 1.6.2
  195. * Sun Sep 28 2003 Dams <anvil[AT]livna.org> 0:1.6.1-0.fdr.6
  196. - Removed comment after scriptlets
  197. * Fri Aug 22 2003 Dams <anvil[AT]livna.org> 0:1.6.1-0.fdr.5
  198. - buildroot -> RPM_BUILD_ROOT
  199. * Sun Aug 10 2003 Dams <anvil[AT]livna.org> 0:1.6.1-0.fdr.4
  200. - Applied upstream patches to fix build on gcc3.3 systems
  201. * Tue Apr 29 2003 Dams <anvil[AT]livna.org> 0:1.6.1-0.fdr.3
  202. - Now test arch for configure options (from Ville)
  203. - Removed ImageMagick-devel BuildRequires
  204. * Sun Apr 27 2003 Dams <anvil[AT]livna.org> 0:1.6.1-0.fdr.2
  205. - Added missing BuildRequires
  206. - Added post/postun scriplets for libs package
  207. * Wed Apr 23 2003 Dams <anvil[AT]livna.org>
  208. - Initial build.