self-build-mjpegtools-vl.spec 5.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141
  1. %define pkgname mjpegtools
  2. %define name self-build-%{pkgname}
  3. %define version 1.9.0
  4. %define release 1%{?_dist_release}
  5. %define sourceurl0 http://prdownloads.sourceforge.net/mjpeg/%{pkgname}-%{version}.tar.gz
  6. Summary: Package to automatically build %{pkgname} rpm package
  7. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  8. Name: %{name}
  9. Version: %{version}
  10. Release: %{release}
  11. Source0: %{pkgname}-vl.spec
  12. Source100: mjpegtools-1.9.0rc1-anytovcd-ffmpegver.patch
  13. Source101: mjpegtools-1.9.0-gcc44.patch
  14. Source102: mjpegtools-1.9.0-png-memleak.patch
  15. License: GPLv2+
  16. Group: Restricted Software
  17. # Requires(posttrans) not yet implemented. So we use (post) instead.
  18. Requires(post): self-build-setup >= 0.9.0
  19. Requires(post): libjpeg-devel
  20. Requires(post): nasm
  21. Requires(post): libdv-devel
  22. Requires(post): SDL-devel >= 1.1.3
  23. Requires(post): SDL_gfx-devel
  24. Requires(post): self-build-libquicktime >= 0.9.8
  25. Requires(post): libpng-devel
  26. Requires(post): gtk2-devel >= 2.4.0
  27. Requires(post): self-build-mplayer
  28. Requires(post): self-build-ffmpeg
  29. #Requires(post): y4mscaler
  30. Requires: which
  31. Requires(post): /sbin/install-info
  32. Requires(preun): /sbin/install-info
  33. BuildArch: noarch
  34. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  35. Packager: munepi
  36. %description
  37. The mjpeg programs are a set of tools that can do recording of videos
  38. and playback, simple cut-and-paste editing and the MPEG compression of
  39. audio and video under Linux.
  40. If you install this package, it automaticaly downloads source
  41. code ,compile it, and create rpm packages of %{pkgname}-%{version}.
  42. And the created rpm packages are automatically installed
  43. if installation is executed by apt-get command or synaptic
  44. package manager.
  45. [Note]
  46. This package requires many other packages to compile
  47. targetsoftware. So it consume more disk space than usual.
  48. Also installation takes logner time because of compilation.
  49. (This will take a few minutes to quarter or half of an hour,
  50. depends on building environment)
  51. [About self-build package]
  52. For some kind of software, distributing of binary package
  53. may viorate the patent or law. Therefore we chose self-build
  54. packge, create binary package on your machine, for such kind
  55. of softwares instead of distributing binary package.
  56. Please obey the national law when you use the created binary
  57. packages. And if you want to use the softwares using patented
  58. thechnology, it may be required to get a permission, make an
  59. agreement or purchas a license. Please consider it with your
  60. purpose or way of use and take appropriate action.
  61. %description -l ja
  62. mjpegtools は、Linux 上で
  63. ビデオ録画や再生、
  64. 簡単なカット&ペーストの編集、
  65. オーディオやビデオの MPEG 圧縮
  66. ができるツール集です。
  67. このパッケージをインストールすると、自動的にソースコードを
  68. ダウンロードしてコンパイルし、%{pkgname}-%{version}
  69. の rpm パッケージを作成します。
  70. また apt-get コマンドや synaptic パッケージマネージャから実行
  71. した場合は、作成された rpm パッケージのインストールも自動的に
  72. 行います。
  73. [注意]
  74. コンパイルに必要な多くの関連パッケージを要求するので通常より
  75. ディスクの領域を多く消費します。
  76. またインストール時にコンパイルを行うため、通常より時間がかか
  77. る場合があります。(環境にもよりますが数分から数十分程度)
  78. [self-build パッケージについて]
  79. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  80. 違反する可能性があるものがあります。その為、このような問題が
  81. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  82. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  83. ジという方法を採っています。
  84. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  85. アのライセンス、および利用する国の各種法令に従ってください。
  86. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  87. センスの購入などが必要となる場合がありますので、利用する目的
  88. や形態に応じて各自で判断し適切な対応を取ってください。
  89. %prep
  90. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  91. %install
  92. %{__rm} -rf ${RPM_BUILD_ROOT}
  93. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  94. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  95. %{__install} -m 644 \
  96. %{SOURCE100} %{SOURCE101} %{SOURCE102} \
  97. ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  98. %clean
  99. %{__rm} -rf ${RPM_BUILD_ROOT}
  100. %posttrans
  101. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 194000
  102. /usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
  103. %{pkgname}-devel-%{version}-%{release}
  104. %files
  105. %defattr(-,root,root)
  106. %{_datadir}/%{name}/*
  107. %changelog
  108. * Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.0-1
  109. - initial build
  110. ### end of file