self-build-mplayer-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408
  1. %define pkgname mplayer
  2. %define name self-build-%{pkgname}
  3. %define version 1.0
  4. %define extver rc3
  5. #% define release 4%{?extver:.%{extver}}%{?_dist_release}
  6. %define svndate 20100709
  7. %define release 39.%{svndate}%{?_dist_release}
  8. %define source0path MPlayer/releases/MPlayer-%{version}%{extver}.tar.bz2
  9. %define source1path MPlayer/skins/Blue-1.7.tar.bz2
  10. %define with_vaapi 1
  11. %define with_libvpx 1
  12. Summary: Package to automatically build %{pkgname} rpm package
  13. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  14. Name: %{name}
  15. Version: %{version}
  16. Release: %{release}
  17. Source0: %{pkgname}-vl.spec
  18. Source1: %{pkgname}-snapshot-vine.sh
  19. #Source11: %{pkgname}-export-%{svndate}.tar.bz2
  20. #Source12: Blue-1.7.tar.bz2
  21. #Source102: %{pkgname}-config.patch
  22. Source102: %{pkgname}-config-20100709-vine.patch
  23. Source108: %{pkgname}-manlinks.patch
  24. Source114: %{pkgname}-nodvdcss.patch
  25. Source150: mplayer-20100709-fixed-vo_x11_create_vo_window.patch
  26. License: GPLv2+
  27. Group: Restricted Software
  28. Requires(post): self-build-setup >= 0.9.9
  29. Requires(post): subversion
  30. # (build)requies of target package.
  31. Requires(post): gtk2-devel
  32. Requires(post): freetype2-devel
  33. Requires(post): SDL-devel
  34. Requires(post): alsa-lib-devel
  35. Requires(post): esound-devel
  36. Requires(post): cdparanoia-devel
  37. Requires(post): libvorbis-devel
  38. Requires(post): libjpeg-devel
  39. Requires(post): libpng-devel
  40. Requires(post): giflib-devel
  41. Requires(post): zlib-devel
  42. Requires(post): libdvdread
  43. Requires(post): libmpcdec-devel
  44. Requires(post): twolame-devel
  45. Requires(post): yasm
  46. Requires(post): libvdpau-devel
  47. %{?with_vaapi:Requires(post): libva-devel}
  48. %{?with_libvpx:Requires(post): libvpx-devel >= 0.9.1}
  49. Requires(post): libXinerama-devel
  50. Requires(post): libXScrnSaver-devel
  51. Requires(post): self-build-mplayer-codecs
  52. Requires(post): self-build-libdvdcss
  53. Requires(post): self-build-libdvdnav
  54. Requires(post): self-build-faac
  55. Requires(post): self-build-faad2 >= 2.6
  56. Requires(post): self-build-lame
  57. Requires(post): self-build-libdca
  58. Requires(post): self-build-libmad
  59. Requires(post): self-build-x264 >= 0.0.0-9.20090522
  60. Requires(post): self-build-xvidcore >= 0.9.2
  61. Requires(post): self-build-libmpeg2
  62. Requires: TrueType-vlgothic
  63. %if %{?_dist_release} == "vl5" || %{?_dist_release} == "vl6"
  64. Requires: mesa-libGL
  65. Requires(post): xorg-x11-devel
  66. Requires(post): mesa-libGL-devel
  67. %endif
  68. BuildArch: noarch
  69. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  70. Packager: munepi
  71. %description
  72. MPlayer can play most standard video formats out of the box and almost
  73. all others with the help of external codecs.
  74. MPlayer currently works best from the command line, but visual feedback
  75. for many functions is available from its onscreen status display (OSD),
  76. which is also used for displaying subtitles.
  77. MPlayer also has a GUI with skin support and several unofficial alternative
  78. graphical frontends are available.
  79. MEncoder is a command line video encoder for advanced users that can
  80. be built from the MPlayer source tree. Unofficial graphical frontends
  81. exist but arenot included.
  82. MPlayer supports most common formats, like DVDs, MPEG-1/2/4, etc, but
  83. support for some newer codecs are not yet inpmlemented.
  84. You should install mplayer-codecs package if you want to play videos
  85. using those new codecs.
  86. Additional function is automatically included if following
  87. packages are installed in advance.
  88. samba-libsmbclient-devel: SMB file system support
  89. [Note]
  90. This package requires many other packages to compile
  91. targetsoftware. So it consume more disk space than usual.
  92. Also installation takes logner time because of compilation.
  93. (This will take a few minutes to quarter or half of an hour,
  94. depends on building environment)
  95. [About self-build package]
  96. For some kind of software, distributing of binary package
  97. may viorate the patent or law. Therefore we chose self-build
  98. packge, create binary package on your machine, for such kind
  99. of softwares instead of distributing binary package.
  100. Please obey the national law when you use the created binary
  101. packages. And if you want to use the softwares using patented
  102. thechnology, it may be required to get a permission, make an
  103. agreement or purchas a license. Please consider it with your
  104. purpose or way of use and take appropriate action.
  105. %description -l ja
  106. MPlayer は一般的なフォーマットの動画ならそのままですぐ再生できます。
  107. またそれ以外のほとんど全てのフォーマットも外部 Codec を使用すること
  108. で生できます。
  109. 現在の MPlayer はコマンドラインから使うのが一番便利ですが、多くの操作
  110. は字幕と同様に、オンスクリーン・ディスプレイ (OSD) によりその結果が画
  111. 面上で確認できます。
  112. MPlayer には スキンを変更できる GUI も用意されていますし、また複数の
  113. 非公式なフロントエンドも利用できます。
  114. MEncoder は上級者向けのコマンドラインの動画用エンコーダーです。
  115. 非公式な GUI フロントエンドもありますが、このパッケージには含まれて
  116. いません。
  117. MPlayer は何もしなくても DVD や MPEG-1/2/4 のように一般的なフォーマット
  118. を再生できます。ただし一部の最新のフォーマットへの対応はまだ実装されて
  119. いないので、そのような動画を再生したい場合は mplayer-codecs パッケージ
  120. をインストールする必要があります。
  121. このパッケージより前に以下の関連パッケージをインストールして
  122. おくと、%{pkgname} が対応できる機能が自動的に追加されます。
  123. samba-libsmbclient-devel: SMB ファイルシステムのサポート
  124. [注意]
  125. コンパイルに必要な多くの関連パッケージを要求するので通常より
  126. ディスクの領域を多く消費します。
  127. またインストール時にコンパイルを行うため、通常より時間がかか
  128. る場合があります。(環境にもよりますが数分から数十分程度)
  129. [self-build パッケージについて]
  130. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  131. 違反する可能性があるものがあります。その為、このような問題が
  132. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  133. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  134. ジという方法を採っています。
  135. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  136. アのライセンス、および利用する国の各種法令に従ってください。
  137. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  138. センスの購入などが必要となる場合がありますので、利用する目的
  139. や形態に応じて各自で判断し適切な対応を取ってください。
  140. %prep
  141. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  142. %install
  143. %{__rm} -rf ${RPM_BUILD_ROOT}
  144. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  145. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  146. %{__install} -m 644 %{SOURCE1} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  147. #%{__install} -m 644 %{SOURCE11} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  148. #%{__install} -m 644 %{SOURCE12} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  149. %{__install} -m 644 %{SOURCE102} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  150. %{__install} -m 644 %{SOURCE108} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  151. %{__install} -m 644 %{SOURCE114} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  152. %{__install} -m 644 %{SOURCE150} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  153. %clean
  154. %{__rm} -rf ${RPM_BUILD_ROOT}
  155. %posttrans
  156. ## svn checkout
  157. # set locale
  158. case $LANG in
  159. ja*)LOCALE=ja ;;
  160. *) LOCALE=C ;;
  161. esac
  162. GetSrc_C(){
  163. echo -n " "
  164. echo "Download source file with Subversion..."
  165. }
  166. GetSrc_ja(){
  167. echo -n " "
  168. echo "Subversion を用いてソースファイルをダウンロードしています..."
  169. }
  170. GetSrc_$LOCALE
  171. # svn checkout
  172. . /etc/self-build.conf
  173. (cd $TEMP_DIR
  174. su $BUILD_USER -c "/bin/bash %{_datadir}/%{name}/%{pkgname}-snapshot-vine.sh >/dev/null 2>&1 || exit 1"
  175. %__mv %{pkgname}-export-%{svndate}.tar.bz2 %{_datadir}/%{name}/ || exit 1
  176. )
  177. # /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec \
  178. # http://www{,1,2,3,4,5,7,8}.mplayerhq.hu/%{source0path} \
  179. # http://www{,1,2,3,4,5,7,8}.mplayerhq.hu/%{source1path} \
  180. # 635000
  181. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec \
  182. http://www{,1,2,3,4,5,7,8}.mplayerhq.hu/%{source1path} \
  183. 635000
  184. %files
  185. %defattr(-,root,root)
  186. %{_datadir}/%{name}
  187. %changelog
  188. * Sun Jul 25 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-39.20100709
  189. - updated fixed %{name}-config.patch
  190. - applied %{name}-config-20100709-vine.patch
  191. * Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-38.20100709
  192. - unpacked source archives
  193. * Sat Jul 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-37.20100709
  194. - updated source snapshot 20100709
  195. - renamed %%Source10 to mplayer-snapshot-vine.sh
  196. - added Requires(post): libva-devel, libvpx-devel >= 0.9.1
  197. - dropped vl4 support
  198. - updated %%description
  199. * Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-36.20100621
  200. - updated source snapshot 20100621
  201. - added Requires(post): libXinerama-devel
  202. - dropped vl4 support
  203. * Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-33.20100401
  204. - updated source snapshot 20100401
  205. * Thu Mar 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-31.20100317
  206. - updated source snapshot 20100317
  207. - renamed %%{Source0} to mplayer-vl.spec
  208. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-30.20100216
  209. - updated source snapshot 20100216
  210. - dropped obsolete patches
  211. - added Requires(post): libvdpau-devel libXScrnSaver-devel
  212. * Sat Dec 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-28.20091031
  213. - update mplayer-config-20091215-vine.patch
  214. - update mplayer-20091215-x86_32-compile.patch
  215. * Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-27.20091031
  216. - source snapshot 20091031
  217. - updated mplayer-20091031-x86_32-compile.patch
  218. * Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-26.20091003
  219. - source snapshot 20091003
  220. * Sun Sep 13 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-25.20090905
  221. - added some if conditions for "vl6"
  222. * Sun Sep 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-24.20090905
  223. - source snapshot 20090905
  224. - added settings for vl6
  225. * Thu Aug 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-23.20090821
  226. - source snapshot 20090821
  227. - replaced BR: libungif-devel with BR: giflib-devel
  228. - mentioned VDPAU support in %%description
  229. * Thu Jul 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-22.20090722
  230. - source snapshot 20090722
  231. * Fri Jul 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-21.20090702
  232. - source snapshot 20090702
  233. - check version between original spec and self-build spec in %%prep
  234. * Fri Jun 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-20.20090611
  235. - source snapshot 20090611
  236. * Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-19.20090522
  237. - added Requires: TrueType-vlgothic
  238. * Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-18.20090522
  239. - source snapshot 20090522
  240. - build with x264 >= 0.0.0-9.20090522
  241. - updated mplayer-20090502-nodvdcss.patch
  242. - avoided to execute self-build-rpm.sh on RPM transaction
  243. - moved %%post actions to %%posttrans
  244. * Thu May 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-17.20090502
  245. - added PreReq: self-build-mplayer-codecs
  246. * Tue May 05 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-16.20090502
  247. - added BuildArch: noarch
  248. - source snapshot 20090502
  249. - updated mplayer-20090503-x86_32-compile.patch
  250. - updated mplayer-20090502-nodvdcss.patch
  251. * Thu Apr 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-15.20090327
  252. - included source archives:
  253. - mplayer-export-20090327.tar.bz2
  254. - Blue-1.7.tar.bz2
  255. - applied mplayer-config-vine.patch
  256. * Sat Mar 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-14.20090327
  257. - source snapshot 20090327
  258. - updated mplayer-20090327-x86_32-compile.patch
  259. - updated mplayer-20090325-nodvdcss.patch
  260. - dropped gmplayer-about-vine.patch
  261. * Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-10.20090206
  262. - source snapshot 20090206
  263. - dropped mplayer-man-zh_CN.patch
  264. - updated mplayer-20090206-nodvdcss.patch
  265. - changed to PreReq: self-build-faad2 from faad2-devel
  266. - added PreReq: self-build-libmad
  267. * Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-9.20090131
  268. - source snapshot 20090131
  269. - fixed %%files section
  270. * Thu Jan 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-8.20090122
  271. - fixed %%post: added rm -f "$pwd"/%{pkgname}-export-%{svndate}.tar.bz2
  272. * Sun Jan 25 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-7.20090122
  273. - source snapshot
  274. - update mplayer-nodvdcss.patch: mplayer-20090122-nodvdcss.patch
  275. - added PreReq:
  276. - faad2-devel
  277. - libmpcdec-devel
  278. - twolame-devel
  279. - yasm
  280. - self-build-libdvdcss
  281. - self-build-libdvdnav
  282. - self-build-faac
  283. - self-build-lame
  284. - self-build-libdca
  285. - self-build-x264 >= 0.0.0-4.20090110
  286. - self-build-xvidcore >= 0.9.2
  287. - move %%define source0Exists() from %%post section to header
  288. - fixed %%post section: clean up source archive
  289. * Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-6.20090109
  290. - source snapshot
  291. - added --disable-faac-lavc --disable-mp3lame-lavc --disable-x264-lavc
  292. --disable-faad-internal in configure options
  293. - dropped gmplayer-add-flv-extension.patch
  294. * Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-5.20081001
  295. - source snapshot
  296. - fixed License
  297. - added some patches from RPM Fusion
  298. - updated gmplayer-about-vine.patch for 20081001 snapshot
  299. - added BuildRequires: libdvdread
  300. - added BuildRequires: self-build-libdvdcss self-build-libdvdnav
  301. - added --disable-dvdread-internal --enable-dvdread --enable-dvdnav
  302. in configure options
  303. #- applied mplayer-avoid-Warning_MVs_not_available.patch for VineSeed
  304. - added PreReq: subversion
  305. * Mon Nov 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-4.rc2
  306. - fixed License
  307. - added some devel packages to support OpenGL
  308. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-3.rc2
  309. - spec in utf8
  310. - fix sybolic link of subfont for vl5
  311. * Wed May 07 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-2.rc2vl4
  312. - add "Source105: CVE-2008-1558.patch".
  313. * Fri May 02 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-1.rc2vl4
  314. - build with new versioning policy.
  315. - add "Source200: gmplayer-about-vine.patch".
  316. - add "Source201: gmplayer-add-flv-extension.patch".
  317. - fix <BTS:VineLinux:603>.
  318. - add ">= 0.7-1vl4" to "PreReq: self-build-setup".
  319. - add mirror URLs to self-build-rpm.sh.
  320. * Sun Feb 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-0vl0.3rc2
  321. - add four official security patches (CVE-2008-0485, CVE-2008-0486,
  322. CVE-2008-0629, CVE-2008-0630)
  323. - add mplayer-1.0rc2-20080211-stream_cddb.patch
  324. * Tue Feb 12 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.2rc2
  325. - change source download URL. <BTS:VineLinux:603>
  326. * Sun Jan 27 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.1rc2
  327. - fix CONFDIR for make install in mplayer.spec. <BTS:wishes:33>
  328. * Fri Jan 18 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.0rc2
  329. - initial build for Vine Linux.