perl-Crypt-DSA-vl.spec 2.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879
  1. %define module Crypt-DSA
  2. %define name perl-%{module}
  3. %define version 0.14
  4. %define release 1%{_dist_release}
  5. Name: %{name}
  6. Version: %{version}
  7. Release: %{release}
  8. Summary: DSA Signatures and Key Generation
  9. Group: Development/Languages
  10. License: GPL or Artistic
  11. Url: http://search.cpan.org/dist/%{module}/
  12. Source: http://search.cpan.org/CPAN/authors/id/B/BT/BTROTT/%{module}-%{version}.tar.gz
  13. Requires: perl-Digest-SHA1, perl(Math::BigInt)
  14. Requires: perl-Convert-PEM
  15. Requires: perl-Data-Buffer
  16. BuildArch: noarch
  17. BuildRoot: %{_tmppath}/%{name}-%{version}
  18. BuildRequires: perl-Digest-SHA1, perl(Math::BigInt)
  19. BuildRequires: perl-Convert-PEM
  20. BuildRequires: perl-Data-Buffer
  21. Vendor: Project Vine
  22. Distribution: Vine Linux
  23. %description
  24. Crypt::DSA is an implementation of the DSA (Digital Signature Algorithm)
  25. signature verification system. The implementation itself is pure Perl,
  26. although the heavy-duty mathematics underneath are provided by
  27. the Math::Pari library.
  28. This package provides DSA signing, signature verification,
  29. and key generation.
  30. %prep
  31. %setup -q -n %{module}-%{version}
  32. %build
  33. CFLAGS="%{optflags}" %{__perl} Makefile.PL INSTALLDIRS="vendor" PREFIX="%{buildroot}%{_prefix}"
  34. %{__make}
  35. %check
  36. echo " "
  37. echo "Several Minutes is needed for test. Please wait."
  38. echo " "
  39. %{__make} test
  40. %install
  41. rm -rf %{buildroot}
  42. %makeinstall
  43. # rm -f %{buildroot}%{perl_archlib}/perllocal.pod
  44. # rm -rf %{buildroot}%{perl_vendorarch}
  45. %clean
  46. rm -rf %{buildroot}
  47. %files
  48. %defattr(-,root,root)
  49. %doc README Changes
  50. %{_mandir}/man3*/*
  51. %{perl_vendorlib}/Crypt/*
  52. %changelog
  53. * Fri May 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.14-1vl5
  54. - rebuild with perl 5.10
  55. - new versioning policy
  56. * Mon Mar 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.14-0vl1
  57. - built for VineSeed
  58. * Sat Mar 08 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.14-0vl0.43
  59. - add Requires: perl-Convert-PEM/perl-Data-Buffer
  60. * Sun Mar 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.14-0vl0.42
  61. - built for Vine 4.2 (testing)
  62. - 1st build for Vine