perl-Parse-RecDescent-vl.spec 5.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180
  1. Name: perl-Parse-RecDescent
  2. Version: 1.964
  3. Release: 1%{?_dist_release}
  4. Summary: Parse-RecDescent Perl module
  5. Group: Development/Libraries
  6. License: GPL+ or Artistic
  7. URL: http://search.cpan.org/dist/Parse-RecDescent/
  8. Source0: http://search.cpan.org/CPAN/authors/id/D/DC/DCONWAY/Parse-RecDescent-%{version}.tar.gz
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  10. BuildArch: noarch
  11. BuildRequires: perl(ExtUtils::MakeMaker), perl(version), perl(Test::More)
  12. BuildRequires: perl(Test::Pod)
  13. BuildRequires: perl(Text::Balanced)
  14. Distribution: Vine
  15. Vendor: Project Vine
  16. Packager: munepi
  17. %{?perl_default_filter}
  18. %description
  19. Parse::RecDescent incrementally generates top-down recursive-descent
  20. text parsers from simple yacc-like grammar specifications. It
  21. provides:
  22. * Regular expressions or literal strings as terminals (tokens),
  23. * Multiple (non-contiguous) productions for any rule,
  24. * Repeated and optional subrules within productions,
  25. * Full access to Perl within actions specified as part of the
  26. grammar,
  27. * Simple automated error reporting during parser generation and
  28. parsing,
  29. * The ability to commit to, uncommit to, or reject particular
  30. productions during a parse,
  31. * The ability to pass data up and down the parse tree ("down" via
  32. subrule argument lists, "up" via subrule return values)
  33. * Incremental extension of the parsing grammar (even during a
  34. parse),
  35. * Precompilation of parser objects,
  36. User-definable reduce-reduce conflict resolution via "scoring" of
  37. matching productions.
  38. %prep
  39. %setup -q -n Parse-RecDescent-%{version}
  40. chmod a-x demo/* tutorial/*
  41. %{__perl} -pi -e 's|^#!\s?/usr/local/bin/perl\b|#!%{__perl}|' demo/*
  42. %{__perl} -pi -e 's|^#!\s?/opt/local/bin/perl5\.10\.0\b|#!%{__perl}|' demo/*
  43. for f in Changes demo/demo_dot.pl; do
  44. iconv -f iso-8859-1 -t utf-8 < "$f" > "${f}_" && %__mv -f "${f}_" "$f"
  45. done
  46. %build
  47. %{__perl} Makefile.PL INSTALLDIRS=vendor
  48. %__make %{?_smp_mflags}
  49. %install
  50. %__rm -rf $RPM_BUILD_ROOT
  51. %__make pure_install DESTDIR=$RPM_BUILD_ROOT
  52. find $RPM_BUILD_ROOT -type f -name .packlist -exec %__rm -f {} ';'
  53. find $RPM_BUILD_ROOT -type d -depth -exec %__rmdir {} 2>/dev/null ';'
  54. %__chmod -R u+w $RPM_BUILD_ROOT/*
  55. %check
  56. %__make test
  57. %clean
  58. %__rm -rf $RPM_BUILD_ROOT
  59. %files
  60. %defattr(-,root,root,-)
  61. %{perl_vendorlib}/Parse/
  62. %{_mandir}/man3/*.3*
  63. %doc Changes README demo/ tutorial/
  64. %changelog
  65. * Thu Aug 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 1.964-1
  66. - initial build
  67. * Tue May 04 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.964-2
  68. - Mass rebuild with perl-5.12.0
  69. * Fri Feb 19 2010 Marcela Mašláňová <mmaslano@redhat.com> 1.964-1
  70. - update, fix previous issue and https://rt.cpan.org/Public/Bug/Display.html?id=53948
  71. * Tue Feb 16 2010 Marcela Mašláňová <mmaslano@redhat.com> 1.963-2
  72. - apply upstream patch https://rt.cpan.org/Public/Bug/Display.html?id=54457
  73. which should fix problems with rebuilds of other modules
  74. * Tue Feb 9 2010 Paul Howarth <paul@city-fan.org> 1.963-1
  75. - update to 1.963 (fix subtle bug in leftop and rightop due to removal of $&)
  76. - recode Changes as utf-8
  77. - more script interpreter fixes
  78. * Sun Sep 27 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.962.2-1
  79. - updated for latest GA SQL::Translator
  80. - add default filtering
  81. - auto-update to 1.962.2 (by cpan-spec-update 0.01)
  82. - added a new br on perl(Text::Balanced) (version 0)
  83. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.96-3
  84. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  85. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.96-2
  86. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  87. * Mon Feb 2 2009 Stepan Kasal <skasal@redhat.com> - 1.96-1
  88. - new upstream version
  89. * Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.95.1-5
  90. - Rebuild for perl 5.10 (again)
  91. * Sun Jan 20 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.95.1-4
  92. - rebuild for new perl
  93. * Wed Nov 14 2007 Robin Norwood <rnorwood@redhat.com> - 1.95.1-3
  94. - Apply fixes from package review:
  95. - Remove BR: perl
  96. - Use iconv to convert file to utf-8
  97. - Include BR: perl(Test::Pod)
  98. - Fix old changelog entry
  99. - Resolves: bz#226274
  100. * Tue Oct 16 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 1.95.1-2
  101. - add BR: perl(version), perl(Test::More)
  102. * Tue Oct 16 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 1.95.1-1
  103. - bump to 1.95.1
  104. - correct license tag (now under perl license)
  105. - add BR: perl(ExtUtils::MakeMaker)
  106. * Fri Jul 20 2007 Robin Norwood <rnorwood@redhat.com> - 1.94-6.fc8
  107. - Bring fixes from EPEL build into F8
  108. - Fix minor specfile issues
  109. - Package the docs as well
  110. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.94-5.2.1
  111. - rebuild
  112. * Fri Feb 03 2006 Jason Vas Dias <jvdias@redhat.com> - 1.94-5.2
  113. - rebuild for new perl-5.8.8
  114. * Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
  115. - rebuilt for new gcc
  116. * Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
  117. - rebuilt for new gcj
  118. * Thu Apr 21 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.94-5
  119. - #155620
  120. - Bring up to date with current Fedora.Extras perl spec template.
  121. * Wed Sep 22 2004 Chip Turner <cturner@redhat.com> 1.94-4
  122. - rebuild
  123. * Tue Feb 17 2004 Chip Turner <cturner@redhat.com> 1.94-2
  124. - fix rm to not be interactive (bz115997)
  125. * Fri Feb 13 2004 Chip Turner <cturner@redhat.com> 1.94-1
  126. - update to 1.94
  127. * Tue Aug 6 2002 Chip Turner <cturner@redhat.com>
  128. - automated release bump and build
  129. * Sat Jul 20 2002 Chip Turner <cturner@localhost.localdomain>
  130. - remove Text::Balanced modules since they are now in core perl
  131. * Thu Jun 27 2002 Chip Turner <cturner@redhat.com>
  132. - description update
  133. * Fri Jun 07 2002 cturner@redhat.com
  134. - Specfile autogenerated