perl-XML-DOM-vl.spec 2.8 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788899091929394959697
  1. Name: perl-XML-DOM
  2. Version: 1.44
  3. Release: 7%{?_dist_release}
  4. Summary: DOM extension to XML::Parser
  5. Group: Development/Libraries
  6. License: GPL+ or Artistic
  7. URL: http://search.cpan.org/dist/XML-DOM/
  8. Source0: http://www.cpan.org/authors/id/T/TJ/TJMATHER/XML-DOM-%{version}.tar.gz
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  10. BuildArch: noarch
  11. # perl(XML::Parser::PerlSAX)
  12. BuildRequires: perl-libxml-perl
  13. BuildRequires: perl-XML-RegExp
  14. # for testing perl(LWP::UserAgent)
  15. BuildRequires: perl-libwww-perl
  16. Requires: perl-XML-Parser
  17. Requires: perl-libwww-perl
  18. Requires: perl >= %(eval "`%{__perl} -V:version`"; echo $version)
  19. Obsoletes: perl-libxml-enno <= 1.02
  20. %description
  21. This is a Perl extension to XML::Parser. It adds a new 'Style' to
  22. XML::Parser, called 'Dom', that allows XML::Parser to build an Object
  23. Oriented datastructure with a DOM Level 1 compliant interface. For a
  24. description of the DOM (Document Object Model), see
  25. http://www.w3.org/DOM/
  26. %prep
  27. %setup -q -n XML-DOM-%{version}
  28. cat <<EOF > %{name}-prov
  29. #!/bin/sh
  30. %{__perl_provides} \$* | grep -v 'perl(XML::XQL::Node)'
  31. EOF
  32. %define __perl_provides %{_builddir}/XML-DOM-%{version}/%{name}-prov
  33. chmod +x %{__perl_provides}
  34. %build
  35. %{__perl} Makefile.PL INSTALLDIRS=vendor
  36. make %{?_smp_mflags}
  37. %install
  38. rm -rf $RPM_BUILD_ROOT
  39. make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
  40. find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
  41. find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
  42. chmod -R u+w $RPM_BUILD_ROOT/*
  43. %check
  44. make test
  45. %clean
  46. rm -rf $RPM_BUILD_ROOT
  47. %files
  48. %defattr(-,root,root,-)
  49. %doc BUGS Changes README
  50. %{perl_vendorlib}/XML/
  51. %{_mandir}/man3/XML::*.3*
  52. %changelog
  53. * Sat Aug 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.44-7
  54. - Initial build for Vine Linux
  55. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.44-6
  56. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  57. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.44-5
  58. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  59. * Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.44-4
  60. - Rebuild for perl 5.10 (again)
  61. * Thu Jan 24 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.44-3
  62. - rebuild for new perl
  63. * Wed Oct 17 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 1.44-2.1
  64. - correct license tag
  65. - add BR: perl(ExtUtils::MakeMaker)
  66. * Thu Jun 29 2006 Orion Poplawski <orion@cora.nwra.com> - 1.44-2
  67. - Bump for new perl version (#196667)
  68. * Sat Nov 5 2005 Ville Skyttä <ville.skytta at iki.fi> - 1.44-1
  69. - First Fedora Extras release (#172331).
  70. * Thu Oct 27 2005 Ville Skyttä <ville.skytta at iki.fi> - 1.44-0.1
  71. - First build (#128879).