phonon-vl.spec 7.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252
  1. %define qt4_ver 4.6.3
  2. # Qt4 version auto-detection
  3. %define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
  4. %define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt-%{qt4_ver})
  5. %define _qt4_headerdir %(pkg-config --variable headerdir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/include)
  6. %define tar_ver 4.4
  7. Name: phonon
  8. Summary: Multimedia framework api
  9. Summary(ja): マルチメディアフレームワーク API
  10. Version: 4.4.3
  11. Release: 1%{?_dist_release}
  12. Group: System Environment/Libraries
  13. License: LGPLv2+
  14. URL: http://phonon.kde.org/
  15. Source0: ftp://ftp.kde.org/pub/kde/stable/phonon/4.4.3/phonon-%{version}.tar.bz2
  16. Source10: http://gstreamer.freedesktop.org/data/images/artwork/gstreamer-logo.svg
  17. Source11: hi16-phonon-gstreamer.png
  18. Source12: hi22-phonon-gstreamer.png
  19. Source13: hi32-phonon-gstreamer.png
  20. Source14: hi48-phonon-gstreamer.png
  21. Source15: hi64-phonon-gstreamer.png
  22. Source16: hi128-phonon-gstreamer.png
  23. ## Mandriva/upstreamable patches
  24. Patch51: phonon-4.3.50-fix-decodebin-usage.patch
  25. Patch52: phonon-4.3.50-gstreamer-fix-seekable-query-failed.patch
  26. Patch53: phonon-4.3.50-phonon-allow-stop-empty-source.patch
  27. Patch57: phonon-4.3.80-pulse-devicemove-rejig.patch
  28. ## Upstream patches
  29. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  30. BuildRequires: automoc4 >= 0.9.86
  31. BuildRequires: cmake >= 2.6.2
  32. BuildRequires: glib2-devel
  33. BuildRequires: gstreamer-devel
  34. BuildRequires: gstreamer-plugins-base-devel
  35. BuildRequires: libxcb-devel
  36. BuildRequires: libxml2-devel
  37. BuildRequires: qt4-devel >= 4.4.0
  38. BuildRequires: xine-lib-devel
  39. BuildRequires: pulseaudio-libs-devel
  40. Requires: phonon-backend >= %{version}
  41. Requires: qt4 >= 4.4.0
  42. %description
  43. Phonon is a cross-platform portable Multimedia Support Abstraction,
  44. which allows you to play multiple audio or video formats with the same
  45. quality on all platforms, no matter which underlying architecture is
  46. used.
  47. %package backend-gstreamer
  48. Summary: Gstreamer phonon backend
  49. Group: System Environment/Libraries
  50. Requires: %{name} = %{version}-%{release}
  51. Requires: gstreamer-plugins-good
  52. Obsoletes: %{name}-backend-gst < 4.2.0-4
  53. Provides: %{name}-backend-gst = %{version}-%{release}
  54. Provides: phonon-backend = %{version}-%{release}
  55. %description backend-gstreamer
  56. %{summary}.
  57. %package backend-xine
  58. Summary: xine phonon backend
  59. Group: System Environment/Libraries
  60. Requires: %{name} = %{version}-%{release}
  61. Provides: phonon-backend = %{version}-%{release}
  62. %description backend-xine
  63. %{summary}.
  64. %package devel
  65. Summary: Development files for phonon
  66. Group: Development/Libraries
  67. Requires: %{name} = %{version}-%{release}
  68. Requires: qt4-devel = %{_qt4_version}
  69. %description devel
  70. Header files for developing applications using phonon
  71. %prep
  72. %setup -q
  73. #patch51 -p0 -b .fix-decodebin-usage
  74. %patch52 -p1 -b .gstreamer-fix-seekable-query-failed
  75. %patch53 -p1 -b .phonon-allow-stop-empty-source
  76. #patch57 -p1 -b .pulse-devicemove-rejig
  77. %build
  78. %ifarch x86_64
  79. PATH="$PATH:`/usr/bin/pkg-config --variable=bindir Qt`"
  80. %endif
  81. mkdir -p %{_target_platform}
  82. pushd %{_target_platform}
  83. unset QTDIR || : ; . /etc/profile.d/qt4.sh
  84. %cmake \
  85. -DUSE_INSTALL_PLUGIN=TRUE \
  86. ..
  87. popd
  88. make %{?_smp_mflags} -C %{_target_platform}
  89. %install
  90. rm -rf $RPM_BUILD_ROOT
  91. make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
  92. # symlink for qt/phonon compatibility
  93. ln -s ../KDE/Phonon $RPM_BUILD_ROOT%{_includedir}/phonon/Phonon
  94. # move the oxygen-only phonon-xine icons to hicolor
  95. test -d $RPM_BUILD_ROOT%{_datadir}/icons/hicolor && exit 0
  96. mv $RPM_BUILD_ROOT%{_datadir}/icons/oxygen \
  97. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor
  98. # gstreamer icons
  99. install -D -m 0644 %{SOURCE10} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/apps/phonon-gstreamer.svg
  100. install -D -m 0644 %{SOURCE11} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/phonon-gstreamer.png
  101. install -D -m 0644 %{SOURCE12} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps/phonon-gstreamer.png
  102. install -D -m 0644 %{SOURCE13} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/phonon-gstreamer.png
  103. install -D -m 0644 %{SOURCE14} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/phonon-gstreamer.png
  104. install -D -m 0644 %{SOURCE15} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/64x64/apps/phonon-gstreamer.png
  105. install -D -m 0644 %{SOURCE16} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/128x128/apps/phonon-gstreamer.png
  106. mkdir -p $RPM_BUILD_ROOT%{_qt4_headerdir}
  107. pushd $RPM_BUILD_ROOT%{_qt4_headerdir}
  108. ln -sf %{_includedir}/phonon phonon
  109. popd
  110. %clean
  111. rm -rf $RPM_BUILD_ROOT
  112. %post -p /sbin/ldconfig
  113. %postun -p /sbin/ldconfig
  114. %posttrans backend-gstreamer
  115. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
  116. %posttrans backend-xine
  117. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
  118. %postun backend-gstreamer
  119. if [ $1 -eq 0 ] ; then
  120. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
  121. fi
  122. %postun backend-xine
  123. if [ $1 -eq 0 ] ; then
  124. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
  125. fi
  126. %files
  127. %defattr(-,root,root)
  128. %doc COPYING.LIB
  129. %{_libdir}/*.so.*
  130. %{_datadir}/dbus-1/interfaces/*
  131. # kde4-specific dirs
  132. %dir %{_libdir}/kde4/plugins/phonon_backend
  133. %dir %{_datadir}/kde4/services/phononbackends
  134. %files backend-gstreamer
  135. %defattr(-,root,root,-)
  136. %{_libdir}/kde4/plugins/phonon_backend/phonon_gstreamer.so
  137. %{_datadir}/kde4/services/phononbackends/gstreamer.desktop
  138. %{_datadir}/icons/hicolor/*/apps/phonon-gstreamer.*
  139. %files backend-xine
  140. %defattr(-,root,root,-)
  141. %{_libdir}/kde4/plugins/phonon_backend/phonon_xine.so
  142. %{_datadir}/kde4/services/phononbackends/xine.desktop
  143. %{_datadir}/icons/hicolor/*/apps/phonon-xine.*
  144. %files devel
  145. %defattr(-,root,root)
  146. %dir %{_includedir}/KDE
  147. %{_includedir}/KDE/Phonon/
  148. %{_includedir}/phonon/
  149. %{_qt4_headerdir}/phonon
  150. %{_libdir}/*.so
  151. %{_libdir}/pkgconfig/*.pc
  152. %{_qt4_prefix}/mkspecs/modules/qt_phonon.pri
  153. %changelog
  154. * Mon Dec 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.4.3-1
  155. - new upstream release
  156. * Sun Oct 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-2
  157. - added sybolic link in %%{_qt4_headerdir}
  158. * Mon Sep 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
  159. - new upstream release
  160. - dropt Patch51 and 57
  161. - rebuilt with rpm-4.8.1
  162. * Sat Mar 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.0-1
  163. - new upstream release
  164. - dropt Patch1, 50, 54 and 100
  165. - added Patch57
  166. * Fri Jan 22 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.3.80-5.2
  167. - F11: patch/modularize pa device-manager bits
  168. * Sun Feb 14 2010 Shu KONNO <owa@bg.wakwak.com> 4.3.80-2
  169. - added qmake path to PATH (if x86_64)
  170. * Sat Feb 13 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.80-1
  171. - new upstream release
  172. - built with new toolchain
  173. * Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-3
  174. - added Patch102 and 103 from FC
  175. * Thu Jun 18 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.3.1-11
  176. - fix for '#' in filenames
  177. * Fri Jun 05 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.3.1-8
  178. - restore patches to the xine backend
  179. * Fri Aug 14 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-2
  180. - added Patch100 and 101 from FC
  181. * Tue Mar 3 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.3.1-2
  182. - backport GStreamer backend bugfixes (UTF-8 file handling, volume fader)
  183. - added backend sub-pakcages
  184. * Thu Mar 26 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.3.1-1
  185. - new upstream release
  186. - add BuildPrereq: cmake
  187. * Sat Jan 24 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.3.0-1
  188. - new upstream release
  189. * Wed Jan 14 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.96-1
  190. - new upstream release
  191. - update %%files
  192. - add BuildPrereq: xine-lib-devel libxcb-devel
  193. * Wed Nov 26 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.80-1
  194. - new upstream release
  195. * Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 4.2.0-2
  196. - added script to append qmake path
  197. - added option -DLIB_INSTALL_DIR at cmake
  198. * Tue Oct 7 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.0-1
  199. - initial release for VineSeed