texlive-macros-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411
  1. ## -*- coding: utf-8-unix -*-
  2. %define tex_destdir %{_datadir}
  3. %define texmf %{_prefix}/share/texmf
  4. %define texlive_src %{tex_destdir}/texlive-sources
  5. %define build_tex_destdir %{buildroot}%{tex_destdir}
  6. %define build_texmf %{buildroot}%{texmf}
  7. %define build_texlive_src %{buildroot}%{tex_destdir}-sources
  8. %define knjfonts kanjifonts-3.1
  9. %define jsclasses_ver 100314
  10. %define jlisting_ver 0.2
  11. %define bkmk2uni convert-bkmk2uni
  12. %define exec_texhash [ -x %{_bindir}/texhash ] && %{_bindir}/env - %{_bindir}/texhash 2> /dev/null
  13. %define exec_updmap [ -x %{_bindir}/updmap-sys ] && %{_bindir}/env - %{_bindir}/updmap-sys --nostop 2> /dev/null
  14. %define list_macros \
  15. jsclasses-%{jsclasses_ver} \
  16. jlisting-%{jlisting_ver}
  17. Summary: A collection of useful macro packages for texlive package
  18. Summary(ja): texlive パッケージで使うマクロパッケージ集
  19. Name: texlive-macros
  20. Version: 2009
  21. Release: 2%{?_dist_release}
  22. License: distributable
  23. Group: Applications/Publishing
  24. ## Vine Linux
  25. Source0: %{knjfonts}.tar.bz2
  26. Source1: sample.tex
  27. ## jsclasses
  28. Source10: http://oku.edu.mie-u.ac.jp/~okumura/jsclasses/jsclasses-%{jsclasses_ver}.zip
  29. Source11: http://oku.edu.mie-u.ac.jp/~okumura/jsclasses/index.html
  30. ## jlisting
  31. Source20: http://prdownloads.sourceforge.jp/mytexpert/26068/jlisting.sty.bz2
  32. Requires: perl
  33. Requires: texlive = %{version}
  34. BuildRequires: texlive = %{version}
  35. BuildRequires: jvf nkf unzip
  36. Buildroot: %{_tmppath}/%{name}-%{version}-root
  37. BuildArch: noarch
  38. Obsoletes: tetex-macros <= 3.0
  39. Obsoletes: pLaTeX2e_Macros
  40. Distribution: Vine Linux
  41. Vendor: Project Vine
  42. Packager: munepi
  43. %description
  44. A collection of useful macro packages for texlive package, including
  45. kanjifonts-3.1 (for Ricoh Fonts/DynaLab Fonts and JIS font metric)
  46. %{list_macros}
  47. # This package contained a perl script
  48. # http://www.rmatsumoto.org/tex-ps-pdf/convert-euc.txt
  49. %description -l ja
  50. texlive パッケージで使うマクロパッケージ集です。
  51. 以下のマクロを収録しています。
  52. kanjifonts-3.1 (Vine Linux 3.1R 付属のリコーフォント/ダイナフォントやJISフォントメトリックを使う)
  53. %{list_macros}
  54. # このパッケージには prosper, powerdot 用に
  55. # PDF ブックマークの文字化けを修正するための perl スクリプト
  56. # http://www.rmatsumoto.org/tex-ps-pdf/convert-euc.txt
  57. # を同梱しています.
  58. %prep
  59. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && %__rm -rf $RPM_BUILD_ROOT
  60. %setup -q -c -n %{name}-%{version}
  61. %__mkdir_p jsclasses
  62. (cd jsclasses
  63. %__mkdir_p jsclasses
  64. %__unzip -a -qq %{SOURCE10}
  65. %__cp -p %{SOURCE11} ./jsclasses/README.html
  66. )
  67. # get rid of unwanted files
  68. find . -type d -name CVS | xargs -r %__rm -frv
  69. find . -type f -name .cvsignore | xargs -r %__rm -fv
  70. (cd jsclasses
  71. %__mkdir_p tmp
  72. for i in *.*; do nkf $i > tmp/$i; done
  73. %__mv tmp/* .
  74. %__rmdir tmp
  75. )
  76. %build
  77. (cd jsclasses
  78. for i in jsclasses okumacro okuverb morisawa; do
  79. platex ${i}.dtx && platex ${i}.dtx || exit 1
  80. done
  81. for i in jsclasses okumacro okuverb; do
  82. dvipdfmx $i || exit 1
  83. done
  84. %__cp *.dvi *.pdf jsclasses
  85. )
  86. %install
  87. %__rm -rf %{buildroot}
  88. # InstallClass(){
  89. # target=$1; shift
  90. # (cd $target
  91. # bzip2 -dc ${RPM_SOURCE_DIR}/$target.tar.bz2 | tar xf - -C %{build_texmf}/packages/
  92. # rm %{build_texmf}/packages/$target/*.{ins,def,bst,rtx,sty,cls,ltx,fnt,cyr,fdd} || :
  93. # if [ -f src/$target.ins ]; then
  94. # cp src/* .
  95. # fi
  96. # latex $target.ins
  97. # mkdir -p %{build_texmf}/tex/latex/$target
  98. # cp *.{ldf,sty,def,cls,rtx} %{build_texmf}/tex/latex/$target || :
  99. # if [ ! -z "$*" ]; then
  100. # cp -d $* %{build_texmf}/tex/latex/$target || :
  101. # fi
  102. # if [ -n "`ls *.bst`" ]; then
  103. # mkdir -p %{build_texmf}/bibtex/bst/$target
  104. # cp *.bst %{build_texmf}/bibtex/bst/$target || :
  105. # fi
  106. # )
  107. # }
  108. %__mkdir_p %{build_texmf}/packages/
  109. #InstallClass geometry
  110. ## install kanjifonts
  111. %__mkdir_p %{build_texmf}/ptex/platex/generic
  112. %__mv %{knjfonts}/*.sty %{build_texmf}/ptex/platex/generic
  113. %__mv %{knjfonts}/*.def %{build_texmf}/ptex/platex/generic
  114. # nkf --utf8 %{SOURCE25} | \
  115. # sed -e "s@^#!/usr/local/bin/perl5 -w@#!/usr/bin/perl -w@" > \
  116. # %{buildroot}%{_bindir}/%{bkmk2uni}
  117. # chmod 755 %{buildroot}%{_bindir}/%{bkmk2uni}
  118. ## install jsclasses
  119. (cd jsclasses
  120. %__mkdir_p %{build_texmf}/ptex/platex/js
  121. %__cp -fp *.dtx *.ins *.cls *.sty %{build_texmf}/ptex/platex/js/
  122. )
  123. ## install jlisting
  124. %__mkdir_p %{build_texmf}/ptex/platex/jlisting
  125. %__install -m 644 %{SOURCE20} %{build_texmf}/ptex/platex/jlisting/
  126. bunzip2 %{build_texmf}/ptex/platex/jlisting/jlisting.sty.bz2
  127. # ## install MORISAWA basic 5 fonts
  128. # #mkdir -p %{build_texmf}/dvips/config/extmap
  129. # %__mkdir_p %{build_texmf}/fonts/tfm/ptex
  130. # %__mkdir_p %{build_texmf}/fonts/tfm/dvips
  131. # %__mkdir_p %{build_texmf}/fonts/vf/ptex
  132. # #mv morisawa/morisawa.map %{build_texmf}/dvips/config/extmap/
  133. # %__mv morisawa/tfm/ptex/* %{build_texmf}/fonts/tfm/ptex/
  134. # %__mv morisawa/tfm/dvips/* %{build_texmf}/fonts/tfm/dvips/
  135. # %__mv morisawa/vf/* %{build_texmf}/fonts/vf/ptex/
  136. %post
  137. %{exec_texhash}
  138. # %{exec_updmap}
  139. exit 0
  140. %postun
  141. if [ "$1" = 0 ]; then
  142. %{exec_texhash}
  143. # %{exec_updmap}
  144. fi
  145. exit 0
  146. %clean
  147. %__rm -rf $RPM_BUILD_ROOT
  148. %files
  149. %defattr(-,root,root)
  150. %doc %{knjfonts}
  151. %doc jsclasses/jsclasses
  152. #%{_bindir}/%{bkmk2uni}
  153. %{texmf}/ptex/platex/generic/kanjifonts.sty
  154. %{texmf}/ptex/platex/generic/*.def
  155. %{texmf}/ptex/platex/js
  156. %{texmf}/ptex/platex/jlisting
  157. %changelog
  158. * Tue Aug 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
  159. - removed %%{exec_updmap} in %%post and %%postun
  160. * Tue May 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
  161. - ported from tetex-macros-3.0-7
  162. - TeX Live 2009
  163. * Mon Oct 12 2009 Munehiro Yamamoto <munepi@vinelinux.org> 3.0-7
  164. - added BuildRequires: unzip
  165. - updated jsclasses to 090826
  166. - updated pict2e to 0.2x
  167. * Sun May 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-6
  168. - dropped epsbox.sty, eclepsf.sty
  169. (bacause there style files for platex209 are obsolete)
  170. * Fri May 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-5
  171. - added jlisting v0.2
  172. - defined list_macros
  173. - used %%{list_macros} in %%description and %%description -l ja
  174. * Thu May 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-4
  175. - dropped convert-euc.txt
  176. * Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-3
  177. - updated prosper
  178. - added some contrib themes from CTAN
  179. - added prosper.cls v1.6 from CVS HEAD
  180. - added a perl script: convert-euc.txt
  181. - added powerdot v1.3
  182. - added xkeyval v2.5d
  183. - added beamer v3.07
  184. - added pgf v2.00
  185. - added pict2e v0.2w
  186. * Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-2
  187. - updated jsclasses to 20090222
  188. - updated jsclasses/index.html to 2009-02-22
  189. - removed /usr/share/texmf/dvips/config/extmap/morisawa.map (See [BTS:524])
  190. * Wed Sep 03 2008 Shu KONNO <owa@bg.wakwak.com> 3.0-1vl5
  191. - applied new versioning policy, spec in utf-8
  192. * Mon Oct 08 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl3
  193. - update jsclasses/index.html to 2006-11-06.
  194. * Fri May 19 2006 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl2
  195. - update jsclasses/index.html to 2006-02-12.
  196. * Sun Nov 06 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl1
  197. - update jsclasses/index.html to 2005-10-26.
  198. * Sat Jun 18 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl0.1
  199. - update jsclasses/index.html to 2005-4-30.
  200. - added breqn
  201. * Tue Jan 18 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 2.0-0vl7
  202. - update jsclasses/index.html to 2004-12-29.
  203. * Mon Jan 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-0vl6
  204. - add missing files in kanjifonts-3.0
  205. * Sun Jan 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-0vl6
  206. - update to kanjifonts.sty-3.0.
  207. * Mon Nov 29 2004 KOBAYASHI Taizo <tkoba@vinelinux.org> 2.0-0vl4
  208. - update jsclasses/index.html to 2004-11-03.
  209. * Sat Oct 16 2004 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl3
  210. - update jsclasses/index.html to 2004-09-27.
  211. * Sat Apr 17 2004 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl2
  212. - update jsclasses/index.html to 2004-02-25.
  213. - added eclepsf.sty.
  214. - removed epsf.sty (symlink to epsbox.sty).
  215. - removed geometry, which is in tetex-2.0.
  216. * Fri Apr 18 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl1
  217. - update jsclasses/index.html to 2003-04-18.
  218. - added morisawa.dvi.
  219. * Fri Mar 14 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0t2
  220. - update jsclasses/index.html to 2003-03-06
  221. * Mon Feb 3 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0t1
  222. - remove natbib, which is in tetex-2.0
  223. - let version number same as tetex
  224. - added Requires: tetex
  225. * Sat Jan 18 2003 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl9
  226. - update jsclasses/index.html to 2003-01-16
  227. * Mon Jan 13 2003 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl8
  228. - update jsclasses to 2003-01-05
  229. - update index.html to 2003-01-12
  230. * Thu Nov 28 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl7
  231. - update jsclasses and index.html to 2002-11-27
  232. * Sun Nov 03 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl6
  233. - update jsclasses and index.html to 2002-11-01
  234. * Thu Oct 17 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl5
  235. - oops, packager was incorrect
  236. * Mon Jul 15 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl4
  237. - update jsclasses to 2002-06-29
  238. - update index.html to 2002-07-03
  239. * Sun Apr 28 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl3
  240. - update jsclasses to 2002-04-21
  241. - update index.html to 2002-04-09
  242. * Tue Apr 16 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.1-0vl2
  243. - added MORISAWA basic 5 fonts
  244. * Mon Mar 25 2002 Jun Nishii <jun@vinelinux.org> 1.1-0vl1
  245. - update to kanjifonts-1.1
  246. * Thu Feb 07 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl11
  247. - update jsclasses and index.html to 2002-02-07
  248. * Tue Jan 31 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl10
  249. - update jsclasses and index.html to 2002-01-27
  250. - fix typo in changelog
  251. * Fri Jan 25 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl9
  252. - update jsclasses and index.html to 2002-01-18
  253. * Tue Dec 18 2001 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl8
  254. - update index.html (jsclasses)
  255. * Sat Dec 15 2001 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl7
  256. - update jsclasses to 2001-11-29
  257. * Sun Sep 16 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.0-0vl6
  258. - fixed spec file for Prosper and jsclasses
  259. - use RPM macro in %files
  260. - added BuildPrereq: jvf
  261. * Mon Sep 10 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl5
  262. - move revtex4 to texmacro-aps package
  263. * Sun Sep 9 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl4
  264. - added prosper jsclasses
  265. * Mon Sep 6 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl3
  266. - added revtex4 natbib
  267. * Mon Sep 3 2001 Jun Nishii <jun@vinelinux.org> 1.0-0vl2
  268. - remove prereq tetex to avoid dependency-loop
  269. * Wed Aug 1 2001 Jun Nishii <jun@vinelinux.org>
  270. - tetex-macros-1.0-0vl1
  271. * Fri Jan 21 2000 Jun Nishii <jun@vinelinux.org>
  272. - 2.0-2
  273. - added kanjifonts-1.0 and removed jisfontsmetric
  274. * Sun Jan 9 2000 Jun Nishii <jun@vinelinux.org>
  275. - 2.0-1
  276. - install ldf in babel
  277. * Sat Jan 8 2000 Jun Nishii <jun@vinelinux.org>
  278. - added jisfontmetric.tex
  279. * Fri Oct 29 1999 Norihito Ohmori <ohmori@flatout.org>
  280. - change group.
  281. * Sun Oct 17 1999 Jun Nishii <jun@flatout.org>
  282. - added babel
  283. * Fri Aug 27 1999 Jun Nishii <jun@flatout.org>
  284. - added hoekwater
  285. * Mon Aug 3 1999 Jun Nishii <jun@flatout.org>
  286. - added psfrag
  287. * Mon Jun 21 1999 Jun Nishii <jun@flatout.org>
  288. - added psnfss
  289. - Change directory tree according to the suggestion by Dr.Okumura.
  290. - remove many files from packages directory except documentations
  291. - disable mktexlsr and erase ls-R
  292. * Tue Feb 16 1999 Jun Nishii <jun@flatout.org>
  293. - added url.sty
  294. * Thu Dec 3 1998 Jun Nishii <jun@flatout.org>
  295. - pLaTeX2e_Macros-1-2
  296. - added fancyhdr.sty, boxedminipage.sty
  297. - added graphics.cfg, color.cfg (use dvips as default)
  298. - symlink from epsbox to epsf
  299. * Mon Nov 9 1998 Jun Nishii <jun@flatout.org>
  300. - pLaTeX2e_Macros-1-1
  301. (rename as pLaTeX2e_Macros from pLaTeX-Classes)
  302. - added def files of graphics
  303. - added tools and hyperref
  304. - check the existence of mktexlsr
  305. * Tue Oct 5 1998 Jun Nishii <jun@flatout.org>
  306. - buildarch: noarch
  307. - added requires
  308. * Tue Sep 29 1998 Jun Nishii <jun@flatout.org>
  309. - tiny bug fix and add %defattr
  310. * Wed Sep 23 1998 Jun Nishii <jun@flatout.org>
  311. - first version fo platex-19980901