po-mode-vl.spec 7.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258
  1. %define origname po-mode
  2. Summary: Emacs Lisp for editing po file of gettext
  3. Summary(ja): gettextの po ファイルを編集するためのEmacs Lisp
  4. Name: po-mode
  5. Version: 0.17
  6. Release: 5%{?_dist_release}
  7. License: GPLv3 and LGPLv2+
  8. Group: Applications/Editors/Emacs
  9. Source: ftp://ftp.gnu.org/gnu/gettext/gettext-%{version}.tar.gz
  10. URL: http://www.gnu.org/software/gettext/
  11. Source1: po-mode-init.el
  12. Source3: %{origname}-install.sh
  13. Source4: %{origname}-remove.sh
  14. Source5: vine-default-%{origname}.el
  15. ## <BTS:VineLinux:934>:
  16. # http://git.savannah.gnu.org/cgit/gettext.git/commit/?id=9a6599c4d3d3db699b269b53a9a458bf0728ce08
  17. Patch0: po-mode-fix934.patch
  18. Requires(post): emacsen, emacsen-common >= 0.1
  19. Buildroot: %{_tmppath}/%{name}-%{version}-root
  20. BuildArch: noarch
  21. Packager: iwaim
  22. Vendor: Project Vine
  23. Distribution: Vine Linux
  24. %description
  25. Emacs Lisp for editing po file of gettext
  26. %description -l ja
  27. gettext の po ファイルを編集するための Emacs Lisp です.
  28. %prep
  29. %setup -q -n gettext-%{version}
  30. %patch0 -p1
  31. %build
  32. %install
  33. [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
  34. [ "%{buildroot}" != "/" ] && mkdir -p %{buildroot}
  35. mkdir -p %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}/packages
  36. mkdir -p %{buildroot}%{emacsen_pkgdir}/install
  37. mkdir -p %{buildroot}%{emacsen_pkgdir}/remove
  38. #
  39. # install el files
  40. #
  41. pushd gettext-tools/misc
  42. cp -p *.el %{SOURCE1} %{SOURCE5} %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}
  43. popd
  44. #
  45. # install script (bytecompile el and install elc , remove)
  46. #
  47. %_installemacsenscript %{origname} %{SOURCE3}
  48. %_removeemacsenscript %{origname} %{SOURCE4}
  49. %clean
  50. [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
  51. %post
  52. if [ "$1" = 2 ]; then
  53. %_emacsenPackageRemove %{origname}
  54. fi
  55. %_addemacsenlist %{origname}
  56. %_emacsenPackageInstall %{origname}
  57. %preun
  58. if [ "$1" = 0 ]; then
  59. %_emacsenPackageRemove %{origname}
  60. %_removeemacsenlist %{origname}
  61. fi
  62. %files
  63. %defattr(-,root,root,-)
  64. %doc AUTHORS COPYING THANKS NEWS
  65. %doc gettext-tools/misc/ChangeLog
  66. %{_datadir}/emacs/site-lisp/%{origname}
  67. %{emacsen_pkgdir}/install/%{origname}
  68. %{emacsen_pkgdir}/remove/%{origname}
  69. %changelog
  70. * Wed Feb 24 2010 IWAI, Masaharu <iwai@alib.jp> - 0.17-5
  71. - split from gettext package: [VineSeed:20076]
  72. - add Packager
  73. - replace Prereq to Requires(post)
  74. - add using forward-line patch (Patch1): <BTS:VineLinux:934>
  75. * Tue Dec 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> - 0.17-4
  76. - correct some output messages on po-mode-install.sh
  77. - use %%emacsen_pkgdir
  78. * Sun May 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.17-3
  79. - we better not to use BuildConflicts very often :-P
  80. instead we pass --disable-java to configure here
  81. - add --enable-shared --disable-static --without-included-gettext to configure
  82. - remove .la files
  83. - add -devel and --libs subpackages
  84. * Wed May 6 2009 IWAI, Masaharu <iwai@alib.jp> 0.17-2
  85. - apply vine-default
  86. - update po-mode-init.el (Source1)
  87. - update po-mode-install.sh (Source3)
  88. - update po-mode-remove.sh (Source4)
  89. - add vine-default-po-mode.el (Source5): based 0.17-1's po-mode-init.el
  90. - update %%doc: gettext-runtime/libasprintf/autosprintf_all.html
  91. * Sat Aug 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17-1
  92. - new upstream release
  93. * Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 0.16.1-1vl5
  94. - applied new versioning policy, spec in utf-8
  95. * Wed Jan 31 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.16.1-0vl2
  96. - changelog update missing
  97. * Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.16.1-0vl1
  98. - new upstream release
  99. * Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.14.5-0vl6
  100. - changed po-mode Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
  101. * Mon Aug 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.14.5-0vl5
  102. - add BuildConflicts: libgcj34-devel not to depend on libgcj34
  103. * Fri Aug 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.14.5-0vl4
  104. - add BuildConflicts: libgcj-devel not to depend on libgcj
  105. - add BuildRequires: emacsen (if emacsen_pkg is enabled)
  106. - remove unneeded files at the %%install
  107. * Mon Aug 07 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.14.5-0vl3
  108. - rebuilt without libgcj package
  109. * Sat Aug 05 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.14.5-0vl2
  110. - modified emacsen-common path
  111. * Wed Jun 15 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.14.5-0vl1
  112. - new upstream release
  113. - updated Source3
  114. - added --disable-csharp
  115. * Wed Apr 7 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.14.1-0vl2
  116. - remove dependency to libgcj
  117. * Wed Apr 7 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.14.1-0vl1
  118. - new upstream release
  119. * Mon Sep 22 2003 IWAI, Masaharu <iwai@alib.jp> 0.12.1-1vl2
  120. - build without libgcj package
  121. - create po-mode package for Emacsen
  122. * Sun Sep 21 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.12.1-1vl1
  123. - based on Redhat Rawhide 0.12.1-1
  124. - dropped all patches (Rawhide does so)
  125. - Source100(ja.po) is much older than source, dropped
  126. - s/Copyright/License/
  127. * Sun Sep 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.11.5-0vl1
  128. - new upstream release
  129. * Mon Jun 10 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org>
  130. - sync with rawhide 0.11.2-2 and Mandrake 0.11.2-4mdk
  131. * Wed Jun 7 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  132. - sync with RH6.2
  133. * Fri Apr 28 2000 Bill Nottingham <notting@redhat.com>
  134. - minor configure tweaks for ia64
  135. * Sun Feb 27 2000 Cristian Gafton <gafton@redhat.com>
  136. - add --comments to msghack
  137. * Thu Feb 10 2000 Cristian Gafton <gafton@redhat.com>
  138. - fix bug #9240 - gettextize has the right aclocal patch
  139. * Wed Jan 12 2000 Cristian Gafton <gafton@redhat.com>
  140. - add the --diff and --dummy options
  141. * Wed Oct 06 1999 Cristian Gafton <gafton@redhat.com>
  142. - add the --missing option to msghack
  143. * Wed Sep 22 1999 Cristian Gafton <gafton@redhat.com>
  144. - updated msghack not to merge in fuzzies in the master catalogs
  145. * Sat Sep 18 1999 Norihito Ohmori <ohmori@flatout.org>
  146. - update ja.po
  147. * Tue Sep 14 1999 Jun Nishii <jun@flatout.org>
  148. - use message.c.diff-2
  149. * Thu Aug 26 1999 Cristian Gafton <gafton@redhat.com>
  150. - updated msghack to understand --append
  151. * Wed Aug 11 1999 Cristian Gafton <gafton@redhat.com>
  152. - updated msghack to correctly deal with sorting files
  153. * Tue Jun 29 1999 Norihito Ohmori <ohmori@flatout.org>
  154. - added multibyte patch for msgmerge
  155. * Sun Jun 27 1999 Norihito Ohmori <ohmori@flatout.org>
  156. - ja locale support from JaPO Project
  157. * Thu May 06 1999 Cristian Gafton <gafton@redhat.com>
  158. - msghack updates
  159. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  160. - auto rebuild in the new build environment (release 8)
  161. * Mon Mar 08 1999 Cristian Gafton <gafton@redhat.com>
  162. - added patch for misc hacks to facilitate rpm translations
  163. * Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com>
  164. - patch to allow to build on ARM
  165. * Wed Sep 30 1998 Jeff Johnson <jbj@redhat.com>
  166. - add Emacs po-mode.el files.
  167. * Sun Sep 13 1998 Cristian Gafton <gafton@redhat.com>
  168. - include the aclocal support files
  169. * Fri Sep 3 1998 Bill Nottingham <notting@redhat.com>
  170. - remove devel package (functionality is in glibc)
  171. * Tue Sep 1 1998 Jeff Johnson <jbj@redhat.com>
  172. - update to 0.10.35.
  173. * Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
  174. - add gettextize.
  175. - create devel package for libintl.a and libgettext.h.
  176. * Mon Apr 27 1998 Prospector System <bugs@redhat.com>
  177. - translations modified for de, fr, tr
  178. * Sun Nov 02 1997 Cristian Gafton <gafton@redhat.com>
  179. - added info handling
  180. - added misc-patch (skip emacs-lisp modofications)
  181. * Sat Nov 01 1997 Erik Troan <ewt@redhat.com>
  182. - removed locale.aliases as we get it from glibc now
  183. - uses a buildroot
  184. * Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
  185. - Built against glibc