123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407 |
- %define _root_sbindir /sbin
- %define upstream_version %{version}
- Summary: A utility for setting up encrypted disks
- Summary(ja): 暗号化ファイルシステム設定用ユーティリティ
- Name: cryptsetup
- Version: 1.4.1
- Release: 3%{?_dist_release}
- License: GPLv2 and LGPLv2+
- Group: Applications/System
- URL: http://cryptsetup.googlecode.com/
- BuildRequires: libgcrypt-devel, popt-devel, device-mapper-devel
- BuildRequires: libgpg-error-devel, libuuid-devel
- BuildRequires: python-devel
- Provides: cryptsetup-luks = %{version}-%{release}
- Obsoletes: cryptsetup-luks < 1.4.0
- Requires: cryptsetup-libs = %{version}-%{release}
- Source0: http://cryptsetup.googlecode.com/files/cryptsetup-%{upstream_version}.tar.bz2
- %description
- The cryptsetup package contains a utility for setting up
- disk encryption using dm-crypt kernel module.
- %description -l ja
- cryptsetup パッケージには、dm-crypt カーネルモジュールを使って
- ディスクの暗号化を設定するユーティリティが収録されています。
- %package devel
- Group: Development/Libraries
- Requires: %{name} = %{version}-%{release}
- Requires: libgcrypt-devel > 1.1.42, device-mapper-devel, libuuid-devel
- Requires: pkgconfig
- Summary: Headers and libraries for using encrypted file systems
- Summary(ja): 暗号化ファイルシステムを使うためのヘッダとライブラリ
- Provides: cryptsetup-luks-devel = %{version}-%{release}
- Obsoletes: cryptsetup-luks-devel < 1.4.0
- %description devel
- The cryptsetup-devel package contains libraries and header files
- used for writing code that makes use of disk encryption.
- %description devel -l ja
- cryptsetup-devel パッケージには、ディスクの暗号化を使うコードを
- 書くのに使われるライブラリとヘッダファイルが収録されています。
- %package libs
- Group: System Environment/Libraries
- Summary: Cryptsetup shared library
- Summary(ja): Cryptsetup 共有ライブラリ
- Provides: cryptsetup-luks-libs = %{version}-%{release}
- Obsoletes: cryptsetup-luks-libs < 1.4.0
- %description libs
- This package contains the cryptsetup shared library, libcryptsetup.
- %description libs -l ja
- このパッケージには、cryptsetup の共有ライブラリ、libcryptsetup が
- 収録されています。
- %package python
- Group: System Environment/Libraries
- Summary: Python bindings for libcryptsetup
- Summary(ja): libcryptsetup の Python バインディング
- Requires: %{name}-libs = %{version}-%{release}
- Provides: python-cryptsetup = %{version}-%{release}
- Obsoletes: python-cryptsetup < 1.4.0
- %description python
- This package provides Python bindings for libcryptsetup, a library
- for setting up disk encryption using dm-crypt kernel module.
- %description python -l ja
- このパッケージには、dm-crypt カーネルモジュールを使って
- ディスクの暗号化を設定するライブラリ libcryptsetup の
- Python バインディングが収録されています。
- %prep
- %setup -q -n cryptsetup-%{upstream_version}
- chmod -x python/pycryptsetup-test.py
- %build
- %configure --sbindir=%{_root_sbindir} --libdir=/%{_lib} \
- --enable-python \
- --disable-selinux
- # remove rpath
- sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
- sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
- make %{?_smp_mflags}
- %install
- rm -rf %{buildroot}
- make install DESTDIR=%{buildroot}
- rm -rf %{buildroot}/%{_lib}/*.la %{buildroot}/%{_lib}/cryptsetup
- # move libcryptsetup.so to %%{_libdir}
- pushd %{buildroot}/%{_lib}
- rm libcryptsetup.so
- mkdir -p %{buildroot}/%{_libdir}
- ln -s ../../%{_lib}/$(ls libcryptsetup.so.?.?.?) %{buildroot}/%{_libdir}/libcryptsetup.so
- mv %{buildroot}/%{_lib}/pkgconfig %{buildroot}/%{_libdir}
- popd
- %find_lang cryptsetup
- %post -n cryptsetup-libs -p /sbin/ldconfig
- %postun -n cryptsetup-libs -p /sbin/ldconfig
- %files -f cryptsetup.lang
- %doc COPYING ChangeLog AUTHORS TODO FAQ
- %{_mandir}/man8/cryptsetup.8.gz
- %{_root_sbindir}/cryptsetup
- %files devel
- %doc docs/examples/*
- %{_includedir}/libcryptsetup.h
- %{_libdir}/libcryptsetup.so
- %{_libdir}/pkgconfig/libcryptsetup.pc
- %files libs
- %doc COPYING
- /%{_lib}/libcryptsetup.so.*
- %files python
- %doc COPYING.LGPL python/pycryptsetup-test.py
- %exclude %{python_sitearch}/pycryptsetup.la
- %{python_sitearch}/pycryptsetup.so
- %clean
- rm -rf %{buildroot}
- %changelog
- * Fri Mar 23 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4.1-3
- - updated to 1.4.1; spec revamp; Japanese summary & description
- - Sun Sep 21 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.5-8vl5
- - applied new versioning policy
-
- - Sun Dec 9 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.5-7vl1
- - initial build for VineSeed
- * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.1-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
- * Wed Nov 09 2011 Milan Broz <mbroz@redhat.com> - 1.4.1-1
- - Update to cryptsetup 1.4.1.
- - Add Python cryptsetup bindings.
- - Obsolete separate python-cryptsetup package.
- * Wed Oct 26 2011 Milan Broz <mbroz@redhat.com> - 1.4.0-1
- - Update to cryptsetup 1.4.0.
- * Mon Oct 10 2011 Milan Broz <mbroz@redhat.com> - 1.4.0-0.1
- - Update to cryptsetup 1.4.0-rc1.
- - Rename package back from cryptsetup-luks to cryptsetup.
- * Wed Jun 22 2011 Milan Broz <mbroz@redhat.com> - 1.3.1-2
- - Fix return code for status command when device doesn't exist.
- * Tue May 24 2011 Milan Broz <mbroz@redhat.com> - 1.3.1-1
- - Update to cryptsetup 1.3.1.
- * Tue Apr 05 2011 Milan Broz <mbroz@redhat.com> - 1.3.0-1
- - Update to cryptsetup 1.3.0.
- * Tue Mar 22 2011 Milan Broz <mbroz@redhat.com> - 1.3.0-0.2
- - Update to cryptsetup 1.3.0-rc2
- * Mon Mar 14 2011 Milan Broz <mbroz@redhat.com> - 1.3.0-0.1
- - Update to cryptsetup 1.3.0-rc1
- * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
- * Mon Dec 20 2010 Milan Broz <mbroz@redhat.com> - 1.2.0-1
- - Update to cryptsetup 1.2.0
- * Thu Nov 25 2010 Milan Broz <mbroz@redhat.com> - 1.2.0-0.2
- - Fix crypt_activate_by_keyfile() to work with PLAIN devices.
- * Tue Nov 16 2010 Milan Broz <mbroz@redhat.com> - 1.2.0-0.1
- - Add FAQ to documentation.
- - Update to cryptsetup 1.2.0-rc1
- * Sat Jul 03 2010 Milan Broz <mbroz@redhat.com> - 1.1.3-1
- - Update to cryptsetup 1.1.3
- * Mon Jun 07 2010 Milan Broz <mbroz@redhat.com> - 1.1.2-2
- - Fix alignment ioctl use.
- - Fix API activation calls to handle NULL device name.
- * Sun May 30 2010 Milan Broz <mbroz@redhat.com> - 1.1.2-1
- - Update to cryptsetup 1.1.2
- - Fix luksOpen handling of new line char on stdin.
- * Sun May 23 2010 Milan Broz <mbroz@redhat.com> - 1.1.1-1
- - Update to cryptsetup 1.1.1
- - Fix luksClose for stacked LUKS/LVM devices.
- * Mon May 03 2010 Milan Broz <mbroz@redhat.com> - 1.1.1-0.2
- - Update to cryptsetup 1.1.1-rc2.
- * Sat May 01 2010 Milan Broz <mbroz@redhat.com> - 1.1.1-0.1
- - Update to cryptsetup 1.1.1-rc1.
- * Sun Jan 17 2010 Milan Broz <mbroz@redhat.com> - 1.1.0-1
- - Update to cryptsetup 1.1.0.
- * Fri Jan 15 2010 Milan Broz <mbroz@redhat.com> - 1.1.0-0.6
- - Fix gcrypt initialisation.
- - Fix backward compatibility for hash algorithm (uppercase).
- * Wed Dec 30 2009 Milan Broz <mbroz@redhat.com> - 1.1.0-0.5
- - Update to cryptsetup 1.1.0-rc4
- * Mon Nov 16 2009 Milan Broz <mbroz@redhat.com> - 1.1.0-0.4
- - Update to cryptsetup 1.1.0-rc3
- * Thu Oct 01 2009 Milan Broz <mbroz@redhat.com> - 1.1.0-0.3
- - Update to cryptsetup 1.1.0-rc2
- - Fix libcryptsetup to properly export only versioned symbols.
- * Tue Sep 29 2009 Milan Broz <mbroz@redhat.com> - 1.1.0-0.2
- - Update to cryptsetup 1.1.0-rc1
- - Add luksHeaderBackup and luksHeaderRestore commands.
- * Thu Sep 11 2009 Milan Broz <mbroz@redhat.com> - 1.1.0-0.1
- - Update to new upstream testing version with new API interface.
- - Add luksSuspend and luksResume commands.
- - Introduce pkgconfig.
- * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.7-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
- * Wed Jul 22 2009 Milan Broz <mbroz@redhat.com> - 1.0.7-1
- - Update to upstream final release.
- - Split libs subpackage.
- - Remove rpath setting from cryptsetup binary.
- * Wed Jul 15 2009 Till Maas <opensource@till.name> - 1.0.7-0.2
- - update BR because of libuuid splitout from e2fsprogs
- * Mon Jun 22 2009 Milan Broz <mbroz@redhat.com> - 1.0.7-0.1
- - Update to new upstream 1.0.7-rc1.
- - Wipe old fs headers to not confuse blkid (#468062)
- * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.6-7
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
- * Thu Oct 30 2008 Milan Broz <mbroz@redhat.com> - 1.0.6-6
- - Wipe old fs headers to not confuse blkid (#468062)
- * Tue Sep 23 2008 Milan Broz <mbroz@redhat.com> - 1.0.6-5
- - Change new project home page.
- - Print more descriptive messages for initialization errors.
- - Refresh patches to versions commited upstream.
- * Sat Sep 06 2008 Milan Broz <mbroz@redhat.com> - 1.0.6-4
- - Fix close of zero decriptor.
- - Fix udevsettle delays - use temporary crypt device remapping.
- * Wed May 28 2008 Till Maas <opensource till name> - 1.0.6-3
- - remove a duplicate sentence from the manpage (RH #448705)
- - add patch metadata about upstream status
- * Tue Apr 15 2008 Bill Nottinghm <notting@redhat.com> - 1.0.6-2
- - Add the device to the luksOpen prompt (#433406)
- - Use iconv, not recode (#442574)
- * Thu Mar 13 2008 Till Maas <opensource till name> - 1.0.6-1
- - Update to latest version
- - remove patches that have been merged upstream
- * Mon Mar 03 2008 Till Maas <opensource till name> - 1.0.6-0.1.pre2
- - Update to new version with several bugfixes
- - remove patches that have been merged upstream
- - add patch from cryptsetup newsgroup
- - fix typo / missing luksRemoveKey in manpage (patch)
- * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.5-9
- - Autorebuild for GCC 4.3
- * Sat Jan 19 2008 Peter Jones <pjones@redhat.com> - 1.0.5-8
- - Rebuild for broken deps.
- * Thu Aug 30 2007 Till Maas <opensource till name> - 1.0.5-7
- - update URL
- - update license tag
- - recode ChangeLog from latin1 to uf8
- - add smp_mflags to make
- * Fri Aug 24 2007 Till Maas <opensource till name> - 1.0.5-6
- - cleanup BuildRequires:
- - removed versions, packages in Fedora are new enough
- - changed popt to popt-devel
- * Thu Aug 23 2007 Till Maas <opensource till name> - 1.0.5-5
- - fix devel subpackage requires
- - remove empty NEWS README
- - remove uneeded INSTALL
- - remove uneeded ldconfig requires
- - add readonly detection patch
- * Wed Aug 08 2007 Till Maas <opensource till name> - 1.0.5-4
- - disable patch2, libsepol is now detected by configure
- - move libcryptsetup.so to %%{_libdir} instead of /%%{_lib}
- * Fri Jul 27 2007 Till Maas <opensource till name> - 1.0.5-3
- - Use /%%{_lib} instead of /lib to use /lib64 on 64bit archs
- * Thu Jul 26 2007 Till Maas <opensource till name> - 1.0.5-2
- - Use /lib as libdir (#243228)
- - sync header and library (#215349)
- - do not use %%makeinstall (recommended by PackageGuidelines)
- - select sbindir with %%configure instead with make
- - add TODO
- * Wed Jun 13 2007 Jeremy Katz <katzj@redhat.com> - 1.0.5-1
- - update to 1.0.5
- * Mon Jun 04 2007 Peter Jones <pjones@redhat.com> - 1.0.3-5
- - Don't build static any more.
- * Mon Feb 05 2007 Alasdair Kergon <agk@redhat.com> - 1.0.3-4
- - Add build dependency on new device-mapper-devel package.
- - Add preun and post ldconfig requirements.
- - Update BuildRoot.
- * Wed Nov 1 2006 Peter Jones <pjones@redhat.com> - 1.0.3-3
- - Require newer libselinux (#213414)
- * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.0.3-2.1
- - rebuild
- * Wed Jun 7 2006 Jeremy Katz <katzj@redhat.com> - 1.0.3-2
- - put shared libs in the right subpackages
- * Fri Apr 7 2006 Bill Nottingham <notting@redhat.com> 1.0.3-1
- - update to final 1.0.3
- * Wed Feb 27 2006 Bill Nottingham <notting@redhat.com> 1.0.3-0.rc2
- - update to 1.0.3rc2, fixes bug with HAL & encrypted devices (#182658)
- * Wed Feb 22 2006 Bill Nottingham <notting@redhat.com> 1.0.3-0.rc1
- - update to 1.0.3rc1, reverts changes to default encryption type
- * Tue Feb 21 2006 Bill Nottingham <notting@redhat.com> 1.0.2-1
- - update to 1.0.2, fix incompatiblity with old cryptsetup (#176726)
- * Mon Feb 20 2006 Karsten Hopp <karsten@redhat.de> 1.0.1-5
- - BuildRequires: libselinux-devel
- * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.0.1-4.2.1
- - bump again for double-long bug on ppc(64)
- * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.0.1-4.2
- - rebuilt for new gcc4.1 snapshot and glibc changes
- * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
- - rebuilt
- * Mon Dec 5 2005 Bill Nottingham <notting@redhat.com> 1.0.1-4
- - rebuild against new libdevmapper
- * Thu Oct 13 2005 Florian La Roche <laroche@redhat.com>
- - add -lsepol to rebuild on current fc5
- * Mon Aug 22 2005 Karel Zak <kzak@redhat.com> 1.0.1-2
- - fix cryptsetup help for isLuks action
- * Fri Jul 1 2005 Bill Nottingham <notting@redhat.com> 1.0.1-1
- - update to 1.0.1 - fixes incompatiblity with previous cryptsetup for
- piped passwords
- * Thu Jun 16 2005 Bill Nottingham <notting@redhat.com> 1.0-2
- - add patch for 32/64 bit compatibility (#160445, <redhat@paukstadt.de>)
- * Tue Mar 29 2005 Bill Nottingham <notting@redhat.com> 1.0-1
- - update to 1.0
- * Thu Mar 10 2005 Bill Nottingham <notting@redhat.com> 0.993-1
- - switch to cryptsetup-luks, for LUKS support
- * Tue Oct 12 2004 Bill Nottingham <notting@redhat.com> 0.1-4
- - oops, make that *everything* static (#129926)
- * Tue Aug 31 2004 Bill Nottingham <notting@redhat.com> 0.1-3
- - link some things static, move to /sbin (#129926)
- * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
- - rebuilt
- * Fri Apr 16 2004 Bill Nottingham <notting@redhat.com> 0.1-1
- - initial packaging
|