tzdata-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424
  1. Summary: Timezone data
  2. Summary(ja): タイムゾーンのデータ
  3. Name: tzdata
  4. Version: 2022f
  5. %define tzdata_version 2022f
  6. %define tzcode_version 2022f
  7. Release: 1%{?_dist_release}
  8. Group: system
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. License: Public Domain
  12. URL: https://www.iana.org/time-zones
  13. # These are official upstream.
  14. Source0: https://data.iana.org/time-zones/releases/tzdata%{tzdata_version}.tar.gz
  15. Source1: https://data.iana.org/time-zones/releases/tzcode%{tzcode_version}.tar.gz
  16. Source2: javazic.tar.gz
  17. Source3: javazic-1.8-37392f2f5d59.tar.xz
  18. Patch002: 0002-Fix-have-snprintf-error.patch
  19. Patch100: javazic-fixup.patch
  20. Patch101: rebase-01.patch
  21. Patch102: rebase-02.patch
  22. Patch103: 7090844.patch
  23. Patch104: 7133138.patch
  24. BuildArch: noarch
  25. BuildRequires: gawk, glibc, perl
  26. BuildRequires: java-1.8.0-openjdk-devel
  27. BuildRequires: glibc-common >= 2.5.90-7
  28. Conflicts: glibc-common <= 2.3.2-63
  29. %description
  30. This package contains data files with rules for various timezones around
  31. the world.
  32. %description -l ja
  33. このパッケージには世界中のタイムゾーンに関するデータファイルが収録されています.
  34. %package java
  35. Summary: Timezone data for Java
  36. Group: system
  37. %description java
  38. This package contains timezone information for use by Java runtimes.
  39. %prep
  40. %setup -q -c -a 1
  41. %patch002 -p1
  42. # tzdata-2018g introduce 25:00 transition times. This breaks OpenJDK.
  43. # Use rearguard for tzdata-2018g java
  44. mkdir rearguard
  45. make VERSION=%{version} tzdata%{version}-rearguard.tar.gz
  46. mv tzdata%{version}-rearguard.tar.gz rearguard
  47. pushd rearguard
  48. tar zxf tzdata%{version}-rearguard.tar.gz
  49. popd
  50. mkdir javazic
  51. tar zxf %{SOURCE2} -C javazic
  52. pushd javazic
  53. %patch100
  54. %patch101
  55. %patch102
  56. %patch103
  57. %patch104
  58. # Hack alert! sun.tools may be defined and installed in the
  59. # VM. In order to guarantee that we are using IcedTea/OpenJDK
  60. # for creating the zoneinfo files, rebase all the packages
  61. # from "sun." to "rht.". Unfortunately, gcj does not support
  62. # any of the -Xclasspath options, so we must go this route
  63. # to ensure the greatest compatibility.
  64. mv sun rht
  65. find . -type f -name '*.java' -print0 \
  66. | xargs -0 -- sed -i -e 's:sun\.tools\.:rht.tools.:g' \
  67. -e 's:sun\.util\.:rht.util.:g'
  68. popd
  69. tar xf %{SOURCE3}
  70. echo "%{name}%{tzdata_version}" >> VERSION
  71. %build
  72. # Run make to create the tzdata.zi file
  73. rm tzdata.zi
  74. make tzdata.zi
  75. FILES="africa antarctica asia australasia europe northamerica southamerica
  76. etcetera backward factory"
  77. mkdir zoneinfo/{,posix,right}
  78. zic -y ./yearistype -d zoneinfo -L /dev/null -p America/New_York $FILES
  79. zic -y ./yearistype -d zoneinfo/posix -L /dev/null $FILES
  80. zic -y ./yearistype -d zoneinfo/right -L leapseconds $FILES
  81. # tzdata-2018g uses 25:00 which breaks java - use the rearguard files for java
  82. JAVA_FILES="rearguard/africa rearguard/antarctica rearguard/asia \
  83. rearguard/australasia rearguard/europe rearguard/northamerica \
  84. rearguard/southamerica rearguard/pacificnew rearguard/etcetera \
  85. rearguard/backward"
  86. # Java 6/7 tzdata
  87. pushd javazic
  88. javac -source 1.5 -target 1.5 -classpath . `find . -name \*.java`
  89. popd
  90. java -classpath javazic/ rht.tools.javazic.Main -V %{version} \
  91. -d javazi \
  92. $JAVA_FILES javazic/tzdata_jdk/gmt javazic/tzdata_jdk/jdk11_backward
  93. # Java 8 tzdata
  94. pushd javazic-1.8
  95. javac -source 1.7 -target 1.7 -classpath . `find . -name \*.java`
  96. popd
  97. java -classpath javazic-1.8 build.tools.tzdb.TzdbZoneRulesCompiler \
  98. -srcdir . -dstfile tzdb.dat \
  99. -verbose \
  100. $JAVA_FILES javazic-1.8/tzdata_jdk/gmt javazic-1.8/tzdata_jdk/jdk11_backward
  101. %install
  102. rm -fr $RPM_BUILD_ROOT
  103. install -d $RPM_BUILD_ROOT%{_datadir}
  104. cp -prd zoneinfo $RPM_BUILD_ROOT%{_datadir}
  105. install -p -m 644 zone.tab zone1970.tab iso3166.tab leapseconds tzdata.zi $RPM_BUILD_ROOT%{_datadir}/zoneinfo
  106. cp -prd javazi $RPM_BUILD_ROOT%{_datadir}/javazi
  107. mkdir -p $RPM_BUILD_ROOT%{_datadir}/javazi-1.8
  108. install -p -m 644 tzdb.dat $RPM_BUILD_ROOT%{_datadir}/javazi-1.8/
  109. %clean
  110. rm -fr $RPM_BUILD_ROOT
  111. %files
  112. %defattr(-,root,root)
  113. %{_datadir}/zoneinfo
  114. %license LICENSE
  115. %doc README
  116. %doc theory.html
  117. %doc tz-link.html
  118. %doc tz-art.html
  119. %files java
  120. %defattr(-,root,root)
  121. %{_datadir}/javazi
  122. %{_datadir}/javazi-1.8
  123. %changelog
  124. * Sun Nov 20 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2022f-1
  125. - updated to 2022f.
  126. * Wed Nov 24 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2021e-1
  127. - updated to 2021e.
  128. * Thu Feb 25 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2021a-1
  129. - updated to 2021a.
  130. * Sat Mar 21 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2019c-1
  131. - updated to 2019c.
  132. * Sun Jan 06 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2018i-1
  133. - updated to 2018i.
  134. * Mon Jun 26 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2017b-1
  135. - update to 2017b
  136. * Mon Nov 28 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 2016j-1
  137. - updated to 2016j.
  138. * Thu Jul 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016f-2
  139. - fixed changelog.
  140. - added Vendor and Distribution tag.
  141. * Thu Jul 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016f-1
  142. - updated to 2016f.
  143. * Sun Jun 19 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016e-1
  144. - updated to 2016e.
  145. - enabled java18 stuff.
  146. * Mon May 9 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016d-1
  147. - updated to 2016d.
  148. * Mon Aug 17 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2015f-1
  149. - updated to 2015f.
  150. * Wed Jun 17 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2015e-1
  151. - updated to 2015e.
  152. * Sun Jun 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2012c-1
  153. - update to tzdata-2012c, tzcode-2012b
  154. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 2010l-2
  155. - rebuilt with rpm-4.8.1-3
  156. * Sat Sep 04 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2010l-1
  157. - update to tzdata-2010l, tzcode-2010l
  158. - added java subpackage
  159. * Tue Apr 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2009d-1
  160. - update to tzdata-2009d, tzcode-2009d
  161. - spec in utf-8
  162. * Sun Apr 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2008b-1
  163. - update to tzdata-2008b, tzcode-2008a
  164. * Sun May 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2007d-1vl1
  165. - initial build for VineSeed
  166. * Fri Mar 23 2007 Petr Machata <pmachata@redhat.com> - 2007d-1
  167. - Upstream 2007d
  168. - Mongolia has abolished DST.
  169. - Turkey will use EU rules this year, changing at 01:00 UTC rather
  170. than 01:00 standard time.
  171. - Cuba observed DST starting Sunday.
  172. - Resolute, Nunavut switched from Central to Eastern time last
  173. November.
  174. * Mon Feb 26 2007 Petr Machata <pmachata@redhat.com> - 2007c-1
  175. - Upstream 2007c
  176. - Pulaski County, Indiana, switched back to eastern time.
  177. - Turkey switches at 01:00 standard time, not at 01:00 UTC.
  178. - Upstream 2007b
  179. - Changes to the commentary in "leapseconds".
  180. - Upstream 2007a
  181. - Updates to Bahamas, they will be in sync with 2007 US DST change
  182. - New zone Australia/Eucla
  183. - Africa/Asmera renamed to Africa/Asmara, link created
  184. - Atlantic/Faeroe renamed to Atlantic/Faroe, link created
  185. * Wed Nov 29 2006 Petr Machata <pmachata@redhat.com> - 2006p-1
  186. - Upstream 2006p
  187. - Covers changes from 2006m-2 and 2006m-3
  188. - Latitude/longitude changes for Europe/Jersey and Europe/Podgorica
  189. * Wed Nov 22 2006 Petr Machata <pmachata@redhat.com> - 2006m-3
  190. - Patch for Western Australia DST trial
  191. * Tue Oct 10 2006 Petr Machata <pmachata@redhat.com> - 2006m-2
  192. - Proposed upstream patch (#210058)
  193. - Jordan will switch to winter time on October 27, not September 29
  194. - Brazil's DST this year is the first Sunday in November to the last
  195. Sunday in February. (Thanks to Frederico A. C. Neves.)
  196. - ISO 3166 codes for Serbia and Montenegro, zone Europe/Podgorica
  197. - Commentary and past timestamps changes
  198. * Tue Oct 3 2006 Petr Machata <pmachata@redhat.com> - 2006m-1
  199. - Upstream 2006m:
  200. - Adjustments for Egypt, Palestine, Uruguay
  201. - Better description of `until' field in zic (8) manpage
  202. * Thu Sep 21 2006 Petr Machata <pmachata@redhat.com> - 2006l-1
  203. - Upstream 2006k, 2006l:
  204. - Adjustments for Egypt, Palestine, Cuba, Honduras
  205. - Documentation changes
  206. * Tue Aug 22 2006 Petr Machata <pmachata@redhat.com> - 2006j-1
  207. - Upstream 2006j
  208. - Honduras stopped observing DST on Monday at 00:00
  209. - America/Bermuda will follow the US's lead next year
  210. - America/Moncton will use US-style rules next year
  211. - New Zone America/Blanc-Sablon, for Canadians who observe AST all
  212. year
  213. - New zone: America/Atikokan instead of America/Coral_Harbour
  214. - New zones: Europe/Jersey, Europe/Guernsey, Europe/Isle_of_Man
  215. - Historical changes
  216. - Commentary updates
  217. - Upstream 2006i
  218. - localtime.c fixes
  219. - Upstream 2006h
  220. - zic leapsecond fix
  221. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2006g-1.1
  222. - rebuild
  223. * Thu May 11 2006 Petr Machata <pmachata@redhat.com> - 2006g-1
  224. - Honduras chose to follow Guatemala and will observe DST May/6 to Sep/2
  225. - Nicaragua updates
  226. * Tue May 2 2006 Petr Machata <pmachata@redhat.com> - 2006f-1
  227. - Upstream 2006f
  228. - America/Guatemala observes DST between Apr/30 and Oct/1
  229. - Historical changes for Nicaragua
  230. - Update of America/Indiana/Vincennes in zone table
  231. * Thu Apr 20 2006 Petr Machata <pmachata@redhat.com> - 2006d-1
  232. - Upstream 2006d
  233. - Haiti observes DST
  234. - Sri Lanka change actually took effect Apr/15
  235. - All Canada is now scheduled for 2007 US DST rules
  236. - Some historical fixes
  237. * Thu Apr 6 2006 Petr Machata <pmachata@redhat.com> - 2006c-1
  238. - Upstream 2006c
  239. - Time-related changes:
  240. - dozens of historical and commentary changes
  241. - Iran stopped observing DST
  242. - Sri Lanka switches from UTC+6 to UTC+5:30
  243. - America/Thule and America/Edmonton will adopt new US rules,
  244. starting 2007
  245. - Tunisia is adopting regular DST
  246. - Code:
  247. - asctime.c: Chages in format strings to silent gcc warnings
  248. - removing K&R notation from function signatures
  249. - few fixes across the code
  250. * Thu Mar 16 2006 Petr Machata <pmachata@redhat.com> - 2006b-2
  251. - Patch for Sri Lanka time zone change (#184514)
  252. * Wed Feb 22 2006 Petr Machata <pmachata@redhat.com> 2006b-1
  253. - Upstream 2006b:
  254. - using tz64code version, as 32 is legacy according to tzdata ML
  255. - new manual pages for ctime, strftime, tzset
  256. - some source code reorganizations
  257. - no timezone/dst rule updates
  258. * Thu Feb 02 2006 Petr Machata <pmachata@redhat.com> 2006a-2
  259. - Small changes in tst-timezone.c
  260. * Thu Feb 02 2006 Petr Machata <pmachata@redhat.com> 2006a-1
  261. - Upstream 2006a:
  262. - private.h(scheck): changing char* to char const*
  263. - Rule changes for Palestine, zone changes for Indiana/US, both
  264. changes for Canada.
  265. - Many related doc changes.
  266. - Naming scheme in spec file doesn't use %%{name}, but tzdata.
  267. * Thu Jan 12 2006 Petr Machata <pmachata@redhat.com> 2005r-3
  268. - 2005r-3
  269. - Meta changes. Renaming tzdata.tar.bz2 file to tzdata$ver-base,
  270. so that it won't clash across updates.
  271. * Thu Jan 5 2006 Petr Machata <pmachata@redhat.com> 2005r-2
  272. - 2005r
  273. - Zones EST, MST, HST, EST5EDT, CST6CDT, MST7MDT, PST8PDT moved to
  274. northamerica to guard against old files with obsolete information
  275. being left in the time zone binary directory.
  276. - Changes for countries that are supposed to join 2007 US DST
  277. change. This includes most of Canada, however entries already in
  278. the database (Alberta, British Columbia, Newfoundland, Northwest
  279. Territories, and Yukon) were left alone for the time being.
  280. - Fixes in zdump.c (abbrok): conditions are chained, and the string
  281. is checked for emptiness.
  282. * Sat Dec 17 2005 Jakub Jelinek <jakub@redhat.com> 2005q-2
  283. - 2005q
  284. - changes for Georgia, Azerbaijan, Jordan, Palestine, Cuba, Nicaragua
  285. - SystemV timezone changes
  286. * Wed Nov 2 2005 Jakub Jelinek <jakub@redhat.com> 2005n-2
  287. - 2005n
  288. - changes for Kyrgyzstan and Uruguay
  289. - fix a typo in the Makefile (used TZDATA env var instead of TZDIR during
  290. make check), update tst-timezone.c from glibc CVS (#172102)
  291. * Tue Sep 6 2005 Jakub Jelinek <jakub@redhat.com> 2005m-2
  292. - 2005m
  293. - changes for USA (extending DST by 4 weeks since 2007), Tunisia,
  294. Australia, Kazakhstan
  295. - historical timezone data changes for Japan, Poland, Northern Ireland and
  296. Mali
  297. - timezone name change for East Timor
  298. * Fri Jul 15 2005 Jakub Jelinek <jakub@redhat.com> 2005k-2
  299. - 2005k
  300. - leap seconds update
  301. * Sat Apr 30 2005 Jakub Jelinek <jakub@redhat.com> 2005i-2
  302. - 2005i
  303. - updates for Iran, Haiti and Nicaragua
  304. * Mon Apr 4 2005 Jakub Jelinek <jakub@redhat.com> 2005h-2
  305. - 2005h
  306. - fixes for Kazakhstan
  307. * Thu Mar 17 2005 Jakub Jelinek <jakub@redhat.com> 2005g-2
  308. - 2005g
  309. - fixes for Uruguay
  310. - include README and Theory from tzcode tarball in %{_docdir};
  311. Theory includes a good summary of how the timezone data files
  312. are supposed to be named
  313. * Tue Mar 1 2005 Jakub Jelinek <jakub@redhat.com> 2005f-2
  314. - 2005f
  315. - more updates for Israel, updates for Azerbaijan
  316. * Wed Jan 26 2005 Jakub Jelinek <jakub@redhat.com> 2005c-3
  317. - 2005c
  318. - updates for Israel and Paraguay
  319. * Mon Nov 29 2004 Jakub Jelinek <jakub@redhat.com> 2004g-1
  320. - 2004g (#141107)
  321. - updates for Cuba
  322. * Mon Oct 11 2004 Jakub Jelinek <jakub@redhat.com> 2004e-2
  323. - 2004e (#135194)
  324. - updates for Brazil, Uruguay and Argentina
  325. * Wed Aug 4 2004 Jakub Jelinek <jakub@redhat.com> 2004b-2
  326. - 2004b
  327. * Mon Oct 6 2003 Jakub Jelinek <jakub@redhat.com> 2003d-1
  328. - 2003d
  329. * Thu Sep 25 2003 Jakub Jelinek <jakub@redhat.com> 2003c-1
  330. - 2003c
  331. - updates for Brazil (#104840)
  332. * Mon Jul 28 2003 Jakub Jelinek <jakub@redhat.com> 2003a-2
  333. - rebuilt
  334. * Mon Jul 28 2003 Jakub Jelinek <jakub@redhat.com> 2003a-1
  335. - initial package