thunderbird-vl.spec 25 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746
  1. # do not include minor version number in MOZILLA_FIVE_HOME
  2. %define tbmajor 3.1
  3. %define tbversion %{tbmajor}
  4. %define tbrelease 2%{?_dist_release}
  5. # The tarball is pretty inconsistent with directory structure.
  6. # Sometimes there is a top level directory. That goes here.
  7. #
  8. # IMPORTANT: If there is no top level directory, this should be
  9. # set to the cwd, ie: '.'
  10. #%define tarballdir .
  11. %define tarballdir comm-1.9.2
  12. %define mozappdir %{_libdir}/%{name}-%{version_internal}
  13. %define moz_objdir objdir-tb
  14. %define version_internal 3.1
  15. %define thunderbird_app_id \{3550f703-e582-4d05-9a08-453d09bdfdc6\}
  16. %define desktop_file_utils_version 0.6
  17. %define nspr_version 4.8
  18. %define nss_version 3.12.6
  19. %define cairo_version 1.6.0
  20. %define freetype_version 2.1.9
  21. %define sqlite_version 3.6.14
  22. %define libnotify_version 0.4
  23. %define build_vineseed 0
  24. %define build_vine5 0
  25. %if "%{?_dist_release}" == "vl6"
  26. %define build_vineseed 1
  27. %endif
  28. %if "%{?_dist_release}" == "vl5"
  29. %define build_vine5 1
  30. %endif
  31. Summary: Thunderbird Community Edition, Mail/newsgroup client
  32. Summary(ja): Thunderbirdコミュニティエディション, メール・ニュースクライアント
  33. Name: thunderbird
  34. Version: %{tbversion}
  35. Release: %{tbrelease}
  36. URL: http://www.mozilla.org/projects/thunderbird/
  37. License: MPL
  38. Group: Applications/Internet
  39. Source0: ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/source/thunderbird-%{version}.source.tar.bz2
  40. #Source1010: mozconfig-thunderbird-vine3
  41. #Source1020: mozconfig-thunderbird-vine4
  42. Source1030: mozconfig-thunderbird-vine5
  43. Source1040: mozconfig-thunderbird-vine6
  44. Source12: thunderbird-vine-default-prefs.js
  45. Source20: thunderbird.desktop
  46. Source21: thunderbird.vine.sh.in
  47. #Source22: thunderbird.png
  48. Source30: thunderbird-open-browser.sh
  49. Source40: thunderbird-unofficial-brandig-tb-brand.properties
  50. Source41: thunderbird-unofficial-brandig-tb-brand.dtd
  51. Source100: find-external-requires
  52. # locale sources
  53. %define MOZ_BUILD_LOCALES "ja"
  54. # get from mercurial repository with command,
  55. # hg clone http://hg.mozilla.org/releases/l10n-mozilla-1.9.2/ja l10n
  56. Source1000: thunderbird-%{tbversion}-ja.tar.bz2
  57. # upstream patch
  58. # Fix for jemalloc
  59. Patch1: mozilla-jemalloc.patch
  60. # Fix for installation fail when building with dynamic linked libraries
  61. Patch2: thunderbird-shared-error.patch
  62. # Fixes gcc complain that nsFrame::delete is protected
  63. Patch4: xulrunner-1.9.2.1-build.patch
  64. # customization patches
  65. #Patch22: firefox-1.0-psfonts.patch
  66. #Patch24: thunderbird-2.0-default-applications.patch
  67. #Patch25: thunderbird-1.1-software-update.patch
  68. Patch26: firefox-1.5-default-a4-paper.patch
  69. # font system fixes
  70. #Patch81: firefox-nopangoxft.patch
  71. ## Vine patch
  72. # http://bugzilla.mozilla.org/show_bug.cgi?id=179248
  73. Patch1000: thunderbird-3.1-sjisalias.patch
  74. # use /proc/net/netstat for random seed instead of netstat command.
  75. #Patch1010: firefox-nss-no_netstat.patch
  76. # workaround gcc visibility hidden bugs (see gcc#26905)
  77. Patch1020: firefox-2.0.0.3-visibility.patch
  78. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  79. BuildRequires: pango-devel
  80. BuildRequires: cairo-devel >= %{cairo_version}
  81. %if %{build_vineseed}
  82. BuildRequires: nspr-devel >= %{nspr_version}
  83. BuildRequires: nss-devel >= %{nss_version}
  84. %endif
  85. BuildRequires: pixman-devel
  86. BuildRequires: libpng-devel
  87. BuildRequires: libjpeg-devel
  88. BuildRequires: gtk2-devel
  89. BuildRequires: zlib-devel, gzip, zip, unzip
  90. BuildRequires: libIDL-devel
  91. BuildRequires: freetype2-devel >= %{freetype_version}
  92. ## disabled libnotify support
  93. ## see related bug: https://bugzilla.mozilla.org/show_bug.cgi?id=478463
  94. #BuildRequires: libnotify-devel >= %{libnotify_version}
  95. BuildRequires: bzip2-devel
  96. BuildRequires: gnome-vfs2-devel
  97. BuildRequires: libgnome-devel
  98. BuildRequires: libgnomeui-devel
  99. BuildRequires: krb5-devel
  100. BuildRequires: pango-devel
  101. BuildRequires: libXt-devel
  102. BuildRequires: libXrender-devel
  103. BuildRequires: hunspell-devel
  104. BuildRequires: sqlite3-devel >= %{sqlite_version}
  105. BuildRequires: startup-notification-devel
  106. BuildRequires: desktop-file-utils
  107. BuildRequires: alsa-lib-devel
  108. Requires: sqlite3 >= %{sqlite_version}
  109. Requires(post): desktop-file-utils >= %{desktop_file_utils_version}
  110. Requires(postun): desktop-file-utils >= %{desktop_file_utils_version}
  111. Obsoletes: MozillaThunderbird
  112. Provides: MozillaThunderbird = %{version}
  113. Packager: daisuke, ryoichi, kazutaka
  114. AutoProv: 0
  115. %define _use_internal_dependency_generator 0
  116. %define __find_requires %{SOURCE100}
  117. %description
  118. Thunderbird is a standalone mail and newsgroup client.
  119. %description -l ja
  120. Thunderbird はスタンドアローンのメールおよびニュースクライアントです。
  121. #===============================================================================
  122. %prep
  123. %setup -q %{name}-%{version} -c -b 1000
  124. cd %{tarballdir}
  125. %patch1 -p0 -b .jemalloc
  126. %patch2 -p1 -b .shared-error
  127. %patch4 -p1 -b .protected
  128. cd mozilla
  129. #%patch22 -p1
  130. #%patch24 -p1
  131. #%patch25 -p0
  132. %patch26 -p1 -b .default-a4
  133. %patch1000 -p1 -b .sjis-alias
  134. cd -
  135. %{__rm} -f .mozconfig
  136. %if %{build_vine5}
  137. %{__cp} %{SOURCE1030} .mozconfig
  138. %endif
  139. %if %{build_vineseed}
  140. %{__cp} %{SOURCE1040} .mozconfig
  141. # cat not build with xulrunner (yet)
  142. # see tracking bugs.
  143. # https://bugzilla.mozilla.org/show_bug.cgi?id=306324
  144. # https://bugzilla.mozilla.org/show_bug.cgi?id=377319
  145. #echo "ac_add_options --with-libxul-sdk=`pkg-config --variable=sdkdir libxul`" >> .mozconfig
  146. %endif
  147. # setup unofficial branding name
  148. %{__cp} %{SOURCE40} mail/branding/unofficial/locales/en-US/brand.properties
  149. %{__cp} %{SOURCE41} mail/branding/unofficial/locales/en-US/brand.dtd
  150. #===============================================================================
  151. %build
  152. cd %{tarballdir}
  153. INTERNAL_GECKO=%{version_internal}
  154. MOZ_APP_DIR=%{mozappdir}
  155. #MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2/-Os/' -e 's/-Wall//')
  156. MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
  157. export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
  158. export CFLAGS="$RPM_OPT_FLAGS"
  159. export CXXFLAGS="$CFLAGS"
  160. export MOZ_APP_DISPLAYNAME="Tb for Vine Linux"
  161. %ifarch ppc ppc64 s390 s390x
  162. %define moz_make_flags -j1
  163. %else
  164. %define moz_make_flags %{?_smp_mflags}
  165. %endif
  166. export PREFIX='%{_prefix}'
  167. export LIBDIR='%{_libdir}'
  168. export LDFLAGS="-Wl,-rpath,%{mozappdir}"
  169. export MAKE="gmake %{moz_make_flags}"
  170. %{__make} -f client.mk build
  171. # build locales
  172. LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
  173. sed -e 's|\./\(.*\)/locales/.*|\1|g'`
  174. for dir in $LOCALEDIRS
  175. do
  176. for lang in %{MOZ_BUILD_LOCALES} ; do
  177. make -C $dir/locales AB_CD=$lang
  178. done
  179. done
  180. #===============================================================================
  181. %install
  182. %{__rm} -rf $RPM_BUILD_ROOT
  183. cd %{tarballdir}
  184. INTERNAL_GECKO=%{version_internal}
  185. INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
  186. MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
  187. cd %{moz_objdir}
  188. DESTDIR=$RPM_BUILD_ROOT make install
  189. # install unofficial icons
  190. cd -
  191. %{__cp} mail/branding/unofficial/mailicon16.png \
  192. $RPM_BUILD_ROOT/%{mozappdir}/icons/
  193. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps
  194. %{__cp} mail/branding/unofficial/mailicon16.png \
  195. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
  196. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps
  197. %{__cp} mail/branding/unofficial/mailicon22.png \
  198. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
  199. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps
  200. %{__cp} mail/branding/unofficial//mailicon24.png \
  201. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
  202. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
  203. %{__cp} mail/branding/unofficial/mailicon32.png \
  204. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
  205. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
  206. %{__cp} mail/branding/unofficial/mailicon48.png \
  207. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
  208. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps
  209. %{__cp} mail/branding/unofficial/mailicon256.png \
  210. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
  211. desktop-file-install --vendor vine \
  212. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  213. --add-category Application \
  214. --add-category Network \
  215. %{SOURCE20}
  216. # set up the thunderbird start script
  217. rm -f $RPM_BUILD_ROOT/%{_bindir}/thunderbird
  218. %{__cat} %{SOURCE21} | %{__sed} -e 's,TBDIR,%{mozappdir},g' > \
  219. $RPM_BUILD_ROOT%{_bindir}/thunderbird
  220. %{__chmod} 755 $RPM_BUILD_ROOT/%{_bindir}/thunderbird
  221. install -Dm755 %{SOURCE30} $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
  222. %{__sed} -i -e 's|LIBDIR|%{_libdir}|g' $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
  223. %{__cat} %{SOURCE12} | %{__sed} -e 's,THUNDERBIRD_RPM_VR,%{version}-%{release},g' \
  224. -e 's,COMMAND,%{mozappdir}/open-browser.sh,g' > \
  225. $RPM_BUILD_ROOT/vine-default-prefs
  226. %{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/greprefs/all-vine.js
  227. %{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/defaults/pref/all-vine.js
  228. %{__rm} $RPM_BUILD_ROOT/vine-default-prefs
  229. %{__rm} -f $RPM_BUILD_ROOT%{_bindir}/thunderbird-config
  230. # own mozilla plugin dir (#135050)
  231. %{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins
  232. # own extension directories
  233. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/mozilla/extensions/%{thunderbird_app_id}
  234. %{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/extensions/%{thunderbird_app_id}
  235. # install locales
  236. for lang in %{MOZ_BUILD_LOCALES} ; do
  237. %{__install} -p -D -m 664 %{moz_objdir}/mozilla/dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT%{mozappdir}/chrome/
  238. done
  239. %clean
  240. %{__rm} -rf $RPM_BUILD_ROOT
  241. #===============================================================================
  242. %post
  243. update-desktop-database &> /dev/null || :
  244. touch --no-create %{_datadir}/icons/hicolor
  245. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  246. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  247. fi
  248. %postun
  249. update-desktop-database &> /dev/null || :
  250. touch --no-create %{_datadir}/icons/hicolor
  251. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  252. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  253. fi
  254. %files
  255. %defattr(-,root,root,-)
  256. %attr(755,root,root) %{_bindir}/thunderbird
  257. %attr(644,root,root) %{_datadir}/applications/vine-thunderbird.desktop
  258. %{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
  259. %{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
  260. %{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
  261. %{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
  262. %{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
  263. %{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
  264. %{mozappdir}
  265. #===============================================================================
  266. %changelog
  267. * Sat Jul 03 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-2
  268. - add BuildRequires: alsa-lib-devel
  269. - remove BuildRequires: libnotify-devel
  270. (workaround for known bug)
  271. - update mozconfig to add --disable-libnotify option
  272. * Tue Jun 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-1
  273. - new upstream release
  274. - update spec entirely
  275. - import patches from fedora (Patch1, 2 & 4)
  276. - drop outdated patches (Patch22, 24)
  277. - update Sources:
  278. - mozconfig (Source1030 & Source1040)
  279. - default prefs.js (Source12)
  280. - unofficial branding (Source40 & Source41)
  281. - japanese translation (Source1000)
  282. - update Patch1000 (sjis-alias)
  283. * Sun Aug 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.23-1
  284. - new upstream release
  285. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.22-1
  286. - new upstream release
  287. * Wed May 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.21-3
  288. - don't install official branding logos
  289. * Mon May 04 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-2
  290. - add necessary icons in %%{tbdir}/chrome/icons/default
  291. - add Packager tag
  292. * Fri Mar 20 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-1
  293. - new upstream release
  294. * Sun Jan 25 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.19-1
  295. - new upstream release
  296. * Sun Nov 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.18-1
  297. - new upstream release
  298. * Wed Apr 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.14-1
  299. - new upstream release
  300. * Sun Aug 5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl2
  301. - rebuilt for VineSeed
  302. * Sun Aug 5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl1
  303. - new upstream release
  304. * Sat Jul 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.5-0vl1
  305. - new upstream release
  306. - built for Vine Linux 4.x
  307. - dropped Patch1020 (merged into upstream)
  308. * Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.0.0-0vl4
  309. - added Patch1020 for workaround gcc visibility hidden bugs
  310. * Sat May 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl3
  311. - build with new environment/toolchain
  312. - add build options to build with external nss/nspr libraries
  313. ac_add_options --with-system-nspr
  314. ac_add_options --with-system-nss
  315. * Mon Apr 23 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl2
  316. - new upstream release
  317. * Mon Oct 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.7-0vl2
  318. - new upstream release
  319. * Fri Jul 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.5-0vl2
  320. - new upstream release
  321. * Fri Jun 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.4-0vl1
  322. - new upstream release
  323. * Fri Apr 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.2-0vl1
  324. - new upstream release
  325. - merge changes from firefox
  326. - use thunderbird-1.5 for MOZILLA_FIVE_HOME instead of thunderbird-1.5.0.2
  327. * Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl2
  328. - new upstream release
  329. - build en-US locale
  330. - merge changes from firefox
  331. - add upstream patches
  332. - disable pango rendering by default
  333. (workaround fix slow rendering in some page)
  334. * Thu Dec 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl0.rc2
  335. - initial build for Vine Linux based on FC package
  336. - update to 1.5RC2
  337. * Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> - 1.5-0.5.1.rc1
  338. - Fix issue with popup dialogs and other actions causing lockups
  339. * Sat Nov 5 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.rc1
  340. - Update to 1.5 rc1
  341. * Sat Oct 8 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta2
  342. - Update to 1.5 beta2
  343. * Wed Sep 28 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta1
  344. - Update to 1.5 beta1
  345. - Bring the install phase of the spec file up to speed
  346. * Sun Aug 14 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-4
  347. - Rebuild
  348. * Sat Aug 6 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-3
  349. - Add patch to make file chooser dialog modal
  350. * Fri Jul 22 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-2
  351. - Update to 1.0.6
  352. * Mon Jul 18 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-0.1.fc5
  353. - 1.0.6 Release Candidate
  354. * Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-8
  355. - Use system NSPR
  356. - Fix crash on 64bit platforms (#160330)
  357. * Thu Jun 23 2005 Kristian H淡gsberg <krh@redhat.com> 1.0.2-7
  358. - Add firefox-1.0-pango-cairo.patch to get rid of the last few Xft
  359. references, fixing the "no fonts" problem.
  360. * Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-6
  361. - Change the Exec line in the desktop file to `thunderbird`
  362. * Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-5
  363. - Update pango patche, MOZ_DISABLE_PANGO now works as advertised.
  364. * Mon May 9 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-4
  365. - Add temporary workaround to not create files in the user's $HOME (#149664)
  366. * Wed May 4 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-3
  367. - Don't have downloads "disappear" when downloading to desktop (#139015)
  368. - Fix for some more cursor issues in textareas (149991, 150002, 152089)
  369. - Add upstream patch to fix bidi justification of pango
  370. - Add patch to fix launching of helper applications
  371. - Add patch to properly link against libgfxshared_s.a
  372. - Fix multilib conflicts
  373. * Wed Apr 27 2005 Warren Togami <wtogami@redhat.com>
  374. - correct confusing PANGO vars in startup script
  375. * Wed Mar 23 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-1
  376. - Thunderbird 1.0.2
  377. * Tue Mar 8 2005 Christopher Aillon <caillon@redhat.com> 1.0-5
  378. - Add patch to compile against new fortified glibc macros
  379. * Sat Mar 5 2005 Christopher Aillon <caillon@redhat.com> 1.0-4
  380. - Rebuild against GCC 4.0
  381. - Add execshield patches
  382. - Minor specfile cleanup
  383. * Mon Dec 20 2004 Christopher Aillon <caillon@redhat.com> 1.0-3
  384. - Rebuild
  385. * Thu Dec 16 2004 Christopher Aillon <caillon@redhat.com> 1.0-2
  386. - Add RPM version to useragent
  387. * Thu Dec 16 2004 Christopher Blizzard <blizzard@redhat.com>
  388. - Port over pango patches from firefox
  389. * Wed Dec 8 2004 Christopher Aillon <caillon@redhat.com> 1.0-1
  390. - Thunderbird 1.0
  391. * Mon Dec 6 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.1
  392. - Fix advanced prefs
  393. * Fri Dec 3 2004 Christopher Aillon <caillon@redhat.com>
  394. - Make this run on s390(x) now for real
  395. * Wed Dec 1 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.0
  396. - Update to 1.0 rc1
  397. * Fri Nov 19 2004 Christopher Aillon <caillon@redhat.com>
  398. - Add patches to build and run on s390(x)
  399. * Thu Nov 11 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-2
  400. - Rebuild to fix file chooser
  401. * Fri Nov 5 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-1
  402. - Update to 0.9
  403. * Fri Oct 22 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-10
  404. - Prevent inlining of stack direction detection (#135255)
  405. * Tue Oct 19 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-9
  406. - More file chooser fixes (same as in firefox)
  407. - Fix for upstream 28327.
  408. * Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
  409. - Update the pango patch
  410. * Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
  411. - Pull over patches from firefox build:
  412. - disable default application dialog
  413. - don't include software update since it doesn't work
  414. - make external app support work
  415. * Thu Oct 14 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-7
  416. - Use pango for rendering
  417. * Tue Oct 12 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-6
  418. - Fix for 64 bit crash at startup (b.m.o #256603)
  419. * Sat Oct 9 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-5
  420. - Add patches to fix xremote (#135036)
  421. * Fri Oct 8 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-4
  422. - Add patch to fix button focus issues (#133507)
  423. - Add patch for fix IMAP race issues (bmo #246439)
  424. * Fri Oct 1 2004 Bill Nottingham <notting@redhat.com> 0.8.0-3
  425. - filter out library Provides: and internal Requires:
  426. * Tue Sep 28 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-2
  427. - Backport the GTK+ File Chooser.
  428. - Add fix for JS math on x86_64 systems
  429. - Add pkgconfig patch
  430. * Thu Sep 16 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-1
  431. - Update to 0.8.0
  432. - Remove enigmail
  433. - Update BuildRequires
  434. - Remove gcc34 and extension manager patches -- they are upstreamed.
  435. - Fix for gnome-vfs2 error at component registration
  436. * Fri Sep 03 2004 Christopher Aillon <caillon@redhat.com> 0.7.3-5
  437. - Build with --disable-xprint
  438. * Wed Sep 01 2004 David Hill <djh[at]ii.net> 0.7.3-4
  439. - remove all Xvfb-related hacks
  440. * Wed Sep 01 2004 Warren Togami <wtogami@redhat.com>
  441. - actually apply psfonts
  442. - add mozilla gnome-uriloader patch to prevent build failure
  443. * Tue Aug 31 2004 Warren Togami <wtogami@redhat.com> 0.7.3-3
  444. - rawhide import
  445. - apply NetBSD's freetype 2.1.8 patch
  446. - apply psfonts patch
  447. - remove BR on /usr/bin/ex, breaks beehive
  448. * Tue Aug 31 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.2
  449. - oops, fix %%install
  450. * Thu Aug 26 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.1
  451. - update to Thunderbird 0.7.3 and Enigmail 0.85.0
  452. - remove XUL.mfasl on startup, add Debian enigmail patches
  453. - add Xvfb hack for -install-global-extension
  454. * Wed Jul 14 2004 David Hill <djh[at]ii.net> 0.7.2-0.fdr.0
  455. - update to 0.7.2, just because it's there
  456. - update gcc-3.4 patch (Kaj Niemi)
  457. - add EM registration patch and remove instdir hack
  458. * Sun Jul 04 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.1
  459. - re-add Enigmime 1.0.7, omit Enigmail until the Mozilla EM problems are fixed
  460. * Wed Jun 30 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.0
  461. - update to 0.7.1
  462. - remove Enigmail
  463. * Mon Jun 28 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.1
  464. - re-enable Enigmail 0.84.1
  465. - add gcc-3.4 patch (Kaj Niemi)
  466. - use official branding (with permission)
  467. * Fri Jun 18 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.0
  468. - update to 0.7
  469. - temporarily disable Enigmail 0.84.1, make ftp links work (#1634)
  470. - specify libdir, change BR for apt (V. Skytt辰, #1617)
  471. * Tue May 18 2004 Warren Togami <wtogami@redhat.com> 0.6-0.fdr.5
  472. - temporary workaround for enigmail skin "modern" bug
  473. * Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.4
  474. - update to Enigmail 0.84.0
  475. - update launch script
  476. * Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.3
  477. - installation directory now versioned
  478. - allow root to run the program (for installing extensions)
  479. - remove unnecessary %%pre and %%post
  480. - remove separators, update mozconfig and launch script (M. Schwendt, #1460)
  481. * Wed May 05 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.2
  482. - include Enigmail, re-add release notes
  483. - delete %{_libdir}/thunderbird in %%pre
  484. * Mon May 03 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.1
  485. - update to Thunderbird 0.6
  486. * Fri Apr 30 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.rc1
  487. - update to Thunderbird 0.6 RC1
  488. - add new icon, remove release notes
  489. * Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.20040415
  490. - update to latest CVS, update mozconfig and %%build accordingly
  491. - update to Enigmail 0.83.6
  492. - remove x-remote and x86_64 patches
  493. - build with -Os
  494. * Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.5-0.fdr.12
  495. - update x-remote patch
  496. - more startup script fixes
  497. * Tue Apr 06 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.11
  498. - startup script fixes, and a minor cleanup
  499. * Sun Apr 04 2004 Warren Togami <wtogami@redhat.com> 0:0.5-0.fdr.10
  500. - Minor cleanups
  501. * Sun Apr 04 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.8
  502. - minor improvements to open-browser.sh and startup script
  503. - update to latest version of Blizzard's x-remote patch
  504. * Thu Mar 25 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.7
  505. - update open-browser.sh, startup script, and BuildRequires
  506. * Sun Mar 14 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.6
  507. - update open-browser script, modify BuildRequires (Warren)
  508. - add Blizzard's x-remote patch
  509. - initial attempt at x-remote-enabled startup script
  510. * Sun Mar 07 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.5
  511. - refuse to run with excessive privileges
  512. * Fri Feb 27 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.4
  513. - add Mozilla x86_64 patch (Oliver Sontag)
  514. - Enigmail source filenames now include the version
  515. - modify BuildRoot
  516. * Thu Feb 26 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.3
  517. - use the updated official tarball
  518. * Wed Feb 18 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.2
  519. - fix %%prep script
  520. * Mon Feb 16 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.1
  521. - update Enigmail to 0.83.3
  522. - use official source tarball (after removing the CRLFs)
  523. - package renamed to thunderbird
  524. * Mon Feb 09 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.0
  525. - update to 0.5
  526. - check for lockfile before launching
  527. * Fri Feb 06 2004 David Hill <djh[at]ii.net>
  528. - update to latest cvs
  529. - update to Enigmail 0.83.2
  530. * Thu Jan 29 2004 David Hill <djh[at]ii.net> 0:0.4-0.fdr.5
  531. - update to Enigmail 0.83.1
  532. - removed Mozilla/Firebird script patching
  533. * Sat Jan 03 2004 David Hill <djh[at]ii.net> 0:0.4-0.fdr.4
  534. - add startup notification to .desktop file
  535. * Thu Dec 25 2003 Warren Togami <warren@togami.com> 0:0.4-0.fdr.3
  536. - open-browser.sh release 3
  537. - patch broken /usr/bin/mozilla script during install
  538. - dir ownership
  539. - XXX: Source fails build on x86_64... fix later
  540. * Tue Dec 23 2003 David Hill <djh[at]ii.net> 0:0.4-0.fdr.2
  541. - update to Enigmail 0.82.5
  542. - add Warren's open-browser.sh (#1113)
  543. * Tue Dec 09 2003 David Hill <djh[at]ii.net> 0:0.4-0.fdr.1
  544. - use Thunderbird's mozilla-xremote-client to launch browser
  545. * Sun Dec 07 2003 David Hill <djh[at]ii.net> 0:0.4-0.fdr.0
  546. - update to 0.4
  547. - make hyperlinks work (with recent versions of Firebird/Mozilla)
  548. * Thu Dec 04 2003 David Hill <djh[at]ii.net>
  549. - update to 0.4rc2
  550. * Wed Dec 03 2003 David Hill <djh[at]ii.net>
  551. - update to 0.4rc1 and Enigmail 0.82.4
  552. * Thu Nov 27 2003 David Hill <djh[at]ii.net>
  553. - update to latest CVS and Enigmail 0.82.3
  554. * Sun Nov 16 2003 David Hill <djh[at]ii.net>
  555. - update to latest CVS (0.4a)
  556. - update Enigmail to 0.82.2
  557. - alter mozconfig for new build requirements
  558. - add missing BuildReq (#987)
  559. * Thu Oct 16 2003 David Hill <djh[at]ii.net> 0:0.3-0.fdr.0
  560. - update to 0.3
  561. * Sun Oct 12 2003 David Hill <djh[at]ii.net> 0:0.3rc3-0.fdr.0
  562. - update to 0.3rc3
  563. - update Enigmail to 0.81.7
  564. * Thu Oct 02 2003 David Hill <djh[at]ii.net> 0:0.3rc2-0.fdr.0
  565. - update to 0.3rc2
  566. * Wed Sep 17 2003 David Hill <djh[at]ii.net> 0:0.2-0.fdr.2
  567. - simplify startup script
  568. * Wed Sep 10 2003 David Hill <djh[at]ii.net> 0:0.2-0.fdr.1
  569. - add GPG support (Enigmail 0.81.6)
  570. - specfile fixes (#679)
  571. * Thu Sep 04 2003 David Hill <djh[at]ii.net> 0:0.2-0.fdr.0
  572. - update to 0.2
  573. * Mon Sep 01 2003 David Hill <djh[at]ii.net>
  574. - initial RPM
  575. (based on the fedora MozillaFirebird-0.6.1 specfile)