bluefish-vl.spec 9.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320
  1. Name: bluefish
  2. Version: 2.2.4
  3. Release: 1%{?_dist_release}
  4. Summary: GTK2 web development application for experienced users
  5. Summary(ja): 経験者向け Web 開発用 GTK2 アプリケーション
  6. Group: Applications/Editors
  7. License: GPLv3+
  8. URL: http://bluefish.openoffice.nl/
  9. # Upstream source contains non-free jsmin.py
  10. # Source0: http://www.bennewitz.com/bluefish/stable/source/bluefish-%{version}%{?prerel:-%{prerel}}.tar.bz2
  11. # To generate clean source, simply rm -rf data/jsmin.py
  12. # We provide a replacement in Source1.
  13. Source0: bluefish-%{version}%{?prerel:-%{prerel}}-clean.tar.bz2
  14. Source1: https://raw.github.com/v8/v8/master/tools/jsmin.py
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: desktop-file-utils
  17. BuildRequires: enchant-devel >= 1.4.2
  18. BuildRequires: gettext
  19. BuildRequires: glib2-devel >= 2.24
  20. %if "%{?_dist_release}" < "vl7"
  21. BuildRequires: gtk2-devel >= 2.20
  22. BuildRequires: gucharmap-devel >= 2.20
  23. %else
  24. BuildRequires: gtk3-devel >= 3.2
  25. BuildRequires: gucharmap-devel >= 2.90
  26. %endif
  27. BuildRequires: intltool
  28. BuildRequires: libxml2-devel
  29. BuildRequires: python-devel
  30. # Needed to check man pages
  31. BuildRequires: /usr/bin/man
  32. # For the Advanced Open function
  33. Requires: findutils, grep
  34. Requires: %{name}-shared-data = %{version}-%{release}
  35. # Automatically upgrade bluefish-unstable
  36. Obsoletes: bluefish-unstable < %{version}-%{release}
  37. Provides: bluefish-unstable = %{version}-%{release}
  38. # XML Catalog registration
  39. Requires(post): /usr/bin/xmlcatalog, xml-common
  40. Requires(postun): /usr/bin/xmlcatalog, xml-common
  41. # Don't "provide" plugin shared objects
  42. %{?filter_setup:
  43. %filter_provides_in %{_libdir}/%{name}/.*\.so$
  44. %filter_setup
  45. }
  46. # Move to unversioned documentation directories from F-20
  47. # https://fedoraproject.org/wiki/Changes/UnversionedDocdirs
  48. %global bluefish_docdir %{?_pkgdocdir}%{!?_pkgdocdir:%{_docdir}/%{name}-%{version}}
  49. %description
  50. Bluefish is a powerful editor for experienced web designers and programmers.
  51. Bluefish supports many programming and markup languages, but it focuses on
  52. editing dynamic and interactive websites.
  53. %package shared-data
  54. Summary: Architecture-independent data for %{name}
  55. Group: Development/Tools
  56. BuildArch: noarch
  57. # For ownership of %%{_datadir}/mime/packages
  58. Requires: shared-mime-info
  59. # For ownership of %%{_datadir}/icons/hicolor/*/{apps,mimetypes}
  60. Requires: hicolor-icon-theme
  61. # Automatically upgrade bluefish-unstable-shared-data
  62. Obsoletes: bluefish-unstable-shared-data < %{version}-%{release}
  63. Provides: bluefish-unstable-shared-data = %{version}-%{release}
  64. %description shared-data
  65. Files common to every architecture version of %{name}.
  66. %prep
  67. %setup -q -n %{name}-%{version}%{?prerel:-%{prerel}}
  68. cp -a %{SOURCE1} data/
  69. sed -i 's|python2.4|python|g' data/jsmin.py
  70. %build
  71. %configure --disable-dependency-tracking \
  72. --disable-static \
  73. --disable-update-databases \
  74. --disable-xml-catalog-update \
  75. --docdir=%{bluefish_docdir}
  76. make %{?_smp_mflags}
  77. %install
  78. rm -rf %{buildroot}
  79. mkdir -p %{buildroot}%{_datadir}/applications
  80. make install DESTDIR=%{buildroot} INSTALL="install -p"
  81. # Make zencoding plugin scripts executable to placate rpmlint
  82. find %{buildroot}%{_datadir}/bluefish/plugins/zencoding -name '*.py' |
  83. xargs awk '/^#!/ { print FILENAME }' |
  84. xargs chmod -c +x
  85. %find_lang %{name}
  86. %find_lang %{name}_plugin_about
  87. %find_lang %{name}_plugin_charmap
  88. %find_lang %{name}_plugin_entities
  89. %find_lang %{name}_plugin_htmlbar
  90. %find_lang %{name}_plugin_infbrowser
  91. %find_lang %{name}_plugin_snippets
  92. %find_lang %{name}_plugin_zencoding
  93. cat %{name}_plugin_{about,charmap,entities,htmlbar,infbrowser,snippets,zencoding}.lang >> \
  94. %{name}.lang
  95. desktop-file-validate \
  96. %{buildroot}%{_datadir}/applications/%{name}.desktop
  97. # Manually install docs so that they go into
  98. # %%{bluefish_docdir} even though we put them in the
  99. # shared-data subpackage
  100. install -m 644 -p -t %{buildroot}%{bluefish_docdir}/ \
  101. AUTHORS ChangeLog COPYING NEWS README TODO
  102. # Unpackaged files
  103. rm -f %{buildroot}%{_libdir}/%{name}/*.la
  104. %clean
  105. rm -rf %{buildroot}
  106. %post
  107. /usr/bin/update-mime-database %{_datadir}/mime &> /dev/null || :
  108. /usr/bin/update-desktop-database &> /dev/null || :
  109. /usr/bin/xmlcatalog --noout --add 'delegateURI' \
  110. 'http://bluefish.openoffice.nl/ns/bflang/2.0/' \
  111. '%{_datadir}/xml/%{name}' \
  112. %{_sysconfdir}/xml/catalog &> /dev/null || :
  113. %postun
  114. /usr/bin/update-mime-database %{_datadir}/mime &> /dev/null || :
  115. /usr/bin/update-desktop-database &> /dev/null || :
  116. if [ "$1" = 0 ]; then
  117. /usr/bin/xmlcatalog --noout --del \
  118. 'http://bluefish.openoffice.nl/ns/bflang/2.0/' \
  119. %{_sysconfdir}/xml/catalog &> /dev/null || :
  120. fi
  121. %files
  122. %defattr(-,root,root,-)
  123. %{_bindir}/%{name}
  124. %{_libdir}/%{name}/
  125. %files shared-data -f %{name}.lang
  126. %defattr(-,root,root,-)
  127. %doc %{bluefish_docdir}/
  128. %{_datadir}/%{name}/
  129. %{_datadir}/applications/%{name}.desktop
  130. %{_datadir}/mime/packages/%{name}.xml
  131. %{_datadir}/icons/hicolor/*/mimetypes/application-x-bluefish-project.png
  132. %{_datadir}/icons/hicolor/*/apps/%{name}.png
  133. %{_datadir}/icons/hicolor/scalable/mimetypes/bluefish-project.svg
  134. %{_datadir}/icons/hicolor/scalable/apps/bluefish-icon.svg
  135. %{_datadir}/pixmaps/application-x-bluefish-project.png
  136. %{_datadir}/pixmaps/%{name}.png
  137. %{_datadir}/xml/%{name}/
  138. %{_mandir}/man1/%{name}.1*
  139. %changelog
  140. * Thu Jan 23 2014 TANAKA hiroaki <mosaicist@jcom.home.ne.jp> 2.2.4
  141. - all resources renew from fedora bluefish-2.2.4-3.fc20.src.rpm
  142. * Sun Aug 21 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.3-1
  143. - new upstream release
  144. - built without gucharmap (VineSeed)
  145. - added BR: libxml2-devel
  146. * Tue Oct 12 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.2-1
  147. - new upstream release
  148. * Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.1-1
  149. - new upstream release
  150. * Fri Mar 19 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0-1
  151. - new upstream release
  152. - updated BR
  153. * Thu Jul 30 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.7-2
  154. - added Japanese description
  155. * Fri Sep 19 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.7-1vl5
  156. - applied new versioning policy, spec in utf-8
  157. * Tue Nov 7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.7-0vl2
  158. - rebuilt for Vine Linux 4.0
  159. * Tue Nov 7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.7-0vl1
  160. - new upstream release
  161. * Sat Feb 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.5-0vl3
  162. - rebuild for VineSeed Plus
  163. * Sat Feb 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.5-0vl2
  164. - rebuit for VinePlus/3.0
  165. - dropped Patch0 (fixed at upstream version)
  166. * Wed Feb 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.5-0vl1
  167. - new upstream release
  168. * Tue Sep 6 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.4-0vl1.1
  169. - added Patch0 for disable PCRE_UTF8 in highlighting
  170. * Sat Sep 3 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.4-0vl1
  171. - new upstream release
  172. * Thu Aug 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.3-0vl2
  173. - rebuild for VineSeed Plus
  174. * Thu Aug 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.3-0vl1
  175. - new upstream release
  176. * Tue Aug 16 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.2-0vl2
  177. - rebuild for VineSeed Plus
  178. * Tue Aug 16 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.2-0vl1
  179. - new upstream release
  180. * Mon Jun 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.1-0vl3
  181. - rebuild for VineSeed Plus
  182. * Mon Jun 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.1-0vl2
  183. - rebuild for VinePlus/3.1
  184. - added BuildRequires: shared-mime-info
  185. * Sun Jun 5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.1-0vl1
  186. - new upstream release
  187. * Thu May 26 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0-0vl2
  188. - rebuild for VineSeed Plus
  189. - added --disable-update-databases option
  190. - run update-mime-database on %post
  191. - added Prereq: shared-mime-info
  192. * Sun Feb 6 2005 Masaki Shinomiya <shino@pos.to> 1.0-0vl1
  193. - new upstream release, make install, files. desktop, compile ja.po
  194. * Sun Apr 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.13-0vl1
  195. - new upstream release
  196. - dropped patch0
  197. * Mon Jul 28 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11-0vl1
  198. - new upstream release
  199. * Fri Jul 18 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10-0vl1
  200. - Rebuild with new toolchains and Gnome2 for VineSeedPlus
  201. - add makefile.patch to fix Makefile.in
  202. - modified encodings.default
  203. * Fri Aug 2 2002 Masaki Shinomiya <shino@pos.to>
  204. - 0.7-0vl1 for VinePllus2.1, 0.7-0vl2 for VinePlus2.5/VineSeedPlus
  205. - vine.patch, without perl
  206. * Fri Mar 1 2002 Shingo Akagaki <dora@kondara.org>
  207. - (0.7-8k)
  208. - fix file attributes
  209. * Thu Feb 21 2002 Shingo Akagaki <dora@kondara.org>
  210. - (0.7-6k)
  211. - rebuild against for db3,4
  212. * Thu Feb 07 2002 Motonobu Ichimura <famao@kondara.org>
  213. - (0.7-4k)
  214. - add perl,attrpage,internal-preview support
  215. * Thu Feb 07 2002 Motonobu Ichimura <famao@kondara.org>
  216. - (0.7-2k)
  217. - add xim patch
  218. - up to 0.7
  219. * Thu Oct 18 2001 Motonobu Ichimura <famao@kondara.org>
  220. - (0.6-4k)
  221. - not egcs, but gcc2.95.3
  222. * Thu Oct 18 2001 Motonobu Ichimura <famao@kondara.org>
  223. - (0.6-2k)
  224. - up to 0.6
  225. - add BuildRequires: egcs ...
  226. - include .desktop file
  227. * Wed Oct 17 2001 Toru Hoshina <t@kondara.org>
  228. - (0.4-10k)
  229. - rebuild against gettext 0.10.40.
  230. * Mon Oct 15 2001 Toru Hoshina <t@kondara.org>
  231. - (0.4-8k)
  232. - rebuild against libpng 1.2.0.
  233. * Sat Dec 2 2000 MATSUDA, Daiki <dyky@df-usa.com>
  234. - (0.4-4k)
  235. - modified spec file with macros
  236. * Thu Jul 13 2000 AYUHANA Tomonori <l@kondara.org>
  237. - (0.4-2k)
  238. - SPEC fixed ( BuildRoot )
  239. - missing bluefish.desktop!
  240. * Tue Jun 13 2000 haruka kusumi <haruka76@kondara.org>
  241. - changed some items for kondara
  242. * Fri May 5 2000 Bo Forslund <bo.forslund@abc.se>
  243. - fine tuning of the spec file
  244. - possible to build with all processors on smp machines
  245. - an entry for RedHats wmconfig
  246. * Tue Mar 21 2000 CW Zuckschwerdt <zany@triq.net>
  247. - complete rewrite of spec file
  248. - relocateable on build-time
  249. - no privileges required while building
  250. - fix for install_location (should really be $(LIBDIR)/bluefish!)
  251. - included man, locale and lib into RPM (was seriously broken)
  252. * Thu Jan 13 2000 Chris Lea <chrislea@luciddesigns.com>
  253. - Fixed up spec file some. bluefish-0.3.5
  254. * Wed Nov 17 1999 Chris Lea <chrislea@luciddesigns.com>
  255. - added spec file. this is my third RPM that I've made a spec
  256. file for, so please be merciful if I've screwed something up