dump-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430
  1. %define _sbindir /sbin
  2. # XXX --enable-kerberos needs krcmd
  3. %define myoptions --enable-largefile --with-binmode=6755 --with-manowner=root --with-mangrp=root --with-manmode=0644 --enable-readline
  4. Summary: Programs for backing up and restoring ext2/ext3/ext4 filesystems.
  5. Summary(ja): ext2/ext3/ext4 ファイルシステムをバックアップ/リストアするプログラム
  6. Name: dump
  7. Version: 0.4b44
  8. Release: 1%{?_dist_release}
  9. License: BSD
  10. Group: Applications/Archiving
  11. URL: http://dump.sourceforge.net/
  12. Source: dump-%{version}.tar.gz
  13. Patch0: dump-buildfix.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: libtermcap-devel
  16. BuildRequires: e2fsprogs-devel >= 1.18, readline-devel >= 4.2
  17. BuildRequires: zlib-devel, device-mapper-devel
  18. BuildRequires: libblkid-devel
  19. BuildRequires: libuuid-devel
  20. BuildRequires: bzip2-devel
  21. # This Prereq is now required because we only ship static binaries, and
  22. # need to ensure the "disk" group is created before installation (#60461)
  23. Requires(pre): setup
  24. Requires: rmt
  25. Obsoletes: dump-static
  26. Packager: daisuke, kazutaka, shaolin
  27. %description
  28. The dump package contains both dump and restore. Dump examines files
  29. in a filesystem, determines which ones need to be backed up, and
  30. copies those files to a specified disk, tape, or other storage medium.
  31. The restore command performs the inverse function of dump; it can
  32. restore a full backup of a filesystem. Subsequent incremental backups
  33. can then be layered on top of the full backup. Single files and
  34. directory subtrees may also be restored from full or partial backups.
  35. Install dump if you need a system for both backing up filesystems and
  36. restoring filesystems after backups.
  37. %description -l ja
  38. dump パッケージは dump と restore の両方を含んでいます。dump はファイル
  39. システム上のファイルを検査し、どれがバックアップが必要が特定し、指定し
  40. たディスク、テープ、あるいはその他のバックアップ用メディアにファイルを
  41. コピーします。
  42. restore コマンドは dump とは反対の処理を行います。restore コマンドを使
  43. うとファイルシステムのフルバックアップを復元できます。またフルバックアッ
  44. プからの増分バックアップを適用することもできます。フルバックアップ、ま
  45. たは部分パックアップから、単一のファイルやディレクトリのサブツリーだけ
  46. を復元することもできます。
  47. もしファイルシステムのフルバックアップや復元が必要な場合は、dump をイン
  48. ストールしてください。
  49. %package -n rmt
  50. Summary: Provides certain programs with access to remote tape devices.
  51. Summary(ja): リモートテープ装置のアクセスに必要なプログラム
  52. Group: Applications/Archiving
  53. %description -n rmt
  54. The rmt utility provides remote access to tape devices for programs
  55. like dump (a filesystem backup program), restore (a program for
  56. restoring files from a backup), and tar (an archiving program).
  57. %description -n rmt -l ja
  58. rmt ユーティリティは、dump (ファイルシステムのバックアップ)や restore
  59. (バックアップからの復元)、tar (アーカイブの作成/展開) といったプログラ
  60. ムに、テープ装置へのリモートアクセスを提供します。
  61. %prep
  62. %setup -q
  63. %patch0 -p1 -b .buildfix
  64. for i in THANKS MAINTAINERS COPYRIGHT CHANGES; do
  65. iconv -f iso-8859-1 -t utf-8 $i -o $i.new
  66. touch -r $i $i.new
  67. mv $i.new $i
  68. done
  69. %build
  70. autoreconf -fiv
  71. %configure %{myoptions} --disable-static --enable-rmt --disable-transselinux
  72. %ifarch alpha
  73. RPM_OPT_FLAGS=""
  74. %endif
  75. make OPT="$RPM_OPT_FLAGS -Wall -Wpointer-arith -Wstrict-prototypes \
  76. -Wmissing-prototypes -Wno-char-subscripts "
  77. %install
  78. rm -rf %{buildroot}
  79. mkdir -p %{buildroot}%{_sbindir}
  80. mkdir -p %{buildroot}%{_mandir}/man8
  81. %makeinstall SBINDIR=%{buildroot}%{_sbindir} BINDIR=%{buildroot}%{_sbindir} MANDIR=%{buildroot}%{_mandir}/man8 BINOWNER=$(id -un) BINGRP=$(id -gn) MANOWNER=$(id -un) MANGRP=$(id -gn)
  82. pushd $RPM_BUILD_ROOT
  83. ln -sf dump .%{_sbindir}/rdump
  84. ln -sf restore .%{_sbindir}/rrestore
  85. chmod ug-s .%{_sbindir}/rmt
  86. mkdir -p .%{_sysconfdir}
  87. > .%{_sysconfdir}/dumpdates
  88. ln -sf ..%{_sbindir}/rmt .%{_sysconfdir}/rmt
  89. popd
  90. %clean
  91. rm -rf %{buildroot}
  92. %files
  93. %defattr(-,root,root)
  94. %doc CHANGES COPYRIGHT KNOWNBUGS MAINTAINERS README REPORTING-BUGS THANKS TODO
  95. %doc dump.lsm
  96. %attr(0664,root,disk) %config(noreplace) %{_sysconfdir}/dumpdates
  97. %attr(0755,root,root) /sbin/dump
  98. /sbin/rdump
  99. %attr(0755,root,root) /sbin/restore
  100. /sbin/rrestore
  101. #/sbin/*.static
  102. %{_mandir}/man8/dump.*
  103. %{_mandir}/man8/rdump.*
  104. %{_mandir}/man8/restore.*
  105. %{_mandir}/man8/rrestore.*
  106. %files -n rmt
  107. %defattr(-,root,root)
  108. %attr(0755,root,root)
  109. %{_sbindir}/rmt
  110. %{_sysconfdir}/rmt
  111. %{_mandir}/man8/rmt.*
  112. %changelog
  113. * Sat Aug 27 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.4b44-1
  114. - updated to 0.4b44 (ext4 support in particular)
  115. * Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4b41-3
  116. - rebuild with rpm-4.8.1
  117. - add BuildRequires: libblkid-devel, libuuid-devel, bzip2-devel
  118. * Mon Jun 22 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4b41-2
  119. - spec in UTF-8
  120. - change configure option to --disable-static
  121. - remove -static stuffs
  122. * Sun Apr 27 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4b41-1
  123. - add Patch1 based on fedora development to build with device-mapper
  124. - add japanese summary and description.
  125. - apply new versioning policy.
  126. * Sun May 13 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4b41-0vl1
  127. - new upstream release
  128. * Fri Oct 15 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.4b34-0vl2
  129. - spec file was in SJIS. fixed.
  130. * Sat Feb 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4b34-0vl1
  131. - new upstream release
  132. * Sun Feb 9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4b28-5vl1
  133. - update upstream release based on rawhide package.
  134. - rebuild on new environment.
  135. * Fri Mar 15 2002 Toru Sagami <sagami@vinelinux.org> 0.4b22-4vl2
  136. - rebuilt against fixed statically linked system libraries
  137. * Sat Jul 14 2001 Toru Sagami <sagami@vinelinux.org>
  138. - 0.4b22-4vl1: based on 0.4b22-4 from Rawhide
  139. * Mon Oct 7 2002 Mike A. Harris <mharris@redhat.com> 0.4b28-5
  140. - All-arch rebuild
  141. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  142. - automated rebuild
  143. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  144. - automated rebuild
  145. * Tue May 21 2002 Mike A. Harris <mharris@redhat.com> 0.4b28-2
  146. - Updated to dump 0.4b28
  147. - Removed atomic_read/write patch, not needed anymore
  148. * Fri Mar 1 2002 Mike A. Harris <mharris@redhat.com> 0.4b27-3
  149. - BuildRequires readline-devel >= 4.2 for the rl_completion_matches function
  150. - Added dump-0.4b27-dump-atomic-read-write.patch to avoid namespace conflict
  151. with included kernel headers. atomic_read is a function on s390 and as
  152. such, cannot be #undef'd
  153. * Thu Feb 28 2002 Mike A. Harris <mharris@redhat.com> 0.4b27-2
  154. - Added prereq on "setup" to ensure disk group is created prior to this
  155. package being installed
  156. - Somehow the dump package changelog got hosed, and part of the spec file
  157. regressed. I believe it is fixed now.
  158. * Tue Feb 26 2002 Mike A. Harris <mharris@redhat.com> 0.4b27-1
  159. - Updated to dump 0.4b27-1
  160. * Fri Feb 22 2002 Mike A. Harris <mharris@redhat.com> 0.4b25-5
  161. - Bumped release up a couple notches to rebuild in rawhide
  162. * Thu Feb 21 2002 Mike A. Harris <mharris@redhat.com> 0.4b25-1.72.0
  163. - Rebuilt 0.4b25 for erratum release. Fixes various bugs that have been
  164. reported in bugzilla which are logged below. Also fixes a bug caused by
  165. linking statically to a faulty system library.
  166. - Added Provides dump-static line
  167. * Mon Feb 11 2002 Mike A. Harris <mharris@redhat.com> 0.4b25-3
  168. - Added missing zlib buildprereq
  169. - Rebuild in new environment
  170. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  171. - automated rebuild
  172. * Wed Nov 21 2001 Mike A. Harris <mharris@redhat.com> 0.4b25-1
  173. - Updated to version 0.4b25-1
  174. - Added homepage URL for RFE (#54601)
  175. - Also fixed in this release are (#21272, #52663, #56616)
  176. - Dropped time.h patch as it is unneeded now
  177. * Tue Nov 6 2001 Mike A. Harris <mharris@redhat.com> 0.4b22-7
  178. - Updated BuildPreReq to e2fsprogs-devel >= 1.18, readline-devel >= 4.1 to
  179. explicitly state the minimum required deps and fix (#51900)
  180. * Sat Sep 8 2001 Trond Eivind Glomsr藷?<teg@redhat.com> 0.4b22-6
  181. - Kill the static subpackage - the standard binaries are now static
  182. This removes /usb/sbin/*. The static versions are now in /sbin
  183. (#53433)
  184. - Obsolete dump-static
  185. * Tue Aug 14 2001 Trond Eivind Glomsr藷?<teg@redhat.com> 0.4b22-5
  186. - Move non-static binaries to /usr/sbin (#49520)
  187. * Fri Jun 29 2001 Mike A. Harris <mharris@redhat.com> 0.4b22-4
  188. - Added BuildPrereq: readline-devel (#44734 - which was reopened and changed)
  189. * Sat Jun 16 2001 Mike A. Harris <mharris@redhat.com> 0.4b22-3
  190. - Added BuildPrereq: libtermcap-devel (#44734)
  191. * Tue Jun 12 2001 Mike A. Harris <mharris@redhat.com> 0.4b22-2
  192. - Removed release tag from buildroot dirname - messy.
  193. - Broke all lines over multiple lines for readability in specfile.
  194. - Added --enable-largefile configure flags
  195. * Mon Jun 11 2001 Florian La Roche <Florian.LaRoche@redhat.de> 0.4b22-1
  196. - 0.4b22
  197. * Mon May 7 2001 Mike A. Harris <mharris@redhat.com> 0.4b21-5
  198. - Added BuildPrereq: e2fsprogs-devel (#27428)
  199. * Mon Apr 9 2001 Bill Nottingham <notting@redhat.com>
  200. - fix ia64
  201. * Wed Feb 14 2001 Bill Nottingham <notting@redhat.com>
  202. - fix build with current glibc
  203. * Mon Jan 29 2001 Nalin Dahyabhai <nalin@redhat.com>
  204. - change copyright: UCB to License: BSD
  205. * Fri Jan 26 2001 Nalin Dahyabhai <nalin@redhat.com>
  206. - update to 0.4b21.
  207. * Sun Nov 26 2000 Jeff Johnson <jbj@redhat.com>
  208. - update to 0.4b20.
  209. * Fri Nov 10 2000 Stelian Pop <pop@cybercable.fr>
  210. - dump 0.4b20 released, first packaging.
  211. * Tue Oct 31 2000 Jeff Johnson <jbj@redhat.com>
  212. - remove setuid bits for Red Hat 5.x errata.
  213. * Wed Aug 30 2000 Matt Wilson <msw@redhat.com>
  214. - rebuild to cope with glibc locale binary incompatibility, again
  215. * Wed Aug 30 2000 Preston Brown <pbrown@redhat.com>
  216. - fix for dumping files between 2 and 4 gigs (#16466)
  217. * Mon Aug 21 2000 Matt Wilson <msw@redhat.com>
  218. - don't use -O2 on alpha because of compiler ICE
  219. * Sun Aug 20 2000 Jeff Johnson <jbj@redhat.com>
  220. - update to 0.4b19.
  221. * Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
  222. - summaries from specspo.
  223. * Wed Aug 16 2000 Erik Troan <ewt@redhat.com>
  224. - support LABEL= in fstab
  225. * Sat Jul 22 2000 Bill Nottingham <notting@redhat.com>
  226. - if dump/restore aren't set(u|g)id, they don't need group tty (#12670)
  227. * Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
  228. - rebuild to cope with glibc locale binary incompatibility
  229. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  230. - automatic rebuild
  231. * Tue Jun 27 2000 Preston Brown <pbrown@redhat.com>
  232. - whoops I had dump commented out of the file list. fixed.
  233. - dropped suid bits on the static binaries.
  234. - fix char buffer size issue (#11880)
  235. * Mon Jun 19 2000 Preston Brown <pbrown@redhat.com>
  236. - dropped SUID bits
  237. * Tue Jun 6 2000 Jeff Johnson <jbj@redhat.com>
  238. - update to 0.4b17.
  239. - FHS packaging.
  240. * Thu Jun 1 2000 Stelian Pop <pop@cybercable.fr>
  241. - dump 0.4b17 released, first packaging.
  242. * Sat Mar 11 2000 Stelian Pop <pop@cybercable.fr>
  243. - dump 0.4b16 released, first packaging.
  244. * Tue Mar 7 2000 Jeff Johnson <jbj@redhat.com>
  245. - use posix signal handling to preserve dump functionality with libc5.
  246. * Thu Mar 2 2000 Bill Nottingham <notting@redhat.com>
  247. - update to 0.4b15
  248. * Thu Feb 10 2000 Jeff Johnson <jbj@redhat.com>
  249. - dump -0ufB /dev/ftape 1638000 /mnt2 fails to use /mnt2 as tape device (#8036)
  250. * Thu Feb 10 2000 Stelian Pop <pop@cybercable.fr>
  251. - dump 0.4b14 released, first packaging.
  252. * Wed Feb 9 2000 Jeff Johnson <jbj@redhat.com>
  253. - compress man pages.
  254. * Thu Jan 27 2000 Jeff Johnson <jbj@redhat.com>
  255. - update to 0.4b13.
  256. * Fri Jan 21 2000 Stelian Pop <pop@cybercable.fr>
  257. - dump 0.4b13 released, first packaging.
  258. * Mon Jan 10 2000 Jeff Johnson <jbj@redhat.com.
  259. - update to 0.4b12.
  260. * Fri Jan 8 2000 Stelian Pop <pop@cybercable.fr>
  261. - dump 0.4b12 released, first packaging.
  262. * Sun Dec 5 1999 Stelian Pop <pop@cybercable.fr>
  263. - dump 0.4b11 released, first packaging.
  264. * Sat Nov 27 1999 Jeff Johnson <jbj@redhat.com>
  265. - intergrate Stelian's fixes (Thanks!).
  266. * Sun Nov 21 1999 Stelian Pop <pop@cybercable.fr>
  267. - dump 0.4b10 released, first packaging.
  268. * Thu Nov 11 1999 Stelian Pop <pop@cybercable.fr>
  269. - make static versions also for rescue purposes.
  270. * Wed Nov 5 1999 Stelian Pop <pop@cybercable.fr>
  271. - dump 0.4b9 released, first packaging.
  272. * Wed Nov 3 1999 Stelian Pop <pop@cybercable.fr>
  273. - dump 0.4b8 released, first packaging.
  274. * Thu Oct 8 1999 Stelian Pop <pop@cybercable.fr>
  275. - dump 0.4b7 released, first packaging.
  276. * Thu Sep 30 1999 Stelian Pop <pop@cybercable.fr>
  277. - dump 0.4b6 released, first packaging.
  278. * Fri Sep 10 1999 Jeff Johnson <jbj@redhat.com>
  279. - recompile with e2fsprogs = 1.15 (#4962).
  280. * Sat Jul 31 1999 Jeff Johnson <jbj@redhat.com>
  281. - workaround egcs bug (#4281) that caused dump problems (#2989).
  282. - use sigjmp_buf, not jmp_buf (#3260).
  283. - invoke /etc/rmt (instead of rmt) like other unices. (#3272).
  284. - use glibc21 err/glob rather than the internal compatibility routines.
  285. - wire $(OPT) throughout Makefile's.
  286. - fix many printf problems, mostly lint clean.
  287. - merge SuSE, Debian and many OpenBSD fixes.
  288. * Thu Mar 25 1999 Jeff Johnson <jbj@redhat.com>
  289. - remove setuid/setgid bits from /sbin/rmt (dump/restore are OK).
  290. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  291. - auto rebuild in the new build environment (release 6)
  292. * Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
  293. - strip binaries.
  294. * Thu Mar 18 1999 Jeff Johnson <jbj@redhat.com>
  295. - Fix dangling symlinks (#1551).
  296. * Wed Mar 17 1999 Michael Maher <mike@redhat.com>
  297. - Top O' the morning, build root's fixed for man pages.
  298. * Fri Feb 19 1999 Preston Brown <pbrown@redhat.com>
  299. - upgraded to dump 0.4b4, massaged patches.
  300. * Tue Feb 02 1999 Ian A Cameron <I.A.Cameron@open.ac.uk>
  301. - added patch from Derrick J Brashear for traverse.c to stop bread errors
  302. * Wed Jan 20 1999 Jeff Johnson <jbj@redhat.com>
  303. - restore original 6755 root.tty to dump/restore, defattr did tty->root (#684).
  304. - mark /etc/dumpdates as noreplace.
  305. * Tue Jul 14 1998 Jeff Johnson <jbj@redhat.com>
  306. - add build root.
  307. * Tue May 05 1998 Prospector System <bugs@redhat.com>
  308. - translations modified for de, fr, tr
  309. * Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
  310. - added a patch for resolving linux/types.h and sys/types.h conflicts
  311. * Wed Dec 31 1997 Erik Troan <ewt@redhat.com>
  312. - added prototype of llseek() so dump would work on large partitions
  313. * Thu Oct 30 1997 Donnie Barnes <djb@redhat.com>
  314. - made all symlinks relative instead of absolute
  315. * Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
  316. - built against glibc
  317. * Thu Mar 06 1997 Michael K. Johnson <johnsonm@redhat.com>
  318. - Moved rmt to its own package.
  319. * Tue Feb 11 1997 Michael Fulbright <msf@redhat.com>
  320. - Added endian cleanups for SPARC
  321. * Fri Feb 07 1997 Michael K. Johnson <johnsonm@redhat.com>
  322. - Made /etc/dumpdates writeable by group disk.