cmake-vl.spec 6.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217
  1. # Set to bcond_without or use --with bootstrap if bootstrapping a new release
  2. # or architecture
  3. %bcond_with bootstrap
  4. # Set to bcond_with or use --without gui to disable qt4 gui build
  5. %bcond_without gui
  6. Name: cmake
  7. Summary: Cross-platform make system
  8. Summary(ja): クロスプラットフォームな Make システム
  9. Version: 2.8.10.2
  10. Release: 1%{?_dist_release}
  11. Group: Development/Tools
  12. License: BSD
  13. URL: http://www.cmake.org/
  14. Source0: http://www.cmake.org/files/v2.8/%{name}-%{version}.tar.gz
  15. Source1: macros.cmake
  16. # Patch to find DCMTK in Fedora (bug #720140)
  17. Patch0: cmake-dcmtk.patch
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. BuildRequires: curl-devel
  20. BuildRequires: expat-devel
  21. BuildRequires: gcc-gfortran
  22. BuildRequires: libarchive-devel
  23. BuildRequires: libidn-devel
  24. BuildRequires: ncurses-devel
  25. BuildRequires: openssl-devel
  26. BuildRequires: zlib-devel
  27. %if %{with gui}
  28. BuildRequires: qt4-devel, desktop-file-utils
  29. %define qt_gui --qt-gui
  30. %else
  31. %define qt_gui --no-qt-gui
  32. %endif
  33. Vendor: Project Vine
  34. Distribution: Vine Linux
  35. %description
  36. CMake is used to control the software compilation process using simple
  37. platform and compiler independent configuration files. CMake generates
  38. native makefiles and workspaces that can be used in the compiler
  39. environment of your choice. CMake is quite sophisticated: it is possible
  40. to support complex environments requiring system configuration, pre-processor
  41. generation, code generation, and template instantiation.
  42. %package gui
  43. Summary: Qt GUI for %{name}
  44. Group: Development/Tools
  45. Requires: %{name} = %{version}-%{release}
  46. Requires(post): desktop-file-utils, shared-mime-info
  47. Requires(postun): desktop-file-utils, shared-mime-info
  48. %description gui
  49. The %{name}-gui package contains the Qt based GUI for CMake.
  50. %prep
  51. %setup -q
  52. %patch0 -p1 -b .dcmtk
  53. # Fixup permissions
  54. #find -name \*.h -o -name \*.cxx -print0 | xargs -0 chmod -x
  55. #fix desktop file warning
  56. sed -i 's:\(Icon=\)\(CMakeSetup32.png\):\1/usr/share/pixmaps/\2:' Source/QtDialog/CMake.desktop
  57. %build
  58. ./bootstrap \
  59. --prefix=%{_prefix} \
  60. --datadir=/share/%{name} \
  61. --mandir=/share/man \
  62. --%{?with_bootstrap:no-}system-libs \
  63. %{?qt_gui}
  64. sed -i 's/-lcurses/-lcurses -ltinfo/' Source/CMakeFiles/ccmake.dir/link.txt
  65. %if %{?_dist_release} == "vl5"
  66. sed -i 's/HAVE_SYS_WAIT_H:INTERNAL=/HAVE_SYS_WAIT_H:INTERNAL=1/' CMakeCache.txt
  67. %endif
  68. make VERBOSE=1 %{?_smp_mflags}
  69. %install
  70. rm -rf $RPM_BUILD_ROOT
  71. make install DESTDIR=$RPM_BUILD_ROOT
  72. find $RPM_BUILD_ROOT/%{_datadir}/%{name}/Modules -type f | xargs chmod -x
  73. rm -rf $RPM_BUILD_ROOT/usr/doc
  74. # RPM macros
  75. install -p -m0644 -D %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
  76. sed -i -e "s|@@CMAKE_VERSION@@|%{version}|" $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
  77. touch -r %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
  78. %if %{with gui}
  79. # Desktop file
  80. desktop-file-install --delete-original \
  81. --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
  82. $RPM_BUILD_ROOT/%{_datadir}/applications/CMake.desktop
  83. %endif
  84. %clean
  85. rm -rf $RPM_BUILD_ROOT
  86. %if %{with gui}
  87. %post gui
  88. update-desktop-database &> /dev/null || :
  89. update-mime-database %{_datadir}/mime &> /dev/null || :
  90. %postun gui
  91. update-desktop-database &> /dev/null || :
  92. update-mime-database %{_datadir}/mime &> /dev/null || :
  93. %endif
  94. %files
  95. %defattr(-,root,root)
  96. %doc CMakeLogo.gif ChangeLog.* Copyright.txt
  97. %doc Docs/*
  98. %doc Example/
  99. %config(noreplace) %{_sysconfdir}/rpm/macros.cmake
  100. %{_bindir}/ccmake
  101. %{_bindir}/cmake
  102. %{_bindir}/cpack
  103. %{_bindir}/ctest
  104. %{_datadir}/%{name}/
  105. %{_datadir}/aclocal/cmake.m4
  106. %{_mandir}/man1/*
  107. %if %{with gui}
  108. %files gui
  109. %defattr(-,root,root,-)
  110. %{_bindir}/cmake-gui
  111. %{_datadir}/applications/CMake.desktop
  112. %{_datadir}/mime/packages/cmakecache.xml
  113. %{_datadir}/pixmaps/CMakeSetup32.png
  114. %endif
  115. %changelog
  116. * Mon Apr 29 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.10.2-1
  117. - new upstream release
  118. - fixed desktop file warning
  119. * Sun Jun 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.6-2
  120. - rebuild with libarchive-3.0.4
  121. * Sat Nov 19 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.6-1
  122. - new upstream release
  123. - forced to link with libtinfo.so (ccmake)
  124. - used --system-libs again
  125. * Sat Jan 8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-1
  126. - new upstream release
  127. - used --no-system-libs, removed BR: curl-devel, expat-devel, zlib-devel
  128. * Sun Sep 5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-4
  129. - fixed typo (not --with-system-libs, but --system-libs)
  130. - added BR: curl-devel, expat-devel, zlib-devel
  131. * Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.2-3
  132. - add BuildRequires: ncurses-devel
  133. * Sun Aug 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-2
  134. - generate gui package
  135. - renamed module directory
  136. * Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-1
  137. - new upstream release
  138. * Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-3
  139. - rebuilt with new toolchain
  140. * Sun Aug 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.4-2
  141. - imported RPM macros from Fedora (cmake-2.6.4-3.fc12)
  142. * Tue Aug 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.4-1
  143. - new upstream release
  144. - added Vendor/Distribution tag
  145. * Wed Mar 25 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.3-1
  146. - new upstream release
  147. * Tue Oct 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.2-1
  148. - new upstream release
  149. * Sat Mar 29 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.8-1
  150. - new upstream release
  151. * Wed Aug 15 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.7-0vl1
  152. - new upstream release
  153. * Mon May 14 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.6-0vl1
  154. - new upstream release
  155. - drop Patch100
  156. - use bootstrap script instead of configure
  157. - delete caches from %%doc
  158. * Sat May 12 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.3-0vl2
  159. - rebuilt with new toolchain
  160. * Tue Oct 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.3-0vl1
  161. - new upstream release
  162. - delete duped docs
  163. * Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.3-0vl2
  164. - added Patch100 (especially for ppc to solve ppc/powerpc issue)
  165. * Mon Feb 06 2006 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.2.3-0vl1
  166. - source version up
  167. * Sun Mar 20 2005 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.0.5-0vl1
  168. - initial build for Vine Linux