tix-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314
  1. %define tcl_major 8.6
  2. %define tk_major 8.6
  3. %define thread_major 2.8
  4. %define tix_major 8.4
  5. %define tixversion %{tix_major}.3
  6. ## can't find all provides
  7. #define _use_internal_dependency_generator 0
  8. Summary: A Tcl/Tk development environment: tix
  9. Summary(ja): Tcl/Tk 開発環境: tix
  10. Name: tix
  11. Version: %{tixversion}
  12. Release: 4%{?_dist_release}
  13. Group: Development/Languages
  14. License: BSD
  15. Vendor: Project Vine
  16. Distribution: Vine Linux
  17. URL: http://tix.sourceforge.net/
  18. Source0: Tix%{tixversion}-src.tar.gz
  19. # 0: Fixes BZ#81297 (soname of libraries)
  20. Patch0: tix-8.4.2-link.patch
  21. Patch1: tix-8.4.3-tcl86.patch
  22. Patch2: tix-8.4.3-covscan-fixes.patch
  23. Buildroot: %{_tmppath}/%{name}-%{version}-root
  24. BuildRequires: tcl-devel >= %{tcl_major}
  25. BuildRequires: tk-devel >= %{tk_major}
  26. BuildRequires: tcl-thread
  27. BuildRequires: libX11-devel
  28. Requires: tcl >= %{tcl_major}
  29. Requires: tk >= %{tk_major}
  30. Requires: tcl-thread
  31. %description
  32. Tix (Tk Interface Extension), an add-on for the Tk widget set, is an
  33. extensive set of over 40 widgets. In general, Tix widgets are more
  34. complex and more capable than the widgets provided in Tk. Tix widgets
  35. include a ComboBox, a Motif-style FileSelectBox, an MS Windows-style
  36. FileSelectBox, a PanedWindow, a NoteBook, a hierarchical list, a
  37. directory tree and a file manager.
  38. Install the tix package if you want to try out more complicated widgets
  39. for Tk. You'll also need to have the tcl and tk packages installed.
  40. %description -l ja
  41. Tk ウィジェットセットのためのアドオンである、Tix (Tk Interface Extension)
  42. は 40 ウィジェットを超える拡張セットです。Tix ウィジェットの多くが、
  43. Tk から供給されるウィジェットよりも高機能です。Tix ウィジェットは
  44. コンボボックス、Motif スタイルのファイルボックス、MS Windows スタイルの
  45. ファイルボックス、パネルウィンドウ、ノートブック、階層リスト、
  46. ディレクトリツリー、ファイルマネージャを含んでいます。
  47. Tk で、より複雑ななウィジェットを試したい時には、tix パッケージをインストール
  48. してください。tcl と tk のパッケージもインストールする必要があります。
  49. %prep
  50. %setup -q -n Tix%{tixversion}
  51. %patch0 -p1 -b .link
  52. %patch1 -p1 -b .tcl86
  53. %patch2 -p1 -b .covscan-fixes
  54. %build
  55. # make the libraries reentrant
  56. RPM_OPT_FLAGS="$RPM_OPT_FLAGS -D_REENTRANT"
  57. %configure \
  58. --with-tcl=%{_libdir} \
  59. --with-tk=%{_libdir} \
  60. --enable-shared \
  61. --disable-threads \
  62. ;
  63. make %{?_smp_mflags} all
  64. %install
  65. rm -rf ${RPM_BUILD_ROOT}
  66. %makeinstall
  67. SOFILE=libTix%{version}.so
  68. mv $RPM_BUILD_ROOT%{_libdir}/Tix%{version}/$SOFILE $RPM_BUILD_ROOT%{_libdir}
  69. ln -sf ../$SOFILE $RPM_BUILD_ROOT%{_libdir}/Tix%{version}/$SOFILE
  70. ln -sf ./$SOFILE $RPM_BUILD_ROOT%{_libdir}/libTix.so
  71. ln -sf ./$SOFILE $RPM_BUILD_ROOT%{_libdir}/libTix%{tix_major}.so
  72. ln -sf ./$SOFILE $RPM_BUILD_ROOT%{_libdir}/libtix.so
  73. ## internal_dependency_generator can't find provides
  74. #ln -sf ./$SOFILE $RPM_BUILD_ROOT%{_libdir}/libtix%{tix_major}.so
  75. cp -p ./$SOFILE $RPM_BUILD_ROOT%{_libdir}/libtix%{tix_major}.so
  76. install -d $RPM_BUILD_ROOT%{_mandir}/man1
  77. install -d $RPM_BUILD_ROOT%{_mandir}/mann
  78. install -m 644 man/tixwish.1 $RPM_BUILD_ROOT%{_mandir}/man1
  79. install -m 644 man/*.n $RPM_BUILD_ROOT%{_mandir}/mann
  80. install -d $RPM_BUILD_ROOT%{_includedir}
  81. install -m 0644 generic/tix.h $RPM_BUILD_ROOT%{_includedir}/tix.h
  82. ## others
  83. SHAREDDIR=$RPM_BUILD_ROOT%{_datadir}/tix-%{version}
  84. install -d $SHAREDDIR/demos/bitmaps
  85. install -d $SHAREDDIR/demos/samples
  86. install -m 755 demos/widget $SHAREDDIR/demos
  87. install -m 644 demos/{*.tcl,tclIndex} $SHAREDDIR/demos
  88. install -m 644 demos/bitmaps/* $SHAREDDIR/demos/bitmaps
  89. install -m 644 demos/samples/* $SHAREDDIR/demos/samples
  90. cp -a tests $SHAREDDIR
  91. ## * old scripts *
  92. ## find . -type d -name CVS | xargs -r rm -frv
  93. ## echo "%%defattr(-,root,root)" > tix.files
  94. ## (find ${RPM_BUILD_ROOT}%{_bindir} \
  95. ## ${RPM_BUILD_ROOT}%{_mandir} -type f -o -type l;
  96. ## find ${RPM_BUILD_ROOT}%{_libdir}/*) | cat - *.files \
  97. ## | sort | uniq -u >> tix.files
  98. ##
  99. ## set +x +H
  100. ## for n in `cat tix.files`; do
  101. ## test -f $n || continue
  102. ## head -1 $n | grep -q ^#! || continue
  103. ## chmod u+w $n
  104. ## perl -pi -e "s|${RPM_BUILD_ROOT}||" $n
  105. ## done
  106. ## set -x -H
  107. ##
  108. ## #==========================================
  109. ## # post process the *.files list, removing build sys references and mark
  110. ## # which are directories
  111. ## set +x
  112. ## for n in *.files; do
  113. ## mv $n $n.in
  114. ## sed "s|.*%{_prefix}\\>|%{_prefix}|" < $n.in | while read file; do
  115. ## if [ -d ${RPM_BUILD_ROOT}/$file ]; then
  116. ## echo -n '%dir '
  117. ## fi
  118. ## echo $file
  119. ## done > $n
  120. ## rm -f $n.in
  121. ## done
  122. ## set -x
  123. ##
  124. ## # Man pages can be compressed
  125. ## perl -pi -e 's|(^%{_mandir}/man.*$)|\1\*|' *.files
  126. %post -p /sbin/ldconfig
  127. %postun -p /sbin/ldconfig
  128. %clean
  129. rm -rf $RPM_BUILD_ROOT
  130. %files
  131. %defattr(-,root,root,-)
  132. %{_libdir}/libTix*.so
  133. %{_libdir}/libtix*.so
  134. %{_libdir}/Tix%{version}
  135. %{_datadir}/tix-%{tixversion}
  136. %{_mandir}/man1/tixwish.1.gz
  137. %{_mandir}/mann/*.n.gz
  138. %{_includedir}/*.h
  139. %doc ChangeLog README.txt man/html man/index.html
  140. %changelog
  141. * Fri Oct 04 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.4.3-4
  142. - rebuilt with tcl/tk-8.6.9.
  143. - dropped all patches.
  144. - imported Patch0-2 from rawhide.
  145. * Wed Dec 31 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.4.3-3
  146. - rebuilt with tcl/tk 8.5.15 and thread 2.7.1
  147. * Thu Feb 24 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.3-2
  148. - added BR: libX11-devel
  149. * Tue Feb 22 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.3-1
  150. - updated tix to 8.4.3
  151. - dropt tix-8.1.4-perf.patch
  152. - dropt tix-8.2.0b1-dirtree.patch
  153. - added "cp -p libTix8.4.3.so libtix8.4.so"
  154. - rebuilt with file-5.05-2
  155. * Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.2-2
  156. - rebuilt with tcl/tk-8.4.19-2
  157. * Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.2-1vl5
  158. - applied new versioning policy
  159. * Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.2-0vl3
  160. - rebuild with tcl/tk-8.4.18
  161. * Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.2-0vl2
  162. - rebuild with tcl/tk-8.4.16
  163. * Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.2-0vl1
  164. - updated tix to 8.4.2
  165. - rebuilt with new toolchain
  166. * Sat Jan 28 2006 Shu KONNO <owa@bg.wakwak.com> 8.2.0-0vl5
  167. - rebuild for tcl/tk-8.4.12, and x86_64 architecture support
  168. * Fri Sep 09 2005 Shu KONNO <owa@bg.wakwak.com> 8.2.0-0vl4
  169. - changed url to http://tix.sourceforge.net/download.shtml
  170. - rebuild for tcl/tk-8.4.11
  171. * Wed Jun 30 2004 Shu KONNO <owa@bg.wakwak.com> 8.2.0-0vl3
  172. - rebuild for tcl/tk-8.4.6
  173. * Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.2.0-0vl2
  174. - rebuild for tcl/tk-8.4.5
  175. * Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.2.0-0vl1
  176. - update based on BitWalk's tcltk-8.4.2-83bw
  177. * Thu Nov 15 2001 Kazuhusa TAKEI <takei@linux.or.jp> 8.0.5_jp-10vl3
  178. - splite source package
  179. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
  180. - expand some macros.. (FIXME)
  181. * Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
  182. - use %configure macros
  183. - add Patch 47,50
  184. * Thu May 31 2001 <sagami@vinelinux.org>
  185. - 8.0.5_jp-10
  186. - unexpand old %%{configure}, new one causes build failure
  187. - fixed missing libtkx.so libtclx.so symlink in /usr/lib
  188. - install manpages into %%{_mandir} and mode 644
  189. * Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  190. - 8.0.5_jp-9
  191. - modified %install section to handle compressed man pages
  192. - fixed /usr/lib/tk8.0jp/demos.jp/images symlink
  193. * Sun Jul 2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
  194. - changed default fonts
  195. * Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
  196. - added defattr
  197. * Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
  198. - added some symlinks, such as libtcl8.0.so.
  199. - obsoletes version number using _jp, now 8.0.5-31vl1
  200. * Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
  201. - Apply Tcl/Tk 8.0 Japanese Patch 1.7
  202. * Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
  203. - fix tclX symlinks.
  204. - compile on systems where SIGPWR == SIGLOST.
  205. * Sat May 1 1999 Jeff Johnson <jbj@redhat.com>
  206. - update tcl/tk to 8.0.5.
  207. - avoid "containing" in Tix (#2332).
  208. * Thu Apr 8 1999 Jeff Johnson <jbj@redhat.com>
  209. - use /usr/bin/write in kibitz (#1320).
  210. - use cirrus.sprl.umich.edu in weather (#1926).
  211. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  212. - auto rebuild in the new build environment (release 28)
  213. * Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
  214. - whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
  215. * Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
  216. - expect does unaligned access on alpha (#989)
  217. - upgrade tcl/tk/tclX to 8.0.4
  218. - upgrade expect to 5.28.
  219. - add itcl 3.0.1
  220. * Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
  221. - call libtoolize to allow building on the arm
  222. - build for glibc 2.1
  223. - strip binaries
  224. * Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
  225. - update tcl/tk/tclX to 8.0.3, expect is updated also.
  226. * Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
  227. - expect: mkpasswd needs delay before sending password (problem #576)
  228. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  229. - translations modified for de, fr, tr
  230. * Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
  231. - fixed expect binaries exec permissions
  232. * Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
  233. - updated to Tix 4.1.0.006
  234. - updated version numbers of tcl/tk to relflect includsion of p2
  235. * Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
  236. - updated tcl/tk to patch level 2
  237. - updated tclX to 8.0.2
  238. * Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
  239. - fixed filelist for tix... replacing path to the expect binary in scripts
  240. was leaving junk files around.
  241. * Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
  242. - added patch to remove libieee test in configure.in for tcl and tk.
  243. Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
  244. solution for all systems
  245. - fixed src urls
  246. * Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
  247. - removed version numbers from descriptions
  248. * Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
  249. - updated to tcl/tk 8.0 and related versions of packages
  250. * Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
  251. - built against glibc
  252. - fixed dangling tclx/tkx symlinks